Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie
Toon posts:

Zigbee2mqtt - open source zigbee bridge

Pagina: 1
Acties:

  • PuckStar
  • Registratie: juli 2000
  • Laatst online: 15:29

Intro

Dit topic is bedoelt om zigbee2mqtt gebruikers en wannabe gebruikers bij elkaar te brengen.

Zigbee2mqtt is open source software waarmee je je zigbee apparaten via MQTT kunt uitlezen en aansturen.
Je kunt het dus onder andere koppelen aan Home Assistant en Domoticz.
Met deze software en relatief goedkope hardware die je ervoor nodig hebt, heb je in principe geen andere Zigbee hubs meer nodig zoals Philips Hue, Xiaomi Gateway of Trädfri. Dat scheelt dus geld en extra devices.

Architectuur:



Ondersteunde componenten:

Klik hier voor een lijst van alle ondersteunde componenten.
Alsnog kun je een (nog) niet ondersteund component ook zelf toevoegen.

Routers:

Om het bereik van het Zigbee netwerk te vergroten kun je onder andere routers inzetten.
Dat is niets meer dan het flashen van de router firmware op een usb stick (bijvoorbeeld de CC2531).
Deze kun je direct in een usb adapter stoppen. Meer is er niet nodig.
Je moet hem natuurlijk nog wel een keer pairen vlakbij je main hub (coordinator).

Pairing tips:

De meldingen "Message without device!" komen wel langs maar dat weerhoudt het pairen niet.
Pairen kun je als volgt doen:
- zet zigbee2mqtt in pair modus
- eventueel: schakel over naar zigbee2mqtt log scherm en refresh regelmatig,
- eventueel: haal batterij even uit het device dat je wilt pairen zodat zodat het goed gereset is,
- druk op de reset knop 3-5 sec. tot de led oplicht (pairing aanduiding - per device is dat soms wat verschillend),
- daarna elke 2 seconden even kort de reset knop intikken zodat hij verbinding onderhoudt. Pairing kan soms wel 10 - 15 sec. duren dus gewoon doorgaan,
- indien je in de zigbee2mqtt log "Message without device!" en "Device incoming" meldingen ziet gewoon even doorgaan met elke 2 seconden even kort de reset knop intikken, tot je de string met info van het device langs ziet komen die aangeven dat het pairen gelukt is.
- eventueel daarna de zigbee2mqtt even herstarten zodat je het device netjes in de lijst van zigbee2mqtt ziet terugkomen.
- als het toch niet is gelukt dit geheel herhalen.

Wellicht heb je dit allemaal wel gedaan, maar ik zie toch vaak dat men te vroeg stopt bij melding "Message without device!". Het contact onderhouden door om de sec. even kort de reset knop intikken is belangrijk. Verder moet de batterij in orde zijn (2.9 - 3.0 volt) en de zigbee2mqtt cc2531 niet te ver weg zijn (<5 mtr) .

Firmware flashen:

Je kunt de firmware dus op een CC2531 USB stick zetten maar daar heb je een CC debugger en Downloader cable voor nodig van ongeveer 13euro bij elkaar. Terwijl je die dus waarschijnlijk maar 1 keer nodig hebt.
Daarom zijn er een aantal Tweakers die bereid zijn om voor jou een CC2531 of soortgelijke stick van firmware te voorzien. Dan hoef jij dus niet de CC Debugger te kopen en zelf te gaan flashen.
Als je interesse hebt neem dan contact op met een van deze Tweakers:
- Regio Utrecht, Veenendaal, Wageningen (@PuckStar.
- Regio gemeente Overbetuwe @sanderdw
- Regio Groningen @sk1nny666
- Regio Enschede @Luqq
- Regio Amsterdam @symen89
- Regio Zoetermeer @iMars

Kopen van onderdelen:

Er is in ieder geval goeie ervaring met het kopen van de Debugger bij deze shop.
En de tussenkabel (nodig om te flashen) en sticks bij deze shop.

Behuizingen:

Een aantal behuizingen om te 3D printen, voor de zigbee2mqtt stick en optionele extra routers:
https://www.thingiverse.com/search?q=Zigbee2mqtt

Tips & Tricks:

  • Het staat ook in de documentatie, maar je kunt de LED uitzetten in de configuration.yaml
    Het moet onder serial. Zie Configuration:

    code:
    1
    2
    3
    4
    5
    6
    
    # Required: serial settings
    serial:
      # Required: location of CC2531 USB sniffer
      port: /dev/tty.usbmodem1411
      # Optional: disable LED of CC2531 USB sniffer
      disable_led: true

  • Hoe kun je een friendly name geven aan een device dat je nieuw gaat pairen, zonder dat de initiele naam gelijk al in Home Assistant komt? Dit is een manier om dat te voorkomen.


In principe kun je alle informatie op de officiële website vinden maar in dit topic kunnen we elkaar verder helpen en tips&tricks uitwisselen.

Heb je aanvullingen voor deze topicstart laat het mij aub weten.

PuckStar wijzigde deze reactie 24-05-2019 15:29 (91%)

[My Home Automations] - [Cheap controllable Wifi Ledstrip]


  • Kodess
  • Registratie: september 2009
  • Laatst online: 21:45
CypherMK schreef op woensdag 16 januari 2019 @ 11:36:
[...]


Kun je die behuizingen ook ergens kant en klaar kopen?
Je kan ze laten 3dprinten bij een printer service zoals 3dhubs.com

Door de verzending wordt het alleen altijd zo prijzig :|

  • rorie
  • Registratie: maart 2007
  • Laatst online: 10:30
Oké, zo te lezen werkt het idd alleen niet via usb maar direct via de GPIO pinnen van de Raspberry Pi. Dat zou voor mij ook geen oplossing zijn. Was er eigenlijk na het zien van de onderstaande afbeelding vanuit gegaan dat dit al kon, dus via usb 😀.

https://goo.gl/images/pEK62R

Gezien de range heeft de cc2530 wel mijn voorkeur, dan proberen we het eerst eens met de cc2531.
dof schreef op donderdag 17 januari 2019 @ 17:41:
[...]


Hij werkt wel want in de fora waar @Koenkk eentje van aanhaalt zie je wel meer discussie over de cc2530 met zigbee2mqtt.

Ook hier is discussie over de cc2530 te vinden (even zoeken op cc2530).

Sterker nog :) , ik heb hem hier zelf ook nog steeds liggen om te proberen. Alleen is het niet zo handig (in vergelijk met de USB cc2531) aangezien je een aantal losse draadjes aan de diverse pennen van zowel de Pi als de cc2530 moet aansluiten. Zo ook bij het flashen. Ik vrees dat het een beetje rommelig oogt. Althans ik heb nog geen mooie (doosje) oplossing in gedachten...

  • Rmg
  • Registratie: november 2003
  • Nu online
Ik heb gister een cover gemaakt voor de CC2531 Sticks met het HomeAssistant logo er in.

In het wit erg tof geworden als zeg ik het zelf:
https://tweakers.net/ext/f/UzscRb4hSNjamDZSQHekcS5V/thumb.jpg

Op thingiverse heb ik ook meteen een step file toegevoegd, dat maakt het voor iedereen een stuk makkelijker om zelf wat te ontwerpen :Y) https://www.thingiverse.com/thing:3371273

  • R2D2
  • Registratie: mei 2001
  • Laatst online: 07:39
Sander schreef op woensdag 23 januari 2019 @ 08:50:
Ik merk dat Zigbee2mqtt nu met 30 devices (23 zijn lampen dus routers) erg traag is met schakelen, soms duurt het wel een minuut voor de laatste lamp uit gaat of aan na een commando (als dat al gebeurd). Schakelen van een individuele lamp gaat over algemeen vrij goed. Geheel draait in een docker container op een Mac Mini met een 8GB geheugen en een i5 en gedurende mijn tests met enkele devices was er geen verschil met tradfri (behalve bij schakelen groepen) maar nu is het eigenlijk praktisch onwerkbaar. Iemand enig idee hoe verder te debuggen of waar dit in te zoeken?
Wat ik heb gemerkt is dat wanneer er een device niet / slecht bereikbaar is daar de rest ook vaak op blijft hangen met de nodige vertraging.

Als ik bijvoorbeeld onderstaande card in 1 keer in/uit schakel terwijl er 1 lamp bijvoorbeeld geen stroom heeft dan hangt de boel even om na een tiental seconden de lampen welke wel van stroom voorzien zijn in te schakelen.



Bovenstaand was toen er nog maar 4 lampen gekoppeld waren via Zigbee2Mqtt, inmiddels zijn dat er op de begane grond 13 waarvan lang niet alles voorzien is van een Xiaomi wireless switch waardoor het nog wel eens wil gebeuren dat er geen stroom meer op een lamp staat en de boel dus op een hoopje loopt (om zich vervolgens ook wel weer te herstellen).

Maar volgens mij gaan daar oplossingen voor komen, https://github.com/Koenkk/zigbee2mqtt/issues/775

  • MooiWeb
  • Registratie: mei 2006
  • Laatst online: 20-05 21:09
Ik heb een IKEA TRADFRI LED bulb E12/E14/E17 400 lumen weten te koppelen via mijn nieuwe CC2531 zigbee dongle in HA 0.86.3. Ik zie hem ook in de zigbee2mqtt log voorbij komen:

http://www.mooiweb.nl/images/ikea.jpg

Maar nu weet ik niet hoe ik deze in HA kan aansturen? In configuration.yaml van HA het volgende toegevoegd:
light:
- platform: mqtt
name: 'KASTJE'
command_topic: "zigbee2mqtt/Ikea_lamp_1/"
payload_on: "on"
payload_off: "off"

Maar dit werkt niet.
Zie de lamp ook niet terugkomen in: HA - Instelingen - Integraties - MQTT
Wie kan mij helpen?

  • MooiWeb
  • Registratie: mei 2006
  • Laatst online: 20-05 21:09
PuckStar schreef op woensdag 30 januari 2019 @ 15:08:
[...]

Volgens mij moet er nog /set bij.
Zie ook https://koenkk.github.io/...nd_message_structure.html
Test (als dat kan) het eerst eens vanuit Hass Mqtt service. Staat in het rijtje links onderaan.
Dat test wat sneller.
Bedankt voor je snelle reactie PucStar,
Heb al gedaan wat je hebt voorgesteld:
http://www.mooiweb.nl/images/publish.jpg

maar krijg dan:
http://www.mooiweb.nl/images/service.jpg

MooiWeb wijzigde deze reactie 30-01-2019 15:18 (4%)


  • MooiWeb
  • Registratie: mei 2006
  • Laatst online: 20-05 21:09
Possible schreef op woensdag 30 januari 2019 @ 15:41:
@MooiWeb Wellicht werkt dit?


code:
1
2
3
4
5
6
7
8
9
light:
  - platform: "mqtt"
    name: 'KASTJE'
    state_topic: "zigbee2mqtt/Ikea_lamp_1/"
    payload_on: "on" 
    payload_off: "off"
    brightness: true
    schema: "json"
    command_topic: "zigbee2mqtt/Ikea_lamp_1/set"

Heb de config aangepast:

code:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
mqtt:
  broker: homeassistant # This will have to be your mqtt broker
  discovery: true
  discovery_prefix: homeassistant

light:
  - platform: "mqtt"
    name: 'KASTJE'
    state_topic: "zigbee2mqtt/Ikea_lamp_1"
    command_topic: "zigbee2mqtt/Ikea_lamp_1/set"
    payload_on: "on" 
    payload_off: "off"
    brightness: true
    schema: "json"


[/quote]

Kan het lampje niet aan of uit schakelen.
Zie ook geen apparaten in MQTT config:
http://www.mooiweb.nl/images/mqtt.jpg

  • BizzieBis
  • Registratie: maart 2004
  • Laatst online: 23-05 09:50
En daar gaat mijn network map weer.. Ik geef het op 8)7

Van
https://tweakers.net/ext/f/dfAjg4x1f3yWbr75HmGFxegE/thumb.png

Naar
https://tweakers.net/ext/f/oihLakIZV4GUVJ5Q69MQBqyd/thumb.png

  • R2D2
  • Registratie: mei 2001
  • Laatst online: 07:39
Koenkk schreef op vrijdag 1 februari 2019 @ 11:53:
[...]


Heb je toevallig nog een log wanneer zigbee2mqtt er mee ophoudt na het pairen van een nieuw device?
Probleem gevonden, ik had net weer last van hetzelfde....

Maar nu ook duidelijk waarom. Als je je settings aanpast vanuit de addon is na het opslaan ervan je MQTT wachtwoord regel verdwenen. Of het zo hoort of niet geen idee maar ik had dus wat zaken in de config.yaml gezet (ik hou er niet zo van als dingen verdwijnen dus dan maar direct in de .yaml file), als daar een foutje in zit (in mijn geval een spatie teveel) gaat de boel ook onderuit echter zonder noemenswaardige foutmelding in de logs.

Vraag is dus waarom vind de addon het noodzaak een wachtwoord regel te verwijderen?

Die typo was dus mijn eigen stomme schuld en ook de reden waarom het geheel onderuit ging. :+
BizzieBis schreef op vrijdag 1 februari 2019 @ 12:51:
Ik vraag me sowieso af of bepaalde routers wel gebruikt worden door de coordinator. Ik heb 6 ikea lampen die als router zouden moeten werken, maar ik krijg nooit een status update te zien. Ook lijkt er geen enkel end device mee te willen verbinden. In de log zie ik niet dat ze gepinged worden

code:
1
2
3
4
5
6
7
8
2019-2-1 12:39:16 - debug: Check online Router Beneden 0x00124b0001490d7c
2019-2-1 12:39:16 - debug: Successfully pinged 0x00124b0001490d7c
2019-2-1 12:39:16 - debug: Check online Kodi Powerplug 0x00158d00024d8998
2019-2-1 12:39:26 - debug: Failed to ping 0x00158d00024d8998
2019-2-1 12:39:26 - debug: Check online Router WTW 0x00124b00016f2bd5
2019-2-1 12:39:26 - debug: Successfully pinged 0x00124b00016f2bd5
2019-2-1 12:39:26 - debug: Check online Xiaomi PowerPlug 0x00158d0002370efc
2019-2-1 12:39:37 - debug: Failed to ping 0x00158d0002370efc

Ik heb de debug log ook maar eens aangezet. In de network map zie ik de lampen wel allemaal onderling met elkaar verbinden maar de end devices bungelen er een beetje los langs... Welke powerplugs gebruik jij?

R2D2 wijzigde deze reactie 01-02-2019 13:33 (41%)


  • R2D2
  • Registratie: mei 2001
  • Laatst online: 07:39
Meer mensen die sinds de laatste update last hebben van "unavailable" zigbee apparaten.

Ik heb de afgelopen week nogal vaak onderstaande beeld (even wat screens gemaakt en aan elkaar geplakt, in werkelijkheid zijn er nog wel wat meer welke ineens onbeschikbaar zijn)



Lang niet alles komt ook weer terug online, vaak is een herstart nodig van Zigbee2Mqtt om de boel weer een beetje tot leven te wekken. Ook lijkt het er op dat dit meer voor komt sinds de INNR powerplugs in het netwerk opgenomen zijn.

Ik heb de availability timeout op 300 seconden staan maar soms lijkt het wel een uur te duren voor er weer beweging vanuit Zigbee2Mqtt zelf in zit. Wanneer ik de boel handmatig weer op gang probeer te krijgen door de addon te herstarten resulteert dat vaak in een crashende CC2531.

Laatste versie firmware en stable addon overigens.

  • gladz0r
  • Registratie: mei 2007
  • Laatst online: 15-05 19:39
PuckStar schreef op zondag 10 februari 2019 @ 12:09:
[...]

Welke mqtt broker gebruik je en heb je daar geen login/ww ingesteld?
Mosquitto op een Synology NAS. Bij mijn weten heb ik hier geen ww ingesteld - heb dit ook niet ingegeven bij zigbee2mqtt.

Denk dat het in mijn Hass config misloopt, heb ik hier een spatie ofzo fout?

https://i.imgur.com/zq4MUfA.png

gladz0r wijzigde deze reactie 10-02-2019 13:54 (22%)


  • dof
  • Registratie: juli 2010
  • Laatst online: 23-05 17:03
sander817 schreef op dinsdag 12 februari 2019 @ 10:44:
[...]

Hoe verzend ik zo'n commando?
Via HA sidemenu > Developer tools > MQTT Publish a packet.

https://tweakers.net/ext/f/z6QLGtTiH8TU9CmiRultQoeP/thumb.png

  • dof
  • Registratie: juli 2010
  • Laatst online: 23-05 17:03
Lifelogger schreef op woensdag 13 februari 2019 @ 22:08:
[...]

Oh vet! Heel benieuwd hoe die dingen werken. Daar zie ik ook nog wel wat in. :-)

Ben benieuwd naar je bevindingen.
Tradfri signaalversterker installatie:
Moest even de "zigbee2mqtt-edge" updaten (uninstall -> install) want hij werd niet herkend.

code:
1
2
 zigbee2mqtt:warn 2019-2-13 22:35:04 Device with modelID 'TRADFRI signal repeater' is not supported.
zigbee2mqtt:warn 2019-2-13 22:35:04 Please see: https://koenkk.github.io/zigbee2mqtt/how_tos/how_to_support_new_devices.html


Daarna ook nog even nodig de tradfri signaalversterker te resetten: druk 5 s met paperclip in gaatje naast de usb aansluiting.
https://tweakers.net/ext/f/EACzTUyzeJIQlEljJrA6GAuW/thumb.png

Na het pairen in zigbee2mqtt de aanmelding met keurig de log regel:

code:
1
zigbee2mqtt:info 2019-2-13 22:49:47 0x000d6ffffe7890cb (0x000d6ffffe7890cb): E1746 - IKEA TRADFRI signal repeater (Router)


Voor en tijdens pairing zie je het ledje naast de USB poort zachtjes lichter en donker oplichten, eenmaal gepaird is het ledje constant.

Ook nog even gekeken hoeveel stroom hij neemt en dat blijkt een keurige 55 mA te zien, ongeveer net zoveel als de cc2531's.

In de zigbee2mqtt netwerkmap komt hij ook netjes tevoorschijn.
Maar verder geen HA entity aanduidingen, anders dan de cc2531's geflasht als routers die wel in HA zichtbaar zijn.

Hoe de Tradfri werkelijk functioneert als zigbee router is even lastig te testen met 4 andere zigbee routers in bedrijf. De netwerkmap geeft bij mij geen duidelijke aanwijzingen; hij is wel verbonden met de concentrator maar er hangen (nog) geen end-devices aan.

  • bartbh
  • Registratie: maart 2004
  • Niet online
Scatman_II schreef op woensdag 16 januari 2019 @ 13:47:
[...]

Klopt! Ik heb de debug-pinnen van de CC stick op de pinnen van de Wemos D1 mini (een arduino gebaseerd op de ESP8266) aangesloten (dat deel is wel een beetje tricky, ik vond de schema's die ik vond op https://koenkk.github.io/...ive_flashing_methods.html niet heel duidelijk, zodra ik thuis ben en tijd heb zal ik proberen een foto/fritzing schemaatje te delen).

[...]
Mocht je hiervoor nog wat instructies hebben, dan hoor ik ze graag! Met name de pinout van de CC2531. De afbeelding van alternative_flashing_methods geeft mij namelijk nog geen goed beeld wat pin 1 en wat 10 is. (links, rechts, boven, onder)



  • Scatman_II
  • Registratie: december 2001
  • Laatst online: 22-05 11:14

Scatman_II

R9500 Pro >:)

bartbh schreef op vrijdag 15 februari 2019 @ 14:59:
[...]

Mocht je hiervoor nog wat instructies hebben, dan hoor ik ze graag! Met name de pinout van de CC2531. De afbeelding van alternative_flashing_methods geeft mij namelijk nog geen goed beeld wat pin 1 en wat 10 is. (links, rechts, boven, onder)


[Afbeelding]
Ik was inderdaad nog van plan dat verder uit te werken... En toen werd zoon nummer twee geboren _/-\o_ - laatste weken een beetje druk geweest :O

Ik heb dus nog geen schema, alleen een onduidelijke foto die ik voor je zal reconstrueren (want onduidelijk gecropped en niet op draadjes kleuren gelet.. sorry 8)7 ):
https://tweakers.net/ext/f/zTRkKWwygZHdUbkM9f5HAmmd/thumb.png

Wemos D1 mini --> CC-stick
Pin Ground (Zwart) --> Ground pin 1 ( --> dit is dus de pin aan de kant van de antenne (niet de USB kant), tegen het midden van de stick aan. Edit: Op mijn stick staat zelfs een kleine '1' gedrukt bij die pin)
Pin +3.3 (rood) --> 3.3V (from debugger) pin 9
Pin D5 én D6 samen --> DD pin 4
Pin D2 --> DC debug clock pin 3
Pin D1 --> Resetn pin 7

Garantie tot de deur :+

Arduino code:

code:
1
2
3
4
int CC_RST   = 5;
int CC_DC    = 4;
int CC_DD_I  = 14; // voor wemos d1
int CC_DD_O  = 12; // voor wemos d1

Scatman_II wijzigde deze reactie 15-02-2019 21:57 (6%)

OC / CM - Begint eer ge Bezint


  • Kvn
  • Registratie: maart 2001
  • Laatst online: 21:34
trekker22 schreef op maandag 25 februari 2019 @ 09:24:
[...]
En werken deze ook goed als router in je netwerk? Wil er 14 betellen ook nog 6 voor de badkamer.
Ik heb deze bij de Aldi gekocht een tijdje terug;
https://www.elv.de/mueller-licht-tint-5-4-w-gu10-led-lampe-36-farbtemperatur-einstellbar-zigbee.html

M'n netwerkmap ziet er sinds de laatste dev-versie erg mooi uit :-)
Zigbee2mqtt map

Kvn wijzigde deze reactie 25-02-2019 10:22 (50%)


  • jossie67
  • Registratie: oktober 2006
  • Laatst online: 14:18
Gisteren een Coordinator geupgrade naar '20190223' zigbee2mqtt is version 1.1.1 (commit #92d88b6)
Toch was alles niet meteen online, is in mijn geval niet zo'n een issue.
De lampen verwijderen en opnieuw toegevoegd

zigbee

Nu zijn mijn "RTCGQ11LM - Xiaomi Aqara human body movement and illuminance sensor" en "WSDCGQ01LM - Xiaomi MiJia temperature & humidity sensor"
wel online en geven ook data door aan MQTT. Maar ik zie in mijn networkmap geen verbindingen, kan ik dit nog fixen of even verwijderen en weer toevoegen?

Mijn networkmap staat in HA mbv

https://community.home-as...p-in-home-assistant/89116

  • flyboarder
  • Registratie: maart 2009
  • Laatst online: 22-05 20:50
Ik heb sinds gister de data van mijn 2 xiaomi aqara temperatuur sensoren via Domoticz in Grafana gezet. Maar zoals je kan zitten er heel veel onjuiste waarde tussen, waarvan vaak 0. Heeft hier iemand ook xiaomi sensoren verbonden via zigbee2mqtt en de data in Grafana staan? Als ik de sensor log in Domoticz zelf bekijk zie ik niks geks. Ik vraag mij af of het probleem zit in de waarde die via zigbee2mqtt binnen komen of dat het ligt aan de manier waarop Grafana de data verwerkt?


  • Kaspers
  • Registratie: juni 2004
  • Laatst online: 15:38
Dat ben ik helaas met je eens ;)
rinkel schreef op dinsdag 12 maart 2019 @ 21:45:
In de ts staat: zet zigbee2mqtt in pair modus
Hoe zet ik de cc2531 in pair modus?
Ik kan dit echt nergens terugvinden, ook niet op de zigbee2mqtt site
Het staat er wel degelijk in:




  • Kvn
  • Registratie: maart 2001
  • Laatst online: 21:34
mbuurman schreef op zaterdag 16 maart 2019 @ 15:12:
Na een week alleen Xiaomi sensoren actief te hebben met Zigbee2mqtt heb ik nu ook een Tradfri Leddriver via Zigbee2mgtt werkend. Sindsdien valt me op in de log dat ik elke keer 2 enties voorbij zie komen voor deze Leddriver:

Mar 16 14:47:11 raspberrypi npm[1378]: zigbee2mqtt:info 3/16/2019, 2:47:11 PM Zigbee publish to device '0x000d6ffffe2ac211', genOnOff - off - {} - {"manufSpec":0,"disDefaultRsp":0} - null
Mar 16 14:47:11 raspberrypi npm[1378]: zigbee2mqtt:info 3/16/2019, 2:47:11 PM MQTT publish: topic 'zigbee2mqtt/BGG - Gang - Schoenenkast verlichting', payload '{"state":"OFF","brightness":2}'

Herkent iemand dit gedrag en kan mij vertellen waarom dit gebeurd?
Tevens zou ik graag een networkmap willen maken om te zien of deze Leddriver zich ook als router is gaan gedragen, is dat makkelijk te doen?
Gebruik je Hass? Daar is een prima componentje voor https://community.home-as...p-in-home-assistant/89116

Dat ziet er bij mij inmiddels zo uit O+

Zigbee2mqtt map 2

Acties:
  • +1Henk 'm!

  • KRGT
  • Registratie: september 2001
  • Niet online

KRGT

Have a nice day!

Na ontvangst van de C2531 ben ik zo langzaamaan alles aan het overzetten naar Zigbee2Mqtt, zit nu op 31 devices.

Moest wel omflashen naar de Max stability firmware op de stick, de default ging een beetje over zijn zeur vanwege de hoeveelheid (denk ik, want op deze kunnen er nu maar max 5 op connecteren) en met de default liep de Zigbee2MQTT steeds "vast" of kon hij devices niet meer pingen.

https://github.com/Koenkk...ware/tree/dev/coordinator

De stick zit op een Pi, de MQTT broker draait op de HomeAssistant server en HA zelf kijkt weer naar localhost.

De Hue bridge is ondertussen uit, dan rest nog de Xiaomi bridge (nog een paar sensoren over) en de Ikea Hub en dan stuur ik alles aan met 1 bridge.

De grootste uitdaging zit soms in het wat dichterbij plaatsen van de coordinator, maar door de Pi op een USB lader te hangen kan ik die mobiel overal mee naartoe nemen :)

In de Zigbee2MQTT config maak ik gelijk groepen aan en met HA pagina DEV-MQTT verstuur ik de commando's om de groepen te vullen. (is wel een aanrader om groepen te bouwen, scheelt een hoop verkeer)

Klein stukje uit HA:

  • Possible
  • Registratie: mei 2002
  • Nu online
Is dit een beetje normaal? Ik heb namelijk 2 devices die nu niet lijken te connecten met de hub / stick?

Ze doen het overigens wel prima. Daarnaast heb ik ook 3 x xiaomi smart sockets welke blijkbaar als routers functioneren. Moet dit ook wat doen met het signaal?

1500wp-Z Live 5100wp-W Live 6600wp-Merged Live Altantic Explorer 200 Live


  • KRGT
  • Registratie: september 2001
  • Niet online

KRGT

Have a nice day!

@Possible

Aangezien ik niet online een graph kan maken ; hier zie je een beetje wat routers doen, alles doet het verder gewoon.

Vindt het vreemd dat bij je de enddevices niet geplot zijn qua lijntjes.

https://tweakers.net/ext/f/FNuoh72D5PCxRb33p4bx68Mx/thumb.png

  • Kvn
  • Registratie: maart 2001
  • Laatst online: 21:34
Ik ben een admin-tooltje aan het bouwen (Desktop, multiplatform), de node-red flow die ik nu gebruik komt me de neus uit.
Bij interesse deel ik 'm graag als ie af is.

Kvn wijzigde deze reactie 28-03-2019 22:17 (69%)
Reden: Beter plaatje


  • Kvn
  • Registratie: maart 2001
  • Laatst online: 21:34
Ik ben inmiddels een aardig end klaar, de laatste status:

Device overview



Logs



2 soorten networkmaps (zoom / pan mogelijk)




Voor de bindings / groups zoek ik nog even de juiste plek&vorm.

  • Possible
  • Registratie: mei 2002
  • Nu online
Grrrrr heb een klein probleempje met Zigbee2MQtt i.c.m. HA..

Als ik op de knop ''Allow devices to join'' druk, dan gaat de timer niet aan (10 min). Als ik de logs bekijk dan zie ik ook geen message ''zigbee2mqtt:info Zigbee: allowing new devices to join.''

Wat kan dit zijn? Het heeft altijd gewerkt namelijk en heb verder niks aangepast?

Bridge state is wel gewoon online

Possible wijzigde deze reactie 05-04-2019 09:31 (12%)

1500wp-Z Live 5100wp-W Live 6600wp-Merged Live Altantic Explorer 200 Live


  • Sjef_
  • Registratie: september 2012
  • Laatst online: 16:56
Possible schreef op vrijdag 5 april 2019 @ 09:29:
Grrrrr heb een klein probleempje met Zigbee2MQtt i.c.m. HA..

Als ik op de knop ''Allow devices to join'' druk, dan gaat de timer niet aan (10 min). Als ik de logs bekijk dan zie ik ook geen message ''zigbee2mqtt:info Zigbee: allowing new devices to join.''

Wat kan dit zijn? Het heeft altijd gewerkt namelijk en heb verder niks aangepast?

Bridge state is wel gewoon online

[Afbeelding]
Beetje lastig te zeggen zo.
Wat gebeurt er in je log als je "true" naar het topic "zigbee2mqtt/bridge/config/permit_join" stuur?


  • Sjef_
  • Registratie: september 2012
  • Laatst online: 16:56
Possible schreef op vrijdag 5 april 2019 @ 11:28:
[...]


Wou het net doen haha :)

Bij deze:


code:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
- id: enable_zigbee_join
  alias: Enable Zigbee joining
  hide_entity: true
  trigger:
    platform: state
    entity_id: input_boolean.zigbee_permit_join
    to: 'on'
  action:
  - service: mqtt.publish
    data:
      topic: zigbee2mqtt/bridge/config/permit_join
      payload: 'true'
  - service: timer.start
    data:
      entity_id: timer.zigbee_permit_join
- id: disable_zigbee_join
  alias: Disable Zigbee joining
  trigger:
  - entity_id: input_boolean.zigbee_permit_join
    platform: state
    to: 'off'
  action:
  - data:
      payload: 'false'
      topic: zigbee2mqtt/bridge/config/permit_join
    service: mqtt.publish
  - data:
      entity_id: timer.zigbee_permit_join
    service: timer.cancel
  hide_entity: true


- id: disable_zigbee_join_timer
  alias: Disable Zigbee joining by timer
  hide_entity: true
  trigger:
  - platform: event
    event_type: timer.finished
    event_data:
      entity_id: timer.zigbee_permit_join
  action:
  - service: mqtt.publish
    data:
      topic: zigbee2mqtt/bridge/config/permit_join
      payload: 'false'
  - service: input_boolean.turn_off
    data:
      entity_id: input_boolean.zigbee_permit_join

Dat ziet er goed uit...
Staan je automations wel aan?

  • bing69
  • Registratie: december 2000
  • Laatst online: 08:27
chriistiix schreef op maandag 8 april 2019 @ 16:21:
[...]


Zou je is een screenshot willen delen van je apparaatbeheer & de Flash programmer?
Kunnen we even de basis dingen uitsluiten!
vergeten de vermelden, het flashprogramma is 1.12.8

Hierbij de screenshots

https://www.dropbox.com/s/tb6515hcxo3w300/beheer.jpg?dl=0
https://www.dropbox.com/s/q7iwrugsx1m4lrf/debug.jpg?dl=0

Bing


Acties:
  • 0Henk 'm!

  • renedis
  • Registratie: juli 2003
  • Laatst online: 22-05 13:18
Imperial Guard schreef op donderdag 16 mei 2019 @ 09:02:
[quote]renedis schreef op woensdag 15 mei 2019 @ 13:40:
[...]
Werkt dit inmiddels goed? Ben wel benieuwd eigenlijk, misschien dat ik dan ook compleet over ga op dit systeem.
[...]

Ja tot zover geen issues :) paar kleine workarounds moeten doen om het als een HVAC thermostaat aan de praat kunnen krijgen voor Home Assistant.

Indien nodig kan ik je de scripts, etc wel delen.
Ik wil graag gebruik maken van je scripts indien mogelijk :> Auto-discovery in HA geeft enkel dit weer:



Moet wel zeggen, het is een behoorlijk groot apparaat maar wel redelijk stil. Installeren en configureren ging overigens bizar makkelijk tot zo ver. Ingebouwde temperatuurmeter en setpoint kan ik nog niet over oordelen uiteraard.
Pagina: 1


OnePlus 7 Pro (8GB intern) Microsoft Xbox One S All-Digital Edition LG OLED C9 Google Pixel 3a XL FIFA 19 Samsung Galaxy S10 Sony PlayStation 5 Smartphones

Tweakers vormt samen met Tweakers Elect, Hardware.Info, Autotrack, Nationale Vacaturebank, Intermediair en Independer de Persgroep Online Services B.V.
Alle rechten voorbehouden © 1998 - 2019 Hosting door True