Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie
Toon posts:

SpotWeb - Webbased Spotnet - deel 2 Vorige deelOverzicht

Pagina: 1 ... 43 44 45 Laatste
Acties:

Acties:
  • +1Henk 'm!

  • Peter is Gamer
  • Registratie: oktober 2003
  • Laatst online: 13-11 12:05
Ik heb exact het zelfde probleem, een oplossing heb ik helaas nog niet.

Het volledig verwijderen en opnieuw aanmaken is in ieder geval niet de oplossing (voor mij)

Ik draai de volgende versies:
Webstation 2.1.7.-0147
HTTP backend: Apache HTTP Server 2.2
PHP versie: php5.6
Sa1 schreef op donderdag 6 juni 2019 @ 10:36:
Heb sinds 2 dagen een probleempje. Volgens mij is er niets gewijzigd, maar goed, er zal wel 'iets' veranderd zijn. Ik heb een scheduled task in m'n synology, die automatisch retrieve.php aftrapt.

Doet eigenlijk geen gekke dingen anders dan het aftrappen van het commando, het ziet er als volgt uit:

code:
1
2
cd /volume1/web/spotweb/
sudo /usr/local/bin/php56 /volume1/web/spotweb/retrieve.php --force


Ik had dus al 2 dagen geen updates meer, dus ik in de log kijken kom ik het volgende tegen:

code:
1
Unable to connect to database: SQLSTATE[HY000] [2002] No such file or directory


Dat is even schrikken natuurlijk, maar de site doet het prima dus de DB koppeling is er gewoon nog. Ook even naar de dbsettings gekeken, juiste gegevens en met die gegevens kan ik via MySQL ook gewoon aanmelden bij de DB.

Nu als ik druk op 'retrieve' op de site zelf, dan doet ie het dus ook gewoon. Dus alleen van commandline af doet ie het niet.

Via SSH aftrappen van 't commando lukt dus ook niet, krijg ik dezelfde foutmelding. Nu zie ik wel dat de retrieve knop op de site een APIKEY mee stuurt, maar daar kan het toch niets mee te maken hebben? 't Heeft het altijd gewoon vlekkenloos gedaan.

ps, kom wel veel dezelfde melding ook in dit forum tegen, maar niet echt een oplossing, iemand die al gevonden?

Peter is Gamer wijzigde deze reactie 07-06-2019 09:46 (3%)


Acties:
  • +2Henk 'm!

  • AuroraNL
  • Registratie: juni 2001
  • Laatst online: 13:56
Zelfde probleem hier, lijkt gekomen na een update van PHP56. Ik ben nu overgeschakeld naar PHP70 (in webstation samen met Nginx). Na de wizzard van spotweb opnieuw te doorlopen kreeg ik bij retrieve een foutmelding, die is opgelost door handmatig /usr/local/etc/php70/conf.d/webstation-extensions.ini aan te maken met de volgende content:

extension = bcmath.so
extension = bz2.so
extension = curl.so
extension = gd.so
extension = gettext.so
extension = openssl.so
extension = pdo_mysql.so
extension = zip.so

retrieve vanaf de CLI werkt weer, vergeet niet je cronjob aan te passen naar PHP70 :)

Acties:
  • 0Henk 'm!

  • Sa1
  • Registratie: oktober 2000
  • Laatst online: 11:21
Peter is Gamer schreef op vrijdag 7 juni 2019 @ 09:42:
Ik heb exact het zelfde probleem, een oplossing heb ik helaas nog niet.

Het volledig verwijderen en opnieuw aanmaken is in ieder geval niet de oplossing (voor mij)

Ik draai de volgende versies:
Webstation 2.1.7.-0147
HTTP backend: Apache HTTP Server 2.2
PHP versie: php5.6


[...]
Ik gebruik exact dezelfde versies. K ga eens kijken of de upgrade inderdaad voor mij hetgeen ook oplost.

Okay, heb de boel omgezet en werkt. Wel is het inderdaad noodzakelijk om die .ini aan te maken zoals AuroraNL aangeeft, anders doet de retrieve.php via de commandline het nog steeds niet. De website deed het wel direct, ik hoefde achteraf denk ik niet install.php te draaien.

Super, heel fijn, tnx!

Sa1 wijzigde deze reactie 07-06-2019 11:46 (22%)


Acties:
  • 0Henk 'm!

  • Sa1
  • Registratie: oktober 2000
  • Laatst online: 11:21
Goed, volgende probleem. Zal hier zeker aan gerelateerd zijn. Als ik nu een NZB push naar SabNZB, wat uiteraard altijd gefunctioneerd heeft geeft nu een foutmelding in SabNZB.

code:
1
Invalid NZB file LinuxDistro.nzb, skipping (reason=syntax error, line=2)


Kan dat te maken hebben dat die nog op PHP56 draait ofzo?

Als ik een NZB zelf download, dan staat het volgende in de eerste paar lines:

code:
1
2
3
4
5
Warning: fileperms(): stat failed for /volume1/web/spotweb/lib/../cache/nzb/56 in /volume1/web/spotweb/lib/dao/Base/Dao_Base_Cache.php on line 293

Warning: fileowner(): stat failed for /volume1/web/spotweb/lib/../cache/nzb/56 in /volume1/web/spotweb/lib/dao/Base/Dao_Base_Cache.php on line 294

Warning: filegroup(): stat failed for /volume1/web/spotweb/lib/../cache/nzb/56 in /volume1/web/spotweb/lib/dao/Base/Dao_Base_Cache.php on line 295


Lijkt me niet goed, toch? Die 56 zal refereren naar PHP versie.

M'n vermoeden klopt wel. Als ik die NZB incl deze 3 lines upload naar SAB, dan zegt hij hetzelfde. Haal ik de 3 lines weg, dan start hij direct met downloaden. Iets in spotweb genereert dit dus, maar wat.

Edit:

En opgelost.

code:
1
php70 ./bin/check-cache.php



Nu lijkt alles weer keurig te werken.

Sa1 wijzigde deze reactie 07-06-2019 12:57 (62%)


Acties:
  • 0Henk 'm!

  • Ringgss
  • Registratie: oktober 2001
  • Laatst online: 16-11 22:28
Bij testen van configuratie krijg ik de volgende foutmelding

Include(/opt/lampp/htdocs/spotweb/vendor/composer/../../lib/dao/Mysql/Dao_Mysql_Factory.php): failed to open stream: No such file or directoryinclude(): Failed opening '/opt/lampp/htdocs/spotweb/vendor/composer/../../lib/dao/Mysql/Dao_Mysql_Factory.php' for inclusion (include_path='.:/opt/lampp/lib/php')
Fatal error: Uncaught Error: Class 'Dao_Mysql_Factory' not found in /opt/lampp/htdocs/spotweb/lib/dao/Dao_Factory.php:118 Stack trace: #0 /opt/lampp/htdocs/spotweb/lib/SpotInstall.php(287): Dao_Factory::getDAOFactory('pdo_mysql') #1 /opt/lampp/htdocs/spotweb/install.php(71): SpotInstall::askSpotwebSettings() #2 {main} thrown in /opt/lampp/htdocs/spotweb/lib/dao/Dao_Factory.php on line 118

config:
Ubuntu 18.04
Xampp

Ringgss wijzigde deze reactie 10-06-2019 10:52 (0%)
Reden: Typo


Acties:
  • 0Henk 'm!

  • Sa1
  • Registratie: oktober 2000
  • Laatst online: 11:21
En je vraag is?

Acties:
  • +1Henk 'm!

  • duiveltje666
  • Registratie: mei 2005
  • Laatst online: 13:02
Peter is Gamer schreef op vrijdag 7 juni 2019 @ 09:42:
Ik heb exact het zelfde probleem, een oplossing heb ik helaas nog niet.

Het volledig verwijderen en opnieuw aanmaken is in ieder geval niet de oplossing (voor mij)

Ik draai de volgende versies:
Webstation 2.1.7.-0147
HTTP backend: Apache HTTP Server 2.2
PHP versie: php5.6


[...]
Please note the 2.2.x branch has now passed the end of life at the Apache HTTP Server project and no further activity will occur including security patches. Users must promptly complete their transitions to this 2.4.x release of httpd to benefit from further bug fixes or new features.
Perhaps es upgraden ?

  • Ringgss
  • Registratie: oktober 2001
  • Laatst online: 16-11 22:28
Iemand enig idee wat er fout gaat?

Update: Heb het werkend, na nieuwe pull van git

Ringgss wijzigde deze reactie 10-06-2019 19:51 (13%)


  • mrwolf
  • Registratie: maart 2001
  • Niet online
Peter is Gamer schreef op vrijdag 7 juni 2019 @ 09:42:
Ik heb exact het zelfde probleem, een oplossing heb ik helaas nog niet.

Het volledig verwijderen en opnieuw aanmaken is in ieder geval niet de oplossing (voor mij)

Ik draai de volgende versies:
Webstation 2.1.7.-0147
HTTP backend: Apache HTTP Server 2.2
PHP versie: php5.6


[...]
Drie dagen gezocht naar een oplossing, en gevonden!

  • Slowmotion
  • Registratie: maart 2002
  • Laatst online: 13:46
Thanks, wel een oplossing waar je op moet komen..

  • Sangroid
  • Registratie: oktober 2004
  • Niet online

Sangroid

SjoebieDoowah.

@mrwolf Thanks, prima oplossing, ik had het zoeken al wat eerder opgegeven...

  • d-vine
  • Registratie: augustus 2006
  • Laatst online: 11:41
Door de laatste problemen met spotweb wat ik opgelost kreeg (poortnummer bij localhost) dacht ik laat ik spotweb net als mijn wordpress overzetten op php72. Alles draait op mijn synology DS716

Nu draait alles goed en ik kan via putty alles keer op keer binnenhalen. Echter via taakplanner van mijn synology komt er een fout melding acces denied
Deze werkte altijd bij php56 en dezelfde command line heb ik aangepast naar php72.
In putty werkt deze command line maar synology niet.
ik heb op advies al keer sudo -i bij command gezet maar dat mocht niet baten.


/usr/local/bin/php72 /volume1/web/spotweb/retrieve.php

https://tweakers.net/ext/f/eo2ZjVigPwTgqqBrchIeOv0e/thumb.jpg

de taakplanner met user root ingesteld

-- foutmelding via mail --
foutmelding via mail
Taak: Spotweb retrive
Starttijd: Thu, 27 Jun 2019 11:38:23 GMT
Stoptijd: Thu, 27 Jun 2019 11:38:23 GMT
Huidige status: 255 (Onderbroken)
Standaard uitvoer/fout:


SpotWeb v0.68.29.32 on PHP v7.2.13 crashed

Fatal error occured retrieving reports:
Permission denied [21] for objectid []


#0 {main}

PHP Notice: Undefined variable: retriever in /volume1/web/spotweb/retrieve.php on line 304

Notice: Undefined variable: retriever in /volume1/web/spotweb/retrieve.php on line 304
PHP Fatal error: Uncaught Error: Call to a member function quit() on null in /volume1/web/spotweb/retrieve.php:304
Stack trace:
#0 {main}
thrown in /volume1/web/spotweb/retrieve.php on line 304

Fatal error: Uncaught Error: Call to a member function quit() on null in /volume1/web/spotweb/retrieve.php:304
Stack trace:
#0 {main}
thrown in /volume1/web/spotweb/retrieve.php on line 304

---------------------------------------------------------------------------------------------------------------------------------

Omdat het met putty wel werkt en ik de toegang foutmelding krijg in synology terwijl ik niets met de rechten heb gedaan na aanpassen php56 naar php72 ben ik een beetje het spoor bijster.

EDIT:
opgelost
Ik heb met puty de root rechten nog een keer doorgevoerd op de map en files.
Het werkte niet met handmatig uitvoeren ik was er even klaar mee maar vanmorgen kreeg ik ineens een mail dat mijn spots zijn binnengehaald. Ik juich nog niet te vroeg maar hoop dat dit het was.
blijft raar dat het handmatig uitvoeren een fout gaf en nu met dat geplande tijd van de taak het goed gaat

d-vine wijzigde deze reactie 01-07-2019 09:34 (9%)


Acties:
  • 0Henk 'm!

  • Sa1
  • Registratie: oktober 2000
  • Laatst online: 11:21
Sinds m'n upgrade naar PHP70 heb ik een vervelend terugkomend probleem. Als ik een NZB doorstuur naar SabNZB dan vindt hij hem fout. Dat klopt ook want als je hem handmatig download (de nzb) dan staan er regels in als volgt:
code:
1
2
3
4
5
Warning: fileperms(): stat failed for /volume1/web/spotweb/lib/../cache/nzb/64 in /volume1/web/spotweb/lib/dao/Base/Dao_Base_Cache.php on line 293

Warning: fileowner(): stat failed for /volume1/web/spotweb/lib/../cache/nzb/64 in /volume1/web/spotweb/lib/dao/Base/Dao_Base_Cache.php on line 294

Warning: filegroup(): stat failed for /volume1/web/spotweb/lib/../cache/nzb/64 in /volume1/web/spotweb/lib/dao/Base/Dao_Base_Cache.php on line 295

Als ik handmatig deze regels weghaal, en upload naar Sab dan werkt het gewoon.

Ik kan deze regels wegkrijgen door de cache te checken ( php70 ./check-cache.php). Maar dit lijkt niet altijd te werken.

Heeft iemand dit wel is gehad? Of hier een oplossing voor of een idee waar dit vandaan komt?

Acties:
  • 0Henk 'm!

  • thejoker80
  • Registratie: april 2002
  • Niet online

thejoker80

leuk hè?

een klein vraagje. Ik heb handmatig de retrieve uitgevoerd maar hij laadt alleen spots van voor 2009..... iemand enig idee. Ik zag wel dat in de settings de retentie op 50 dagen staat maar de datum vanaf stond nog op de allereerste datum, 1-1-2007 geloof ik.

Ik heb de retrieve gisterochtend gestart en vanochtend was hij niks verder dan gistermiddag. Als ik de retrieve echter opnieuw probeer uit te voeren zegt hij dat er al een proces loopt.

moet ik eerst een nieuwe retrieve forcen? (of moet ik daarvoor de database is weggooien? Ik heb de database overigens niet op shared staan, kan dat kwaad?)

Acties:
  • +1Henk 'm!

  • Sa1
  • Registratie: oktober 2000
  • Laatst online: 11:21
thejoker80 schreef op maandag 8 juli 2019 @ 11:27:
een klein vraagje. Ik heb handmatig de retrieve uitgevoerd maar hij laadt alleen spots van voor 2009..... iemand enig idee. Ik zag wel dat in de settings de retentie op 50 dagen staat maar de datum vanaf stond nog op de allereerste datum, 1-1-2007 geloof ik.

Ik heb de retrieve gisterochtend gestart en vanochtend was hij niks verder dan gistermiddag. Als ik de retrieve echter opnieuw probeer uit te voeren zegt hij dat er al een proces loopt.

moet ik eerst een nieuwe retrieve forcen? (of moet ik daarvoor de database is weggooien? Ik heb de database overigens niet op shared staan, kan dat kwaad?)
Je kunt hem nog een x starten met de optie --force, start je hem overigens van de commandline? Denk het haast niet.

Acties:
  • 0Henk 'm!

  • thejoker80
  • Registratie: april 2002
  • Niet online

thejoker80

leuk hè?

Sa1 schreef op maandag 8 juli 2019 @ 11:54:
[...]
Je kunt hem nog een x starten met de optie --force, start je hem overigens van de commandline? Denk het haast niet.
ga ik doen, via putty.

  • Tomba
  • Registratie: mei 2000
  • Laatst online: 13:52

Tomba

Quis custodiet ipsos custodes?

3 dagen geleden heb ik (met Git) mijn spotweb bijgewerkt, de upgrade-db.php gerund en sindsdien haalt de retriever geen nieuwe spots meer op. Als ik m handmatig run krijg ik de melding dat retriever.php al loopt. Als ik --force toevoeg krijg ik deze melding:

code:
1
2
3
4
5
6
7
8
9
10
11
php /var/www/spotweb/spotweb/retrieve.php --force
Last retrieve at Wed 31 Jul 2019 11:30:51 AM CEST
Retrieving new Spots from server news.newshosting.com...
Appr. Message count:    3285102
First message number:   2
Last message number:    3285104
Current article number: 3284025

Retrieving 3284025 till 3285105 (parsed: 1080, in DB: 0, signed: 998, invalid: 23, rtntn.skip: 0, mod: 59, full: 0, total: 1080)Programming error for: INSERT INTO spots(messageid, poster, title, tag, category, subcata,
                                                                                                                subcatb, subcatc, subcatd, subcatz, stamp, reversestamp, filesize, spotterid)
                                                                        VALUES


De table zelf lijkt mij in orde:

code:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
mysql> show columns from spots;
+--------------+---------------------+------+-----+---------+----------------+
| Field        | Type                | Null | Key | Default | Extra          |
+--------------+---------------------+------+-----+---------+----------------+
| id           | int(11)             | NO   | PRI | NULL    | auto_increment |
| messageid    | varchar(128)        | NO   | UNI |         |                |
| poster       | varchar(128)        | YES  | MUL | NULL    |                |
| title        | varchar(128)        | YES  | MUL | NULL    |                |
| tag          | varchar(128)        | YES  | MUL | NULL    |                |
| category     | int(11)             | YES  | MUL | NULL    |                |
| subcata      | varchar(64)         | YES  |     | NULL    |                |
| subcatb      | varchar(64)         | YES  |     | NULL    |                |
| subcatc      | varchar(64)         | YES  |     | NULL    |                |
| subcatd      | varchar(64)         | YES  |     | NULL    |                |
| subcatz      | varchar(64)         | YES  |     | NULL    |                |
| stamp        | int(10) unsigned    | YES  | MUL | NULL    |                |
| reversestamp | int(11)             | YES  | MUL | 0       |                |
| filesize     | bigint(20) unsigned | NO   |     | 0       |                |
| moderated    | tinyint(1)          | YES  |     | NULL    |                |
| commentcount | int(11)             | YES  |     | 0       |                |
| spotrating   | int(11)             | YES  |     | 0       |                |
| reportcount  | int(11)             | YES  |     | 0       |                |
| spotterid    | varchar(32)         | YES  | MUL | NULL    |                |
| editstamp    | int(10) unsigned    | YES  |     | NULL    |                |
| editor       | varchar(128)        | YES  |     | NULL    |                |
+--------------+---------------------+------+-----+---------+----------------+
21 rows in set (0.00 sec)



Het nogmaals runnen van upgrade-db.php geeft een crash:

code:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
php /var/www/spotweb/spotweb/bin/upgrade-db.php
Updating schema..(pdo_mysql)
        Validating spots(messageid)
        Validating spots(poster)
        Validating spots(title)
        Validating spots(tag)
        Validating spots(category)
        Validating spots(subcata)
        Validating spots(subcatb)
        Validating spots(subcatc)
        Validating spots(subcatd)
        Validating spots(subcatz)
        Validating spots(stamp)
                Modifying column stamp (type) on spots
        Validating spots(reversestamp)
        Validating spots(filesize)
                Modifying column filesize (type) on spots


SpotWeb crashed

Database schema or settings upgrade failed:
   42000: 1064: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'BIGINTEGER UNSIGNED  DEFAULT 0 NOT NULL' at line 1


#0 /var/www/spotweb/spotweb/lib/dbstruct/SpotStruct_mysql.php(223): dbeng_pdo->rawExec('ALTER TABLE spo...')
#1 /var/www/spotweb/spotweb/lib/dbstruct/SpotStruct_abs.php(161): SpotStruct_mysql->modifyColumn('filesize', 'spots', 'BIGINTEGER UNSI...', 'DEFAULT 0', true, '', 'type')
#2 /var/www/spotweb/spotweb/lib/dbstruct/SpotStruct_abs.php(356): SpotStruct_abs->validateColumn('filesize', 'spots', 'BIGINTEGER UNSI...', '0', true, '')
#3 /var/www/spotweb/spotweb/lib/services/Upgrade/Services_Upgrade_Base.php(42): SpotStruct_abs->updateSchema()
#4 /var/www/spotweb/spotweb/bin/upgrade-db.php(34): Services_Upgrade_Base->database()


Iemand enig idee hoe ik dit zou kunnen fixen? Systeem draait op Ubuntu 18.04 (met alle updates)

Tomba wijzigde deze reactie 03-08-2019 11:05 (67%)

tomba.tweakblogs.net || Mijn V&A


  • Tomba
  • Registratie: mei 2000
  • Laatst online: 13:52

Tomba

Quis custodiet ipsos custodes?

Tomba schreef op zaterdag 3 augustus 2019 @ 11:01:
3 dagen geleden heb ik (met Git) mijn spotweb bijgewerkt, de upgrade-db.php gerund en sindsdien haalt de retriever geen nieuwe spots meer op. Als ik m handmatig run krijg ik de melding dat retriever.php al loopt. Als ik --force toevoeg krijg ik deze melding:

code:
1
2
3
4
5
6
7
8
9
10
11
php /var/www/spotweb/spotweb/retrieve.php --force
Last retrieve at Wed 31 Jul 2019 11:30:51 AM CEST
Retrieving new Spots from server news.newshosting.com...
Appr. Message count:    3285102
First message number:   2
Last message number:    3285104
Current article number: 3284025

Retrieving 3284025 till 3285105 (parsed: 1080, in DB: 0, signed: 998, invalid: 23, rtntn.skip: 0, mod: 59, full: 0, total: 1080)Programming error for: INSERT INTO spots(messageid, poster, title, tag, category, subcata,
                                                                                                                subcatb, subcatc, subcatd, subcatz, stamp, reversestamp, filesize, spotterid)
                                                                        VALUES


De table zelf lijkt mij in orde:

code:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
mysql> show columns from spots;
+--------------+---------------------+------+-----+---------+----------------+
| Field        | Type                | Null | Key | Default | Extra          |
+--------------+---------------------+------+-----+---------+----------------+
| id           | int(11)             | NO   | PRI | NULL    | auto_increment |
| messageid    | varchar(128)        | NO   | UNI |         |                |
| poster       | varchar(128)        | YES  | MUL | NULL    |                |
| title        | varchar(128)        | YES  | MUL | NULL    |                |
| tag          | varchar(128)        | YES  | MUL | NULL    |                |
| category     | int(11)             | YES  | MUL | NULL    |                |
| subcata      | varchar(64)         | YES  |     | NULL    |                |
| subcatb      | varchar(64)         | YES  |     | NULL    |                |
| subcatc      | varchar(64)         | YES  |     | NULL    |                |
| subcatd      | varchar(64)         | YES  |     | NULL    |                |
| subcatz      | varchar(64)         | YES  |     | NULL    |                |
| stamp        | int(10) unsigned    | YES  | MUL | NULL    |                |
| reversestamp | int(11)             | YES  | MUL | 0       |                |
| filesize     | bigint(20) unsigned | NO   |     | 0       |                |
| moderated    | tinyint(1)          | YES  |     | NULL    |                |
| commentcount | int(11)             | YES  |     | 0       |                |
| spotrating   | int(11)             | YES  |     | 0       |                |
| reportcount  | int(11)             | YES  |     | 0       |                |
| spotterid    | varchar(32)         | YES  | MUL | NULL    |                |
| editstamp    | int(10) unsigned    | YES  |     | NULL    |                |
| editor       | varchar(128)        | YES  |     | NULL    |                |
+--------------+---------------------+------+-----+---------+----------------+
21 rows in set (0.00 sec)



Het nogmaals runnen van upgrade-db.php geeft een crash:

code:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
php /var/www/spotweb/spotweb/bin/upgrade-db.php
Updating schema..(pdo_mysql)
        Validating spots(messageid)
        Validating spots(poster)
        Validating spots(title)
        Validating spots(tag)
        Validating spots(category)
        Validating spots(subcata)
        Validating spots(subcatb)
        Validating spots(subcatc)
        Validating spots(subcatd)
        Validating spots(subcatz)
        Validating spots(stamp)
                Modifying column stamp (type) on spots
        Validating spots(reversestamp)
        Validating spots(filesize)
                Modifying column filesize (type) on spots


SpotWeb crashed

Database schema or settings upgrade failed:
   42000: 1064: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'BIGINTEGER UNSIGNED  DEFAULT 0 NOT NULL' at line 1


#0 /var/www/spotweb/spotweb/lib/dbstruct/SpotStruct_mysql.php(223): dbeng_pdo->rawExec('ALTER TABLE spo...')
#1 /var/www/spotweb/spotweb/lib/dbstruct/SpotStruct_abs.php(161): SpotStruct_mysql->modifyColumn('filesize', 'spots', 'BIGINTEGER UNSI...', 'DEFAULT 0', true, '', 'type')
#2 /var/www/spotweb/spotweb/lib/dbstruct/SpotStruct_abs.php(356): SpotStruct_abs->validateColumn('filesize', 'spots', 'BIGINTEGER UNSI...', '0', true, '')
#3 /var/www/spotweb/spotweb/lib/services/Upgrade/Services_Upgrade_Base.php(42): SpotStruct_abs->updateSchema()
#4 /var/www/spotweb/spotweb/bin/upgrade-db.php(34): Services_Upgrade_Base->database()


Iemand enig idee hoe ik dit zou kunnen fixen? Systeem draait op Ubuntu 18.04 (met alle updates)
Niemand een idee? Heb niet zo'n zin om heel Spotweb opnieuw te installeren :'(

tomba.tweakblogs.net || Mijn V&A


  • nero355
  • Registratie: februari 2002
  • Laatst online: 00:14

nero355

ph34r my [WCG] Cows :P

Tomba schreef op zondag 4 augustus 2019 @ 13:38:
Niemand een idee? Heb niet zo'n zin om heel Spotweb opnieuw te installeren :'(
Zeker ook geen backups gemaakt ?! :P

Maar ehh... waarom probeer je niet te achterhalen op welk PID dat script loopt VOORDAT je opties als -force gaat proberen :?

Ik zou zeggen doe dat nu alsnog en kijk hoe ver je komt :)

|| DPC GoT WhatPulse Team :) || Pi-Hole : Geen advertenties meer voor je hele netwerk! >:) ||


  • Tomba
  • Registratie: mei 2000
  • Laatst online: 13:52

Tomba

Quis custodiet ipsos custodes?

nero355 schreef op zondag 4 augustus 2019 @ 14:49:
[...]

Zeker ook geen backups gemaakt ?! :P
Nee geen backup gemaakt, tot op heden ook nog nooit nodig gehad d'oh.
nero355 schreef op zondag 4 augustus 2019 @ 14:49:
[...]
Maar ehh... waarom probeer je niet te achterhalen op welk PID dat script loopt VOORDAT je opties als -force gaat proberen :?
Aangezien

code:
1
ps ax | grep php


geen PID terug gaf leek het me aannemelijk dat het script niet liep, vandaar dat ik --force geprobeerd heb.

NB de foutmelding die ik hierboven post staat vanaf de git pull in de logfile, issue is dus direct na upgrade ontstaan.
nero355 schreef op zondag 4 augustus 2019 @ 14:49:
[...]
Ik zou zeggen doe dat nu alsnog en kijk hoe ver je komt :)
Geen stap verder natuurlijk :) Error blijft hetzelfde, heb in crontab de scheduled task uitgeschakeld en server gereboot. Daarna wil retrieve.php eenmalig runnen zonder --force om er dus mee te kappen...

Gezien het feit dat niemand verder reageert loop ik ogenschijnlijk tegen een volledig onbekend Spotweb issue aan :( Zit niets anders op dan een rebuild vrees ik :X :'(

tomba.tweakblogs.net || Mijn V&A


  • pven
  • Registratie: oktober 1999
  • Niet online
@Tomba Heb je geprobeerd om via git naar een vorige release terug te gaan? Met wat geluk heb dan weer iets werkends.

Telegram || Marktplaats-meuk. Afdingen mag! ;-) || slotje.com for sale || DM mij


  • Tomba
  • Registratie: mei 2000
  • Laatst online: 13:52

Tomba

Quis custodiet ipsos custodes?

pven schreef op dinsdag 6 augustus 2019 @ 08:11:
@Tomba Heb je geprobeerd om via git naar een vorige release terug te gaan? Met wat geluk heb dan weer iets werkends.
Yes en ook een compleet nieuwe git pull, maar probleem blijft. Issue moet dus wel aan de database kant zitten, vrees dat t dus kwestie wordt van alle spots opnieuw binnen halen....

tomba.tweakblogs.net || Mijn V&A


  • alesandro_46
  • Registratie: januari 2012
  • Laatst online: 10:35
Tomba schreef op dinsdag 6 augustus 2019 @ 08:29:
[...]

Yes en ook een compleet nieuwe git pull, maar probleem blijft. Issue moet dus wel aan de database kant zitten, vrees dat t dus kwestie wordt van alle spots opnieuw binnen halen....
Misschien is het een optie om een tijdelijke database aan te maken, de gegevens daarvan in te vullen in de 'dbsettings.inc.php' en kijken of de retrieve dan wel verder gaat?

Deze ruimte is bewust leeg gelaten


  • Tomba
  • Registratie: mei 2000
  • Laatst online: 13:52

Tomba

Quis custodiet ipsos custodes?

alesandro_46 schreef op dinsdag 6 augustus 2019 @ 08:38:
[...]

Misschien is het een optie om een tijdelijke database aan te maken, de gegevens daarvan in te vullen in de 'dbsettings.inc.php' en kijken of de retrieve dan wel verder gaat?
Temp database + opnieuw runnen van install.php loopt ook stuk tijdens de initialisatie van de database (MYSQL error op de ROW filesize BIGINT), ik denk dat er een bug in de develop branch zit...
Switch naar Master via

code:
1
2
git checkout master
bin/upgrade-db.php


en alles werkt weer :)

tomba.tweakblogs.net || Mijn V&A


  • mesa57
  • Registratie: juni 2006
  • Laatst online: 18-11 21:41
Er zijn inderdaad recent wat updates in de develop branch geweest.
Bedankt voor het melden !

  • Tomba
  • Registratie: mei 2000
  • Laatst online: 13:52

Tomba

Quis custodiet ipsos custodes?

mesa57 schreef op dinsdag 6 augustus 2019 @ 19:27:
Er zijn inderdaad recent wat updates in de develop branch geweest.
Bedankt voor het melden !
Graag gedaan. Zit me ook af te vragen waarom ik ook alweer überhaupt de develop branch draaide :p Er was ooit een reden voor maar welke? Geen idee ;) Voor nu weer helemaal happy!

tomba.tweakblogs.net || Mijn V&A


  • mesa57
  • Registratie: juni 2006
  • Laatst online: 18-11 21:41
De nieuwste patches vind je natuurlijk op de develop branch.
Ditmaal was het echter een niet volledig geteste pull request van een andere developer.
Werkte wel goed bij hem, maar dus niet bij anderen.

  • ariekanari
  • Registratie: april 2009
  • Laatst online: 12:39
pven schreef op vrijdag 12 april 2019 @ 18:18:
Hm, hij is niet helemaal in orde:

code:
1
2
3
$ /usr/bin/php /blaat/spotweb/retrieve.php
PHP Parse error:  syntax error, unexpected '.', expecting ',' or ';' in /blaat/spotweb/lib/SpotDebug.php on line 17
$

@Matis Ik ken de foutmelding, maar na een paar keer klikken lost ie zichzelf meestal op. Mijn usenet-server was voor de update nog bereikbaar voor het retrieve-gebeuren. Het is een klein block-account welke ik alleen voor spotweb gebruik, te veel lijntjes kan dus eigenlijk niet. Het werkt voor geen enkele spot neer, het lijkt me stug dat alle spots weg zijn.

Werkt het met de laatste update bij jou nog wel?

Kleine update: ik heb de backup terug gezet, dan werkt het weer wel zoals het hoort. Ligt dus echt ergens aan een update. Ik heb ze nu heel even naast elkaar staan in verschillende directories maar met dezelfde database. Het is overduidelijk dat het door de update komt.
Matis schreef op vrijdag 12 april 2019 @ 21:48:
@pven ikzelf heb de laatste versie van SpotWeb (nog) niet gedownload, maar jouw foutmelding leidt me naar een volgend issue: https://github.com/spotweb/spotweb/issues/408

Probeer dat eens...
Dank voor bovenstaande info.
Ik dacht laat ik Spotweb weer eens activeren op mijn Zyxel NAS520 en updaten naar een recente versie.
Hetzelfde probleem speelt ook op de Zyxel NAS520/540/542 (en mogelijk andere modellen)
Geïnstalleerde phpMyAdmin versie-informatie: 4.1.14.3, meest recente versie: 4.9.0.1.

code:
1
Parse error: syntax error, unexpected '.', expecting ',' or ';' in /i-data/e162cf92/www/spotweb/lib/SpotDebug.php on line 17


Vervangen en toevoegen in SpotDebug.php

code:
1
2
3
4
5
6
7
    static private $_logDir;
    static private $_debugLogDao = null;

    function __construct()
    {
    $_logDir = __DIR__ . '/../logs';
    }

Hierna werkt het weer met:

code:
1
2
LD_LIBRARY_PATH=/i-data/e162cf92/.PKG/PHP-MySQL-phpMyAdmin/lib
~ # /i-data/e162cf92/.PKG/PHP-MySQL-phpMyAdmin/php/bin/php /i-data/e162cf92/www/spotweb/retrieve.php

ariekanari wijzigde deze reactie 20-08-2019 17:32 (0%)
Reden: opschonen coderegel


  • pven
  • Registratie: oktober 1999
  • Niet online
Spotweb op mijn Synology (DS214+) geeft al een tijdje dit soort meldingen (op de webpagina). Deze staat er heel vaak, met iedere keer een ander regelnummer. Iemand een idee hoe dit te verhelpen is? Google helpt me niet echt.

[q]Warning: strftime(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone. in /volume1/web/spotweb/lib/SpotTemplateHelper.php on line 862
[/q]

De oplossing hier lost dit probleem overigens niet op.


Never mind, herstart over het hoofd gezien ...

pven wijzigde deze reactie 11-09-2019 16:18 (12%)

Telegram || Marktplaats-meuk. Afdingen mag! ;-) || slotje.com for sale || DM mij


  • remcoXP
  • Registratie: februari 2002
  • Laatst online: 10:43
ik heb het package op mijn synology draaien met nginx en php5.6

nu heb ik de spotweb files overschreven met nieuwe en daar de update gedraaid:

code:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
Notice: Undefined index: COLUMN_NAME in /volume1/web/spotweb/lib/dbstruct/SpotStruct_abs.php on line 227
                Dropping index idx_commentsfull_1


SpotWeb crashed

Database schema or settings upgrade failed:
   HY000: 1553: Cannot drop index 'idx_commentsfull_1': needed in a foreign key constraint


#0 /volume1/web/spotweb/lib/dbstruct/SpotStruct_mysql.php(162): dbeng_pdo->rawExec('DROP INDEX idx_...')
#1 /volume1/web/spotweb/lib/dbstruct/SpotStruct_abs.php(125): SpotStruct_mysql->dropIndex('idx_commentsful...', 'commentsfull')
#2 /volume1/web/spotweb/lib/dbstruct/SpotStruct_abs.php(711): SpotStruct_abs->validateIndex('idx_commentsful...', 'UNIQUE', 'commentsfull', Array)
#3 /volume1/web/spotweb/lib/services/Upgrade/Services_Upgrade_Base.php(42): SpotStruct_abs->updateSchema()
#4 /volume1/web/spotweb/bin/upgrade-db.php(34): Services_Upgrade_Base->database()



wat kan ik hieraan doen? want de gui geeft nu aan dat ik eerst db-update.php moet draaien :(

  • pven
  • Registratie: oktober 1999
  • Niet online
@remcoXP Heb je geprobeerd om php db-update.php vanaf de prompt te draaien?

Telegram || Marktplaats-meuk. Afdingen mag! ;-) || slotje.com for sale || DM mij


  • remcoXP
  • Registratie: februari 2002
  • Laatst online: 10:43
@pven zeker. maar ik heb nu opgelost door het oude package weer te installeren :P
ondertussen vanuit HASS de addon gebruikt die een docker op mijn intel NUC zet. kijken of dat wat is :)

  • Tijntje
  • Registratie: februari 2000
  • Laatst online: 13:57

Tijntje

Hello?!

remcoXP schreef op woensdag 11 september 2019 @ 20:44:
ik heb het package op mijn synology draaien met nginx en php5.6

nu heb ik de spotweb files overschreven met nieuwe en daar de update gedraaid:

code:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
Notice: Undefined index: COLUMN_NAME in /volume1/web/spotweb/lib/dbstruct/SpotStruct_abs.php on line 227
                Dropping index idx_commentsfull_1


SpotWeb crashed

Database schema or settings upgrade failed:
   HY000: 1553: Cannot drop index 'idx_commentsfull_1': needed in a foreign key constraint


#0 /volume1/web/spotweb/lib/dbstruct/SpotStruct_mysql.php(162): dbeng_pdo->rawExec('DROP INDEX idx_...')
#1 /volume1/web/spotweb/lib/dbstruct/SpotStruct_abs.php(125): SpotStruct_mysql->dropIndex('idx_commentsful...', 'commentsfull')
#2 /volume1/web/spotweb/lib/dbstruct/SpotStruct_abs.php(711): SpotStruct_abs->validateIndex('idx_commentsful...', 'UNIQUE', 'commentsfull', Array)
#3 /volume1/web/spotweb/lib/services/Upgrade/Services_Upgrade_Base.php(42): SpotStruct_abs->updateSchema()
#4 /volume1/web/spotweb/bin/upgrade-db.php(34): Services_Upgrade_Base->database()



wat kan ik hieraan doen? want de gui geeft nu aan dat ik eerst db-update.php moet draaien :(
Dit is een issue met MySQL 8, is al een github issue voor.
https://github.com/spotweb/spotweb/issues/437

Als het niet gaat zoals het moet, dan moet het maar zoals het gaat.


  • mesa57
  • Registratie: juni 2006
  • Laatst online: 18-11 21:41
Issue #437 is opgelost in de laatste commit, zowel op de master als develop branch.

  • pven
  • Registratie: oktober 1999
  • Niet online
Iemand toevallig een idee hoe ik de Downloaded-lijst kan inkrimpen? Daar staan nu ongeveer alle downloads die ik ooit vanuit Spotweb heb gestart. Alleen het laden van die lijst duurt al een paar minuten. Op zich ben ik tevreden met alleen de laatste 100 entries ofzo.

Voor het beeld: ik klink linksboven op Downloaded, en krijg dan die lijst te zijn,

Telegram || Marktplaats-meuk. Afdingen mag! ;-) || slotje.com for sale || DM mij


  • SMSfreakie
  • Registratie: maart 2004
  • Niet online
Gok dat 't wel ergens een database table is..

Dell E6440, Dell E6440, Custom homeserver C2750 based, Custom HTPC j4205 Based


  • pven
  • Registratie: oktober 1999
  • Niet online
SMSfreakie schreef op vrijdag 4 oktober 2019 @ 09:38:
Gok dat 't wel ergens een database table is..
De tabel heet niet letterlijk zo, dat maakt het wat lastig. Ik gok dat ergens in een veldje bij wordt gehouden wat wanneer gedownload is.

Telegram || Marktplaats-meuk. Afdingen mag! ;-) || slotje.com for sale || DM mij


  • Kroonkurk
  • Registratie: december 2015
  • Laatst online: 19-11 09:48
Linksonder staat toch een knop met erase downloadhistory ?

  • pven
  • Registratie: oktober 1999
  • Niet online
Kroonkurk schreef op vrijdag 4 oktober 2019 @ 10:53:
Linksonder staat toch een knop met erase downloadhistory ?
Klopt, maar die wist alle history. Ik wil juist een X aantal entries laten staan.

Iemand een idee hoe ik de query achter die erase history kan achterhalen? Als ik de code doorzoek, dan kom ik er niet aan uit.

pven wijzigde deze reactie 04-10-2019 11:25 (20%)

Telegram || Marktplaats-meuk. Afdingen mag! ;-) || slotje.com for sale || DM mij


  • Mr_Blobby
  • Registratie: mei 2000
  • Laatst online: 19-11 10:39
pven schreef op vrijdag 4 oktober 2019 @ 10:58:
[...]

Klopt, maar die wist alle history. Ik wil juist een X aantal entries laten staan.

Iemand een idee hoe ik de query achter die erase history kan achterhalen? Als ik de code doorzoek, dan kom ik er niet aan uit.
In https://github.com/spotwe...ao_Base_SpotStateList.php:

PHP:
1
2
3
4
5
6
7
8
9
10
11
    /*
     * Remove all downloads
     */
    function clearDownloadList($ourUserId) {
        SpotTiming::start(__CLASS__ . '::' . __FUNCTION__);
        $this->_conn->modify("UPDATE spotstatelist SET download = NULL WHERE ouruserid = :ouruserid",
            array(
                ':ouruserid' => array($ourUserId, PDO::PARAM_INT)
            ));
        SpotTiming::stop(__CLASS__ . '::' . __FUNCTION__, array($ourUserId));
    } # clearDownloadList

en zij zagen niet hoe spot in mij worstelde met verdriet


  • pven
  • Registratie: oktober 1999
  • Niet online
Mr_Blobby schreef op vrijdag 4 oktober 2019 @ 12:40:
[...]

In https://github.com/spotwe...ao_Base_SpotStateList.php:

PHP:
1
2
3
4
5
6
7
8
9
10
11
    /*
     * Remove all downloads
     */
    function clearDownloadList($ourUserId) {
        SpotTiming::start(__CLASS__ . '::' . __FUNCTION__);
        $this->_conn->modify("UPDATE spotstatelist SET download = NULL WHERE ouruserid = :ouruserid",
            array(
                ':ouruserid' => array($ourUserId, PDO::PARAM_INT)
            ));
        SpotTiming::stop(__CLASS__ . '::' . __FUNCTION__, array($ourUserId));
    } # clearDownloadList

Dank je! Hier kan ik wel iets mee. :Y)

Ik heb deze aan mijn update-script toegevoegd:

PHP:
1
delete from spotstatelist where download < ( date_add(now(), interval -100 day) );

pven wijzigde deze reactie 04-10-2019 15:05 (9%)

Telegram || Marktplaats-meuk. Afdingen mag! ;-) || slotje.com for sale || DM mij


  • Step
  • Registratie: januari 2004
  • Laatst online: 12:53

Step

step@tweakers.net#

Heb me ff snel verdiept in de CSS, nog niet helemaal compleet maar simpel te plakken in "Custom CSS": Dark Mode.

Als iemand er wat aan heeft. Voor mij kijkt dit s' avonds (en de rest van de dag) wat prettiger. At least it's something! :)


Cascading Stylesheet:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
/* MAIN BODY */
body {
    background: #232526;  /* fallback for old browsers */
    background: -webkit-linear-gradient(to right, #414345, #232526);  /* Chrome 10-25, Safari 5.1-6 */
    background: linear-gradient(to right, #414345, #232526); /* W3C, IE 10+/ Edge, Firefox 16+, Chrome 26+, Opera 12+, Safari 7+ */
}

/* MAINTENANCE */
ul.maintenancebox li.info {text-align:center; color:white; margin:5px 0; height:16px; line-height:16px;}

/* FILTER (LEFT) */
div.filter ul a {
    background-color:#696969;
    color:#fff;
}

div.filter a.selected {background-color:#3e3e3e;}

/* SPOTS */
table.spots tr.spotcat0 td {background-color:#006de7;}
table.spots tr.spotcat1 td {background-color:#c1850e;}
table.spots tr.spotcat2 td {background-color:#116311;}
table.spots tr.spotcat3 td {background-color:#de2500;}

div.filter > ul > li.spotcat0 a {background-color:#006de7;}
div.filter > ul > li.spotcat1 a {background-color:#c1850e;}
div.filter > ul > li.spotcat2 a {background-color:#116311;}
div.filter > ul > li.spotcat3 a {background-color:#de2500;}

/* SPOT DETAILS */
div.details table.spotheader {position:fixed; left:0; right:0; top:0; z-index:4; margin:0 16px 0 0; border-collapse:separate; border-spacing:5px 0; padding:5px 0; background: #232526;  /* fallback for old browsers */
    background: -webkit-linear-gradient(to right, #414345, #232526);  /* Chrome 10-25, Safari 5.1-6 */
    background: linear-gradient(to right, #414345, #232526); /* W3C, IE 10+/ Edge, Firefox 16+, Chrome 26+, Opera 12+, Safari 7+ */;}
div.details {background: #232526;  /* fallback for old browsers */
    background: -webkit-linear-gradient(to right, #414345, #232526);  /* Chrome 10-25, Safari 5.1-6 */
    background: linear-gradient(to right, #414345, #232526); /* W3C, IE 10+/ Edge, Firefox 16+, Chrome 26+, Opera 12+, Safari 7+ */; color:white;  font:11px Arial, Helvetica, sans-serif; padding:28px 0 5px 0; min-width:680px;}

/* HIGHLIGHTED FEED */
.hg1    { background-color: #01bd7f !important; }

/* MAIN COLOR SPOT TITLES */
table.spots a {color:#fff; text-decoration:none; display:block; width:100%; line-height:20px; cursor:pointer;}

/* FILTER COLOR HOVER */
div.filter > ul > li a:hover {background-color:#000;}
div.filter > ul > li a:hover span.newspots {background-color:#000; color:#fff;}
table.spots tr:hover td {background-color:#969696;}

/* FOOTER */
table.footer tr td.next {background-color:#c6c9d3; height:20px; font-weight:bold; min-width:30px; text-align:center; padding:0; -moz-border-radius:0 4px 4px 0; -webkit-border-radius:0 4px 4px 0; border-radius:0 4px 4px 0;}

~Step @ Mac Mini, 2,3 Ghz i5 - 8 GB DDR3 1333 RAM - 240 GB SSD & MacBook Pro, 2.3 GHz i7 - Retina - 8 GB DDR3 RAM - 256 GB SSD & PC (zie inventaris)


  • willem1509
  • Registratie: december 2008
  • Laatst online: 03-11 20:03
Ik kom er niet uit en ben al uren aan het bladeren in het forum/internet maar ik vind het antwoord helaas niet.

Ik heb naar volle tevredenheid Spotweb draaien op mijn oude mac en nu wilde ik het ook op mijn nieuwe macbook installeren, maar ik krijg de image previews niet werkend. Ik heb de installaties al naast elkaar bekeken en ik kan niets raars of anders vinden. Beide Spotweb-master branch.

Zonder previews



Met previews (wat ik eigenlijk wil)


Ik zie deze foutmeldingen voorbij komen in de logs:


Kan iemand vertellen waar het mis gaat?!

willem1509 wijzigde deze reactie 31-10-2019 09:56 (26%)
Reden: Plaatjes lukten niet


  • Satom
  • Registratie: mei 2011
  • Laatst online: 09:11

Satom

Verzamel ervaringen

Zoals de foutmelding al aangeeft: file_get_contents(...) failed to open stream: HTTP request failed, 404

De url die daar staat werkt niet, afijn. Bij (ik gok) niemand werkt de pagina zoals op de 2de foto. De file met Spotweb updates bestaat niet meer.

Waarom de preview niet werkt is lastig te zeggen, je zou eens in je browser de inspector/element inspecteren kunnen openen en dan onder netwerk te kijken.

  • mesa57
  • Registratie: juni 2006
  • Laatst online: 18-11 21:41
Kan een probleem zijn met de rechten op de spotweb cache folder.
De user waaronder spotweb draait moet full access hebben.

  • MrCornholio
  • Registratie: november 2019
  • Laatst online: 11-11 21:40
Hallo,

Heeft iemand een idee wat hoe ik de spots op de index lijst groter kan maken?

Als men niet is ingelogd, zijn er slechts 25 spots zichtbaar met 2 pijltjes.
Ik zou graag een lijst willen die met de muis is door te bladeren.
Zie deze afbeelding.

Advies wordt op prijs gesteld. :)

  • alesandro_46
  • Registratie: januari 2012
  • Laatst online: 10:35
MrCornholio schreef op maandag 11 november 2019 @ 16:55:
Hallo,

Heeft iemand een idee wat hoe ik de spots op de index lijst groter kan maken?

Als men niet is ingelogd, zijn er slechts 25 spots zichtbaar met 2 pijltjes.
Ik zou graag een lijst willen die met de muis is door te bladeren.
Zie deze afbeelding.

Advies wordt op prijs gesteld. :)
Dit kan je aanpassen bij 'config' --> 'Change preferences' --> 'General' --> 'Items per page?'.

Deze ruimte is bewust leeg gelaten


  • MrCornholio
  • Registratie: november 2019
  • Laatst online: 11-11 21:40
Bedankt voor je reactie, @alesandro_46

Dat heb ik al aangepast, maar dan is de lijst die langer is dan 25 spots alleen zichtbaar voor degene die is ingelogd. Ik zou het graag zo willen aanpassen dat de lijst altijd, ook voor mensen die niet zijn ingelogd, 250 is.

Ik zit al uren te zoeken maar kom er niet uit. :P

  • alesandro_46
  • Registratie: januari 2012
  • Laatst online: 10:35
@MrCornholio, dat kan bij:
'Config' --> 'User & Group management' --> 'Edit preferences' van, ik denk de user anonymous.

Deze ruimte is bewust leeg gelaten


  • MrCornholio
  • Registratie: november 2019
  • Laatst online: 11-11 21:40
Bedankt, ik ben eruit. Thanks voor je hulp! _/-\o_

MrCornholio wijzigde deze reactie 11-11-2019 18:37 (79%)


  • alesandro_46
  • Registratie: januari 2012
  • Laatst online: 10:35
@MrCornholio, graag gedaan. Hoe heb je het nu opgelost?

Deze ruimte is bewust leeg gelaten


  • MrCornholio
  • Registratie: november 2019
  • Laatst online: 11-11 21:40
alesandro_46 schreef op maandag 11 november 2019 @ 19:46:
@MrCornholio, graag gedaan. Hoe heb je het nu opgelost?
Ja, ik zat niet goed te kijken. Bedankt voor je hulp!

  • deorder
  • Registratie: juli 2017
  • Laatst online: 14-11 22:51
Heb net spotweb geinstalleerd (vanaf mijn mobiel, geen toegang tot PC momenteel) en krijg alleen een beperkte mobile user interface. Ik kan niet eens bij een Settings scherm komen.

Wanneer ik "ownsettings.php" aanpas (is deze nou deprecated of niet?) en template -> autodetect uitzet dan krijg ik de melding dat ik dat niet mag doen en het in het Settings scherm moet aanpassen (waar ik niet kan komen).

Chaos -> Nature -> Order -> Human -> Law -> Deorder

Pagina: 1 ... 43 44 45 Laatste


Apple iPhone 11 Nintendo Switch Lite LG OLED C9 Google Pixel 4 FIFA 20 Samsung Galaxy S10 Sony PlayStation 5 Elektrische auto

'14 '15 '16 '17 2018

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2019 Hosting door True