Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

DIY Ambilight howto?

Pagina: 1 ... 55 56 57 Laatste
Acties:
  • 520.431 views sinds 30-01-2008
  • Reageer

  • boppos
  • Registratie: februari 2004
  • Laatst online: 07-03 07:44
quote:
hardware-lover schreef op vrijdag 10 februari 2017 @ 15:57:
[...]

Ik wil er toch even op ingaan hier omdat de "oplossing" mogelijk buiten Kodi ligt voor dit probleem. Ik heb nooit de addon binnen Kodi gebruikt maar gebruikte de stand-alone software van Ambibox zelf. Dus configureren via de desktop en dan laten gebruiken door die programma's die er ook mee wilden werken. Dat ging, toen ik mijn "Ambilight" setup nog in gebruik had (op mijn vorige TV), probleemloos met Kodi en MediaPortal, zonder daarvoor iets binnen beide media-pakketten te moeten installeren/activeren.

Dus...., heb je i.p.v. de Kodi Ambibox addon ook al het aparte programma geprobeerd, zonder de addon actief te hebben binnen Kodi?
Ik had de ambibox add on draaien in kodi. Deze pakt alleen het video signaal volgens mij om door te geven aan ambibox zodat daarmee de kleuren van de leds alleen op de video zitten en niet het volledige beeld met ondertiteling enzo. Verbinding met ambibox wordt elke keer gestart als ik een video start. Maar nu blijven de leds dus uit.

  • hardware-lover
  • Registratie: augustus 2005
  • Niet online

hardware-lover

verder kijken dan neus lang is

quote:
boppos schreef op vrijdag 10 februari 2017 @ 17:17:
[...]
Ik had de ambibox add on draaien in kodi. Deze pakt alleen het video signaal volgens mij om door te geven aan ambibox zodat daarmee de kleuren van de leds alleen op de video zitten en niet het volledige beeld met ondertiteling enzo. Verbinding met ambibox wordt elke keer gestart als ik een video start. Maar nu blijven de leds dus uit.
Volgens mij heb je niet helemaal begrepen wat ik heb geschreven? Ik heb het over het gebruiken van de stand-alone oplossing van de Ambibox software, en niet een addon binnen Kodi, MediaPortal, enz.
Deze start dan tegelijk met Windows en draait op de achtergrond en is meteen actief, dus ook met andere programma's.

Dus een installeerbare versie van de Ambibox software, die ook apart geconfigureerd kan worden, ook v.w.b. de vlakken die gescanned moeten worden. Allemaal naar wens in te stellen en ook geschikt voor diverse "ambilight" hardware.

http://www.ambibox.ru/en/index.php/Download_AmbiBox en dan; http://ambibox.ru/ambibox_downloads/AmbiBox_setup_2.1.7.zip

wie baas is bakt koek, niet perse smakelijke koek


  • boppos
  • Registratie: februari 2004
  • Laatst online: 07-03 07:44
quote:
hardware-lover schreef op vrijdag 10 februari 2017 @ 19:09:
[...]

Volgens mij heb je niet helemaal begrepen wat ik heb geschreven? Ik heb het over het gebruiken van de stand-alone oplossing van de Ambibox software, en niet een addon binnen Kodi, MediaPortal, enz.
Deze start dan tegelijk met Windows en draait op de achtergrond en is meteen actief, dus ook met andere programma's.

Dus een installeerbare versie van de Ambibox software, die ook apart geconfigureerd kan worden, ook v.w.b. de vlakken die gescanned moeten worden. Allemaal naar wens in te stellen en ook geschikt voor diverse "ambilight" hardware.

http://www.ambibox.ru/en/index.php/Download_AmbiBox en dan; http://ambibox.ru/ambibox_downloads/AmbiBox_setup_2.1.7.zip
Zoals jij beschrijft had ik het begrepen, maar ik wil niet dat ambibox (die software waar jij naar linkt) iets doet als er geen video wordt afgespeeld. Die software draait ook hier en die ontvangt dus van de ambibox addon alleen een render van het video beeld binnen kodi. Niet van het hele scherm vlak of van overige zaken. Ik ga nog eens zoeken in instellingen in ambibox naar wat instellingen om iets te vinden waar jij het over hebt.

Ik heb dus een profiel in het programma ambibox waar hij bij method of screencapture "XBMC direct" weergeeft. Alles volgens deze wiki http://kodi.wiki/view/Add-on:AmbiBox Ambibox stuurd het via de adalight manier aan. Een arduino met leds, exacte type weet ik niet meer maar het heeft sinds 2013/2014 gewerkt. Nu met kodi 17 dus ineens niet meer :(

Als ik het over ambibox heb dan heb ik het dus over de software die in windows draait! De addon is dus alleen een doorgeefluik naar die software.

boppos wijzigde deze reactie 11-02-2017 16:54 (4%)


  • Harmen070
  • Registratie: januari 2010
  • Laatst online: 24-03 09:38
Vraagje, ik zie overal dat het door middel van splitters / usb grabbers mogelijk wordt om bij het gebruik van HDMI devices de kleuren van de leds te laten bepalen. Nou heb ik een smart tv met Netflix als App en ben ik dus ook erg benieuwd of ik zonder HDMI device ook de leds aan kan sturen. Heeft iemand hier toevallig ervaring mee?

  • FabianNL
  • Registratie: januari 2006
  • Laatst online: 20:25
quote:
Harmen070 schreef op donderdag 16 februari 2017 @ 09:22:
Vraagje, ik zie overal dat het door middel van splitters / usb grabbers mogelijk wordt om bij het gebruik van HDMI devices de kleuren van de leds te laten bepalen. Nou heb ik een smart tv met Netflix als App en ben ik dus ook erg benieuwd of ik zonder HDMI device ook de leds aan kan sturen. Heeft iemand hier toevallig ervaring mee?
Nope, dit is over het algemeen niet mogelijk. Zoek anders in dit draadje even, dan vind je de vergelijkbare vragen meermaals langskomen. Goedkoopste oplossing is om een Chromecast te halen (35 euro?), dan heb je wel Netflix via een HDMI poort.

  • Ozzzz
  • Registratie: februari 2014
  • Laatst online: 23-03 09:01
Heb sinds een aantal maanden mijn Dreamscreen naar tevredenheid in gebruik.

Nu heb ik onlangs van Dreamscreen een nieuwe dongle met voeding ontvangen.

Heeft iemand een idee hoe ik die als basis kan gebruiken voor een DIY set-upje?

https://tweakers.net/ext/f/MzPte72GsWpuVbpStpGFBPJy/thumb.jpg
https://tweakers.net/ext/f/OIH1Hjw4iovXRlkwB218Q7tR/thumb.jpg
https://tweakers.net/ext/f/RZjQXMvsP9lo05IigtpJDvCF/thumb.jpg

Ozzzz wijzigde deze reactie 12-03-2017 12:48 (84%)
Reden: foto aanpassing


  • ThunderStorm
  • Registratie: februari 2000
  • Laatst online: 22-03 21:02
Wat is heden ten dage nu het beste (en enigszins betaalbare) alternatief voor een foolproof ambilight oplossing op een niet Philips Tv? Lightberry complete HDMI set ziet er goed uit, maar is (tijdelijk?) niet meer leverbaar. Het alternatief Dreamscreen zie ik ook regelmatig voorbij komen.

Werken met 'tussenoplossingen' als een Arduino of Raspberry's gaat het hier niet worden.

Is de ene (veel) beter dan de andere?

  • FabianNL
  • Registratie: januari 2006
  • Laatst online: 20:25
quote:
ThunderStorm schreef op vrijdag 17 maart 2017 @ 20:08:
Wat is heden ten dage nu het beste (en enigszins betaalbare) alternatief voor een foolproof ambilight oplossing op een niet Philips Tv? Lightberry complete HDMI set ziet er goed uit, maar is (tijdelijk?) niet meer leverbaar. Het alternatief Dreamscreen zie ik ook regelmatig voorbij komen.

Werken met 'tussenoplossingen' als een Arduino of Raspberry's gaat het hier niet worden.

Is de ene (veel) beter dan de andere?
Dreamscreen werkt sowieso 100% foolproof. Goed, betrouwbaar, nooit problemen mee gehad, gebruik het sinds dag 1. Lightberry is een iets ouder systeem, welke (toentertijd) wat extra kastjes nodig had om een goed HDMI signaal binnen te krijgen.

Wel een maar: Dreamscrean werkt momenteel niet/slecht met 4K. Hier komt binnenkort wel een nieuwe hardware voor uit, volgens mij. Ik heb me er verder nooit in verdiept, omdat ik sowieso maar 1080p doe.

  • ThunderStorm
  • Registratie: februari 2000
  • Laatst online: 22-03 21:02
Heb er zojuist eentje besteld. Ben benieuwd hoe het uit gaat pakken. Led- tv hangt hier slechts ca. 3 cm van de muur dus zal de ledjes wel een beetje schuin moeten richten om een goed effect op de muur te krijgen. Hoe ver hebben jullie de tv van de muur om een optimaal effect te krijgen? Je flatcscreen verder uit de muur plaatsen voor een beter effect is ook wel beetje duf als je eerst zo dun mogelijke beugel hebt uitgezocht.

  • jurk738
  • Registratie: december 2003
  • Niet online
Ik ben ook begonnen met mijn diy ambilight m.b.v. deze tutorial: https://www.youtube.com/watch?v=ZCVfZb4UoO4, maar het lukt nog niet helemaal.

Ik gebruikte van die L-connectors maar daarmee liep bij het opstarten het gele patroon alleen langs de onderste ledstrip, en soms langs de linker strip maar het kwam niet bij de bovenste en de rechter strip. Die deden het nooit.
Na wat prutsen met de hoekconnectors was het startpatroon niet geel meer maar het had juist allemaal verschillende kleuren.
Toen heb ik de L-connectors er maar af gehaald en heb ik de hoeken gesoldeerd. Nu loopt het opstart patroon wel iets verder, maar het komt nog niet helemaal rond. Het komt tot ongeveer 3/4 van de bovenste strip. En het heeft nu ook nog allemaal verschillende kleuren.

Kan iemand me misschien op weg helpen om dit te fixen?

  • MsG
  • Registratie: november 2007
  • Laatst online: 12:09

MsG

Forumzwerver

quote:
ThunderStorm schreef op zaterdag 18 maart 2017 @ 16:45:
Heb er zojuist eentje besteld. Ben benieuwd hoe het uit gaat pakken. Led- tv hangt hier slechts ca. 3 cm van de muur dus zal de ledjes wel een beetje schuin moeten richten om een goed effect op de muur te krijgen. Hoe ver hebben jullie de tv van de muur om een optimaal effect te krijgen? Je flatcscreen verder uit de muur plaatsen voor een beter effect is ook wel beetje duf als je eerst zo dun mogelijke beugel hebt uitgezocht.
Je wilt het ook niet te ver weg denk ik, want dan projecteert het licht van de led nergens op en zie je het alleen als je direct naar het ledje zou kunnen kijken. Dicht op de muur is dan juist goed. Maar zorg inderdaad dat het licht vooral een beetje aan de buitenranden zichtbaar is, dus de ledstrip niet te ver naar het midden van de TV doen.

Ik haal de 3CM niet, ik zit denk ik op 10-15cm.
quote:
jurk738 schreef op zaterdag 18 maart 2017 @ 16:52:
Ik ben ook begonnen met mijn diy ambilight m.b.v. deze tutorial: https://www.youtube.com/watch?v=ZCVfZb4UoO4, maar het lukt nog niet helemaal.

Ik gebruikte van die L-connectors maar daarmee liep bij het opstarten het gele patroon alleen langs de onderste ledstrip, en soms langs de linker strip maar het kwam niet bij de bovenste en de rechter strip. Die deden het nooit.
Na wat prutsen met de hoekconnectors was het startpatroon niet geel meer maar het had juist allemaal verschillende kleuren.
Toen heb ik de L-connectors er maar af gehaald en heb ik de hoeken gesoldeerd. Nu loopt het opstart patroon wel iets verder, maar het komt nog niet helemaal rond. Het komt tot ongeveer 3/4 van de bovenste strip. En het heeft nu ook nog allemaal verschillende kleuren.

Kan iemand me misschien op weg helpen om dit te fixen?
Welke ledstrip-variant heb je? Die L-connectors schijnen niet voor elke ledstrip te werken, aangezien het aantal aansluitingen niet altijd overeenkomt. Eenvoudig met een multimeter te meten natuurlijk. denk ook aan de 'stroom'richting van de led. Er staat een pijl op de ledstrip welke kant hij moet vanaf de bron. Wellicht 1 strip verkeerd om?

Heb je de ground van de stroomadapter ook nog verbonden met de Raspberry of wat je ook gebruikt (hoe meer je noemt hoe accurater, dat hele filmpje ga ik niet kijken ;-))


Gister Hercules (1997) eens gezien, en dan ontdek je weer hoe mooi het erbij is. Bij veel series en normale speelfilms vind ik het een beetje een gimmick, maar bij animatiefilms met relatief weinig verschillende kleuren in beeld en sterke contrasten vind ik het echt heel mooi.

MsG wijzigde deze reactie 18-03-2017 18:19 (48%)

Denk om uw spatiegebruik. Dit scheelt Tweakers.net kostbare databaseruimte!


  • jurk738
  • Registratie: december 2003
  • Niet online
quote:
MsG schreef op zaterdag 18 maart 2017 @ 18:13:
[...]

Welke ledstrip-variant heb je? Die L-connectors schijnen niet voor elke ledstrip te werken, aangezien het aantal aansluitingen niet altijd overeenkomt. Eenvoudig met een multimeter te meten natuurlijk. denk ook aan de 'stroom'richting van de led. Er staat een pijl op de ledstrip welke kant hij moet vanaf de bron. Wellicht 1 strip verkeerd om?

Heb je de ground van de stroomadapter ook nog verbonden met de Raspberry of wat je ook gebruikt (hoe meer je noemt hoe accurater, dat hele filmpje ga ik niet kijken ;-))
Ik heb een WS2812B strip. De pijlen staan in de juiste richting. Bij een paar keer de RP opnieuw opstarten kwam het startpatroon soms tot ~halverwege de rechter strip. Maar niet tot het eind, en de kleur is niet geel maar 'multicolor'.
De ground van de voeding heb ik idd verbonden met de ground van de Arduino Uno.

Wat zou ik kunnen testen?

  • MsG
  • Registratie: november 2007
  • Laatst online: 12:09

MsG

Forumzwerver

Je voeding kan wel genoeg ampère leveren? Ik zou de connectie even met een multimeter doormeten op continuïteit/weerstand

Denk om uw spatiegebruik. Dit scheelt Tweakers.net kostbare databaseruimte!


  • DjVe
  • Registratie: september 2007
  • Laatst online: 19:01

DjVe

Hatsaflats!

quote:
jurk738 schreef op zaterdag 18 maart 2017 @ 18:45:
[...]


Ik heb een WS2812B strip. De pijlen staan in de juiste richting. Bij een paar keer de RP opnieuw opstarten kwam het startpatroon soms tot ~halverwege de rechter strip. Maar niet tot het eind, en de kleur is niet geel maar 'multicolor'.
De ground van de voeding heb ik idd verbonden met de ground van de Arduino Uno.

Wat zou ik kunnen testen?
Andere kant van de strip ook verbonden met de voeding? Anders krijgt het einde te weinig spanning, waardoor de kleuren niet goed overkomen.

  • jurk738
  • Registratie: december 2003
  • Niet online
quote:
MsG schreef op zaterdag 18 maart 2017 @ 19:35:
Je voeding kan wel genoeg ampère leveren? Ik zou de connectie even met een multimeter doormeten op continuïteit/weerstand
Oeps, ik had niet op het vermogen gelet. Als ik het nareken dan kan mijn voeding duidelijk niet genoeg leveren. :$

  • MsG
  • Registratie: november 2007
  • Laatst online: 12:09

MsG

Forumzwerver

Ja daar moet je wel mee uitkijken, ampère wordt gewoon gegeven totdat het ding zo heet wordt dat hij stuk gaat. Voor de veiligheid kan je het beste voor elke RGB led 60mA rekenen, 20mA per kleur.

Ik zit zelf eigenlijk ook te laag, heb 24 + 24 + 14 + 14 = 76 leds * 60mA = 4,56 Ampere. Terwijl ik maar een 2 Ampere voeding er aan heb hangen, omdat het anders meteen zo'n dure reuzenvoeding werd.

MsG wijzigde deze reactie 18-03-2017 22:19 (34%)

Denk om uw spatiegebruik. Dit scheelt Tweakers.net kostbare databaseruimte!


  • jurk738
  • Registratie: december 2003
  • Niet online
Ik heb het aantal leds teruggebracht zodat het gevraagde vermogen netjes bij de specs van de voeding past. En ik heb de Arduino en Hyperion ge-updatet met de nieuwe aantallen leds.
De L-connectors gaven wat dubieuze doormeet-resultaten. Dus ik heb de strips op de hoeken aan elkaar gesoldeerd, en de doormeet-resultaten zien er nu goed uit.

Echter, het eindresultaat is nog hetzelfde: Als ik de pi opstart dan begint na ~20s het opstart patroon waarbij de leds niet in geel oplichten maar in 'multicolor' en het patroon stopt ~halverwege de rechter strip.

Iemand een idee waar ik het probleem moet zoeken?
Pagina: 1 ... 55 56 57 Laatste


Nintendo Switch Google Pixel Sony PlayStation VR Samsung Galaxy S8 Apple iPhone 7 Dishonored 2 Google Android 7.x Watch_Dogs 2

© 1998 - 2017 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Carsom.nl de Persgroep Online Services B.V. Hosting door True

*