Cookies op Tweakers

Tweakers is onderdeel van DPG Media en maakt gebruik van cookies, JavaScript en vergelijkbare technologie om je onder andere een optimale gebruikerservaring te bieden. Ook kan Tweakers hierdoor het gedrag van bezoekers vastleggen en analyseren. Door gebruik te maken van deze website, of door op 'Cookies accepteren' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt? Bekijk dan ons cookiebeleid.

Meer informatie
Toon posts:

[OTGW] OpenTherm gateway

Pagina: 1 ... 22 23 24 Laatste
Acties:

  • sjorsjuhmaniac
  • Registratie: februari 2009
  • Laatst online: 23-05 23:01
martinvdm schreef op zondag 28 februari 2021 @ 17:21:
[...]

Ok dan ik jou voorbeeld dus niet gebruiken? en moet ik dus een mqtt climate in HA bouwen met het juiste command_topic welke dus de OTGW serial commands stuurt middels /command
Juist. Je kan mijn voorbeeld wel 'gebruiken' en alleen de topics vervangen :) scheelt weer werk.

Let op: templating op command topics werkt niet zoals verwacht, in mijn tests.

Ik heb bv het volgende geprobeerd:

code:
1
temperature_command_template: "TT={{ value }}"


Maar HA vind t niet tof dat er nog iets voor de {{ staat. Ik heb ook nog wel andere dingen geprobeerd maar kwam er niet uit. Je kan het wel oplossen door naar volledige ander topic te pushen, bv OTGW/mooihoor zonder een template te gebuiken, je krijgt hier dan gewoon de value direct op binnen.
Vervolgens kan je een automation maken die subscribed op dat topic, OTGW/mooihoor, en de via template de waarde pakt, samenvoegt met TT= en dat weer naar een nieuw topci , OTGW/command, pushed.

Werkt wel, is niet mooi :)

  • martinvdm
  • Registratie: januari 2001
  • Laatst online: 21-06 21:32

martinvdm

Martinvdm = TechJunky.nl

sjorsjuhmaniac schreef op zondag 28 februari 2021 @ 17:27:
[...]


Juist. Je kan mijn voorbeeld wel 'gebruiken' en alleen de topics vervangen :) scheelt weer werk.

Let op: templating op command topics werkt niet zoals verwacht, in mijn tests.

Ik heb bv het volgende geprobeerd:

code:
1
temperature_command_template: "TT={{ value }}"


Maar HA vind t niet tof dat er nog iets voor de {{ staat. Ik heb ook nog wel andere dingen geprobeerd maar kwam er niet uit. Je kan het wel oplossen door naar volledige ander topic te pushen, bv OTGW/mooihoor zonder een template te gebuiken, je krijgt hier dan gewoon de value direct op binnen.
Vervolgens kan je een automation maken die subscribed op dat topic, OTGW/mooihoor, en de via template de waarde pakt, samenvoegt met TT= en dat weer naar een nieuw topci , OTGW/command, pushed.

Werkt wel, is niet mooi :)
Thanks voor de info. Ik heb hem nu zo gebouwd en dat lijkt prima te werken.
YAML:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
  - platform: mqtt
    name: "Thermostaat"
    min_temp: 14
    max_temp: 28
    initial: 21 
    current_temperature_topic: "OTGW/Tr"
    temperature_command_topic: "OTGW/command"
    temperature_command_template: "TT={{ value }}"
    temp_step: 0.5
    precision: 0.5
    modes:
      - "off"
      - "heat"
    mode_state_topic: "OTGW/ch_enable"
    mode_state_template: >
      {% if value == 'ON' %}heat{% else %}off{% endif %}

Weet alleen niet zeker of ik het current_temperature_topic juist heb, maar iig lijkt de temparature_command incl de template wel goed te werken.

He who laughs last thinks slowest! | Drone video’s: Youtube | TechJunky.nl | 3000Wp Zonnepanelen


  • sjorsjuhmaniac
  • Registratie: februari 2009
  • Laatst online: 23-05 23:01
martinvdm schreef op zondag 28 februari 2021 @ 18:09:
[...]

Thanks voor de info. Ik heb hem nu zo gebouwd en dat lijkt prima te werken.
YAML:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
  - platform: mqtt
    name: "Thermostaat"
    min_temp: 14
    max_temp: 28
    initial: 21 
    current_temperature_topic: "OTGW/Tr"
    temperature_command_topic: "OTGW/command"
    temperature_command_template: "TT={{ value }}"
    temp_step: 0.5
    precision: 0.5
    modes:
      - "off"
      - "heat"
    mode_state_topic: "OTGW/ch_enable"
    mode_state_template: >
      {% if value == 'ON' %}heat{% else %}off{% endif %}

Weet alleen niet zeker of ik het current_temperature_topic juist heb, maar iig lijkt de temparature_command incl de template wel goed te werken.
wtf... werkt die template bij jou wel?.... kreeg hem bij mij er niet mee aan de praat.

  • martinvdm
  • Registratie: januari 2001
  • Laatst online: 21-06 21:32

martinvdm

Martinvdm = TechJunky.nl

sjorsjuhmaniac schreef op zondag 28 februari 2021 @ 18:12:
[...]


wtf... werkt die template bij jou wel?.... kreeg hem bij mij er niet mee aan de praat.
ja hoor zie hem netjes in MQTT explorer voorbij komen :)

He who laughs last thinks slowest! | Drone video’s: Youtube | TechJunky.nl | 3000Wp Zonnepanelen


  • sjorsjuhmaniac
  • Registratie: februari 2009
  • Laatst online: 23-05 23:01
martinvdm schreef op zondag 28 februari 2021 @ 18:12:
[...]

ja hoor zie hem netjes in MQTT explorer voorbij komen :)
8)7

Tr is wel de goede overigens, ID 24. Die moet je hebben.

  • martinvdm
  • Registratie: januari 2001
  • Laatst online: 21-06 21:32

martinvdm

Martinvdm = TechJunky.nl

Er lijkt nog wel ergens een issue tussen MQTT en deze sensors te zitten:
Low Water Pressure
Gas/Flame Fault

De Web interface van de OTGW geeft namelijk ON aan, en MQTT staat op Off, en dus HA ook.
Lijkt erop dat deze sensor waardes niet goed middels MQTT gepublished worden.

He who laughs last thinks slowest! | Drone video’s: Youtube | TechJunky.nl | 3000Wp Zonnepanelen


  • sjorsjuhmaniac
  • Registratie: februari 2009
  • Laatst online: 23-05 23:01
martinvdm schreef op zondag 28 februari 2021 @ 18:43:
Er lijkt nog wel ergens een issue tussen MQTT en deze sensors te zitten:
Low Water Pressure
Gas/Flame Fault

De Web interface van de OTGW geeft namelijk ON aan, en MQTT staat op Off, en dus HA ook.
Lijkt erop dat deze sensor waardes niet goed middels MQTT gepublished worden.
er was vorige week een comment dat de webinterface juist iets verkeerd aangaf/niet refresht. Weet je zeker dat de webinterface de juist waarde aangeeft? in je voorbeeld zou je dus juist een storing moeten hebben ...

  • MrBarBarian
  • Registratie: oktober 2003
  • Laatst online: 08:46
sjorsjuhmaniac schreef op zondag 28 februari 2021 @ 17:09:
[...]


Klopt, dat voorbeeld komt uit py-otgw-mqtt. Dat project heeft standaard geen HA discovery maar er is een pull request dat niet gemerged is wat die functionaliteit wel toevoegd. In dat geval krijg je een device (otgw) met daaronder al je sensoren en een thermostaat. Dat project heeft ook voor de meest gebruikte setting een apart topic waar je gewoon simpel de value naartoe kan pushen (daarnaast ook een 'raw' command topic overigens).
Deze, nav jouw tip in het HA-topic, gister eens geinstalleerd. Maar volgens mij is de gehele TCP-ondersteuning (nog) niet aanwezig?

iRacing Profiel


  • sjorsjuhmaniac
  • Registratie: februari 2009
  • Laatst online: 23-05 23:01
Ooh... ik moet je eerlijk zeggen dat ik dat nooit geprobeerd heb :$ ik heb alleen maar OTGW's met de wifi module en dan gebuik je het 'serial' stuk van de code. Heb me totaal niet gerealiseerd dat je met een lan aansluiting het TCP stuk nodig hebt... sorry.

Ik zie wel een heel stuk voor TCP maar geen idee hoe goed dat geimplementeerd is.

[Voor 14% gewijzigd door sjorsjuhmaniac op 05-03-2021 11:18]


  • MrBarBarian
  • Registratie: oktober 2003
  • Laatst online: 08:46
sjorsjuhmaniac schreef op vrijdag 5 maart 2021 @ 11:18:
Ooh... ik moet je eerlijk zeggen dat ik dat nooit geprobeerd heb :$ ik heb alleen maar OTGW's met de wifi module en dan gebuik je het 'serial' stuk van de code. Heb me totaal niet gerealiseerd dat je met een lan aansluiting het TCP stuk nodig hebt... sorry.

Ik zie wel een heel stuk voor TCP maar geen idee hoe goed dat geimplementeerd is.
Dat zag ik ook, maar als je in die code kijkt zie je vooral veel NotYetImplemented :(

iRacing Profiel


Acties:
  • +2Henk 'm!

  • number3
  • Registratie: februari 2002
  • Laatst online: 18-06 06:50
De 9e release van Nodoshop OTGW Firmware (voor de NodeMCU), release v0.8.0.

Opgelet dit is een breaking change voor MQTT integratie met homeassistant.

De release vast de volgende functies:
  • breaking change: aangepaste mqtt naming conventie for otgw topics
  • toegevoegd: otgw als een device en sensors nu gegroepeerd onder 1 device
  • toegevoegd: climate (thermostaat) entity, incl. temperatuur aanpassing
  • toegevoegd: override (middels het TT command) - vanaf HA Core v2021.2.0+)
  • nieuwe restapi - een eenvoudig json array voor simpele integratie met telegraf (/api/v1/otgw/telegraf)
  • fix voor core ot message processing (asf flags en oem code related)
  • fix voor GH issue #14 - watchdog reset indien MQTT timeout (>5 sec)
  • fix voor ASF flas in web UI (restapi otmonitor)
  • toegevoegd een LLMNR voor verbeterde integratie met windows en linux (nu naar: http://otgw/)
Shoutout naar :
  • @sjorsjuhmaniac (voor zijn inspanning om de homeassistant integratie te verbeteren)
  • @Martinvdm & @tjfsteele (voor eindeloos geduld bij het testwerk en remote debugging ondersteuning)
De release is hier te vinden:
https://github.com/rvdbre...mware/releases/tag/v0.8.0

Veel plezier. Net als altijd, issues en pullrequest zijn welkom via Github. Verder kan me vinden op Discord.

[Voor 6% gewijzigd door number3 op 07-03-2021 11:25. Reden: lijstje mooi maken]


Acties:
  • +1Henk 'm!

  • sjorsjuhmaniac
  • Registratie: februari 2009
  • Laatst online: 23-05 23:01

Acties:
  • +1Henk 'm!

  • Mich
  • Registratie: december 2000
  • Laatst online: 15-06 16:28
@number3

Zou ik dit ook op een of andere manier werkend kunnen krijgen op een nodeMCU met een ethernet shield er op? Mijn wifi op zolder is kantje boord. Daarom ben ik al over gegaan naar een USR-TCP232-T2 (serieel naar utp) module.

Acties:
  • 0Henk 'm!

  • martinvdm
  • Registratie: januari 2001
  • Laatst online: 21-06 21:32

martinvdm

Martinvdm = TechJunky.nl

Mich schreef op zondag 7 maart 2021 @ 19:43:
@number3

Zou ik dit ook op een of andere manier werkend kunnen krijgen op een nodeMCU met een ethernet shield er op? Mijn wifi op zolder is kantje boord. Daarom ben ik al over gegaan naar een USR-TCP232-T2 (serieel naar utp) module.
Denk niet dat de ondersteuning van de ethernet module in deze firmware zit.

He who laughs last thinks slowest! | Drone video’s: Youtube | TechJunky.nl | 3000Wp Zonnepanelen


  • Bo0bz
  • Registratie: april 2010
  • Laatst online: 08:59
Op een of andere manier krijg ik via de OTGW niet de juiste buitentemperatuur meer door. Op de warmtepomp staat dat het nu 1.5 graden is maar m'n OTGW geeft al uren 5,4 graden aan. Ook op de thermostaat staat 5.4. Heb al even de OTGW van de stroom afgehaald maar dat heeft niet geholpen. Draai de meegeleverde firmware vanuit nodoshop 4.2.5. Iemand een tip?

7360wp | 17*320 OZO | 6* 320 WNW | PVoutput | Loria 6008 | Fujitsu AGYG09LV | Gasloos sinds 10-07-2020


  • sjorsjuhmaniac
  • Registratie: februari 2009
  • Laatst online: 23-05 23:01
Wat is er veranderd?

zit de sensor nog goed aangesloten? Verandert de waarde uberhaupt door de dag heen?

  • Bo0bz
  • Registratie: april 2010
  • Laatst online: 08:59
sjorsjuhmaniac schreef op dinsdag 9 maart 2021 @ 08:34:
[...]


Wat is er veranderd?

zit de sensor nog goed aangesloten? Verandert de waarde uberhaupt door de dag heen?
De waarde veranderd helemaal niet meer. Sinds ik mijn domoticz heb overgezet naar een Linux systeem. De andere waarden uit de otgw veranderen wel iedere x minuten zoals het hoort. De sensor kan ik ook uitlezen op mijn warmtepomp en die doet het wel. Iedere keer als ik de otgw even uit en aan komt er een nieuwe waarde maar dus niet uit zichzelf. Als ik de otgw er tussen uit haal leest mijn thermostaat wel de juiste waarde uit.

7360wp | 17*320 OZO | 6* 320 WNW | PVoutput | Loria 6008 | Fujitsu AGYG09LV | Gasloos sinds 10-07-2020


Acties:
  • +1Henk 'm!

  • sjorsjuhmaniac
  • Registratie: februari 2009
  • Laatst online: 23-05 23:01
Bo0bz schreef op dinsdag 9 maart 2021 @ 08:40:
[...]


De waarde veranderd helemaal niet meer. Sinds ik mijn domoticz heb overgezet naar een Linux systeem. De andere waarden uit de otgw veranderen wel iedere x minuten zoals het hoort. De sensor kan ik ook uitlezen op mijn warmtepomp en die doet het wel. Iedere keer als ik de otgw even uit en aan komt er een nieuwe waarde maar dus niet uit zichzelf. Als ik de otgw er tussen uit haal leest mijn thermostaat wel de juiste waarde uit.
Dat is heel apart. Domoticz heeft geen invloed op data van de otgw naar thermostaat tenzij je echt commando's stuurt om bepaalde data ID's tegen te houden.

We kunnen proberen of het DATA id misschien even handmatige opgevraagd moet worden om het aan de gang te krijgen. Kun je eens het volgende commando naar de otgw sturen
code:
1
AA=27
, kijken of je dan binnen 15min wel goede data krijgt te zien.

Kan ook OTMonitor eens draaien? Als je die start moet je wel even de otgw op disabled zetten in Domoticz->hardware omdat ze anders vechten wie de verbinding mag hebben en houden.
Zie je de juiste buiten temp in OTMonitor?

  • Bo0bz
  • Registratie: april 2010
  • Laatst online: 08:59
@sjorsjuhmaniac ik ga zo even pielen. Eerst een meeting in. Kom er bij je op terug :-)

EDIT: Command net verstuurd en de temp wijzigt naar 5.8. Even checken of hij blijft bijwerken.
EDIT2: Temp inmiddels 6.2. Het lijkt dus nu wel te werken!

[Voor 48% gewijzigd door Bo0bz op 09-03-2021 10:06]

7360wp | 17*320 OZO | 6* 320 WNW | PVoutput | Loria 6008 | Fujitsu AGYG09LV | Gasloos sinds 10-07-2020


  • bluewalk
  • Registratie: juli 2004
  • Niet online
Hier al jaren gebruiker van de OTGW (eerste generatie + ESP-01 met esp-link) altijd goed gewerkt maar de laatste tijd krijg ik erg vaak dat het ding niet respond en dus niet verwarmd of simpelweg niet stopt met verwarmen omdat de gateway communicatie kwijt is.

Wat ik vervolgens kan doen om het op te lossen in de Reference Voltage verhogen of verlagen. Daarna zijn de errors weer een tijdje over (soms een week/maand maar ook soms maar een dag).

Error 03 -> VR=3 -> OK
Daarna weer Error 03 -> VR=6 -> OK
en vice versa met allerlij voltages daar tussenin.

Iemand anders ervaring hiermee, wordt het tijd voor een nieuwe?

bluewalk.net


  • sjorsjuhmaniac
  • Registratie: februari 2009
  • Laatst online: 23-05 23:01
Bo0bz schreef op dinsdag 9 maart 2021 @ 09:16:
@sjorsjuhmaniac ik ga zo even pielen. Eerst een meeting in. Kom er bij je op terug :-)

EDIT: Command net verstuurd en de temp wijzigt naar 5.8. Even checken of hij blijft bijwerken.
EDIT2: Temp inmiddels 6.2. Het lijkt dus nu wel te werken!
Zie het nu pas maar (y) dat het gewerkt heeft

  • Bo0bz
  • Registratie: april 2010
  • Laatst online: 08:59
@sjorsjuhmaniac wat nog wel vreemd blijft is dat op de thermostaat zelf nog steeds de temperatuur blijft hangen. Op de warmtepomp en de OTGW gaat het wel goed. Daar toevallig ook een tip voor?

7360wp | 17*320 OZO | 6* 320 WNW | PVoutput | Loria 6008 | Fujitsu AGYG09LV | Gasloos sinds 10-07-2020


  • stuffer
  • Registratie: juli 2009
  • Laatst online: 13:07
Bo0bz schreef op zaterdag 13 maart 2021 @ 09:30:
@sjorsjuhmaniac wat nog wel vreemd blijft is dat op de thermostaat zelf nog steeds de temperatuur blijft hangen. Op de warmtepomp en de OTGW gaat het wel goed. Daar toevallig ook een tip voor?
Gaat dat over de buitentemp? Dat heb ik op de iSense ook gehad maar door de OTGW settings in Domoticz op de juiste temperatuur sensor te te zetten of even geforceerd een ander aan te kiezen en weer terug loste het op.

Schaamteloze verkoop van:
http://tweakers.net/aanbod/user/311422/
** NIX **


  • Bo0bz
  • Registratie: april 2010
  • Laatst online: 08:59
@stuffer er ging gelijk een belletje rinkelen haha. Inderdaad stond de OTGW temp sensor op user build-in. Nu omgezet en het werkt weer!

7360wp | 17*320 OZO | 6* 320 WNW | PVoutput | Loria 6008 | Fujitsu AGYG09LV | Gasloos sinds 10-07-2020


  • 1870henk
  • Registratie: februari 2010
  • Niet online
Communicatie fout met iSense F203.

Na een aantal pogingen om OTGW i.c.m. een iSense aan de gang te krijgen, bleek er uiteindelijk een fout op de Nodo print te zitten: R6 was aan 1 kant los, waar die normaal aan R5/pin17 moet zitten.
Nadat ik met een beetje solderen dit weer aan elkaar kreeg, werkte de iSense perfect.
Ik heb nog eens goed naar de Nodo print gekeken en het lijkt er op dat er ook helemaal geen printspoortje loopt naar R6. Die zit alleen maar aan GND.

Ik kwam hier al volgt achter:
tussen IC1-pin17 en X1-pin1 moet 4k7 zijn (dit was dus enkele Mohms)
tussen IC1-pin17 en X1-pin2 moet 33k zijn

  • number3
  • Registratie: februari 2002
  • Laatst online: 18-06 06:50
@1870henk heb je dat ook aan Nodoshop laten weten? Want het kan een productie fout zijn, dat wil hij vast weten.

  • Racer89
  • Registratie: mei 2009
  • Niet online
Hopelijk kan ik hier terecht met mijn vraag, ik zou niet weten waar ik deze anders moet neer zetten.

Sinds ongeveer 2 weken heb ik één OTGW in elkaar gezet en er tussen geplaatst. Ook mede om te kijken of de ketel moduleert. Dit werkt ook allemaal perfect, was wel een beetje ellende om de juiste drivers te vinden voor de USB kabel ( voor te testen rechtstreeks op de laptop ). Uiteindelijk is de OTGW aangesloten op de RPI i.c.m. Domoticz.

Nu ben ik in het bezit van een Honeywell CMT937M1003 Modulation. Deze is aangesloten op een Bosch HRC30. Ik heb een hele hoop handleidingen gelezen en het zou mogelijk zijn om op de Honeywell rechtsreeks een buitenvoeler aan te sluiten en deze te gebruiken als weersafhankelijke regeling. Vol goede moed een buitenvoeler aangeschaft en aangesloten. En wat blijkt ik kom met geen ene mogelijkheid in het installateurs menu..... Natuurlijk niet v.t.v. getest of ik er wel in kom. ( achter af ben je altijd slimmer, domme fout van mezelf... ) Parameter 10 zou ik de voeler moeten activeren maar ik kom niet verder dan 6. Ik kan verder ook totaal niks aanpassen of veranderen.


Zelf heb ik al getest / geprobeerd:

# OTGW er tussen uit, en thermostaat rechtsreeks op de ketel.
# Andere OT printplaat in de ketel geplaatst ( heb een reserve HRC30 liggen )
# Bedrading nagekeken, dit is allemaal zo ver in orde.

Meet nu ongeveer 17,8 Kohm op de voeler met een buiten temperatuur van 9 tot 10 graden. Helaas kan ik nergens vinden wat deze zou moeten zijn.

Wat ik me nu afvraag, heeft de ketel zo veel invloed op de thermostaat dat deze de menu's blokkeert?

Acties:
  • +1Henk 'm!

  • sjorsjuhmaniac
  • Registratie: februari 2009
  • Laatst online: 23-05 23:01
Racer89 schreef op vrijdag 2 april 2021 @ 16:45:
Hopelijk kan ik hier terecht met mijn vraag, ik zou niet weten waar ik deze anders moet neer zetten.

Sinds ongeveer 2 weken heb ik één OTGW in elkaar gezet en er tussen geplaatst. Ook mede om te kijken of de ketel moduleert. Dit werkt ook allemaal perfect, was wel een beetje ellende om de juiste drivers te vinden voor de USB kabel ( voor te testen rechtstreeks op de laptop ). Uiteindelijk is de OTGW aangesloten op de RPI i.c.m. Domoticz.

Nu ben ik in het bezit van een Honeywell CMT937M1003 Modulation. Deze is aangesloten op een Bosch HRC30. Ik heb een hele hoop handleidingen gelezen en het zou mogelijk zijn om op de Honeywell rechtsreeks een buitenvoeler aan te sluiten en deze te gebruiken als weersafhankelijke regeling. Vol goede moed een buitenvoeler aangeschaft en aangesloten. En wat blijkt ik kom met geen ene mogelijkheid in het installateurs menu..... Natuurlijk niet v.t.v. getest of ik er wel in kom. ( achter af ben je altijd slimmer, domme fout van mezelf... ) Parameter 10 zou ik de voeler moeten activeren maar ik kom niet verder dan 6. Ik kan verder ook totaal niks aanpassen of veranderen.


Zelf heb ik al getest / geprobeerd:

# OTGW er tussen uit, en thermostaat rechtsreeks op de ketel.
# Andere OT printplaat in de ketel geplaatst ( heb een reserve HRC30 liggen )
# Bedrading nagekeken, dit is allemaal zo ver in orde.

Meet nu ongeveer 17,8 Kohm op de voeler met een buiten temperatuur van 9 tot 10 graden. Helaas kan ik nergens vinden wat deze zou moeten zijn.

Wat ik me nu afvraag, heeft de ketel zo veel invloed op de thermostaat dat deze de menu's blokkeert?
Probeer eens
https://customer.honeywel...nts/69-0000s/69-1812D.pdf

of
https://www.klusidee.nl/F...neywell-modulation.45532/

  • Racer89
  • Registratie: mei 2009
  • Niet online
@sjorsjuhmaniac bedankt voor je reactie, helaas is dat voor een vision icm een touchscreen. Ik heb een ander type met ander menu opbouw.

Acties:
  • +1Henk 'm!

  • remco_k
  • Registratie: april 2002
  • Laatst online: 12:32

remco_k

een cassettebandje was genoeg

@Racer89
Je kan als alternatief zelf de buitentemperatuur doorgeven via de OTGW.
Ik dacht met OT=
OTGW geeft 'm vervolgens door naar je Honeywell.

Bij mijn Chronotherm Vision i.c.m. exact dezelfde ketel als jij hebt werkt dat prima.

Alles kan stuk.
Goedkoop SHOUTcast stream hosting? Snel online, geen setup kosten. www.digiplay.nl


  • Racer89
  • Registratie: mei 2009
  • Niet online
remco_k schreef op zaterdag 3 april 2021 @ 09:49:
@Racer89
Je kan als alternatief zelf de buitentemperatuur doorgeven via de OTGW.
Ik dacht met OT=
OTGW geeft 'm vervolgens door naar je Honeywell.

Bij mijn Chronotherm Vision i.c.m. exact dezelfde ketel als jij hebt werkt dat prima.
Bedankt voor je reactie, dit had ik al getest en werkt ook. Alleen hangt de buitenvoeler van Domoticz niet op het noorden. De nieuwe voeler heb ik nu wel op het noorden gehangen. Probleem is echter dat ik dan alsnog niet weersafhankelijk kan regelen. Dat moet ook via de parameters worden ingesteld.

Ik was al aan het kijken voor een andere thermostaat waar ook de voeler op werkt. En deze lijkt ook geschikt te zijn voor de Vision of de Touch. Heb jij ook het oudere model bosch met het groene display ?

  • pingwim
  • Registratie: december 2009
  • Laatst online: 20-06 21:29
Racer89 schreef op zaterdag 3 april 2021 @ 10:06:
[...]


Bedankt voor je reactie, dit had ik al getest en werkt ook. Alleen hangt de buitenvoeler van Domoticz niet op het noorden. De nieuwe voeler heb ik nu wel op het noorden gehangen. Probleem is echter dat ik dan alsnog niet weersafhankelijk kan regelen. Dat moet ook via de parameters worden ingesteld.

Ik was al aan het kijken voor een andere thermostaat waar ook de voeler op werkt. En deze lijkt ook geschikt te zijn voor de Vision of de Touch. Heb jij ook het oudere model bosch met het groene display ?
Of haal de buitentemperatuur op via bijvoorbeeld OpenWeatherMap api. Scheelt gedoe met de buitenvoeler, nauwkeuriger en biedt mogelijkheden als "gevoelstemperatuur".

Evohome - OTGW - Remeha hybride - Jaga ltv - Speedcomfort


Acties:
  • +1Henk 'm!

  • remco_k
  • Registratie: april 2002
  • Laatst online: 12:32

remco_k

een cassettebandje was genoeg

Racer89 schreef op zaterdag 3 april 2021 @ 10:06:
[...]
Heb jij ook het oudere model bosch met het groene display ?
Ja.

Alles kan stuk.
Goedkoop SHOUTcast stream hosting? Snel online, geen setup kosten. www.digiplay.nl


  • Racer89
  • Registratie: mei 2009
  • Niet online
Via MP een TH8210M1003 (Modulation touch) kunnen kopen, en hierop werkt de buitenvoeler wel en kan ik ook weersafhankelijk regelen. Ik zie nu ook alle parameters staan.

Snap alleen nog altijd niet waarom de gewone modulation niet werkt. Aangezien het allemaal wel zou moeten kunnen volgens de handleiding.

Alleen zie ik de buiten temperatuur nog niet terug via de OTGW, maar even afwachten...

Acties:
  • +1Henk 'm!

  • 1870henk
  • Registratie: februari 2010
  • Niet online
@number3. Goed idee. Dat heb ik inmiddels gedaan.

  • guus.assmann
  • Registratie: augustus 2006
  • Laatst online: 27-04 13:05
Hallo,
Niet per sé een OTGW vraag, maar toch wel een beetje.
Ik heb een Remeha Quinta28C met een gateway en een Celcia20 thermostaat.
Daar kan de OTGW aan worden gekoppled.
Maar ik heb sinds kort ook een ZentaSol boiler en een remote display.

De vraag is nu, of ik ongestraft die systemen via dezelfde busaansluitingen aan elkaar kan verbinden.
Dit maakt namelijk de bekabeling veel eenvoudiger.
Met name de kabel van de zolder naar de thermostaat is de lastige factor. Die is nu maar 2 aderig.

Guus Assmann


  • 1870henk
  • Registratie: februari 2010
  • Niet online
Ik gebruik een OT commando om de buitentemp. van Openwheathermap naar de OTGW te sturen. Dat werkt keurig.
Toen besloot ik om een tempsensor aan te sluiten op de GPIO pinnen. Vervolgens de GPIO functies ingesteld.
In de OTmonitor was de waarde van outside temp nu de temp van het return water en return water temp was leeg. Vreemd, maar OK.
Ik moest natuurlijk nog een TS=R commando sturen. Dat veranderde echter niets.
Toen opnieuw OT commando gestuurd en toen kreeg ik weer de juiste buitentemp. Maar nog steeds niks op de return temp.

Ik krijg de sensor nu niet meer aan de praat.
Ik begrijp dat OTGW niet 2 sensoren kan lezen, maar het OT commando heeft toch niets met de GPIO te maken (dacht ik)?
OK, als de sensor nog op TS=O staat EN ik stuur een waarde met OT, dan wordt de waarde overschreven.
Maar als ik gewoon TS=R geef dan zou die toch op return water iets moeten laten zien.

Nog iets:
Ik heb een Nodo print en daar zitten maar 4 LED's op. In de OTmonitor staan echter 6 LED's, dus ook op de pinnen die voor GPIO gebruikt worden.
Kan het zijn dat de pinnen van LED E en F aangestuurd worden terwijl daar ook de GPIO voor de sensor op zit?

  • Martidjen
  • Registratie: juni 2016
  • Laatst online: 14-06 07:45
Voor degenen die de Opentherm Gateway gebruiken in combinatie met de climate entity van de standaard Opentherm Gateway integratie in Home Assistant:

Ik heb een wijziging gedaan aan de opties voor de integratie in Home Assistant, sinds de april update 2021.4.0 zijn deze beschikbaar geworden.



Vanaf nu is de optie voor temperatuur precisie verdeeld in lees- en schrijf precisie. Oftewel, het uitlezen van de huidige temperatuur kan met een andere precisie gedaan worden dan de stapgrootte van het instellen van een nieuwe temperatuur setpoint.

Ook heb ik een optie voor 'Temporary Setpoint Override Mode' toegevoegd. Als deze optie is ingeschakeld dan zal het temperatuur commando voor Temporary Temperature gebruikt worden bij het instellen van een nieuwe temperatuur (ook wel bekend als TT=), als deze optie niet is ingeschakeld zal het commando voor Constant Temperature gebruikt worden (TC=).

Zie hier de Home Assistant Docs voor de Opentherm Gateway integratie: https://www.home-assistant.io/integrations/opentherm_gw/

  • bluewalk
  • Registratie: juli 2004
  • Niet online
number3 schreef op zondag 7 maart 2021 @ 02:09:
De 9e release van Nodoshop OTGW Firmware (voor de NodeMCU), release v0.8.0.

Opgelet dit is een breaking change voor MQTT integratie met homeassistant.

De release vast de volgende functies:
  • breaking change: aangepaste mqtt naming conventie for otgw topics
  • toegevoegd: otgw als een device en sensors nu gegroepeerd onder 1 device
  • toegevoegd: climate (thermostaat) entity, incl. temperatuur aanpassing
  • toegevoegd: override (middels het TT command) - vanaf HA Core v2021.2.0+)
  • nieuwe restapi - een eenvoudig json array voor simpele integratie met telegraf (/api/v1/otgw/telegraf)
  • fix voor core ot message processing (asf flags en oem code related)
  • fix voor GH issue #14 - watchdog reset indien MQTT timeout (>5 sec)
  • fix voor ASF flas in web UI (restapi otmonitor)
  • toegevoegd een LLMNR voor verbeterde integratie met windows en linux (nu naar: http://otgw/)
Shoutout naar :
  • @sjorsjuhmaniac (voor zijn inspanning om de homeassistant integratie te verbeteren)
  • @Martinvdm & @tjfsteele (voor eindeloos geduld bij het testwerk en remote debugging ondersteuning)
De release is hier te vinden:
https://github.com/rvdbre...mware/releases/tag/v0.8.0

Veel plezier. Net als altijd, issues en pullrequest zijn welkom via Github. Verder kan me vinden op Discord.
Valt deze ook te flashen op een ESP serial tranciever boardje, denk aan: https://nl.aliexpress.com/item/32673603743.html

bluewalk.net


  • _jap_
  • Registratie: augustus 2011
  • Laatst online: 04-06 13:46
1870henk schreef op woensdag 14 april 2021 @ 15:08:
Ik gebruik een OT commando om de buitentemp. van Openwheathermap naar de OTGW te sturen. Dat werkt keurig.
Toen besloot ik om een tempsensor aan te sluiten op de GPIO pinnen. Vervolgens de GPIO functies ingesteld.
In de OTmonitor was de waarde van outside temp nu de temp van het return water en return water temp was leeg. Vreemd, maar OK.
Ik moest natuurlijk nog een TS=R commando sturen. Dat veranderde echter niets.
Toen opnieuw OT commando gestuurd en toen kreeg ik weer de juiste buitentemp. Maar nog steeds niks op de return temp.
Hier een soortgelijke situatie - ik heb hier een 18B20 op de retourwaterleiding geplakt en die aan m'n OTGW gehangen, en met de nieuwste firmware meet-ie die temperatuur en stuurt dat naar de thermostaat door. De buitentemperatuur (die ik met OT= erin schiet) wordt nu helaas niet meer over de bus verstuurd, en verschijnt niet meer op het display van de thermostaat.

Volgens mij is het een bugje in de firmware dat dit niet werkt (ik ben er ooit eens vluchtig doorheen gegaan, en had het idee dat voor de buitentemperatuur en de retourwatertemperatuur hetzelfde stukje geheugen gebruikt wordt), maar ik ben niet diep genoeg erin gedoken om een fix in te typen. Misschien met het lange koningsweekend voor de boeg een leuk project, tussen al het andere door :)

  • 1870henk
  • Registratie: februari 2010
  • Niet online
_jap_ schreef op vrijdag 23 april 2021 @ 09:29:
[...]


Hier een soortgelijke situatie - ik heb hier een 18B20 op de retourwaterleiding geplakt en die aan m'n OTGW gehangen, en met de nieuwste firmware meet-ie die temperatuur en stuurt dat naar de thermostaat door. De buitentemperatuur (die ik met OT= erin schiet) wordt nu helaas niet meer over de bus verstuurd, en verschijnt niet meer op het display van de thermostaat.

Volgens mij is het een bugje in de firmware dat dit niet werkt (ik ben er ooit eens vluchtig doorheen gegaan, en had het idee dat voor de buitentemperatuur en de retourwatertemperatuur hetzelfde stukje geheugen gebruikt wordt), maar ik ben niet diep genoeg erin gedoken om een fix in te typen. Misschien met het lange koningsweekend voor de boeg een leuk project, tussen al het andere door :)
Als ik TS=R stuur, dan krijg ik via OTmonitor wel de buitentemp binnen via OT. Als ik TS=O stuur dan wordt de temp via OT overschreven door de sensor.
Ik heb een Remeha Avanta en die meet zelf de return water temp. Na het sturen van AA=28 zie ik die nu ook in de OTmonitor.
Het lukt niet om de externe sensor te gebruiken voor de return water temp. Hopelijk een oplosbaar bugje.

Ik heb ook al eens door de code gescand, maar ik moet er weer even aan wennen. PIC's programmeren is voor mij al weer zo'n 30 jaar geleden.

Acties:
  • 0Henk 'm!

  • bprak
  • Registratie: november 2013
  • Laatst online: 10:09
Helaas heeft mijn WiFi otgw het begeven door een lekkage. Is er een thermostaat die rechtstreeks werkt met domoticz? Of iemand toevallig een otgw over die via WiFi werkt?

  • Jeroen1985vag
  • Registratie: februari 2017
  • Laatst online: 17-06 13:38
Gebruik Plugwise Anna onder domoticz ook ondersteund en zeer tevreden over
Pagina: 1 ... 22 23 24 Laatste


Apple iPad Pro (2021) 11" Wi-Fi, 8GB ram Microsoft Xbox Series X LG CX Google Pixel 5a 5G Sony XH90 / XH92 Samsung Galaxy S21 5G Sony PlayStation 5 Nintendo Switch Lite

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2021 Hosting door True