Cookies op Tweakers

Tweakers is onderdeel van DPG Media en maakt gebruik van cookies, JavaScript en vergelijkbare technologie om je onder andere een optimale gebruikerservaring te bieden. Ook kan Tweakers hierdoor het gedrag van bezoekers vastleggen en analyseren. Door gebruik te maken van deze website, of door op 'Cookies accepteren' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt? Bekijk dan ons cookiebeleid.

Meer informatie
Toon posts:

Raspberry Pi met Wireguard

Pagina: 1
Acties:

  • SubSun
  • Registratie: december 2003
  • Niet online
Hoi allen,

Ik wil graag een Raspberry Pi met Wireguard aan mijn modem hangen zodat ik van buitenaf mijn camera kan benaderen. Nu loop ik tegen een aantal problemen aan, maar weet eigenlijk niet goed waar ik mijn vragen kwijt kan. Na veel zoeken, lezen, proberen zie ik ook even door de bomen het bos niet meer.

Wil ook even aangeven dat ik niet zo handig ben en verder weinig weet van netwerken/portforwarding. Mogelijk moet ik met mijn vragen eerder richting 'netwerken', maar ik wil ook checken of ik alles goed heb gedaan met de RPi/Wireguard.

Op een Raspberry Pi (1B) heb ik Raspberry Pi OS Lite 32 bit geïnstalleerd (met de Imager). Vervolgens heb ik deze tutorial gevolgd om Wireguard er op te zetten: https://pimylifeup.com/raspberry-pi-wireguard/. Volgens mij is alles goed gegaan: ik heb uiteindelijk een QR code gekregen, welke ik met de app op mijn telefoon kon scannen.

Nu vroeg ik mij af of dit klopt, met name DNS servers en Allowed IPs?:


Wat mij ook opvalt is dat als ik de RPi aan de Ziggo modem hang, dat de het lampje van de LAN verbinding oranje blijft. Overigens gebeurt dit ook als ik mijn camera aan de modem hang (met een PoE injector), maar dat even terzijde. De router die achter de modem hangt en mijn laptop, ter test even via kabel aangesloten, krijgen wel een groen lampje. Betekent dit dat de RPi geen IP krijgt toegewezen?

Als ik direct op de modem inlog, zie ik de RPi ook niet in het lijst van verbonden gebruikers. Bedoel dit overzicht:


Hierdoor weet ik ook niet hoe ik poort 51820 open kan zetten (want dit is nodig voor Wireguard toch?). Volgens deze handleiding heb ik Mac en IP nodig:
https://community.ziggo.n...rt-forwarding/ba-p/653855

Als tweede (maar misschien is dit meer voor het netwerken topic):
Aan mijn Ziggo modem heb ik een router hangen. Wifi van de modem is uitgeschakeld en mijn apparaten maken altijd gebruik van de wifi van de router. Echter kan ik dan niet de RPi benaderen (dmv Putty, SSH en raspberrypi.local). Als ik direct op de modem ben verbonden, werkt het natuurlijk wel. Enig idee wat ik moet instellen zodat ik ook vanaf mijn router de RPi kan benaderen? Router is overigens een Netgear R7000.

Zoals ik eerder aangaf, ik zie even niet meer waar ik moet beginnen met kijken. Zou mooi zijn als het uiteindelijk lukt, maar als jullie mij mij weer de goede kant op kunnen sturen is dat ook al erg fijn :)

  • SubSun
  • Registratie: december 2003
  • Niet online
Latertje geworden, maar heb het gevoel dat ik een stuk dichterbij ben gekomen..

Volgens mij lag het aan de ip range oid. De Ziggo modem stond in 192.168.178.xxx terwijl de RPi op 192.168.1.xxx zat. Ze staan nu beide in dezelfde range. Als ik op de modem in log dan zie ik ook de RPi in de lijst van gebruikers, inclusief dus mac en ip.

Nu kon ik de ip van de RPi toevoegen aan de "Pre-assigned DHCP IP Addresses". Ik zie wel dat de status op "reserved" staat ipv "active". Zie 2e plaatje van deze handleiding:
https://community.ziggo.n...rt-forwarding/ba-p/653855

Vervolgens ook portforwarding kunnen aanzetten op 51820. Is het zo correct?


De camera zit nu ook in dezelfde range. Deze heb ik opnieuw kunnen initializen en nu kan ik op de laptop/telefoon meekijken als ik met de Ziggo modem ben verbonden. Dus binnenshuis werkt het nu allemaal zoals ik graag wil.

Buitenshuis wil nog niet lukken. Ik denk dat Wireguard niet goed staat. Als ik op 4g zit en ik zet Wireguard aan, dan kan ik de camera niet benaderen, maar ook andere websites niet meer bezoeken. Kan iemand mij hier mee verder helpen?

(overigens lukt het benaderen van de RPi of de camera ook nog niet als ik op de wifi van de router zit, maar dat zoek ik later nog een keer uit. Eerst maar eens zorgen dat ik van buitenaf de camera kan benaderen met Wireguard)

[Voor 7% gewijzigd door SubSun op 02-02-2021 01:32]


  • JanPedaal
  • Registratie: november 2003
  • Niet online

JanPedaal

Coureur extraordinaire

SubSun schreef op dinsdag 2 februari 2021 @ 01:19:
Latertje geworden, maar heb het gevoel dat ik een stuk dichterbij ben gekomen..

Volgens mij lag het aan de ip range oid. De Ziggo modem stond in 192.168.178.xxx terwijl de RPi op 192.168.1.xxx zat. Ze staan nu beide in dezelfde range. Als ik op de modem in log dan zie ik ook de RPi in de lijst van gebruikers, inclusief dus mac en ip.

Nu kon ik de ip van de RPi toevoegen aan de "Pre-assigned DHCP IP Addresses". Ik zie wel dat de status op "reserved" staat ipv "active". Zie 2e plaatje van deze handleiding:
https://community.ziggo.n...rt-forwarding/ba-p/653855

Vervolgens ook portforwarding kunnen aanzetten op 51820. Is het zo correct?
[Afbeelding]

De camera zit nu ook in dezelfde range. Deze heb ik opnieuw kunnen initializen en nu kan ik op de laptop/telefoon meekijken als ik met de Ziggo modem ben verbonden. Dus binnenshuis werkt het nu allemaal zoals ik graag wil.

Buitenshuis wil nog niet lukken. Ik denk dat Wireguard niet goed staat. Als ik op 4g zit en ik zet Wireguard aan, dan kan ik de camera niet benaderen, maar ook andere websites niet meer bezoeken. Kan iemand mij hier mee verder helpen?

(overigens lukt het benaderen van de RPi of de camera ook nog niet als ik op de wifi van de router zit, maar dat zoek ik later nog een keer uit. Eerst maar eens zorgen dat ik van buitenaf de camera kan benaderen met Wireguard)
Heb je nu de RPi op de Ziggo modem aangesloten, terwijl de rest van je apparaten/netwerk op een andere router draait? Dan is het niet zo vreemd dat je er niet bij kan komen. Ik denk dat je beter je RPi zo kan configureren dat die ook op de router zit, en alles op je router instellen en beheren. Anders moet je redelijk ingewikkelde port forwarding gaan instellen op zowel je ziggo modem als je router..
Het klinkt alsof je RPi geen IP adres krijgt, of in een andere range zit dan je andere apparaten. Ik zou dat eerst oplossen voordat je verder gaat met Wireguard instellen en port forwarding configureren.

Release your inner hooligan - With great power comes great responsibility, with horsepower comes no responsibility


  • SubSun
  • Registratie: december 2003
  • Niet online
JanPedaal schreef op dinsdag 2 februari 2021 @ 08:14:
[...]

Heb je nu de RPi op de Ziggo modem aangesloten, terwijl de rest van je apparaten/netwerk op een andere router draait? Dan is het niet zo vreemd dat je er niet bij kan komen. Ik denk dat je beter je RPi zo kan configureren dat die ook op de router zit, en alles op je router instellen en beheren. Anders moet je redelijk ingewikkelde port forwarding gaan instellen op zowel je ziggo modem als je router..
Het klinkt alsof je RPi geen IP adres krijgt, of in een andere range zit dan je andere apparaten. Ik zou dat eerst oplossen voordat je verder gaat met Wireguard instellen en port forwarding configureren.
Dat er nog een router achter de modem hangt, maakt het inderdaad wat complexer. Echter dacht ik juist dat dit de makkelijkste oplossing is, met het oog om de camera van buitenaf te kunnen benaderen. Ik wilde even de router voorlopig buiten beschouwing laten en de rest aan de praat krijgen. Het nadeel is inderdaad dat ik vanaf de router (nog) niet naar de RPi en camera kan.

Aan de modem hangen nu dus: RPi, camera en de extra router.

Als ik de RPi nu achter de router hang en ik wil van buitenaf mee kijken, dan kom ik dus binnen op de modem >> router >> RPi met Wireguard >> router >> modem >> camera. Is dat niet een stuk moeilijker om in te stellen? Ik heb hier geen kennis over, dus ik sta er zeker voor open!

Qua aansluiting wil ik wel graag de camera op de modem houden. Deze staat namelijk in de meterkast, wat het makkelijk maakt om de camera aan te sluiten.


//toevoeging
Overigens hebben de RPi en camera nu gewoon een lokaal ip adres en zitten ze in dezelfde range als de modem.

En gebruik ik een oude smartphone, welke is verbonden met de modem, om thuis live met de camera mee te kijken. Wordt voornamelijk gebruikt om even snel te kijken wie er aan belt. Vandaar dat er niet directe noodzaak is om de camera ook vanaf de router te kunnen benaderen.

[Voor 9% gewijzigd door SubSun op 02-02-2021 10:02]


  • JanPedaal
  • Registratie: november 2003
  • Niet online

JanPedaal

Coureur extraordinaire

SubSun schreef op dinsdag 2 februari 2021 @ 09:56:
[...]
Dat er nog een router achter de modem hangt, maakt het inderdaad wat complexer. Echter dacht ik juist dat dit de makkelijkste oplossing is, met het oog om de camera van buitenaf te kunnen benaderen. Ik wilde even de router voorlopig buiten beschouwing laten en de rest aan de praat krijgen. Het nadeel is inderdaad dat ik vanaf de router (nog) niet naar de RPi en camera kan.

Aan de modem hangen nu dus: RPi, camera en de extra router.

Als ik de RPi nu achter de router hang en ik wil van buitenaf mee kijken, dan kom ik dus binnen op de modem >> router >> RPi met Wireguard >> router >> modem >> camera. Is dat niet een stuk moeilijker om in te stellen? Ik heb hier geen kennis over, dus ik sta er zeker voor open!

Qua aansluiting wil ik wel graag de camera op de modem houden. Deze staat namelijk in de meterkast, wat het makkelijk maakt om de camera aan te sluiten.
Aha, okee. Ik had aangenomen dat de camera ook aan de router hing. Zelf heb ik namelijk het Ziggo modem in bridge mode laten zetten, waar ik alleen mijn router aan heb hangen. Die router regelt vervolgens mijn home netwerk (wifi en bedraad). In jouw geval maakt het er inderdaad makkelijker op, totdat je vanaf een device die via je router contact maakt, ook mee wil kijken.
//toevoeging
Overigens hebben de RPi en camera nu gewoon een lokaal ip adres en zitten ze in dezelfde range als de modem.

En gebruik ik een oude smartphone, welke is verbonden met de modem, om thuis live met de camera mee te kijken. Wordt voornamelijk gebruikt om even snel te kijken wie er aan belt. Vandaar dat er niet directe noodzaak is om de camera ook vanaf de router te kunnen benaderen.
Als camera en RPi elkaar kunnen zien is het alleen nog zaak om wireguard goed te configureren en in je Ziggo modem port forwarding in te stellen. Met beide kan ik je niet helpen. Ik gebruik OpenVPN op mijn Rpi voor VPN toegang tot mijn netwerk, en ik heb juist voor een setup gekozen waarbij het Ziggo modem in bridge modus staat, omdat ik er niet mee kon wat ik wilde en ik op mijn eigen router veel betere configuratiemogelijkheden heb.

Release your inner hooligan - With great power comes great responsibility, with horsepower comes no responsibility


  • SubSun
  • Registratie: december 2003
  • Niet online
JanPedaal schreef op dinsdag 2 februari 2021 @ 11:31:
Aha, okee. Ik had aangenomen dat de camera ook aan de router hing. Zelf heb ik namelijk het Ziggo modem in bridge mode laten zetten, waar ik alleen mijn router aan heb hangen. Die router regelt vervolgens mijn home netwerk (wifi en bedraad). In jouw geval maakt het er inderdaad makkelijker op, totdat je vanaf een device die via je router contact maakt, ook mee wil kijken.
Daar heb je een punt. Ik heb vooral een router er achter gehangen, omdat ik het wifi-bereik van de Ziggo modem niet zo goed vindt. Het zal ook niet helpen dat deze in de meterkast staat. Mijn eigen router geeft een betere dekking (en staat ook ergens anders in het huis).

Het draait al jaren zo en tot zover prima. Totdat ik nu aan het stoeien ben met de RPi, VPN en de camera.

Moeilijke kwestie voor mij, vooral ook door mijn beperkte kennis. Ga ik het zo laten en het proberen werkend te krijgen via de modem. Of ook de modem in bridge mode zetten en dan alles door de router laten bepalen? Op de ziggo modem hoef ik dan niks meer in te stellen/open te zetten toch? Bijkomend nadeel is wel dat ik dan extra kabel moet trekken tussen de router en de camera, wat niet zo eenvoudig is. Of anders ook de router in de meterkast plaatsen, wat het wifi bereik dan weer iets beperkt.
JanPedaal schreef op dinsdag 2 februari 2021 @ 11:31:
Als camera en RPi elkaar kunnen zien is het alleen nog zaak om wireguard goed te configureren en in je Ziggo modem port forwarding in te stellen. Met beide kan ik je niet helpen. Ik gebruik OpenVPN op mijn Rpi voor VPN toegang tot mijn netwerk, en ik heb juist voor een setup gekozen waarbij het Ziggo modem in bridge modus staat, omdat ik er niet mee kon wat ik wilde en ik op mijn eigen router veel betere configuratiemogelijkheden heb.
Ja, daar zit net het punt. Hoe controleer ik wat er nu fout staat..

Ik zie trouwens dat ik alleen via Ziggo de modem in bridge mode kan laten zetten. Dan houden we die optie voor nu even in het achterhoofd. Toch bedankt voor het meedenken!

[Voor 31% gewijzigd door SubSun op 02-02-2021 14:14]


  • nero355
  • Registratie: februari 2002
  • Laatst online: 18:49

nero355

ph34r my [WCG] Cows :P

SubSun schreef op dinsdag 2 februari 2021 @ 13:46:
Ja, daar zit net het punt. Hoe controleer ik wat er nu fout staat...
De situatie die je hebt gecreëerd maakt de boel onnodig ingewikkeld, terwijl het allemaal heel simpel zou zijn als je gewoon de Netgear Router achter je Ziggo modem/router in Bridged mode zou configureren :)
Ik zie trouwens dat ik alleen via Ziggo de modem in bridge mode kan laten zetten. Dan houden we die optie voor nu even in het achterhoofd. Toch bedankt voor het meedenken!
Dat moet je IMHO sowieso doen! d:)b

|| DPC GoT WhatPulse Team :) || Pi-Hole : Geen advertenties meer voor je hele netwerk! >:) ||


  • SubSun
  • Registratie: december 2003
  • Niet online
@JanPedaal @nero355
Nou we gaan het zien.. modem staat nu als bridge! Moest wel 2x de aanvraag doen, de eerste keer hadden ze alleen de modem gereset, maar niet als bridge ingesteld :/

Ga er morgen naar kijken, ben bang dat het weer een latertje worden als ik er nu nog aan begin. Hopelijk kan ik snel goed nieuws melden.. en anders zien jullie mij ook weer snel terug :)

[Voor 4% gewijzigd door SubSun op 02-02-2021 22:12]


  • SubSun
  • Registratie: december 2003
  • Niet online
Bizar..

Ik dacht laat ik alles resetten zodat ik morgen direct schoon van start kan gaan. Router gereset, RPi geleegd en OS er opnieuw opgezet, camera naar fabrieksinstellingen. Redelijk snel alles weer netjes gekregen. Het was nog niet zo heel laat en het bleef toch kriebelen. Dan toch maar verder: WireGuard er op gezet, QR code gegeneerd en telefoon gekoppeld. Even zoeken hoe ik op de router portforwarding kon aanzetten. En het werkt gewoon! _/-\o_

Dubbelcheck gedaan met portforwarding uit en dan kom ik er niet op; netjes. Zelfs al zou een kwaadwillende mijn ip en de port weten, dan nog kan hij er niet op zonder de keys van WireGuard toch?

Dit alles in een ruim een uurtje, waarvan het meeste nog wachten was op de installatie van WireGuard. Als ik dit eerder had geweten.. had mij 2 avonden frustratie gescheeld haha.

  • SA007
  • Registratie: oktober 2002
  • Laatst online: 12-06 21:14

SA007

Moderator Tweaking
Dit is best een eigen topic waard, dus heb het afgesplitst naar een los topic.

Klok is stuk :(


  • SubSun
  • Registratie: december 2003
  • Niet online
Bah, gister kon ik vanaf de 4g op mijn netwerk komen en met de camera meekijken.

Nu ineens niet meer :( Vanavond maar weer eens verder zoeken

  • Thijsmans
  • Registratie: juli 2001
  • Laatst online: 15:18

Thijsmans

⭐⭐⭐⭐⭐ (5/5)

Nu vroeg ik mij af of dit klopt, met name DNS servers en Allowed IPs?:
Ja: de DNS (1.1.1.1) is Cloudflare, en allowed IP's 0.0.0.0/0 betekent - in mijn brakke woorden :P - dat er 0 bits van het IP-adres worden gecheckt (lees: alles is toegestaan/valt eronder).
Wat mij ook opvalt is dat als ik de RPi aan de Ziggo modem hang, dat de het lampje van de LAN verbinding oranje blijft. Overigens gebeurt dit ook als ik mijn camera aan de modem hang (met een PoE injector), maar dat even terzijde. De router die achter de modem hangt en mijn laptop, ter test even via kabel aangesloten, krijgen wel een groen lampje. Betekent dit dat de RPi geen IP krijgt toegewezen?
Nee: een oranje lampje betekent dat je een 100MB apparaat hebt verbonden, een groen lampje is een 1GB apparaat.
Bah, gister kon ik vanaf de 4g op mijn netwerk komen en met de camera meekijken.

Nu ineens niet meer :( Vanavond maar weer eens verder zoeken
Ga na wat er is veranderd. Is de camera niet gewoon vastgelopen?

Benieuwd naar jouw ervaring met mijn e-book prijsvergelijker!


  • SubSun
  • Registratie: december 2003
  • Niet online
Thijsmans schreef op woensdag 3 februari 2021 @ 17:07:
[...]

Ja: de DNS (1.1.1.1) is Cloudflare, en allowed IP's 0.0.0.0/0 betekent - in mijn brakke woorden :P - dat er 0 bits van het IP-adres worden gecheckt (lees: alles is toegestaan/valt eronder).
Ik heb inderdaad gekozen voor Cloudfare.
Nee: een oranje lampje betekent dat je een 100MB apparaat hebt verbonden, een groen lampje is een 1GB apparaat.
👍
Ga na wat er is veranderd. Is de camera niet gewoon vastgelopen?
Ik had ook gehoopt op zoiets, maar op het thuisnetwerk kan ik er wel bij. Gister naar bed gegaan en vandaag werken. Heb zelf niks aangepast dus vraag me echt af wat het kan zijn.

Net klaar met werken en weinig fut meer om er nog in te duiken. Ga morgen alles nalopen.

  • SubSun
  • Registratie: december 2003
  • Niet online
Update:
Eerst mijn telefoon opnieuw gekoppeld met WireGuard; geen verschil helaas. Zag wel in WireGuard onder het kopje 'Transfer' de tx oplopen maar de rx bleef op 0 staan. Via Google gevonden dat dit betekent dat de verbinding maar 1 richting op gaat.

Vervolgens in de router naar de portforwarding gekeken. Deze stond er nog gewoon in. Toch op de gok uitgezet en weer aangezet. Hij doet het weer!Zowel de rx als tx lopen nu op bij verbinding.

En hopelijk blijft ook zo O-)

  • Lennyz
  • Registratie: januari 2010
  • Laatst online: 11-06 07:55
SubSun schreef op donderdag 4 februari 2021 @ 10:04:
Update:
Eerst mijn telefoon opnieuw gekoppeld met WireGuard; geen verschil helaas. Zag wel in WireGuard onder het kopje 'Transfer' de tx oplopen maar de rx bleef op 0 staan. Via Google gevonden dat dit betekent dat de verbinding maar 1 richting op gaat.

Vervolgens in de router naar de portforwarding gekeken. Deze stond er nog gewoon in. Toch op de gok uitgezet en weer aangezet. Hij doet het weer!Zowel de rx als tx lopen nu op bij verbinding.

En hopelijk blijft ook zo O-)
Een VPN moet wel blijven werken. Als je deze steeds opnieuw moet starten dan is er iets niet goed.

Ik weet niet of je bekend bent met docker, maar ik gebruik zelf dit docker image voor wireguard. Werkt perfect.

https://github.com/linuxserver/docker-wireguard

  • SubSun
  • Registratie: december 2003
  • Niet online
Lennyz schreef op donderdag 4 februari 2021 @ 12:03:
[...]


Een VPN moet wel blijven werken. Als je deze steeds opnieuw moet starten dan is er iets niet goed.

Ik weet niet of je bekend bent met docker, maar ik gebruik zelf dit docker image voor wireguard. Werkt perfect.

https://github.com/linuxserver/docker-wireguard
Ben er niet bekend mee..

Voorlopig draait het netjes. Kijk het de komende dagen ff aan. Mocht de verbinding er nu weer uit liggen dan kijken we weer verder. Mogelijk kan het ook aan de RPi hebben gelegen. Het is er nog 1 van de eerste generatie. Na heel lang in de kast te hebben gelegen toch weer leven in geblazen :)

  • Vulpecula
  • Registratie: april 2001
  • Laatst online: 10-06 18:19
Waarom niet gewoon pivpn gebruiken, heeft tegenwoordig ook wireguard support. Toevallig van de week nog geinstalleerd.

[Voor 0% gewijzigd door Vulpecula op 07-02-2021 01:02. Reden: Typo]


  • SubSun
  • Registratie: december 2003
  • Niet online
Vulpecula schreef op zondag 7 februari 2021 @ 01:02:
Waarom niet gewoon pivpn gebruiken, heeft tegenwoordig ook wireguard support. Toevallig van de week nog geinstalleerd.
De tutorial die ik heb gebruikt, maakt ook gebruik van pivpn? Of bedoel je toch wat anders? Ben verder niet bekend met de materie dus ben blij dat het is gelukt.

Het draait nog steeds netjes. Dus so far so good. Ga er vanuit dat het een eenmalig hickupje was :*)
Pagina: 1


Apple iPad Pro (2021) 11" Wi-Fi, 8GB ram Microsoft Xbox Series X LG CX Google Pixel 5a 5G Sony XH90 / XH92 Samsung Galaxy S21 5G Sony PlayStation 5 Nintendo Switch Lite

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2021 Hosting door True