Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie
Toon posts:

Pomp (cv) aansturen met PWM / 0-10v led dimmer

Pagina: 1
Acties:

  • BenH
  • Registratie: juni 2012
  • Laatst online: 08:56
Beste Tweakers,

ik heb in mijn woning verschillende Grundfos UPM3 pompen zitten (o.a. cv, friswaterstation, zonnecollectoren). Deze kunnen allen aangestuurd worden door middel van een PWM signaal (2 aderig). Ik heb een jaar geleden een LTech PWM led dimmer gekocht welke een PWM signaal output a.d.h.v. een 0-10v signaal (deze komt uit mijn Loxone domotica systeem). Ik heb dit toendertijd getest en dit werkte. Daarna niet meer aan toegekomen om het ook echt in te zetten dus wil ik dat nu weer oppakken.

Ik heb de dimmer wederom aangesloten maar, zoals jullie al kunnen raden, doet de pomp niks. De pomp staat in PWM modus maar blijft uit. 1 led op de pomp knippert (groen) dus hij staat klaar om het PWM signaal te ontvangen. Ik heb al van alles geprobeerd maar krijg het gewoon simpelweg niet werkend.

Misschien is hier iemand die mij op weg kan helpen?

Dimmer:
https://ltech-led.eu/nl/0...v-push-1x10a-dinrail.html

Pomp:
https://www.grundfos.com/...-product/upm3-hybrid.html

Ik heb het als volgt aangesloten:

- Loxone miniserver 0-10 volt (+ en -) aangesloten op 1-10v socket
- 24 volt vdc voeding (+ en -) (deze voeding zorgt ook voor de voeding van de Loxone miniserver) aangesloten op 12-24 vdc Power Input Socket
- Grundfos PWM kabel, bruin (PWM input) / blauw (Ground), op Led Lamps Connection Socket

Met de multimeter meet ik het juiste voltage op de dimmer van de 0-10volt. Ik meet op de dimmer ook netjes 24 volt bij de Power Input Socket. Op de Led Lamps Connection Socket meet ik, naar gelang het opgegeven voltage bij 0-10 volt, minimaal 11 volt en maximaal 24 volt.

[Voor 22% gewijzigd door BenH op 05-06-2019 12:47]


  • Xiphalon
  • Registratie: juni 2001
  • Laatst online: 10:23
Die LED dimmer geeft een PWM singaal af voor LEDs. Ik vermoed dat dat veel te hoog is qua frequentie voor de pomp.

De pomp verwacht een blokgolf van 100 tot 4000 Hz

  • BenH
  • Registratie: juni 2012
  • Laatst online: 08:56
Xiphalon schreef op woensdag 5 juni 2019 @ 12:59:
Die LED dimmer geeft een PWM singaal af voor LEDs. Ik vermoed dat dat veel te hoog is qua frequentie voor de pomp.

De pomp verwacht een blokgolf van 100 tot 4000 Hz
Heb je enig idee hoe ik dit wél werkend kan krijgen?

Acties:
  • +1Henk 'm!

  • Proton_
  • Registratie: november 2011
  • Laatst online: 12:55

Proton_

Team Welles

@BenH
Kijk op https://net.grundfos.com/...fosliterature-5439390.pdf pagina 17 voor de PWM specs.
De datasheet van je dimmer vermeldt geen schakelfrequentie of principeschema, dus vanaf hier kunnen we niet controleren of het überhaupt zou moeten werken :)

Het meest voor de hand liggend is dat de dimmer alleen een mosfet naar ground schakelt.
Ik vermoed dat de led-dimmer geen pullup heeft, dus dat de output hoog blijft (iig boven de 1 volt die de pomp wil zien).
Dat klopt met je meting: die gaat niet naar 0 maar begint bij 11V.

Dan kan een weerstand tussen out- en out+ van ergens tussen de 100 en 10k het probleem verhelpen.

'19 Kona na '15 Zoe, douchen met wtw en Auer Edel Eau


  • BenH
  • Registratie: juni 2012
  • Laatst online: 08:56
Proton_ schreef op woensdag 5 juni 2019 @ 14:55:
@BenH
Kijk op https://net.grundfos.com/...fosliterature-5439390.pdf pagina 17 voor de PWM specs.
De datasheet van je dimmer vermeldt geen schakelfrequentie of principeschema, dus vanaf hier kunnen we niet controleren of het überhaupt zou moeten werken :)

Het meest voor de hand liggend is dat de dimmer alleen een mosfet naar ground schakelt.
Ik vermoed dat de led-dimmer geen pullup heeft, dus dat de output hoog blijft (iig boven de 1 volt die de pomp wil zien).
Dat klopt met je meting: die gaat niet naar 0 maar begint bij 11V.

Dan kan een weerstand tussen out- en out+ van ergens tussen de 100 en 10k het probleem verhelpen.
Klinkt inderdaad wel logisch eigenlijk. Ben best technisch maar qua elektronica kan ik nog wel wat leren :-)

Ik ga je tip proberen! Heb volgens mij nog wel een weerstand liggen met de genoemde weerstand. Zodra ik meer weet laat ik het weten!

  • BenH
  • Registratie: juni 2012
  • Laatst online: 08:56
Proton_ schreef op woensdag 5 juni 2019 @ 14:55:
@BenH
Dan kan een weerstand tussen out- en out+ van ergens tussen de 100 en 10k het probleem verhelpen.
Ik heb nog een weerstand liggen van 100 Ohm - 1/4 watt. Deze kan ik zeker niet gebruiken?

Of moet ik gewoon zoiets bestellen?
https://www.allekabels.nl...66/1085882/weerstand.html

[Voor 14% gewijzigd door BenH op 05-06-2019 15:17]


  • Proton_
  • Registratie: november 2011
  • Laatst online: 12:55

Proton_

Team Welles

Nee, daar raak je 6 watt in kwijt op 24V :)
In 1/4W heb je minimaal 2k4 nodig.

'19 Kona na '15 Zoe, douchen met wtw en Auer Edel Eau


  • BenH
  • Registratie: juni 2012
  • Laatst online: 08:56
Proton_ schreef op woensdag 5 juni 2019 @ 15:19:
Nee, daar raak je 6 watt in kwijt op 24V :)
In 1/4W heb je minimaal 2k4 nodig.
Wat voor weerstand raad je aan? Hoeveel watt? Ik moet hem nog bestellen dus kan de wattage nog bepalen (in je voorbeeld hierboven: wat voor wattage praten we dan over met 100 - 10k?)

  • Proton_
  • Registratie: november 2011
  • Laatst online: 12:55

Proton_

Team Welles

P=U²/R (variant van de wet van ohm)
vermogen= spanning²/weerstand
Je spanning is 24 volt.

Probeer eens een 5k weerstand van 1/4 watt.

[Voor 26% gewijzigd door Proton_ op 05-06-2019 15:33]

'19 Kona na '15 Zoe, douchen met wtw en Auer Edel Eau


  • BenH
  • Registratie: juni 2012
  • Laatst online: 08:56
Proton_ schreef op woensdag 5 juni 2019 @ 15:32:
P=U²/R (variant van de wet van ohm)
vermogen= spanning²/weerstand
Je spanning is 24 volt.

Probeer eens een 5k weerstand van 1/4 watt.
Ik heb zojuist een weerstand van 1/4 watt van 4.7kΩ geprobeerd maar de pomp doet nog niks. Wel zie ik dat als ik vanuit mijn Domotica 5 volt uitstuur, de spanning op de dimmer naar de leds toe rond de 7.1 volt is. Bij 3 volt stuurspanning is de uitgaande spanning van de dimmer 3.1 volt.

Heb je nog ideeen?

  • BenH
  • Registratie: juni 2012
  • Laatst online: 08:56
Ik heb overigens een setje weerstanden besteld (allemaal 1/4 watt):


1.5Ω
4.7Ω
10Ω
47Ω
100Ω
220Ω
330Ω
470Ω
680Ω
1kΩ
2.2kΩ
3.3kΩ
4.7kΩ
10kΩ
22kΩ
47kΩ
100kΩ
330kΩ
1MΩ

  • Proton_
  • Registratie: november 2011
  • Laatst online: 12:55

Proton_

Team Welles

@BenH
Hmm. Dat hielp dus niet.
En je geeft aan dat het wel gewerkt heeft...

Met de 4k7 weerstand als belasting kan je met je multimeter nagaan hoe de dimmer werkt.
Zet hem op een 100% signaal, meet zowel out+ als out- ten opzichte van de min van je voedingsspanning (=ground).
Herhaal dit bij een 50% signaal en 10%.

Ik gok dat de pomp tussen ground en out- moet worden aangesloten (en laat de weerstand zitten).

'19 Kona na '15 Zoe, douchen met wtw en Auer Edel Eau


  • BenH
  • Registratie: juni 2012
  • Laatst online: 08:56
Proton_ schreef op dinsdag 11 juni 2019 @ 15:00:
@BenH
Hmm. Dat hielp dus niet.
En je geeft aan dat het wel gewerkt heeft...

Met de 4k7 weerstand als belasting kan je met je multimeter nagaan hoe de dimmer werkt.
Zet hem op een 100% signaal, meet zowel out+ als out- ten opzichte van de min van je voedingsspanning (=ground).
Herhaal dit bij een 50% signaal en 10%.

Ik gok dat de pomp tussen ground en out- moet worden aangesloten (en laat de weerstand zitten).
Ik heb de 4k7 weerstand tussen out + en out - geplaatst.

Bij 10 volt:
Tussen out + en out -: 24 volt
Tussen out + en gnd (van 10 volt signaal): 24 volt
Tussen out + en gnd (van 24 volt voeding): 24 volt
Tussen out - en gnd (van 10 volt signaal): 0 volt

Bij 5 volt:
Tussen out + en out -: 7 volt
Tussen out + en gnd (van 10 volt signaal): 24 volt
Tussen out + en gnd (van 24 volt voeding): 24 volt
Tussen out - en gnd (van 10 volt signaal): 17 volt

Bij 1 volt:
Tussen out + en out -: 0 volt
Tussen out + en gnd (van 10 volt signaal): 24 volt
Tussen out + en gnd (van 24 volt voeding): 24 volt
Tussen out - en gnd (van 10 volt signaal): 24 volt

:?

[Voor 6% gewijzigd door BenH op 11-06-2019 20:18]


  • Proton_
  • Registratie: november 2011
  • Laatst online: 12:55

Proton_

Team Welles

De dimmer werkt dus niet lineair, op zich niet gek want onze ogen zijn dit ook niet.
Maar tussen out+ en out- lijkt wel degelijk het beoogde signaal te staan (afgezien van de frequentie die we niet kunnen controleren).

Andere mogelijke oorzaken: pomp niet juist op PWM ingesteld, kabels omgedraaid, suffe dingen zoals als kabelbreuk of een defect in de pomp.

'19 Kona na '15 Zoe, douchen met wtw en Auer Edel Eau


  • BenH
  • Registratie: juni 2012
  • Laatst online: 08:56
Proton_ schreef op woensdag 12 juni 2019 @ 08:57:
De dimmer werkt dus niet lineair, op zich niet gek want onze ogen zijn dit ook niet.
Maar tussen out+ en out- lijkt wel degelijk het beoogde signaal te staan (afgezien van de frequentie die we niet kunnen controleren).

Andere mogelijke oorzaken: pomp niet juist op PWM ingesteld, kabels omgedraaid, suffe dingen zoals als kabelbreuk of een defect in de pomp.
Andere pomp kan ik nog proberen (heb er 3). Kabels omgedraaid heb ik ook al getest.

Eerder zei je "Ik vermoed dat de led-dimmer geen pullup heeft, dus dat de output hoog blijft (iig boven de 1 volt die de pomp wil zien).". Maar als ik het goed heb, heb ik toch nog steeds een uitgaand signaal > 1 volt?

  • Proton_
  • Registratie: november 2011
  • Laatst online: 12:55

Proton_

Team Welles

Je multimeter laat de gemiddelde waarde zien, voor dit doel goed genoeg, maar om het PWM signaal zichtbaar te maken heb je een oscilloscoop nodig :)
Uitgaande van een 100 Hz signaal op 20% is de uitgang in het ideale geval 2 ms op 0V en 8 ms op 24V. Je multimeter middelt dit uit over een seconde oid en laat dus 4,8V zien.

'19 Kona na '15 Zoe, douchen met wtw en Auer Edel Eau


  • BenH
  • Registratie: juni 2012
  • Laatst online: 08:56
@Proton_ Ah. Helder! Ik zal de kabels nog eens express omdraaien, andere pomp proberen en andere bekabeling. Ik hou je op de hoogte!

  • Proton_
  • Registratie: november 2011
  • Laatst online: 12:55

Proton_

Team Welles

@BenH hoe test je de pomp trouwens? Met een 100% signaal of met een 50% signaal? PWM A betekent 100%=uit.

'19 Kona na '15 Zoe, douchen met wtw en Auer Edel Eau


  • BenH
  • Registratie: juni 2012
  • Laatst online: 08:56
Proton_ schreef op woensdag 12 juni 2019 @ 15:01:
@BenH hoe test je de pomp trouwens? Met een 100% signaal of met een 50% signaal? PWM A betekent 100%=uit.
Ik test hem met beide profielen en loop alle voltages af. Omdat je inderdaad omgekeerde profielen hebt :-)

  • Proton_
  • Registratie: november 2011
  • Laatst online: 12:55

Proton_

Team Welles

Vreemd, je hebt een groen knipperend lampje genoemd en die staat in de handleiding bij de UPMO die alleen profiel A doet :?

'19 Kona na '15 Zoe, douchen met wtw en Auer Edel Eau


  • BenH
  • Registratie: juni 2012
  • Laatst online: 08:56
Proton_ schreef op woensdag 12 juni 2019 @ 15:10:
Vreemd, je hebt een groen knipperend lampje genoemd en die staat in de handleiding bij de UPMO die alleen profiel A doet :?
Ik heb een UPM3 Hybrid (daar test ik mee) en een UPM3 Solar (daar kan ik ook mee testen). In de handleiding staat dat bij een groen knipperend lampje de pomp op een pwm signaal wacht?

  • BenH
  • Registratie: juni 2012
  • Laatst online: 08:56
Tot op heden heb ik het bovenstaande nog steeds niet werkend :(

Ik heb in de tussentijd wel een andere analoog naar pwm converter gekocht om te kijken of dit nog verschil zou maken maar helaas ..

De converter die ik heb gekocht:

https://www.dennisdeal.co...odule-0-5v-0-10v-to-0-100

Weet gewoon niet hoe ik dit aan de praat moet gaan krijgen. Heb al wel gezien dat er ook cv / circulatie pompen zijn met een 0-10v stuur signaal maar dan moet ik alle (3x) pompen gaan vervangen ..

Heeft iemand nog een idee?

Ik heb zelf ook al een tijd geleden de Loxone Multi Extension Air gekocht omdat deze 4 PWM uitgangen heeft:

https://www.loxone.com/nlnl/kb/multi-extention-air/

Volgens de handleiding van de pomp moet ik een signaal maken van:

"Control signals
Digital low-voltage PWM signal
The square-wave PWM signal is designed for a 100 to 4,000 Hz frequency range. The PWM signal is used to select the speed (speed command) and as feedback signal. The PWM frequency on the feedback signal is fixed at 75 Hz in the pump.

Duty cycle
d % = 100 x t/T

Example
T = 2 ms (500 Hz)
t=0.6ms
d%=100x0.6/2=30%

Rating
UiH = 4-24 V
UiL ≤ 1V
IiH ≤ 10mA(dependingonUiH)

Zou het dan nog steeds komen omdat het output voltage te hoog is? Ik gebruik de 24v van de Loxone voeding dus daar zal geen signaal uitkomen < 1V (zoals UiL aangeeft). Is er een manier om een signaal van < 1V als output te krijgen?

Alvast bedankt!

  • DjaRoel
  • Registratie: juli 2016
  • Laatst online: 11:16
BenH schreef op donderdag 1 augustus 2019 @ 20:09:
Tot op heden heb ik het bovenstaande nog steeds niet werkend :(

Ik heb in de tussentijd wel een andere analoog naar pwm converter gekocht om te kijken of dit nog verschil zou maken maar helaas ..

De converter die ik heb gekocht:

https://www.dennisdeal.co...odule-0-5v-0-10v-to-0-100

Weet gewoon niet hoe ik dit aan de praat moet gaan krijgen. Heb al wel gezien dat er ook cv / circulatie pompen zijn met een 0-10v stuur signaal maar dan moet ik alle (3x) pompen gaan vervangen ..

Heeft iemand nog een idee?

Ik heb zelf ook al een tijd geleden de Loxone Multi Extension Air gekocht omdat deze 4 PWM uitgangen heeft:

https://www.loxone.com/nlnl/kb/multi-extention-air/

Volgens de handleiding van de pomp moet ik een signaal maken van:

"Control signals
Digital low-voltage PWM signal
The square-wave PWM signal is designed for a 100 to 4,000 Hz frequency range. The PWM signal is used to select the speed (speed command) and as feedback signal. The PWM frequency on the feedback signal is fixed at 75 Hz in the pump.

Duty cycle
d % = 100 x t/T

Example
T = 2 ms (500 Hz)
t=0.6ms
d%=100x0.6/2=30%

Rating
UiH = 4-24 V
UiL ≤ 1V
IiH ≤ 10mA(dependingonUiH)

Zou het dan nog steeds komen omdat het output voltage te hoog is? Ik gebruik de 24v van de Loxone voeding dus daar zal geen signaal uitkomen < 1V (zoals UiL aangeeft). Is er een manier om een signaal van < 1V als output te krijgen?

Alvast bedankt!
Volgens mij zijn de meest pwm controllers bedoeld voor leds.

Ik had hetzelfde probleem alleen dan met een Wilo pompje, uiteindelijk heeft een collega van me met een Arduino meen ik, een converter voor me gemaakt van 0-10v naar pwm 1000hz.

Dat werkt nu al meer als een jaar als een trein, ik stuur er de pomp voor de zonneboiler mee aan.

Ik kon destijds ook geen pasklaar product vinden, en de pwm functie op mijn industriële IO modules gaat niet hoger als 100hz.

De truuk was met name om het 0-10v signaal om te zetten naar 0-3.3v meen ik, omdat de gpio pennen op de Arduino met een lagere spanning werkte. Als je interesse hebt kan ik wel meer info vragen, al moet je dan wel even geduld hebben, hij is momenteel op vakantie :)

Edit, foto;

Converter Pwm

[Voor 3% gewijzigd door DjaRoel op 01-08-2019 21:09]

3300Wp Zuid Growatt 3000s / 3300Wp West Growatt 3000s / 1440Wp zuid Growatt 1500s / / 3x18HP, Zuid, 400L Buffervat


  • BenH
  • Registratie: juni 2012
  • Laatst online: 08:56
DjaRoel schreef op donderdag 1 augustus 2019 @ 21:05:

Ik kon destijds ook geen pasklaar product vinden, en de pwm functie op mijn industriële IO modules gaat niet hoger als 100hz.

De truuk was met name om het 0-10v signaal om te zetten naar 0-3.3v meen ik, omdat de gpio pennen op de Arduino met een lagere spanning werkte. Als je interesse hebt kan ik wel meer info vragen, al moet je dan wel even geduld hebben, hij is momenteel op vakantie :)

Edit, foto;

[Afbeelding: Converter Pwm]
Ah! Eindelijk iemand gevonden met dezelfde “uitdaging” :9

Ik ben zeker geïnteresseerd!

  • Skipper-93
  • Registratie: november 2009
  • Laatst online: 25-05 16:31
@BenH Ik heb van de week een instelbare PWM generator besteld via AliExpress. Om een GE ECM 2.3 ventilator mee aan te sturen. Die verwacht een signaal van 80Hz. Het printje is instelbaar van 1Hz tot 150KHz.
https://m.nl.aliexpress.com/item/32835541668.html

Edit: Heeft natuurlijk geen 0-10v input (wel serieel TTL), maar misschien handig om mee te testen.

[Voor 15% gewijzigd door Skipper-93 op 02-08-2019 10:30]

PVoutput: One / Two / Three / Wind <- YouTube


  • BenH
  • Registratie: juni 2012
  • Laatst online: 08:56
Skipper-93 schreef op vrijdag 2 augustus 2019 @ 10:23:
@BenH Ik heb van de week een instelbare PWM generator besteld via AliExpress. Om een GE ECM 2.3 ventilator mee aan te sturen. Die verwacht een signaal van 80Hz. Het printje is instelbaar van 1Hz tot 150KHz.
https://m.nl.aliexpress.com/item/32835541668.html

Edit: Heeft natuurlijk geen 0-10v input (wel serieel TTL), maar misschien handig om mee te testen.
Dat is zeker een goede! Misschien ook maar even bestellen :-). Thx!

  • BenH
  • Registratie: juni 2012
  • Laatst online: 08:56

  • BenH
  • Registratie: juni 2012
  • Laatst online: 08:56
Het mysterie gaat verder. Ik heb een Arduino besteld en geprogrammeerd om een PWM signaal te zenden. Wederom gebeurd er helemaal niks.

Ik bedacht mij opeens dat ik nog 2 controllers had liggen van voor de tijd dat ik Loxone / Domotica had. Een van de twee controllers kon een PWM signaal uitzenden dus ideaal om mee te testen! Het gaat om:

Sorel STDC-V3
https://sorel.de/en/controller/tdc-solar-controls/stdc

Ik heb hem aangesloten. Geselecteerd dat hij een PWM signaal moet uitzenden. Het juiste profiel geselecteerd (er was zelfs een speciaal profiel voor Grundfos UPM3 pompen) en gezorgd dat de pomp aanging. Maar helaas .. De pomp doet nog steeds niks. Het lijkt dus niet om de aansturing te gaan?

Ik ben inmiddels alle standen van de Grundfos pomp afgegaan, heb 2 pompen geprobeerd en heb ook verschillende kabels geprobeerd (ook de originele Grundfos kabel met stekker die op de pomp klikt).

Het blijft dus een wazig verhaal allemaal. Zit eraan te denken om een andere (merk) pomp te bestellen met PWM aansturing om te kijken of die wel wil werken met PWM .. Wel zonde want dan moet ik drie pompen (heatpipes, cv en friswaterstation) vervangen ..

  • DjaRoel
  • Registratie: juli 2016
  • Laatst online: 11:16
BenH schreef op donderdag 15 augustus 2019 @ 19:56:
Het mysterie gaat verder. Ik heb een Arduino besteld en geprogrammeerd om een PWM signaal te zenden. Wederom gebeurd er helemaal niks.

Ik bedacht mij opeens dat ik nog 2 controllers had liggen van voor de tijd dat ik Loxone / Domotica had. Een van de twee controllers kon een PWM signaal uitzenden dus ideaal om mee te testen! Het gaat om:

Sorel STDC-V3
https://sorel.de/en/controller/tdc-solar-controls/stdc

Ik heb hem aangesloten. Geselecteerd dat hij een PWM signaal moet uitzenden. Het juiste profiel geselecteerd (er was zelfs een speciaal profiel voor Grundfos UPM3 pompen) en gezorgd dat de pomp aanging. Maar helaas .. De pomp doet nog steeds niks. Het lijkt dus niet om de aansturing te gaan?

Ik ben inmiddels alle standen van de Grundfos pomp afgegaan, heb 2 pompen geprobeerd en heb ook verschillende kabels geprobeerd (ook de originele Grundfos kabel met stekker die op de pomp klikt).

Het blijft dus een wazig verhaal allemaal. Zit eraan te denken om een andere (merk) pomp te bestellen met PWM aansturing om te kijken of die wel wil werken met PWM .. Wel zonde want dan moet ik drie pompen (heatpipes, cv en friswaterstation) vervangen ..
Ik zal m'n collega eens polsen of hij een schema heeft, hij is vandaag weer begonnen 🙂

3300Wp Zuid Growatt 3000s / 3300Wp West Growatt 3000s / 1440Wp zuid Growatt 1500s / / 3x18HP, Zuid, 400L Buffervat


  • BenH
  • Registratie: juni 2012
  • Laatst online: 08:56
DjaRoel schreef op maandag 19 augustus 2019 @ 22:36:
[...]

Ik zal m'n collega eens polsen of hij een schema heeft, hij is vandaag weer begonnen 🙂
Zou top zijn!

  • Jazsie
  • Registratie: juni 2006
  • Laatst online: 12:47
Wat gebeurd er als je de pomp op PWM profiel A zet met niks aangesloten op de PWM in?

Volgens de specs zou de pomp dan op 100% moeten draaien wegen gebrek aan PWM signaal.

Aansturing met Arduino zou moeten werken, wellicht dat je meer succes hebt met het schema van @BenH

1335 Wp op 0° (vrijwel plat)


  • Skipper-93
  • Registratie: november 2009
  • Laatst online: 25-05 16:31
BenH schreef op vrijdag 2 augustus 2019 @ 12:49:
[...]


Dat is zeker een goede! Misschien ook maar even bestellen :-). Thx!
Ik heb dat printje inmiddels kunnen testen. Hij werkt goed met die ventilator. En onthoud zijn instellingen.

PVoutput: One / Two / Three / Wind <- YouTube


  • BenH
  • Registratie: juni 2012
  • Laatst online: 08:56
Skipper-93 schreef op dinsdag 20 augustus 2019 @ 10:34:
[...]

Ik heb dat printje inmiddels kunnen testen. Hij werkt goed met die ventilator. En onthoud zijn instellingen.
Nice! Altijd handig om te hebben om mee te testen :-)


Ik heb het probleem inmiddels opgelost! Ik heb een nieuwe pomp besteld (Oeg.net) met PWM aansturing. Gisteren ertussen gezet en de Arduino eraan gehangen: werkt in een keer! Dus de andere twee pompen komen morgen binnen :9

Vanavond verder met het programmeren van de Arduino (zodat hij een Analoog signaal accepteert en aan de hand daarvan de DutyCycle berekent).

Was het gedoe zo zat (ben hier al maanden mee bezig) dus toen de nieuwe pomp direct werkte op PWM, was voor mij de kogel door de kerk. Ik heb dus na morgen drie Grundfos UPM3 pompen over voor de geïnteresseerde O-)

Bedankt voor alle hulp!

  • Gwaihir
  • Registratie: december 2002
  • Laatst online: 25-05 16:55
Heb je de Arduino nog nodig, of werkt het ook rechstreeks aan de PWM-uitgangen?

Ik zit ondertussen ook verder te puzzelen hieraan en krijg de indruk dat alle standaard digitale uitgangen (5A) van Loxone het zouden moeten kunnen (met zo'n PWM blok).

De voorbeelden koppelen nl. simpelweg naar een digitale uitgang..
https://www.loxone.com/nlnl/kb/impuls-breedte-modulator/
https://www.loxone.com/nlnl/kb/zonnecollector/

Alleen staan bij de 16A en 10A relais reactietijden in de documentatie en daar ga je geen PWM over een 100 - 4000Hz klokpuls mee halen. Dus vermoed ik dat dit voor (alleen) de 5A 'relais' geldt.

Zal 'ns opletten wat mijn installateur in gedachten heeft. Misschien is Grundfoss even niet zo handig..

Acties:
  • 0Henk 'm!

  • PKan
  • Registratie: augustus 2018
  • Laatst online: 25-05 16:42
@BenH Momenteel loop ik tegen dezelfde problemen op als jij dat in dit topic had (PWM pomp aansturen met een Arduino PWM uitgang). In jou laatste post zie ik dat je uiteindelijk succesvol jou nieuwe OEG PMW pomp kan aansturen met een Arduino PMW output.

Kan jij de uiteindelijke configuratie beschrijven (en mssn ook je Arduino scetch code)? Zou mij ontzettend veel helpen :). Alsvast bedankt!

Acties:
  • 0Henk 'm!

  • Gwaihir
  • Registratie: december 2002
  • Laatst online: 25-05 16:55
Ik ben er inmiddels ook wat stappen verder mee.
Gwaihir schreef op vrijdag 1 november 2019 @ 20:30:
Alleen staan bij de 16A en 10A relais reactietijden in de documentatie en daar ga je geen PWM over een 100 - 4000Hz klokpuls mee halen. Dus vermoed ik dat dit voor (alleen) de 5A 'relais' geldt.
Bijgeleerd: de PWM blokken van Loxone (over die uitgangen) zijn bedoeld voor véél langzamere signalen. Om bijv. een elektrische aan/uit verwarming toch min of meer te laten moduleren. Ook het 5A relais zou je - voor zoverre het al meewerkt - in no-time verslijten.

Ze hebben wel een air-multi extension met PWM uitgangen voor bijv. pompen en een PWM dimmer. Omdat de multi-extension een gek en duur ding zou zijn in de centrale kast, ging ik voor de dimmer. En mijn installateur kwam ook met een OEG pomp. Dat blijkt niet zo maar goed te werken. Inmiddels ben ik er achter dat de dimmer een minimum last nodig heeft, ergens tussen de 1 en 5W (mijn test-belastingen), om een stabiel signaal af te geven. Hoop er met een 4W potmeter uit te komen (nog te bestellen).
Pagina: 1


Apple iPhone SE (2020) Microsoft Xbox Series X LG CX Google Pixel 4a CES 2020 Samsung Galaxy S20 4G Sony PlayStation 5 Nintendo Switch Lite

'14 '15 '16 '17 2018

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2020 Hosting door True