Cookies op Tweakers

Tweakers is onderdeel van DPG Media en maakt gebruik van cookies, JavaScript en vergelijkbare technologie om je onder andere een optimale gebruikerservaring te bieden. Ook kan Tweakers hierdoor het gedrag van bezoekers vastleggen en analyseren. Door gebruik te maken van deze website, of door op 'Cookies accepteren' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt? Bekijk dan ons cookiebeleid.

Meer informatie

Vraag


  • Rednas_N
  • Registratie: september 2010
  • Laatst online: 07:50
Sinds vandaag heb ik ook T-Mobile glasvezel en heb direct de standaard router vervangen voor een TP-Link Archer C7 (Ziggo Wifibooster :) ) met OpenWrt erop. Ik moet eerlijk zeggen dat ik niet heel erg thuis ben als het gaat het om netwerkconfiguraties maar ik vind het wel leuk om te doen/leren.

Inmiddels ben ik zover dat internet werkt, ik krijg het echter niet voor elkaar om IPTV aan de praat te krijgen. Ik heb al het een en ander geprobeerd maar het wil maar niet werken. Het idee is dat de TV box aangesloten wordt op poort 4 van de TP-Link router.

Onderstaand mijn configuratie:


Echter krijg ik steeds een fout bij het afspelen, de gids doet het overigens wel (waarschijnlijk is dat gewoon internet). Kan iemand mij op weg helpen of mij vertellen wat ik fout doe?

[Voor 1% gewijzigd door Rednas_N op 15-05-2019 21:23. Reden: Toevoeging]

Just do it.

Beste antwoord (via rens-br op 17-05-2019 09:36)


  • Rednas_N
  • Registratie: september 2010
  • Laatst online: 07:50
spone schreef op donderdag 16 mei 2019 @ 18:44:
Het lijkt erop dat de switch tagged 640 verwacht op poort 1, 5 of 6? Volgens mij moet de switch het verkeer untagged accepteren voor de tv box (ik verwacht in elk geval niet dat de box zelf z'n verkeer op het juiste vlan tagged).
De TV lijkt nu te werken, ik heb het nu als volgt geconfigureerd:

https://i.ibb.co/mHGj5fg/Schermafbeelding-2019-05-16-om-18-57-52.png

/etc/network/config
code:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdac:92af:d764::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth1.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option igmp_snooping '1'

config interface 'wan'
        option proto 'dhcp'
        option ifname 'eth0.300'

config interface 'wan6'
        option proto 'dhcpv6'
        option ifname 'eth0.300'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '0t 2 3'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option vid '300'
        option ports '1t 6t'

config switch_vlan
        option device 'switch0'
        option vlan '3'
        option vid '640'
        option ports '1t 4 5 6t'

[Voor 53% gewijzigd door Rednas_N op 17-05-2019 18:05. Reden: Netwerkconfiguratie toegevoegd]

Just do it.

Alle reacties


  • Quad
  • Registratie: mei 2009
  • Laatst online: 08:23

Quad

Selectief doof

@Rednas_N IGMP proxy op Lan uitgezet?

Geluk heeft geen groot huis nodig, maar wel een deur om binnen te gaan.
PVOutput
Stem hier voor koffie op GoT!


  • Rednas_N
  • Registratie: september 2010
  • Laatst online: 07:50
Heb ik zojuist gecontroleerd en volgens mij staat het uit.

Just do it.


  • hidden
  • Registratie: oktober 2003
  • Laatst online: 18-06 15:09
@Rednas_N
Als je wel je tv gids heb maar een error krijgt met het afspelen werkt meestal terugkijken wel. als dat het geval is dan is het je IGMP instelling

  • Thasaidon
  • Registratie: februari 2006
  • Laatst online: 24-06 09:06

Thasaidon

If nothing goes right, go left

Moet IGMP snooping niet enabled staan?

"Hello IT, have you tried turning it off and on again?" - "Computer says no..."


  • Quad
  • Registratie: mei 2009
  • Laatst online: 08:23

Quad

Selectief doof

Thasaidon schreef op donderdag 16 mei 2019 @ 12:06:
Moet IGMP snooping niet enabled staan?
Potdikke, je hebt gelijk.
Hier staat hij aan. :F

Ik zal te kijken bij mijn eigen config van mijn USG, daar staat het uit, maar dat klopt ook wel, TV signaal gaat via mn switch rechtstreeks door naar de TV decoder.

@Rednas_N Zet IGMP eens aan, try it again.

[Voor 6% gewijzigd door Quad op 16-05-2019 12:52]

Geluk heeft geen groot huis nodig, maar wel een deur om binnen te gaan.
PVOutput
Stem hier voor koffie op GoT!


  • Rednas_N
  • Registratie: september 2010
  • Laatst online: 07:50
Quad schreef op donderdag 16 mei 2019 @ 12:51:
[...]

Potdikke, je hebt gelijk.
Hier staat hij aan. :F

Ik zal te kijken bij mijn eigen config van mijn USG, daar staat het uit, maar dat klopt ook wel, TV signaal gaat via mn switch rechtstreeks door naar de TV decoder.

@Rednas_N Zet IGMP eens aan, try it again.
Bedankt voor de tips! Het werkt echter nog niet. Volgens mij lukt het verbinden met de server nu niet, de box geeft ook aan dat de stekker in de verkeerde poort zit.

Dit is mijn huidige configuratie, zie ik iets over het hoofd?

code:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdac:92af:d764::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth1.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option igmp_snooping '1'

config interface 'wan'
        option proto 'dhcp'
        option ifname 'eth0.300'

config interface 'wan6'
        option proto 'dhcpv6'
        option ifname 'eth0.300'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '0t 2 3 4 5'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option vid '300'
        option ports '1t 6t'

config switch_vlan
        option device 'switch0'
        option vlan '3'
        option ports '1t 5t 6t'
        option vid '640'

Just do it.


  • spone
  • Registratie: mei 2002
  • Niet online
Het lijkt erop dat de switch tagged 640 verwacht op poort 1, 5 of 6? Volgens mij moet de switch het verkeer untagged accepteren voor de tv box (ik verwacht in elk geval niet dat de box zelf z'n verkeer op het juiste vlan tagged).

Acties:
  • Beste antwoord
  • 0Henk 'm!

  • Rednas_N
  • Registratie: september 2010
  • Laatst online: 07:50
spone schreef op donderdag 16 mei 2019 @ 18:44:
Het lijkt erop dat de switch tagged 640 verwacht op poort 1, 5 of 6? Volgens mij moet de switch het verkeer untagged accepteren voor de tv box (ik verwacht in elk geval niet dat de box zelf z'n verkeer op het juiste vlan tagged).
De TV lijkt nu te werken, ik heb het nu als volgt geconfigureerd:



/etc/network/config
code:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdac:92af:d764::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth1.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option igmp_snooping '1'

config interface 'wan'
        option proto 'dhcp'
        option ifname 'eth0.300'

config interface 'wan6'
        option proto 'dhcpv6'
        option ifname 'eth0.300'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '0t 2 3'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option vid '300'
        option ports '1t 6t'

config switch_vlan
        option device 'switch0'
        option vlan '3'
        option vid '640'
        option ports '1t 4 5 6t'

[Voor 53% gewijzigd door Rednas_N op 17-05-2019 18:05. Reden: Netwerkconfiguratie toegevoegd]

Just do it.


Acties:
  • 0Henk 'm!

  • rens-br
  • Registratie: december 2009
  • Laatst online: 08:43

rens-br

Admin IN & Moderator Mobile
@Rednas_N ik heb je vraag afgesplitst van [T-Mobile Thuis Glasvezel] Ervaringen & Discussie. Je vraag werd toch iets te uitgebreid voor een E&D topic.

[Voor 20% gewijzigd door rens-br op 17-05-2019 09:37]


  • Pepperoni
  • Registratie: april 2010
  • Laatst online: 00:55
Bedankt voor deze info, vandaag hetzelfde gedaan en dit was een goede hulp. Wel wat verschillen in mijn opstelling, dus zal de relevante screenshots erbij zetten voor anderen wellicht. Gebruik een oudere TP-link waar al Openwrt op stond(WDR-3600) die binnenkort vervangen gaat worden. Heb geen TV of telefonie, dus geen eth1 in mijn settings. (dacht eerst dat geen eth1 misschien een hardware ding is wat mist op mijn router, maar dat was dus voor de TV).

Acties:
  • 0Henk 'm!

  • nldls
  • Registratie: januari 2011
  • Laatst online: 20-06 11:13
Ik maak nog gebruik van de Draytek modem, maar merk dat ik met deze router vaak de verbinding lijk te verliezen met de modem.

De snelheid van mijn bedrade verbinding wordt dan tergend langzaam (8 mbit ipv 900) en na een reboot werkt het weer.

Wat zou hier de oorzaak van kunnen zijn en hoe kan ik dit aanpassen?

  • staxas
  • Registratie: mei 2014
  • Laatst online: 24-06 11:45
@Rednas_N heb je iets speciaals moeten doen om internet aan de praat te krijgen? En is je setup ook echt bridged?

  • Rednas_N
  • Registratie: september 2010
  • Laatst online: 07:50
staxas schreef op maandag 30 november 2020 @ 09:17:
@Rednas_N heb je iets speciaals moeten doen om internet aan de praat te krijgen? En is je setup ook echt bridged?
Ik ben helemaal vergeten te reageren, sorry. Ik heb de configuratie aangepast in OpenWrt. In mijn post kan je wat afbeeldingen vinden hoe het eruit moet zien. Wat bedoel je met of mijn setup echt bridged is?

Just do it.


  • staxas
  • Registratie: mei 2014
  • Laatst online: 24-06 11:45
Geeft niet, ik heb pas gisteren het modem geinstalleerd, zonder succes overigens. Ik heb een aantal dingen geprobeerd, IGMP zowel aan en uit op zowel WAN en LAN. Bridged modus aan/uit op WAN met eth.300 als interface. Modem WAN/LAN poort op Openwrt router WAN poort. Niets lijkt te werken. Ik heb nu het modem van T-mobile als main modem aangesloten en de openwrt router er tussen uit getrokken, maar ik zou toch graag mijn eigen router willen gebruiken, om dat daar nog wat wireguard funcionaliteit op zat waar ik gebruik van maak.

En met bridged bedoel ik, is het modem dan echt alleen een pass-through apparaat, waarbij de openwrt router een ip adres van de ISP krijgt toegewezen?

Overigens, hier de laatst gebruikte configuratie:

code:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fdad:25f8:cb45::/48'

config interface 'lan'
    option type 'bridge'
    option ifname 'eth0.1'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'
    option ip6assign '60'
    list dns '192.168.1.129'

config interface 'wan'
    option proto 'dhcp'
    list dns '192.168.1.129'
    option peerdns '0'
    option ifname 'eth0.300'

config device 'wan_eth0_2_dev'
    option name 'eth0.2'
    option macaddr '0c:80:63:f6:e3:8c'

config interface 'wan6'
    option ifname 'eth0.2'
    option proto 'dhcpv6'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option vlan '1'

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fdad:25f8:cb45::/48'

config interface 'lan'
    option type 'bridge'
    option ifname 'eth0.1'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'
    option ip6assign '60'
    list dns '192.168.1.129'
    option igmp_snooping '1'

config interface 'wan'
    option proto 'dhcp'
    list dns '192.168.1.129'
    option peerdns '0'
    option ifname 'eth0.300'

[Voor 63% gewijzigd door staxas op 23-12-2020 10:58]


  • Rednas_N
  • Registratie: september 2010
  • Laatst online: 07:50
Mijn OpenWrt router hangt direct aan het kastje waar het glas binnenkomt via een ethernetkabel. Uit mijn hoofd gezegd heet dat een FTU (?). Mijn OpenWrt router krijgt dus een IP adres van T-Mobile. Er zit dus geen router tussen van T-Mobile, die ligt hier ergens in een doos ;).

Mijn configuratie is inmiddels een beetje aangepast omdat we geen televisie meer hebben, alle poorten op de router kunnen nu gebruikt worden voor internet. IGMP Snooping staat uit op de LAN interface en er is volgens mij geen mogelijkheid om dit aan te zetten op de WAN interface.

Ik mis overigens bij jou de poorten in je configuratie. In Luci kan je die configureren via Network > Switch.

Bijgevoegd mijn netwerk configuratie:

code:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fd2b:e348:02ef::/48'

config interface 'lan'
    option type 'bridge'
    option ifname 'eth1.1'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'
    option ip6assign '60'

config interface 'wan'
    option proto 'dhcp'
    option ifname 'eth0.300'
    list dns '8.8.8.8'
    list dns '8.8.4.4'
    option peerdns '0'

config interface 'wan6'
    option proto 'dhcpv6'
    option ifname 'eth0.300'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option vid '1'
    option ports '0t 2 3 4 5'

config switch_vlan
    option device 'switch0'
    option vlan '2'
    option ports '6t 1t'
    option vid '300'

[Voor 3% gewijzigd door Rednas_N op 23-12-2020 12:55]

Just do it.


  • staxas
  • Registratie: mei 2014
  • Laatst online: 24-06 11:45
Dan vermoed ik dat wat ik wil niet kan (ik heb geen glas en alleen het modem als aansluiting). Ik had de vlans ingesteld zoals op de foto's, geen idee waarom dat niet op de output staat.

Ik denk dat ik mijn wens even uit mijn hoofd moet zetten, bedankt voor het meedenken.
Pagina: 1


Apple iPad Pro (2021) 11" Wi-Fi, 8GB ram Microsoft Xbox Series X LG CX Google Pixel 5a 5G Sony XH90 / XH92 Samsung Galaxy S21 5G Sony PlayStation 5 Nintendo Switch Lite

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2021 Hosting door True