Cookies op Tweakers

Tweakers is onderdeel van DPG Media en maakt gebruik van cookies, JavaScript en vergelijkbare technologie om je onder andere een optimale gebruikerservaring te bieden. Ook kan Tweakers hierdoor het gedrag van bezoekers vastleggen en analyseren. Door gebruik te maken van deze website, of door op 'Cookies accepteren' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt? Bekijk dan ons cookiebeleid.

Meer informatie

Vraag


  • deefje76
  • Registratie: april 2005
  • Laatst online: 03-05 16:20
Is er iemand met ervaring met SOLCON en IPTV in combinatie met een Mikrotik router

Sinds vandaag ben ik overgestapt van CaiWay naar Solcon en probeer ik IPTV aan de gang te krijgen over mijn Mikrotik.

Internet werkt prima. Echter IPTV nog niet.

VLAN voor IPTV zou volgens Solcon 188 moeten zijn.

Hoe stel ik mijn Mikrotik zodanig in dat IPTV op poort 6 uitkomt?

Bedankt alvast voor de reacties.

Beste antwoord (via deefje76 op 30-10-2018 21:52)


  • nescafe
  • Registratie: januari 2001
  • Laatst online: 21:14
Hoe kan je STB een adres krijgen terwijl er geen DHCP server op IPTV-Bridge is gedefinieerd? Heb je hem wel op poort 4 aangesloten? Of is de config incompleet?

Er moet dus in ieder geval een ip address en dhcp server op IPTV-Bridge met dhcp network (eigen segment) en ip pool indien je dit gescheiden wilt houden. Als je STB in het LAN mag kun je de igmp-proxy op bridge-local zetten en IPTV-Bridge verwijderen.

Je lokale adres zit nu op een slave interface, die moet naar de master bridge:
code:
1
2
/ip address
add address=192.168.76.1/24 comment="default configuration" interface=bridge-local network=192.168.76.0

Daarnaast is IPTV-Wan nu een privileged interface met all access naar je MT en interne netwerk. Misschien handig om een interface list WAN aan te maken met ether1-gateway en IPTV-Wan als members en inkomende verbindingen te droppen:
code:
1
2
3
4
/ip firewall filter
add action=drop chain=input comment="default configuration" in-interface-list=WAN
add action=drop chain=forward comment="default configuration" connection-nat-state=!dstnat \
  connection-state=new in-interface-list=WAN

Vermoedelijk kan heeft IPTV ook een masquerade rule nodig, dat los je op dezelfde manier op:
code:
1
2
/ip firewall nat
add action=masquerade chain=srcnat comment="Default configuration" out-interface-list=WAN

Je ziet nu een erfenissen van de 'oude' default config in je MT, het kan geen kwaad om eens helemaal opnieuw te beginnen met de huidige default config van stable/long-term, zeker nu je aan het troubleshooten bent.

* Barca zweert ook bij fixedsys... althans bij mIRC de rest is comic sans

Alle reacties


  • larshack
  • Registratie: maart 2007
  • Laatst online: 22:13

larshack

Zonder melk en suiker

Ik ken het hele apparaat niet, maar dit zou je kunnen doen:
- Twee VLANs aanmaken (internet en TV)
- Trunk op WAN interface naar Solcon met VLANs voor Internet en TV
- Alle poorten die internet moeten hebben instellen als access poort op het internet VLAN
- Alle poorten die tv moeten hebben instellen als access poort op het TV VLAN

[Voor 8% gewijzigd door larshack op 16-10-2018 10:11]


  • deefje76
  • Registratie: april 2005
  • Laatst online: 03-05 16:20
Dank Lars, heb een tip gekregen van een andere gebruiker. Deze heb ik net toegepast. Kan alleen pas vanmiddag testen omdat ik dan pas thuis ben. Ben benieuwd:
Via terminal:
/interface vlan add interface=ether1-gateway vlan-id=188 name=ether1_iptv
/interface bridge add name=iptv
/interface bridge port add bridge=iptv interface=ether6
/interface bridge port add bridge=iptv interface=ether1_iptv

  • Kasper1985
  • Registratie: oktober 2014
  • Laatst online: 11-06 18:43
Is je doel routed of bridged iptv? Zie netwerkje.com voor de verschillen.

Ik had hier laatst ook moeite mee (op een edgerouter) maar bedacht me uiteindelijk dat methode 1 veel makkelijker is.

Ik geef oersoonlijk niks om netflix en youtube op een stb (jij misschien wel dan gaat dit niet op maar dat geef je niet aan in je startpost).

Methode 1
Kabel van isp (dsl modem in dsl only mode of ntu voor glas) naar poort 1 van een managed switch
Op je managed switch:
Tag internet en tv vlans op poort 1
Poort 2: untagged (access poort) internet vlan
Poort 3: afhankelijk of hier een stb direct op komt. Voor directe aansluiting stb: untagged (access poort) tv vlan

Als je tv door wilt zetten naar bijvoorbeeld een managed switch in de tv hoek:
Tag tv vlan poort 3

Op de 2e switch:
Poort 1 (verbonden met poort 3 switch 1): tag iptv vlan.

Hou er rekening mee dat je een vlan aan moet maken op je router voor internet anders kan ne je overige poorten op de eerste switch niet zonder mee gebruiken voor internet toegang. Ik heb hiervoor vlan 1 getagged tussen 2 switches. Op netwerkje.com is dit vlan 100.

Voordeel hiervan is dat het iptv verkeer niet direct door de router hoeft. De routed methode zal een stuk meer werk vergen in de router. Omdat bij die methode de stbs direct in je lan hangen maar nog wel met het iptv platform moeten communiceren. Als je al een ander apparaat hebt bij je tv waar je netflix en youtube op kan kijken dan is, wat mij betreft, de bridged methode dmv een managed switch vele malen makkelijker.

  • deefje76
  • Registratie: april 2005
  • Laatst online: 03-05 16:20
Dank Kasper, zal jou post nog even goed doorlezen.

Volgens mij is grootste probleem dat de Amino (tv) nog geen ip adres krijgt. Ik zie wel verkeer voorbij komen, echter geen antwoord op een DHCP request.

  • lier
  • Registratie: januari 2004
  • Laatst online: 22:11

lier

MikroTik nerd

@deefje76 Ik heb zelf Caiway en heb daarbij een glasmodem waarop een Internet en (meerdere) IPTV aansluitingen zitten. Heb jij dat ook?

Ik heb op mijn RB3011 een tweede switch aangemaakt en deze verbonden met zowel het glasmodem (IPTV) als alle interactieve ontvangers. Als je IGMP uit zet dan krijg je ook verder geen problemen :-)

Eerst het probleem, dan de oplossing


  • deefje76
  • Registratie: april 2005
  • Laatst online: 03-05 16:20
@lier nee jammer genoeg niet. Ik had Caiway en nu Solcon. Op de NTU zit maar één ethernet aansluiting. Ik moet iets met de VLANS doen op mijn Mikrotik.

Volgens mij ben ik een heel eind, echter krijgt de Amino geen IP adres.

  • deefje76
  • Registratie: april 2005
  • Laatst online: 03-05 16:20
@Vesper64 Dank je wel voor je hulp. Heb de instructies uitgevoerd. De Amino box krijgt jammer genoeg geen IP ook zie ik op IPTV bridge alleen RX verkeer en geen TX.

Nog tips?

  • Vesper64
  • Registratie: januari 2008
  • Laatst online: 21:29
Amino box helemaal uit/aan gezet? Klopt het vlan nummer? Verwacht de Amino een tagged vlan? Eventueel met 'tools -> torch' kijken of en zo ja wat welk verkeer er langs komt.

  • deefje76
  • Registratie: april 2005
  • Laatst online: 03-05 16:20
Amino box helemaal uit/aan gezet? = Done
Klopt het vlan nummer? = Yep nog extra nagevraagd
Verwacht de Amino een tagged vlan? = Nee zover ik kan zien niet. Kan het niet terugvinden in config van de FritzBox. Dat zegt niets natuurlijk. Van de Fritzbox krijgt hij gewoon een IP adres in default DHCP reeks.

Het is me wel gelukt de Amino box een ip adres te laten krijgen, ik kom dan ook in het opstarten één stapje verder, echter blijft hij dan hangen bij de connectie naar de ACS. Moet even goed kijken hoe ik ervoor zorg dat hij een IP adres krijgt binnen mijn DHCP pool met de juiste opties en dan toch over VLAN 188 naar Solcon gaat.

Dacht dat ik best wel handig was, maar loop nu toch wel vast.

[Voor 18% gewijzigd door deefje76 op 16-10-2018 22:18]


  • deefje76
  • Registratie: april 2005
  • Laatst online: 03-05 16:20
Misschien is er iemand die hier wat mee kan. Dit is de config van de Fritzbox. Is er iemand die daar uit kan vertalen wat ik moet doen om het aan de praat te krijgen? Ben er inmiddels achter dat misschien ook PPPoE passtrough moet aan staan.

Inmiddels ben ik zover dat de Amino box dus een IP adres krijgt. Daarna gaat deze naar de tijd synchronisatie en vervolgens 'checking connection to ACS'', hier gaat het nu fout.

De link naar de config:
https://docs.google.com/document/d/1AYhZEY03UlQ-vbESUBBCNwbJLgeFrCdmGSZzIcchUFc/edit?usp=sharing

At the moment i have:
* added a sub vlan interface to ether1 with vlan ID 188
* created a bridge
* added the earlier created VLAN interface and the ether6 to the bridge.
* created an address space for the bridge and added the DHCP server to the bridge

The Amino box gets and IP address now, but it seems it cannot connect to the Automatic Configuration Server (ACS).

[Voor 22% gewijzigd door deefje76 op 17-10-2018 11:50]


  • Bierkameel
  • Registratie: december 2000
  • Niet online

Bierkameel

Alle proemn in n drek

https://forum.mikrotik.com/viewtopic.php?t=115543
https://taisto.org/RouterOS_IPTV/en

Je Amino moet geen DHCP krijgen uit je eigen range maar van de provider, daarvoor kan je VLAN 188 naar een bepaalde poort koppelen, probeer het eens met bovenstaande guide.

[Voor 10% gewijzigd door Bierkameel op 17-10-2018 12:24]


  • deefje76
  • Registratie: april 2005
  • Laatst online: 03-05 16:20
Thanks @Bierkameel ben iets verder weer nu. Met de instructie op Taisto kom ik nu tot 'Server Connection Complete'. Het gaat lukken, hoe en wanneer weet ik nog niet.

Die post op het Mikrotik forum had ik ook gevonden inderdaad.

  • Kasper1985
  • Registratie: oktober 2014
  • Laatst online: 11-06 18:43
@deefje76 Ga even terug naar het begin. Zoals ik zei: beslis of je dit routed of bridged wil. Wil je die Amino in je eigen LAN erbij hangen of neem je genoegen met bridged?

Voor routed IPTV op je mikrotik zou je dit moeten kunnen volgen: http://netwerkje.com/routed-iptv

Het is me niet echt duidelijk wat je doel is. Dit:

* added a sub vlan interface to ether1 with vlan ID 188
* created a bridge
* added the earlier created VLAN interface and the ether6 to the bridge.

Lijkt erop dat je voor bridged gaat. Maar daarna heb je het toch over DHCP.

  • deefje76
  • Registratie: april 2005
  • Laatst online: 03-05 16:20
@Kasper1985 je hebt gelijk.. De eerlijkheid is dat ik eigenlijk voor de eerste oplossing ben gegaan die ik vinden kon met de basale kennis die ik heb van netwerken en VLAN.

Als ik diverse artikelen lees zou routed een mooiere oplossing zijn dan bridged. Dus die heeft wel mijn voorkeur. Inmiddels heb ik meerdere adviezen en artikelen opgevolgd echter zonder het gewenste resultaat.

Wat me opviel in de bridge oplossing was dat de amino geen IP adres kreeg. Daarom heb ik een poging gedaan dit op te lossen door de DHCP server op de bridge te zetten. De Amino komt dan wel verder maar loopt vast op time sync en ACS connectie.

Als ik de instructie volgd op: https://taisto.org/RouterOS_IPTV/en komt het geheel een stuk verder. Alleen komt niet voorbij de status "Server Connection Complete".

Ik leer mijn Mikrotik overigens wel goed kennen en inmiddels begin ik ook veel meer thuis te worden in VLAN en andere netwerktechnieken, echter het gewenste resultaat is er nog niet.

Momenteel heb ik de Fritzbox er even tussen gezet, waarbij mijn Mikrotik als exposed host heb ingesteld op een statisch IP adres. Maar liefst wil ik de Fritzbox eruit hebben met de meest mooie oplossing vanuit ICT oogpunt gezien, en dat is denk ik de routed oplossing.

  • Kasper1985
  • Registratie: oktober 2014
  • Laatst online: 11-06 18:43
@deefje76 OK dat is een stuk duidelijker :-)

Uiteraard is het aan jou maar de routed oplossing heeft als enig voordeel internet apps op je settopbox. Ik zie niet in waarom dat van een ICT oogpunt gezien een mooiere oplossing is. Maargoed ik gebruik zelf een bridged oplossing.

Het risico van meerdere guides door elkaar gebruiken (daar heb ik ook vaak m'n hoofd aan gestoten) is dat je een beetje van beide gebruikt en je dus nooit een werkende opstelling krijgt.

Als je STB geen IP krijgt dan zit er iets fout in de VLANs (is dit foutcode 143? de eerste stap?). Voor bridged sluit je je STB direct aan op de managed switch. Op 1 poort heb je je tv VLAN geTAGGED dit kan je zien als transporteren tussen apparaten die VLANs snappen. TAGGED vlans moeten uiteindelijk weer geuntagged worden voor eind apparaten zoals printers/PC's (kort door de bocht) en dus ook een STB.

Wat is je opstelling op dit moment? Heb je een managed switch die je kan gebruiken?

Kasper

  • deefje76
  • Registratie: april 2005
  • Laatst online: 03-05 16:20
@Kasper1985 nee. Maar kan ik eventueel wel regelen op mijn werk. Wil eigenlijk niet teveel componenten gebruiken in mijn netwerk, vandaar dat ik de Fritxbox er ook tussen uit wil hebben. Ik was in de veronderstelling dat het met alleen de Mikrotik ook op te lossen zou zijn. Wij gebruiken geen extra apps op de Amino, dus de bridge oplossing zou voldoende moeten zijn.

Heb een Mikrotik RB2011iL momenteel is de opstelling nu:
Ether 1 => WAN, hieraan zit de NTU
Ether 2 => Access Point beheerd middels CAPsMAN
Ether 3 => NAS
Ether 4 => Playstation
Ether 6 => Moet worden Amino Box

2 bridges => bridge-local => alle poorten, behalve ether6
J&J => CAPsMAN en bridge-local

DHCP server => DHCP-Thuis op bridge-local
DHCP Pool => DHCP (192.168.7610-75) gebruikt door DHCP-Thuis
SSTP (192.168.77.2-192.168.77.10) gebruikt door de SSTP VPN server

Networks => 192.168.76.0/24

Op de Mikrotik is de muliticast package geïnstalleerd voor de IGMP proxy.

Solcon levert in het signaal op VLAN7 VOIP (gebruiken wij niet) en op VLAN 188 IPTV

Vraagstelling:
Internet werkt prima nu.

Hoe krijg ik IPTV op ether6. De amino moet volgens mij een IP adres krijgen in de reeks zoals de rest van mijn devices die ook krijgt van DHCP (zo is het op de Fritzbox wel in iedere geval).

Is het niet voldoende op een VLAN sub-interface toe te voegen op ETHER1 met VLAN ID 188 en deze te bridgen met bridge-local? (dit heb ik nog niet geprobeerd).

  • Kasper1985
  • Registratie: oktober 2014
  • Laatst online: 11-06 18:43
Zoals mijn vader zou zeggen haal je 2 misverstanden door elkaar.

IPTV kan op 2 manieren:

1. Routed - Je STB (noem jij Amino) krijgt een IP vanuit je LAN (zoals op de Fritzbox) er zijn speciale DHCP routes en opties toegevoegd aan de Microtik waardoor de Amino snapt "voor TV moet ik route X hebben naar het IPTV platform" "voor Netflix en youtube moet ik route Y hebben via het gewone LAN richting het internet"

2. Bridged - Je Microtik is uitsluitend een bridge (brug) tussen de Amino en het IPTV platform middels een VLAN. De microtik routeert niks en communiceert niet met de Amino ze weten niet eens van elkaars bestaan af. De microtik moet alleen snappen dat hij TAGGED VLAN 188 die leeft op de glas verbinding en dus uitkomt op je WAN poort moet UNTAGGEN voor de Amino om het te snappen. Bij deze variant krijgt je Amino GEEN IP vanuit je DHCP server op de microtik maar een IP RECHTSTREEKS vanuit het IP TV platform. Daar staat apparatuur van KPN die DHCP regelt voor IPTV apparaten zoals de Amnio. Je kan dus niet kiezen voor bridged mode en dan een LAN IP verwachten.

Zolang dat VLAN tagged op je WAN leeft gaat die Amino er niks mee doen. De Amino is een eindapparaat net zoals een printer. Die kunnen niet met VLANS omgaan en snappen dus uitsluitend UNTAGGED VLANS oftewel access poorten. Mocht je last krijgen van haperend beeld of de melding "zap naar een andere zender en weer terug" dan ligt dat aan IGMP snooping en NIET aan IGMP proxy. De IGMP proxy is uitsluitend en alleen relevant bij de ROUTED methode.

Dus het klopt wat je zegt dat de Fritzbox gebruik maakt van IGMP proxy en de DHCP opties. De Fritzboxen worden namelijk geleverd in de routed mode om het gemakkelijk en "plug en play" te maken voor de eindgebruiker.

Als je dus 1 ROUTED buiten beschouwing laat dan is alles wat je nodig hebt een bridge met vlan 188 tussen WAN en Ether 6. Hoe dat werkt in de microtik weet ik niet daar heb ik geen ervaing mee maar met een managed switch is het super makkelijk te doen. Het voordeel daarvan is dat het IPTV onafhankeijk van je microtik is. Dus als je partner GTST aan het kijken is en jij bent met je microtik aan het spelen en reboot die dan speelt GTST of boer zoekt vrouw etc. gewoon door.

Echt het beste wat je kan doen is netwerkje.com lezen en gerichte vragen stellen als je er niet uitkomt.

[Voor 6% gewijzigd door Kasper1985 op 18-10-2018 12:51]


  • Vesper64
  • Registratie: januari 2008
  • Laatst online: 21:29
Wat Kasper1985 zegt klopt. Wil je de bridged optie en geen extra apparaat (switch/fritzbox) op je netwerk. Dan zouden de commando's die ik je eerder heb gegeven voldoende moeten zijn. Indien je wilt kan je wel een export van je configuratie maken.

Voor een beknopte van alleen je interfaces en bridges:
/interface export
Voor alle wijzigingen op de standaard configuratie (let hierbij op wachtwoorden):
/export
Als je een DHCP server aangemaakt hebt op dezelfde bridge die gebruikt voor IPTV, dan deel je IP informatie uit naar iedereen op dat netwerk (ook buiten jouw huis). Hoewel dit waarschijnlijk door Solcon voorkomen wordt is het toch handig om dat te weten en uit te zetten.

  • deefje76
  • Registratie: april 2005
  • Laatst online: 03-05 16:20
Dank wederom.

Nog veel te leren, gelukkig is dit wel de manier waarop!

@Vesper64 de export kan je vinden in het document te vinden via de volgende link: https://docs.google.com/d...NGWR_JkM/edit?usp=sharing

Ik ben in de veronderstelling dat de STB (Amino) een ip adres moet hebben vanuit mijn eigen pool , omdat hij in de nu werkende situatie deze ook krijgt van de Fritzbox in het zelfde subnet als mijn andere devices (op de Fritzbox) en daarop ook reageert op een ping. Zit dus zover mijn kennis reikt in het zelfde netwerk en niet in een apart VLAN.

[Voor 9% gewijzigd door deefje76 op 18-10-2018 22:13]


  • Vesper64
  • Registratie: januari 2008
  • Laatst online: 21:29
Voor zo ver ik kan zien heb je het iptv netwerk van solcon aan je eigen lokale netwerk toegevoegd.

Wat je moet wijzigen is het volgende:
  1. Maak een nieuwe bridge aan. Geef het de naam "bridge-iptv" of iets dergelijks.
  2. Ontkoppel ether6-master-local en IPTV-WAN van de bridge-local.
  3. Koppel ether6-master-local en IPTV-WAN aan de bridge van stap 1.

  • deefje76
  • Registratie: april 2005
  • Laatst online: 03-05 16:20
Dank je wel ga dat nog eens proberen. Volgens mij is dat de opstelling die ik reeds geprobeerd had. Ik krijg dan geen IP adres meer op de amino :(

De interface vlan IPTV-WAN (188) moet wel aan interface ether1 hangen toch?

[Voor 12% gewijzigd door deefje76 op 19-10-2018 11:30]


  • Vesper64
  • Registratie: januari 2008
  • Laatst online: 21:29
Ja, je vlan IPTV-WAN moet op ether1-gateway zitten zoals het nu geconfigureerd is. Het is alleen gekoppeld aan de verkeerde bridge. De amino krijgt geen IP adres van je mikrotik maar van het iptv netwerk van solcon en zal dus niet zichtbaar zijn als 'lease' in je mikrotik.

  • deefje76
  • Registratie: april 2005
  • Laatst online: 03-05 16:20
Mmm ok. Gevoelsmatig, maar ook kijkend naar het gedrag wat de amino vertoont aan de fritzbox is dat dus volgens mij niet zo. Ben er eigenlijk wel van overtuigd dat het IP adres van de fritzbox komt in het zelfde netwerk als de rest van mijn devices die ik aansluit aan de fritzbox

Je zou toch zeggen dat het IP adres afwijken zou moeten van mijn lokale netwerk als hij een IP adres krijgt over het vlan van een dhcp server bij Solcon?

Als ik het netwerk en dhcp scope wijzig op de fritzbox, wijzigt ook het IP adres mee die de amino krijgt.

[Voor 14% gewijzigd door deefje76 op 19-10-2018 12:13]


  • Kasper1985
  • Registratie: oktober 2014
  • Laatst online: 11-06 18:43
@deefje76 Dat klopt in de huidge situatie in ROUTED mode. Maar zoals eerder aangegeven heb je 2 mogelijkheden voor IPTV. Jij hebt aangegeven de keuze te maken voor BRIDGED IPTV. In dat geval krijgt de STB een IP adres direct vanuit het IPTV platform.

Vergeet even de Fritzbox die is op een andere manier ingesteld dan wat we op dit moment voor elkaar proberen te krijgen. Als je je blijft vast pinnen op hoe het op dit moment middels de fritzbox werkt dan blijven we langs elkaar heen praten.

  • deefje76
  • Registratie: april 2005
  • Laatst online: 03-05 16:20
@Kasper1985 en @Vesper64 dank jullie wel.

De laatste oplossing werkt niet. De amino blijft wachten op een IP adres welke hij niet krijgt en geeft dan een fout dat er een network connection error is.

Ik zie de dhcp request voorbij komen maar krijg geen dhcp offer terug.

[Voor 15% gewijzigd door deefje76 op 19-10-2018 13:57]


  • Kasper1985
  • Registratie: oktober 2014
  • Laatst online: 11-06 18:43
Check ook even dit topic: Solcon IPTV op Unifi (instructies)

Misschien dat dat wat opheldering geeft

  • deefje76
  • Registratie: april 2005
  • Laatst online: 03-05 16:20
Even ter toevoeging, ben heel erg blij met jullie hulp. Dat even gezegd is!

  • Kasper1985
  • Registratie: oktober 2014
  • Laatst online: 11-06 18:43
Mijn favoriete merk bier is Heineken maar een lekkere IPA sla ik ook niet af :-)

on topic: probeer even die link. Dat is weleenswaar voor een Unifi maar het idee zou hetzelfde moeten zijn.

Kasper

  • Great-Force
  • Registratie: augustus 2013
  • Laatst online: 07-06 21:00
Ik zie trouwens in je export dat je de nieuwste beta versie draait, dit is niet aan te raden voor dagelijks gebruik omdat er flinke bugs in kunnen zitten. En ja, ook functies die voorheen goed werkte, kunnen in de beta versie kapot gaan. Indien mogelijk de laatste stable release (6.32.4) gebruiken. Mocht je zonder kid control kunnen, dan zou je zelfs nog voor 6.40.8 kunnen kiezen, deze werkt erg fijn met VLAN's en draait zeer stabiel (let wel op!!! Je router moet een factory firmware hebben die lager is dan 6.40.8, anders krijg je problemen). Sinds versie 6.41.0 zijn namelijk alle VLAN's op de schop gegaan, en werken ze met VLAN's via het bridge menu. Dit is nog steeds niet perfect, dus wellicht dat hier een deel van je problemen zit.

Eventueel zouden we via een TeamViewer sessie samen de config na kunnen lopen. Tip: de Torch tool in Winbox is heel erg nuttig om het verkeer te sniffen wat over de interface heen gaat. Eventueel zou je de ingebouwde packet sniffer kunnen gebruiken om een PCAP file te generen en deze te analyseren in Wireshark.

  • deefje76
  • Registratie: april 2005
  • Laatst online: 03-05 16:20
Het wordt steeds gezelliger hier. Leuk dat ik zoveel hulp krijg. Ben een weekendje op stap die kan er nu niet mee spelen.

Heb wel nog reactie gehad van Solcon. Zie hieronder:

"Zoals u al aangeeft is het inderdaad buiten onze support om u hier verder mee te helpen. Overigens hebben wij liever niet dat
klanten zelf het IPTV verkeer opvangen via een eigen router omdat dit voor meer load voor Solcon zorgt, maar aangezien u al
aardig op weg bent; hier nog wat informatie. U dient inderdaad VLAN 188 te gebruiken binnen het Caiway netwerk, dit is dus
correct. U dient ervoor te zorgen dat deze VLAN op de STB binnen komt, u hoeft in principe niet zelf DHCP op te zetten
hiervoor. Onze IPTV DHCP server kan deze voorzien. Als u via routed mode de VLAN doorlinkt op uw router via een specifieke
poort (let op: IGMP Snooping 2.0 + multivlan, niet getrunked) vereist) en dit signaal rechtstreeks bij de STB uitkomt, dan zou
het moeten werken. "

  • Great-Force
  • Registratie: augustus 2013
  • Laatst online: 07-06 21:00
Bedankt voor de update van Solcon. Dit betekent dat je ten minste de laatste stable RouterOS 6.32.4 moet gebruiken ivm IGMP Snooping. Ook ben ik blij met de bevestiging dat zij zelf IP adressen uitdelen. Kortom, het doel is het vlan bridgen naar een fysieke poort en dan moet alles goed komen.

Waar ik ook nog aan zat te denken zijn eventuele NAT problemen, omdat je alles masquerade wat over ether1 naar buiten gaat.

  • DJSmiley
  • Registratie: mei 2000
  • Nu online

DJSmiley

Moderator Internet & Netwerken
Great-Force schreef op zaterdag 20 oktober 2018 @ 12:47:
Bedankt voor de update van Solcon. Dit betekent dat je ten minste de laatste stable RouterOS 6.32.4 moet gebruiken ivm IGMP Snooping. Ook ben ik blij met de bevestiging dat zij zelf IP adressen uitdelen. Kortom, het doel is het vlan bridgen naar een fysieke poort en dan moet alles goed komen.

Waar ik ook nog aan zat te denken zijn eventuele NAT problemen, omdat je alles masquerade wat over ether1 naar buiten gaat.
Dat ligt eraan hoe de masquerade rule nu staat. Als die zonder uitgaande interface gespecificeerd staat dan zal ie idd al het verkeer masqueraden.
Maar met een rule gewoon op ETH1 direct zal alleen het verkeer op ETH1 (untagged) masqueraden. Pas als je de rule op een vlan zet wat ook op eth1 zit dan kan het problemen geven.

Maar als TS de handel bridged is dat allemaal niet van toepassing.

code:
1
2
3
4
5
6
7
/interface bridge
add fast-forward=no igmp-snooping=yes name=IPTV
/interface vlan
add interface=ether1 name=ether1.188 vlan-id=188
/interface bridge port
add bridge=IPTV interface=ether1.188
add bridge=IPTV interface=ether6


Dat zou voldoende zijn om, in bridge mode, je IPTV aan de gang te krijgen. Je doet niets anders dan vlan 188 tagged op de wan knuppen aan (untagged) poortje 6, waar je Amino aan hangt.

IGMP proxy, static routes, dhcp opties enz zijn alleen van toepassing als je ROUTED wilt, dus IPTV in je lan, gecombineeerd met je normale netwerk.

  • deefje76
  • Registratie: april 2005
  • Laatst online: 03-05 16:20
Ok, kon het niet laten de wijzigingen weer door te voeren. Maandagmiddag ga ik het weer testen ben zo benieuwd.

code:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
/interface export geeft nu het volgende resultaat:
# oct/20/2018 20:27:06 by RouterOS 6.43.4

/interface bridge
add fast-forward=no igmp-snooping=yes name=IPTV-Bridge
add admin-mac=E4:8D:8C:2C:30:0E auto-mac=no fast-forward=no name=J&J
add admin-mac=E4:8D:8C:2C:30:0E auto-mac=no dhcp-snooping=yes fast-forward=no igmp-snooping=yes name=bridge-local
/interface ethernet
set [ find default-name=ether1 ] comment=Caiway name=ether1-gateway speed=100Mbps
set [ find default-name=ether2 ] comment="Mikrotik AP BG" name=ether2-master-local speed=100Mbps
set [ find default-name=ether3 ] comment="Synology NAS" name=ether3-slave-local speed=100Mbps
set [ find default-name=ether4 ] name=ether4-slave-local speed=100Mbps
set [ find default-name=ether5 ] comment="Mikrotik AP Zolder" name=ether5-slave-local speed=100Mbps
set [ find default-name=ether6 ] advertise=10M-half,10M-full,100M-half,100M-full,1000M-half,1000M-full name=ether6-master-local
set [ find default-name=ether7 ] advertise=10M-half,10M-full,100M-half,100M-full,1000M-half,1000M-full name=ether7-slave-local
set [ find default-name=ether8 ] advertise=10M-half,10M-full,100M-half,100M-full,1000M-half,1000M-full name=ether8-slave-local
set [ find default-name=ether9 ] advertise=10M-half,10M-full,100M-half,100M-full,1000M-half,1000M-full name=ether9-slave-local
set [ find default-name=ether10 ] advertise=10M-half,10M-full,100M-half,100M-full,1000M-half,1000M-full full-duplex=no name=ether10-slave-local speed=1Gbps
/interface vlan
add interface=ether1-gateway name=ether1.188 vlan-id=188
/interface list
add name=mactel
add name=mac-winbox
add name=WAN
add exclude=dynamic name=discover
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/interface bridge port
add bridge=bridge-local hw=no interface=ether2-master-local
add bridge=bridge-local hw=no interface=ether3-slave-local
add bridge=bridge-local hw=no interface=ether5-slave-local
add bridge=bridge-local hw=no interface=ether7-slave-local
add bridge=bridge-local hw=no interface=ether8-slave-local
add bridge=bridge-local hw=no interface=ether9-slave-local
add bridge=bridge-local hw=no interface=ether10-slave-local
add bridge=bridge-local interface=ether4-slave-local
add bridge=IPTV-Bridge interface=ether1.188
add bridge=IPTV-Bridge interface=ether6-master-local
/interface l2tp-server server
set ipsec-secret=******** use-ipsec=yes
/interface list member
add interface=ether2-master-local list=mactel
add interface=ether3-slave-local list=mactel
add interface=ether2-master-local list=mac-winbox
add interface=ether4-slave-local list=mactel
add interface=ether3-slave-local list=mac-winbox
add interface=ether5-slave-local list=mactel
add interface=ether4-slave-local list=mac-winbox
add interface=ether6-master-local list=mactel
add interface=ether5-slave-local list=mac-winbox
add interface=ether7-slave-local list=mactel
add interface=ether6-master-local list=mac-winbox
add interface=ether8-slave-local list=mactel
add interface=ether9-slave-local list=mactel
add interface=ether10-slave-local list=mactel
add interface=bridge-local list=mactel
add interface=ether7-slave-local list=mac-winbox
add interface=ether8-slave-local list=mac-winbox
add interface=ether9-slave-local list=mac-winbox
add interface=ether10-slave-local list=mac-winbox
add interface=bridge-local list=mac-winbox
add interface=ether1-gateway list=WAN
add interface=ether2-master-local list=discover
add interface=ether3-slave-local list=discover
add interface=ether4-slave-local list=discover
add interface=ether5-slave-local list=discover
add interface=ether6-master-local list=discover
add interface=ether7-slave-local list=discover
add interface=ether8-slave-local list=discover
add interface=ether9-slave-local list=discover
add interface=ether10-slave-local list=discover
add interface=bridge-local list=discover
/interface sstp-server server
set authentication=mschap2 certificate=ca default-profile=default-encryption enabled=yes port=3389

  • deefje76
  • Registratie: april 2005
  • Laatst online: 03-05 16:20
Arghhhh werkt niet.... Zou het probleem dan bij Solcon zitten.... De STB krijgt geen IP adres.

Wat me opvalt is dat ik op de bridge wel packets ontvangen zie worden maar er niets verzonden wordt. Dus Tx blijft op 0 staan.

Op zowel de vlan interface als ether 6 zie ik wel rx en tx.

[Voor 53% gewijzigd door deefje76 op 22-10-2018 14:42]


  • Kasper1985
  • Registratie: oktober 2014
  • Laatst online: 11-06 18:43
Ik zie dat je nog steeds niet de laatste stable release gebruikt zoals een paar posts eerder ie gesuggereerd. Ik zou het even daarmee proberen. Ik heb geen ervaring met Microtik of router OS maar betas zijn in mijn algemene ervaring nooit een goed idee tenzij je weet wat je doet en actief mee werkt aan een project of gevraagd bent als beta tester.

Over het algemeen kan je als eindgebruiker beter voor een stabiele release gaan.

  • deefje76
  • Registratie: april 2005
  • Laatst online: 03-05 16:20
@Kasper1985 downgrade uitgevoerd ;)

  • deefje76
  • Registratie: april 2005
  • Laatst online: 03-05 16:20
Heb gisteravond de downgrade uitgevoerd naar de laatste stabiele versie.

Vanmorgen de hele Mikrotik router naar fabrieksinstellingen gereset en daarna, buiten de standaard instellingen alleen de vlan interface en de bridge gemaakt en aan de bridge de vlan interface en de fysieke poort gekoppeld. De STB krijgt nog steeds geen IP adres.

We gaan vanavond maar weer eens spelen, denk dat ik ook eens rechtstreeks op de NTU ga kijken wat daar binnenkomt met Wireshark

  • Great-Force
  • Registratie: augustus 2013
  • Laatst online: 07-06 21:00
Je zou eens naar dit Wiki artikel (en de solution) kunnen kijken: https://wiki.mikrotik.com...with_a_physical_interface
Deze maakt gebruik van Bridge VLAN Filtering, hiervoor is het echter wel nodig om ether1 en ether6 in dezelfde iptv-bridge te hangen, het kan dus zijn dat je de internetverbinding verliest terwijl je dit doet (i.v.m. je NAT regels, maar dit maakt voor het testen van IPTV niet uit).
Hiermee kun je in ieder geval testen of tagged VLAN 188 over ether1 en untagged VLAN 188 over ether6 wel werkt, vergeet dan niet de vlan interface te verwijderen uit de interfaces en uit de bridge.

code:
1
2
3
4
5
6
7
/interface bridge
add name=bridge-iptv vlan-filtering=yes
/interface bridge port
add bridge=bridge-iptv interface=ether1
add bridge=bridge-iptv interface=ether6 pvid=188
/interface bridge vlan
add bridge=bridge-iptv tagged=ether1 untagged=ether6 vlan-ids=188


Mocht je zonder Kid Control kunnen, dan gewoon terug naar 6.40.8 (alleen als de factory firmware lager is dan deze firmware). Dan weet ik vrijwel zeker dat het bridgen van de VLAN goed zal gaan.

  • deefje76
  • Registratie: april 2005
  • Laatst online: 03-05 16:20
De tip van Kasper1985 heb ik gevolgd, echter lukte het toen ook niet. Het lukt mij maar niet om in de bridge oplossing de STB een IP adres te laten krijgen vanuit Solcon. Waarom? Geen idee, begrijp het ook niet.

Daar in de onderstaand config VLAN interface (IPTV-WAN) wel een ip adres krijgt (IP=10.71.92.168/20, DNS=212.45.45.45, geen gateway), zou ik het in de bridge oplossing toch ook voor mekaar moeten kunnen krijgen dat de STB een ip adres krijgt.

Uiteindelijk heb ik de routed mode eens geprobeerd. Daarmee kom ik een heel eind. Als ik een DHCP client op de VLAN (188) interface zet met option 60 erbij krijg ik netjes een IP adres op de VLAN 188 interface. Daarna heb ik een IGMP proxy gemaakt en op de VLAN (188) gezet, met de upstream aangevinkt en met alternative subnet 0.0.0.0/0. Zodra ik een tweede IGMP Proxy interface aanmaak met als interface bridge-local waar al de poorten (behalve ether1) inzitten, worden de beide IGMP proxies actief en ik zie in het MFC tabblad ook connecties voorbijkomen. Destination netwerken 224.0.0.0 en 239.255.255.0

In de IP firewall heb ik een drietal rules aangemaakt voor UDP (input en forward) en IGMP (input)

De STB krijgt een IP adres, in mijn eigen pool, echter gaat de verbinding met de ACS nog steeds niet lekker, krijg de melding dat de firmware/configuratie niet opgehaald kan worden.

Is er iemand die met bovenstaande informatie en onderstaande export van de config ziet wat er fout gaat?

code:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
/interface ethernet
set [ find default-name=ether1 ] comment=Solcon name=ether1-gateway
set [ find default-name=ether2 ] comment="Mikrotik AP BG" name=ether2-master-local
set [ find default-name=ether3 ] comment="Synology NAS" name=ether3-slave-local
set [ find default-name=ether4 ] name=ether4-slave-local
set [ find default-name=ether5 ] comment="Mikrotik AP Zolder" name=ether5-slave-local
set [ find default-name=ether6 ] name=ether6-master-local
set [ find default-name=ether7 ] name=ether7-slave-local
set [ find default-name=ether8 ] name=ether8-slave-local
set [ find default-name=ether9 ] name=ether9-slave-local
set [ find default-name=ether10 ] full-duplex=no name=ether10-slave-local speed=1Gbps
/interface vlan
add interface=ether1-gateway name=IPTV-Wan vlan-id=188

/ip dhcp-client option
add code=60 name=IPTV_RG value="'IPTV_RG'"

/interface bridge port
add bridge=bridge-local hw=no interface=ether2-master-local
add bridge=bridge-local hw=no interface=ether3-slave-local
add bridge=bridge-local hw=no interface=ether5-slave-local
add bridge=bridge-local hw=no interface=ether7-slave-local
add bridge=bridge-local hw=no interface=ether8-slave-local
add bridge=bridge-local hw=no interface=ether9-slave-local
add bridge=bridge-local hw=no interface=ether10-slave-local
add bridge=bridge-local hw=no interface=ether4-slave-local

/ip address
add address=192.168.76.1/24 comment="default configuration" interface=ether2-master-local network=192.168.76.0

/ip dhcp-client
add dhcp-options=hostname,clientid,*8 disabled=no interface=ether1-gateway
add default-route-distance=10 dhcp-options=IPTV_RG,hostname,clientid_duid disabled=no interface=IPTV-Wan use-peer-dns=no use-peer-ntp=no

/ip dhcp-server network
add address=192.168.76.0/24 comment="default configuration" domain=thuis gateway=192.168.76.1 netmask=24
/ip dns
set allow-remote-requests=yes servers=212.45.45.45,212.45.33.3

/ip firewall filter
add action=drop chain=forward comment="Blokkeer internet toegang camara voortuin" log=yes log-prefix=block_voortuin out-interface=ether1-gateway src-address=192.168.76.230
add action=drop chain=forward comment="Blokkeer internet toegang camara achtertuin" log=yes log-prefix=blockachtertuin out-interface=ether1-gateway src-address=192.168.76.231
add action=drop chain=forward comment="Blokkeer internet toegang camara achtertuin" log=yes log-prefix=blockachtertuin out-interface=ether1-gateway src-address=192.168.76.232
add action=accept chain=input comment="default configuration" protocol=icmp
add action=accept chain=input comment="SSTP VPN naar Router" dst-port=3389 in-interface=ether1-gateway protocol=tcp
add action=accept chain=input comment="default configuration" connection-state=established,related
add action=accept chain=input comment="HTTPS verbinding naar MikroTik beheer" disabled=yes dst-port=1976 protocol=tcp
add action=accept chain=forward comment=IGMP protocol=udp
add action=accept chain=input comment=IGMP protocol=udp
add action=accept chain=forward comment=IGMP disabled=yes protocol=igmp
add action=accept chain=input comment=IGMP protocol=igmp
add action=drop chain=input comment="default configuration" in-interface=ether1-gateway
add action=fasttrack-connection chain=forward comment="default configuration" connection-state=established,related
add action=accept chain=forward comment="default configuration" connection-state=established,related
add action=drop chain=forward comment="default configuration" connection-state=invalid log-prefix=ipv4_fw_drop
add action=drop chain=forward comment="default configuration" connection-nat-state=!dstnat connection-state=new in-interface=ether1-gateway

/ip firewall nat
add action=masquerade chain=srcnat comment="Default configuration" out-interface=ether1-gateway
add action=dst-nat chain=dstnat comment="SSH naar NAS" disabled=yes dst-port=22 in-interface=ether1-gateway protocol=tcp to-addresses=192.168.76.2 to-ports=22
add action=dst-nat chain=dstnat comment="HTTP naar NAS" dst-port=5000 in-interface=ether1-gateway protocol=tcp to-addresses=192.168.76.2 to-ports=5000
add action=dst-nat chain=dstnat comment="HTTPS naar NAS" dst-port=5001 in-interface=ether1-gateway protocol=tcp to-addresses=192.168.76.2 to-ports=5001
add action=dst-nat chain=dstnat comment="HTTP naar NAS" dst-port=80 in-interface=ether1-gateway log-prefix=HTTPNAS protocol=tcp to-addresses=192.168.76.2 to-ports=80
add action=dst-nat chain=dstnat comment="Synology Drive" dst-port=6690 in-interface=ether1-gateway log-prefix=SynDrive protocol=tcp to-addresses=192.168.76.2 to-ports=6690
add action=dst-nat chain=dstnat comment="HTTPS naar NAS" dst-port=443 in-interface=ether1-gateway log-prefix=HTTPSNAS protocol=tcp to-addresses=192.168.76.2 to-ports=443
add action=dst-nat chain=dstnat comment="SMTP naar mailserver NAS" dst-port=25 in-interface=ether1-gateway protocol=tcp to-addresses=192.168.76.2 to-ports=25
add action=dst-nat chain=dstnat comment=PLEX disabled=yes dst-port=32400 in-interface=ether1-gateway protocol=tcp to-addresses=192.168.76.2 to-ports=32400
add action=dst-nat chain=dstnat comment="VPN Synology" dst-port=1701 in-interface=ether1-gateway protocol=udp to-addresses=192.168.76.2 to-ports=1701
add action=dst-nat chain=dstnat comment="VPN Synology" dst-port=500 in-interface=ether1-gateway protocol=udp to-addresses=192.168.76.2 to-ports=500
add action=dst-nat chain=dstnat comment="VPN Synology" dst-port=4500 in-interface=ether1-gateway protocol=udp to-addresses=192.168.76.2 to-ports=4500
add action=dst-nat chain=dstnat comment="VPN Synology" dst-port=1723 in-interface=ether1-gateway protocol=tcp to-addresses=192.168.76.2 to-ports=1723

/routing igmp-proxy
set quick-leave=yes
/routing igmp-proxy interface
add interface=bridge-local
add alternative-subnets=0.0.0.0/0 interface=IPTV-Wan upstream=yes

Acties:
  • Beste antwoord
  • 0Henk 'm!

  • nescafe
  • Registratie: januari 2001
  • Laatst online: 21:14
Hoe kan je STB een adres krijgen terwijl er geen DHCP server op IPTV-Bridge is gedefinieerd? Heb je hem wel op poort 4 aangesloten? Of is de config incompleet?

Er moet dus in ieder geval een ip address en dhcp server op IPTV-Bridge met dhcp network (eigen segment) en ip pool indien je dit gescheiden wilt houden. Als je STB in het LAN mag kun je de igmp-proxy op bridge-local zetten en IPTV-Bridge verwijderen.

Je lokale adres zit nu op een slave interface, die moet naar de master bridge:
code:
1
2
/ip address
add address=192.168.76.1/24 comment="default configuration" interface=bridge-local network=192.168.76.0

Daarnaast is IPTV-Wan nu een privileged interface met all access naar je MT en interne netwerk. Misschien handig om een interface list WAN aan te maken met ether1-gateway en IPTV-Wan als members en inkomende verbindingen te droppen:
code:
1
2
3
4
/ip firewall filter
add action=drop chain=input comment="default configuration" in-interface-list=WAN
add action=drop chain=forward comment="default configuration" connection-nat-state=!dstnat \
  connection-state=new in-interface-list=WAN

Vermoedelijk kan heeft IPTV ook een masquerade rule nodig, dat los je op dezelfde manier op:
code:
1
2
/ip firewall nat
add action=masquerade chain=srcnat comment="Default configuration" out-interface-list=WAN

Je ziet nu een erfenissen van de 'oude' default config in je MT, het kan geen kwaad om eens helemaal opnieuw te beginnen met de huidige default config van stable/long-term, zeker nu je aan het troubleshooten bent.

* Barca zweert ook bij fixedsys... althans bij mIRC de rest is comic sans


  • deefje76
  • Registratie: april 2005
  • Laatst online: 03-05 16:20
nescafe schreef op dinsdag 30 oktober 2018 @ 10:03:
Hoe kan je STB een adres krijgen terwijl er geen DHCP server op IPTV-Bridge is gedefinieerd? Heb je hem wel op poort 4 aangesloten? Of is de config incompleet?
Dank je voor opmerkzaamheid. De config klopte niet helemaal met mijn verhaal. In de huidige config hangt de STB inderdaad op ether4 en aan bridge bridge-local en krijgt een IP adres van de router net als de andere clients. De bridge IPTV-Bridge bestaat ook niet meer. De IGMP-Proxy voor upstream zit op interface IPTV-WAN de tweede IGMP Proxy op bridge-local

Volgens Solcon zou de STB in de bridge oplossing een IP adres moeten krijgen van de IPTV DHCP servers van Solcon zelf. Dit krijg ik niet voor elkaar. Als ik een DHCP client op de VLAN interface krijgt deze wel een IP. Dus die DHCP server (van Solcon)werkt wel. Vandaar dat ik het nu in de routed oplossing probeer,

Je tips ga ik eens toepassen. Ik ben zelf ook niet blij met mijn firewall rules.

[Voor 3% gewijzigd door deefje76 op 30-10-2018 11:17]


  • nescafe
  • Registratie: januari 2001
  • Laatst online: 21:14
Tja sinds de nieuwe bridge-oplossing weet ik eerlijk gezegd ook niet meer wat best practice is. Volgens MT moet één bridge met verschillende tagged/untagged interfaces de oplossing zijn, maar ik vind het nogal contra-intuïtief:

code:
1
2
3
4
5
6
7
8
9
10
11
12
/interface bridge
add name=bridge-wan
/interface bridge port
add bridge=bridge-lan interface=ether1
add bridge=bridge-wan interface=ether4 pvid=188
/interface bridge vlan
add bridge=bridge-wan tagged=bridge-wan untagged=ether1 vlan-ids=1
add bridge=bridge-wan tagged=ether1 untagged=ether4 vlan-ids=188
/interface vlan
add interface=bridge-wan name=bridge-vlan1 vlan-id=1
/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=bridge-vlan1


In dit geval zou bridge-vlan1 je internet-interface zijn en vlan188 de router verder niet raken (helaas geen hw-offloading).

Maar volgens mij is de masquerade-regel key in jouw situatie, die staat ook benoemd in het voorbeeld van netwerkje.com.

[Voor 7% gewijzigd door nescafe op 02-11-2018 11:18. Reden: Bridge port ether4 uitgebreid met pvid=188, edit 2: bridge-wan toegevoegd als tagged port]

* Barca zweert ook bij fixedsys... althans bij mIRC de rest is comic sans


  • Great-Force
  • Registratie: augustus 2013
  • Laatst online: 07-06 21:00
nescafe schreef op dinsdag 30 oktober 2018 @ 11:38:
Tja sinds de nieuwe bridge-oplossing weet ik eerlijk gezegd ook niet meer wat best practice is. Volgens MT moet één bridge met verschillende tagged/untagged interfaces de oplossing zijn, maar ik vind het nogal contra-intuïtief:
Zojuist getest met RouterOS 6.43.4 op een CCR1036 en een Cisco SG350-28P, het toevoegen van een VLAN interface en deze simpelweg bridgen met een fysieke poort werkt nog steeds prima ondanks dat het geen best practice meer is.

Maar even back to basic, heb je de mogelijkheid te testen met een moderne managed switch (welke IGMP Snooping ondersteund)?
Dan sluit je het modem aan op poort 1, de MikroTik op poort 2, en de STB op poort 3.
Poort 1 en poort 2 laat je untagged VLAN 1 (default VLAN), hier gaat je internet overheen. Vervolgens maak je een nieuw VLAN 188 aan, welke je tagged zet op poort 1 en untagged op poort 3 (de meeste managed switches, zelfs hele oude NetGear switches, kunnen dit). Als het goed is moet het geheel dan gewoon werken, zowel internet als TV. Wellicht geen mooie oplossing, maar om te testen ideaal!

  • deefje76
  • Registratie: april 2005
  • Laatst online: 03-05 16:20
Yeah het werkt..... Echt tof en mede dankzij jullie. Heb nu de routed mode aan de gang met de igmp proxy.

Jammer genoeg lijkt mijn router dit niet te trekken. Tijdens een speedtest of download wordt de CPU wat zwaar belast en begint tv te stotteren.

Great-Force: ga er eens naar kijken, je zou denken dat ik nu die bridge oplossing toch ook aan de praat moeten kunnen kijken, ik laat me niet kisten. Als het goed is zou dat minder belastend moeten zijn.

  • nescafe
  • Registratie: januari 2001
  • Laatst online: 21:14
Mocht je het nog eens willen proberen, ik heb mijn voorbeeld zojuist uitgebreid met:

/interface bridge port
add bridge=bridge-wan interface=ether4 pvid=188

Dit is om ervoor te zorgen dat untagged traffic op ether4 vlan 188 meekrijgt.

[Voor 6% gewijzigd door nescafe op 02-11-2018 09:40]

* Barca zweert ook bij fixedsys... althans bij mIRC de rest is comic sans


  • Thralas
  • Registratie: december 2002
  • Laatst online: 23:38
deefje76 schreef op dinsdag 30 oktober 2018 @ 21:57:
Jammer genoeg lijkt mijn router dit niet te trekken. Tijdens een speedtest of download wordt de CPU wat zwaar belast en begint tv te stotteren.
Hoeveel megabit hebben we 't hier over?

Je hebt in je laatste config in ieder geval nog wat twijfelachtige zaken zitten, de fasttrack regel hoort boven alle andere accepts. Al geloof ik niet dat het voor multicast (TV) direct uitmaakt.

Kijk in ieder geval eens met de Profile tool waar de CPU time aan opgaat, en controleer of je speedtest in ieder geval wél gefasttracked wordt (zie de counters op de eerst firewallregel in Winbox).

  • deefje76
  • Registratie: april 2005
  • Laatst online: 03-05 16:20
Thralas schreef op vrijdag 2 november 2018 @ 14:06:
[...]


Hoeveel megabit hebben we 't hier over?

Je hebt in je laatste config in ieder geval nog wat twijfelachtige zaken zitten, de fasttrack regel hoort boven alle andere accepts. Al geloof ik niet dat het voor multicast (TV) direct uitmaakt.

Kijk in ieder geval eens met de Profile tool waar de CPU time aan opgaat, en controleer of je speedtest in ieder geval wél gefasttracked wordt (zie de counters op de eerst firewallregel in Winbox).
Heb 200mbit down en up. Als ik speedtest doe wordt beeld blokkerig en geluid stottert.

Zal die profile tool eens bekijken.

  • deefje76
  • Registratie: april 2005
  • Laatst online: 03-05 16:20
nescafe schreef op vrijdag 2 november 2018 @ 09:40:
Mocht je het nog eens willen proberen, ik heb mijn voorbeeld zojuist uitgebreid met:

/interface bridge port
add bridge=bridge-wan interface=ether4 pvid=188

Dit is om ervoor te zorgen dat untagged traffic op ether4 vlan 188 meekrijgt.
Heb het geprobeerd, maar kom er niet helemaal uit. Zal komende week nog eens kijken.

Wat ik niet begrijp is dat in de documentatie staat dat in een bridge oplossing de gekoppelde poorten zich gedragen als een 'domme' switch op layer 2 niveau.
Theoretisch zouden de vlan (188) subinterface op ether 1 en een willekeurige fysieke ethernet poort, beide lid van dezelfde bridge, met elkaar moeten kunnen praten. Zowel aan de vlan poort kant en de fysieke poort kant van de bridge is het verkeer untagged. Toch komt de dhcp request (en ander verkeer) van de STB niet door de bridge heen. Ook als ik notebook eraan hang neem ik dit waar. Het is net of iets het verkeer tegenhoudt/dropt wat door de bridge heen moet.

  • nescafe
  • Registratie: januari 2001
  • Laatst online: 21:14
Indien je ether1-vlan188 bridged met ether4 zou dat in theorie moeten werken. Alleen krijg je dan problemen met RSTP die niet VLAN aware is. Heb je ook gekeken naar mijn 2e edit, het koppelen van bridge-wan als tagged port aan bridge-wan's vlan1? Dit heeft niets te maken met vlan 188 maar wel met het mogelijk wel of geen internetverbinding kunnen krijgen.

Je kunt m.b.v. packet sniffer al zien of er DHCP requests worden aangeboden op poort ether4. Sniffen op bridge-wan heeft geen zin tenzij je bridge-wan ook als tagged member port toevoegt aan bridge-wan's vlan 188.

Als je met een laptop een ip probeert te verkrijgen, ik kan me voorstellen dat dat niet werkt door het ontbreken van option 60 (IPTV_RG).

* Barca zweert ook bij fixedsys... althans bij mIRC de rest is comic sans


  • Thralas
  • Registratie: december 2002
  • Laatst online: 23:38
Voor je teveel tijd in de bridge-oplossing steekt (routed is imo. de enige nette oplossing) - let erop dat VLANs op een bridge port óók over de CPU moeten (maar itt. routed niet door de firewall).

Als je een wire speed bridge met VLANs wilt garanderen dan moet je het geheel met de switch chip oplossen.

  • harmen.stoffers
  • Registratie: mei 2019
  • Laatst online: 06-06 15:56
Hallo,
Ik ben ook bezig de Fritzbox te vervangen voor een Ubiquiti edgerouter sfp op het Solcon netwerk.
Is er al iemand die de Routed IPTV aan de praat heeft?
Ik heb ondertussen wel beeld alleen haalt de STB niet het zender pakket op en kom telkens uit op TV Harderwijk Kanaal 800. 8)7

  • Thasaidon
  • Registratie: februari 2006
  • Laatst online: 13:17

Thasaidon

If nothing goes right, go left

Heeft iemand toevallig al een Mikrotik aan de "nieuwe" Solcon aansluitingen hangen?

Ik heb nu een Genexis met 1 eth poort waaraan de Fritzbox hangt.
Internet komt hier untagged binnen, IPTV op Vlan4.
Maar alles aan de LAN kant, dus ook de Amino's, krijgen een IP van de lokale DHCP server op de Fritzbox.
De Amino's krijgen dus geen IP meer uit het IPTV netwerk zelf.
Daarnaast zou aan de LAN kant alles untagged zijn.

Ik wil graag mijn MikroTik RB4011iGS+5HacQ2HnD-IN gebruiken als hoofd router.
Maar ik kom er maar niet aan toe om hiermee aan de slag te gaan.

Tips, duwtjes in de goede richting, zijn welkom.

"Hello IT, have you tried turning it off and on again?" - "Computer says no..."


  • JMV2009
  • Registratie: januari 2020
  • Laatst online: 11-01-2020
Glasvezel solcon over caiway/glasvezelbuitaf

Routed IPTV:

Openwrt:

opkg install luci-ssl igmpproxy

wan:
vlan untagged, DHCP in WAN zone

wan188:
vlan 188, DHCP with vendor_class (option 60) IPTV_RG in WAN zone

lan:
DCHP option 43:
43,20:33:52:45:54:5f:53:65:72:76:65:72:3d:31:30:2e:31:2e:35:2e:31:30:20:52:45:54:5f:50:6f:72:74:3d:31:30:30:30:31:20:52:45:54:5f:54:69:6d:65:6f:75:74:3d:32:30:30:19:02:00:d2:08:19:68:74:74:70:3a:2f:2f:73:74:62:2e:73:6f:6c:63:6f:6e:2e:74:76:2f:64:6c:78:2f:1c:33:68:74:74:70:3a:2f:2f:31:30:2e:31:2e:39:2e:31:35:30:2f:33:2e:33:2e:32:61:33:33:2d:41:78:34:78:2d:6f:70:65:72:61:31:31:2d:53:4f:4c:43:4f:4e:2e:6d:63:66:73:6a:29:68:74:74:70:3a:2f:2f:31:30:2e:31:2e:39:2e:31:35:30:2f:61:72:69:61:36:31:30:5f:72:6f:75:74:65:64:5f:6d:6f:64:65:2e:69:6e:69:10:10:45:75:72:6f:70:65:2f:41:6d:73:74:65:72:64:61:6d
(subject to change, apparently relayed from wan188 dhcp)

/etc/config/igmpproxy
option network wan188
list altnet 217.166.0.0/16 (or just 0.0.0.0/0, unless you are expecting rogue traffic from wan188. This is apparently a KPN stream.)

Optional: igmp snooping to avoid multicast iptv traffic everywhere
If the bridge implementation does not support igmp snooping, make separate vlans for the lan ports. These ports can remain untagged.

P.S. bridged IPTV doesn't work for 3 decoders, nor for interactive television.

[Voor 12% gewijzigd door JMV2009 op 01-01-2020 23:28. Reden: relay comment routed iptv]


  • MisteRMeesteR
  • Registratie: december 2001
  • Laatst online: 21:07

MisteRMeesteR

Moderator Internet & Netwerken

Is Gek op... :)

Hi @JMV2009, Welkom op GoT *O*

De oplossing voor het probleem van de TS (topicstarter) was reeds gevonden eerder in het topic, te herkennen aan het groene vlak en de tekst ‘Beste antwoord’.

Het reageren met ongeveer dezelfde informatie is hierdoor niet echt noodzakelijk. Ook ‘schop’ je hiermee een oud topic weer omhoog, iets wat hier ongewenst is.

Neem even een lekker drankje en lees onze prachtige FAQ (Forum FAQ) even door zodat je bekend raakt met de huisregels hier.

Mocht je vragen of opmerkingen hebben, schroom dan niet om mij even een DM (Direct Message) te sturen.

www.google.nl

Pagina: 1

Dit topic is gesloten.



Apple iPad Pro (2021) 11" Wi-Fi, 8GB ram Microsoft Xbox Series X LG CX Google Pixel 5a 5G Sony XH90 / XH92 Samsung Galaxy S21 5G Sony PlayStation 5 Nintendo Switch Lite

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2021 Hosting door True