Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

HTML onthoudt nieuwe afbeeldingen niet

Pagina: 1
Acties:

Onderwerpen

Vraag


  • Hakuna-Matata
  • Registratie: april 2016
  • Laatst online: 15-11 12:50
Mijn vraag
Weet iemand waarom mijn html de afbeelding Annabelle niet wilt vinden?
Als ik na afbeeldingen een / doe en daarna een a dan vindt hij alleen Doofensmirtz en TheConjuringbanner, maar geen Annabelle.
Relevante software en hardware die ik gebruik
Ik gebruik phpstorm.

Wat ik al gevonden of geprobeerd heb
Zelf heb ik geprobeerd de afbeelding te verwijderen, en opnieuw te downloaden, de afbeelding ge´nspecteerd, en dan staat hij er wel maar als ik de pagina refresh dan is die afbeelding weer weg.
code:
1
2
3
4
5
6
<body>
    <div id="wrap">
        <div id="header">
            <h1 class="sitetitle">The Conjuring</h1>
            <img class="logo" src="Afbeeldingen/annabelle.png">
        </div>

Alle reacties


  • skate master
  • Registratie: september 2004
  • Laatst online: 22:28

skate master

Autodesk Educator Expert

Weet je zeker dat je de afbeelding naam goed geschreven hebt in je code?
Wat gebeurt er als je de afbeelding een andere naam geeft, werkt het dan?
Heb je al eens geprobeerd om het volledige pad naar de afbeelding in je code te plaatsen?

Het kleine stukje code wat je hebt geplaatst is niets mis mee.

  • _trickster_
  • Registratie: mei 2005
  • Laatst online: 20-11 18:22
Als ik je tekst goed lees, Bedoel je dat hij die niet in de option-list laat zien van PHPstorm of dat als je hem handmatig invoert dat de afbeelding niet gevonden wordt door de Web-server ?
Let ook op Hoofdletters Linux based Hosting is hoofdletter gevoelig ( ook op folder namen ).

en als het in de browser is probeer eens je cache te legen ( Eventeel in de Chrome Dev tools kan je ook eventueel disable Cache aanvinken

  • Hakuna-Matata
  • Registratie: april 2016
  • Laatst online: 15-11 12:50
Ik heb de geschiedenis ook verwijderd, maar hielp niet.
Ik heb de afbeelding verschillende namen gegeven.
Dat hele pad heb ik nog niet gedaan.
Ik kwam er net achter dat mijn homepage met alleen tekst ook zo doet, dat hij het in de browser niet bijwerkt.
Maar dat lukt in phpstorm wel gewoon.
Met die afbeeldingen laat hij in phpstorm niks zien, 1 verwijderde afbeelding en die banner.

Hakuna-Matata wijzigde deze reactie 22-11-2016 22:55 (20%)


  • mcDavid
  • Registratie: april 2008
  • Laatst online: 22:06
Test je lokaal door gewoon het HTML bestand te openen, of via een webserver?
Check of die "Afbeeldingen" directory ook in je webroot bestaat, of alleen op je lokale filesystem of andersom.

zcflevo.nl


  • Hakuna-Matata
  • Registratie: april 2016
  • Laatst online: 15-11 12:50
quote:
mcDavid schreef op dinsdag 22 november 2016 @ 23:00:
Test je lokaal door gewoon het HTML bestand te openen, of via een webserver?
Check of die "Afbeeldingen" directory ook in je webroot bestaat, of alleen op je lokale filesystem of andersom.
Ik test het via een webserver.
Die afbeeldingen directory bestaat in phpstorm en in mijn lokale filesysteem.
Alleen het punt is dat in mijn lokale filesysteem gewoon de afbeeldingen staan die ik wil hebben.
En in php storm een verwijderde afbeelding en een banner die ik al heb gebruikt.

  • _trickster_
  • Registratie: mei 2005
  • Laatst online: 20-11 18:22
Ik kan er denk ik uit je reactie opnemen dat het niet in PHPstorm is wat je bedoeld maar op de browserkant ( dat je hem niet ziet )

Zoals @mcDavid aangeeft, hoe roep je de pagina aan?
Als je hem vanuit de webserver opend Is er mischien een .htaccess die in de weg zit?
Bekijk anders eens in je log of je daar keurig de 404 tegen komt

  • mcDavid
  • Registratie: april 2008
  • Laatst online: 22:06
quote:
Hakuna-Matata schreef op dinsdag 22 november 2016 @ 23:19:
[...]

Ik test het via een webserver.
Die afbeeldingen directory bestaat in phpstorm en in mijn lokale filesysteem.
Alleen het punt is dat in mijn lokale filesysteem gewoon de afbeeldingen staan die ik wil hebben.
En in php storm een verwijderde afbeelding en een banner die ik al heb gebruikt.
Als je je website via een webserver bekijkt, moet je wel zorgen dat die Afbeeldingen map ook bestaat (en op de juiste plek staat) in je webroot.

Je gebruikt een relatief pad, wat betekent dat je Afbeeldingen map in dezelfde map moet staan als het HTML-bestand.

je kunt in je webbrowser mbv rechtermuis -> element inspecteren kijken welk pad er precies opgevraagd wordt.

zcflevo.nl


  • Hakuna-Matata
  • Registratie: april 2016
  • Laatst online: 15-11 12:50
quote:
mcDavid schreef op dinsdag 22 november 2016 @ 23:34:
[...]


Als je je website via een webserver bekijkt, moet je wel zorgen dat die Afbeeldingen map ook bestaat (en op de juiste plek staat) in je webroot.

Je gebruikt een relatief pad, wat betekent dat je Afbeeldingen map in dezelfde map moet staan als het HTML-bestand.

je kunt in je webbrowser mbv rechtermuis -> element inspecteren kijken welk pad er precies opgevraagd wordt.
Ik heb de map html4site =>map afbeeldingen =>plaatjes.
In de map html4site =>html bestanden los, en een css map in de html4site map.
Deze melding krijg ik als ik de pagina inspecteer: http://localhost:3000/html4site/Afbeeldingen/a Failed to load resource: the server responded with a status of 404 (Not Found).
Deze suggestie krijg ik als ik annabelle wil intypen.
[img]https://http://www.hondenpage.com/fotos/foto/475089/.php[/img]

  • Woy
  • Registratie: april 2000
  • Niet online

Woy

Moderator Devschuur«
Let er op dat url's case sensative zijn. Afhankelijk van je webserver kan het dus zijn dat je de exacte case van de map & afbeelding goed moet typen.

“Build a man a fire, and he'll be warm for a day. Set a man on fire, and he'll be warm for the rest of his life.”


  • Hakuna-Matata
  • Registratie: april 2016
  • Laatst online: 15-11 12:50
quote:
Woy schreef op woensdag 23 november 2016 @ 10:30:
Let er op dat url's case sensative zijn. Afhankelijk van je webserver kan het dus zijn dat je de exacte case van de map & afbeelding goed moet typen.
Ik heb de naam gekopieerd, dus typfouten heb ik niet.
Het lijkt alsof hij moeite heeft om dingen bij te werken.

  • CH4OS
  • Registratie: april 2002
  • Niet online

CH4OS

It's a kind of magic

De HTTP 404 foutmelding betekend in ieder geval dat het opgegeven pad van de afbeelding niet juist is.
quote:
Woy schreef op woensdag 23 november 2016 @ 10:30:
Let er op dat url's case sensative zijn. Afhankelijk van je webserver kan het dus zijn dat je de exacte case van de map & afbeelding goed moet typen.
Op Windows (NTFS) is dat niet zo, Linux is dat wel zo, dankzij het filesystem. Blijft het nog wel best practice om het case sensitive te schrijven, mocht je bijvoorbeeld van server / OS wisselen.

CH4OS wijzigde deze reactie 23-11-2016 10:59 (72%)

[ Overwatch ][ Diablo ][ CptChaos#2957 ]


  • Hakuna-Matata
  • Registratie: april 2016
  • Laatst online: 15-11 12:50
quote:
CH40S schreef op woensdag 23 november 2016 @ 10:58:
De HTTP 404 foutmelding betekend in ieder geval dat het opgegeven pad van de afbeelding niet juist is.
[...]
Op Windows (NTFS) is dat niet zo, Linux is dat wel zo, dankzij het filesystem. Blijft het nog wel best practice om het case sensitive te schrijven, mocht je bijvoorbeeld van server / OS wisselen.
Ja, maar als ik het met een andere afbeelding doe dan doet hij het wel.
Maar hij blijft een verwijdere afbeelding onthouden.
Ik gebruik zelf windows.

  • CH4OS
  • Registratie: april 2002
  • Niet online

CH4OS

It's a kind of magic

quote:
Hakuna-Matata schreef op woensdag 23 november 2016 @ 11:00:
Ja, maar als ik het met een andere afbeelding doe dan doet hij het wel.
Controleer even op het filesysteem of de file die je wil dan wel op de juiste locatie staat.

[ Overwatch ][ Diablo ][ CptChaos#2957 ]


  • Hakuna-Matata
  • Registratie: april 2016
  • Laatst online: 15-11 12:50
quote:
CH40S schreef op woensdag 23 november 2016 @ 11:07:
[...]
Controleer even op het filesysteem of de file die je wil dan wel op de juiste locatie staat.
Dat heb ik gecontroleerd, en hij staat in het juiste bestand.

  • Woy
  • Registratie: april 2000
  • Niet online

Woy

Moderator Devschuur«
quote:
CH40S schreef op woensdag 23 november 2016 @ 10:58:
De HTTP 404 foutmelding betekend in ieder geval dat het opgegeven pad van de afbeelding niet juist is.
[...]
Op Windows (NTFS) is dat niet zo, Linux is dat wel zo, dankzij het filesystem.
Dat de meeste webserver direct het request forwarden naar het filesystem maakt nog niet dat het bij alle webservers geld ;)

“Build a man a fire, and he'll be warm for a day. Set a man on fire, and he'll be warm for the rest of his life.”


  • mcDavid
  • Registratie: april 2008
  • Laatst online: 22:06
quote:
Hakuna-Matata schreef op woensdag 23 november 2016 @ 11:10:
[...]

Dat heb ik gecontroleerd, en hij staat in het juiste bestand.
Ik denk dat je even helemaal back to basic moet. Maak een testcase met een zo minimaal mogelijke html-pagina die de afbeelding zou moeten laten zien, sla die op en kijk wat er gebeurt.

Post eventueel een kopie van die code, Ún een kopie van de paginabron zoals die in je browser staat.

zcflevo.nl


  • RM-rf
  • Registratie: september 2000
  • Laatst online: 23-11 16:18
quote:
Hakuna-Matata schreef op woensdag 23 november 2016 @ 10:16:
[...]

Ik heb de map html4site =>map afbeeldingen =>plaatjes.
In de map html4site =>html bestanden los, en een css map in de html4site map.
Deze melding krijg ik als ik de pagina inspecteer: http://localhost:3000/html4site/Afbeeldingen/a Failed to load resource: the server responded with a status of 404 (Not Found).
Deze suggestie krijg ik als ik annabelle wil intypen.
[afbeelding]
gaat het je nu werkelijk alleen om de 'suggestie's' die PHPStorm je doet als je begint met tiepen ?

https://www.jetbrains.com...auto-completing-code.html

volgens mij ondersteun code completion helemaal geen file's, zijn de suggesties enkel classes en methods uit een zeer brede library (kan er naast zitten, ik gebruik zelf geen phpStorm)


de link http://localhost:3000/html4site/Afbeeldingen/a geeft natuurlijk een 404 aangezien er geen file 'a' in die directory staat, wil je de afbeelding annabel.png laden zul je hem volgens mij gewoon helemaal zelf moeten intypen

1 2 3 4 5 7 6 8 9


  • Hakuna-Matata
  • Registratie: april 2016
  • Laatst online: 15-11 12:50
Het probleem is opgelost, het bleek te gaan dat ik die regel code niet weg had gehaald.
Bedankt voor de hulp van iedereen.

  • RobV
  • Registratie: juni 2013
  • Niet online

RobV

Welcome to the grid, Program.

(overleden)
quote:
Hakuna-Matata schreef op woensdag 23 november 2016 @ 13:00:
Het probleem is opgelost, het bleek te gaan dat ik die regel code niet weg had gehaald.
Bedankt voor de hulp van iedereen.
Welke regel? Ben nu wel benieuwd.

 | Mijn joystick / simpit project | Blog | Elite Dangerous CMDR Cataclysm72


  • ACM
  • Registratie: januari 2000
  • Niet online

ACM

Lead developer

Werkt hier

quote:
RM-rf schreef op woensdag 23 november 2016 @ 11:45:
volgens mij ondersteun code completion helemaal geen file's, zijn de suggesties enkel classes en methods uit een zeer brede library (kan er naast zitten, ik gebruik zelf geen phpStorm)
De code completion van de IDEA-familie is aanzienlijk krachtiger dan alleen een vaste set aangevuld met classes/methods. Files die ie herkent in directories die onderdeel zijn van het project zal ie bijvoorbeeld prima op die plek kunnen aanvullen of in css. En met de juiste plugins kan je ook zaken zoals Symfony-bundles laten aanvullen of templatenamen in phpcode.

Saai uitzicht in je tuin? Hang er een foto voor!


  • Hakuna-Matata
  • Registratie: april 2016
  • Laatst online: 15-11 12:50
quote:
RobV schreef op woensdag 23 november 2016 @ 18:15:
[...]

Welke regel? Ben nu wel benieuwd.
Het was regel 5.
En ik heb voor die website alle punten gehaald die je kon halen.

  • Caelorum
  • Registratie: april 2005
  • Laatst online: 21:47
Heb je die nou weggehaald of verandert? Want je eerdere reactie doet vermoeden dat je de img-tag maar gewoon hebt weggehaald, omdat die 'niet' werkte.

  • RM-rf
  • Registratie: september 2000
  • Laatst online: 23-11 16:18
quote:
Hakuna-Matata schreef op vrijdag 2 december 2016 @ 01:26:
[...]

Het was regel 5.
En ik heb voor die website alle punten gehaald die je kon halen.
het is natuurlijk fijn dat je de gewenste puntenscore behaald hebt, maar heeft dt topic te starten je daarbij geholpen?

ik heb de indruk dat je dit topic hooguit gebruikt hebt om wat losse gedachtes neer te zetten tijdens het vinden van het probleem en dit te oplossen zonder dat een poster hier je wrkelijk erbij kon helpen (omdat de infor,atie die je gaf weing duidelijkheid schept over waar je problee, ligt, wat code-fragmenten, suggestieve abstracte probleemanalyses als 'html onthoud afbeelding niet' (wet een beetje onzin is en zeker _niet_ het probleem) en onduidelijke foutmeldingen die erop ljken te wijzen dat het probleem geheel ergens anders ligt, zoals die 404 die je krijgt op de uri 'Afbeeldingen/a')


Volgens mij is zoiets voor de mensen hier die best bereid zijn je te helpen enigszins frustrerend...
(niet dat je je oplossing vind, maar de indruk dat het eerder weinig ljkt uit te maken of ze je pogen te helen)

verder, als je verder je zult ontwikkelen in een omgeving waar code-ontwikkeling belangrijk is; zijn ook goede probleem-analyses en vaststelling, alswel communicatie met anderen over evt. hindernissen die je in de ontwikkeling ondervind vaak essentieel in het ontwikkelings-proces

1 2 3 4 5 7 6 8 9

Pagina: 1


Apple iPhone X Google Pixel 2 XL LG W7 Samsung Galaxy S8 Google Pixel 2 Sony Bravia A1 OLED Microsoft Xbox One X Apple iPhone 8

© 1998 - 2017 de Persgroep Online Services B.V. Tweakers vormt samen met o.a. Autotrack en Hardware.Info de Persgroep Online Services B.V. Hosting door True

*