[Win2k] Loopt vast tijdens browsen/selecten van media files

Pagina: 1
Acties:
  • 141 views sinds 30-01-2008
  • Reageer

  • Ook
  • Registratie: September 2000
  • Laatst online: 14-07 16:25

Ook

Yes I can!

Topicstarter
Ik heb sinds gister een erg vaag probleem.
Elke keer als ik met de (windows) explorer aan het browsen ben en ik selecteer een media file (wma, mp3, avi, wav etc) dan loopt dat mapje vast. Ik klik de file dus nog niet eens 2 keer aan en het gaat al mis. Als ik winamp (bv) al open heb en dan kies voor "Open File" en dan blader naar een mp3 dan gaat het wel goed, maar (dubbel)klikken op een media file resulteert dus in het vastlopen van dat windowtje (windows werkt gewoon door, maar ik moet de betreffende map met de task manager afsluiten).

Het vreemde is dat elke keer dat ik een media file selecteer de (oude) windowsmediaplayer 6.4 op de achtergrond wordt gestart. Ik zie dus steeds in m'n taskmanager lijstje 'mplayer2.exe' verschijnenen (terwijl mp3's met WinAmp gaan!)

Ik vond dit sinds gister in m'n system logs (heeeel vaak):
Type gebeurtenis: Fout
Bron van gebeurtenis: DCOM
Categorie van gebeurtenis: Geen
Gebeurtenis-ID: 10010
Datum: 7-9-2002
Tijd: 14:44:40
Gebruiker: OOK\michiel
Computer: OOK
Beschrijving: De server {22D6F312-B0F6-11D0-94AB-0080C74C7E95} heeft zich binnen de vereiste termijn niet bij DCOM geregistreerd.
Als ik nou in m'n registry zoek naar die lange (schuingedrukte) string dan kom ik dus steeds bij ClassID: mplayer2.exe terecht. Het 1 heeft dus zeker met het ander te maken, maa HOE in godsnaam? En waarom start die mediaplayer iedere keer?

Ik heb niets veranderd aan mijn settings (alleen Dreamweaver MX geinstalled) en ik draai Win2kPro NL (sinds 4 dagen met SP3). Het enige vreemde is dat ik in mijn log entries als laatste melding (voordat al die DCOM meldingen begonnen) dit zag:
Type gebeurtenis: Informatie
Bron van gebeurtenis: Windows File Protection
Categorie van gebeurtenis: Geen
Gebeurtenis-ID: 64002
Datum: 6-9-2002
Tijd: 10:04:10
Gebruiker: n.v.t.
Computer: OOK
Beschrijving: Er is geprobeerd om bestandsvervanging toe te passen op het beveiligde systeembestand msdxms.ocx. Dit bestand is teruggezet naar de oorspronkelijke versie om systeemstabiliteit te behouden. De bestandsversie van het systeembestand is 6.4.9.1121.
En tien minuten later begon de ellende! Zou dit ermee te maken hebben?

Sorry voor het lange verhaal, maar ik hoop hier echt nog iets aan te kunnen doen! (Anders gooi ik er wel gewoon een format tegenaan, maar ja, nooit geschoten..)

Wees consequent, maar niet altijd


  • marty
  • Registratie: Augustus 2002
  • Laatst online: 27-03-2023
ik heb dat probleem met media files en vastlopen altijd als ik messenger aan heb staan

  • Ook
  • Registratie: September 2000
  • Laatst online: 14-07 16:25

Ook

Yes I can!

Topicstarter
Hmm.. Ik draai zelf nooit messenger (een andere gebruiker wel, maar ik ben wel een heel eind gekomen met een andere foutmelding in m'n (toepassings)logboek.
Er wordt nl ook deze melding gemaakt:
Kan het registerklassebestand niet verwijderen. Als u een zwervend profiel hebt, worden uw instellingen niet gerepliceerd. Neem contact op met de systeembeheerder.
Als ik daar op zoek dan kom ik een hele lap tekst met verschillende tips tegen. De kern van de zaak is dat het vaak gebeurt na installatie van nieuwe software (heb die Dreamweaver inmiddels al geunistalled, maar probleem blijft) en dat het te maken heeft met het feit dat windows een bepaalde register sleutel niet kan sluiten oid.

Ik merk ook dat dat het is want het uitloggen duurt precies 1 minuut langer en dat is de tijd dat windows als maximum (default) heeft staan om het registry bestand te dumpen. Allemaal leuk en aardig maar nu nog een oplossing!

Hieronder staat de lap tekst die bij bovenstaande foutmelding hoort (van eventid.net), misschien dat iemand me iets verder kan helpen, want ik kom er niet uit.

Lap tekst:
Source Userenv
Type Error
Description Windows cannot unload your registry file. If you have a roaming profile, your settings are not replicated. Contact your administrator. DETAIL - Access is denied. , Build number ((2195)).
Comments Adrian Grigorof: As per Microsoft: "This problem can occur if a handle to a registry key is not closed correctly." Several users have reported this problem as occuring after the installation of various software packages.


Kevin Galea: Change the start type of the service Windows Management Instrumentation to manual and then stop the service, in this way the file winmgmt.exe is not used by the system anymore, unless you manually start it. After that, delete any extra profiles that the computer had created and also make a few changes to "My Desktop" to test wheather these changes would be uploaded. Log off and then on again. The error message in the event viewer should disapear.

Anonymous: "I, and others, are working with MS on this one [..] Have you disabled/stopped any default services? Is your "Documents and Settings" folder in the canonical place. I can reproduce the problem right after a restart by simply starting/stopping the NetMeeting client (CONF.EXE, no connection necessary) and then logging off. I have read about others reproducing it by using Netscape, Office2000, etc... The problem is with two registry files, UsrClass.dat and UsrClass.dat.log (buried in one's profile dir) ... which the system process always has open and which (here at least) never contain any data. They can't be "unloaded" at logoff, and remain open even after another user logs on (hence the two "leaked" handles reported in %SystemRoot%\Debug\UserMode\userenv.log (there you see that the minute delay at logoff is caused by the system trying once per second for a minute to unload those files)."

JPElectron: I have tracked this down to after I installed Norton Anti-Virus 7.5 Corp. Ed. and noticed the yellow on-demand scan monitor shield thing has a yellow exclamation mark over it when logged onto a server via terminal services. I belive the duplicate instance of on-demand scan monitor in the terminal service session is the application causing the registry hive not to unload correctly.

Kevin Chapman: When logging off server using Terminal Services with NAV CE enabled, system would wait 60 secondds to unload user profile and then create a Event ID 1000 in the application log. According to MS, this is caused by a registry leak. Symantec has released a fix, v7.6.934.

Anonymous: This event may also occur in the application log if you are running terminal services on Windows 2000 Server/Advanced Server. A fix for this is availible thru microsoft support and shall only be applied to systems experiencing this particular problem, see Q289564. The next service pack (SP3) will solve this problem for this specific case.

Matt Decker: There are 3 options:
1. There is a hotfix available from MS that will be publicly available in SP3.
2. The "Documents and Settings" DACL gets hosed. You can try this pre or post hotfix, but you have to set the Everyone group to Full Controll over Documents and Settings. Log out, then log back in. Then you can set it back to the default permissions (everyone = r&a, R, l, system=full, powerusers, r&a, r, l, local users, r&a, r, l, etc). Also, if you cannot change permissions on Documents and Settings, turn off inheritance.
3.The most effective variable - disable and stop your virus protection. Works like a charm. I'm about to find out if reinstalling it and starting it back up still works.

Derek: There is a fix available from Microsoft. Please see Q285192 for more information.

Paul: There are two Microsoft hotfixes, Q281267 and Q285192, however they did not fix the problem in my case.

Not a fix, but here's a workaround that actually works: Open the MMC and add the Group Policy snap-in, then open the Group Policy editor. Go to Computer Configuration/Administrative Templates/System/Logon and find the policy "Maximum retries to unload and update user profile." Do not click "Disable" nor "Not Configured" as that just will use the default of 60. Rather, lower the # of tries to unload downward from 60. I figured, "If you can't unload it, don't bother trying", so I set mine to 0 and shutdown is (finally!) instantaneous once again.

Lucid: The Norton Antivirus Corporate Edition doesn't differentiate between a terminal session and a console session, thus it loads the user profile when it shouldn't. Upgrade to version 7.61 build 34a. They've added code to fix this issue.

Sandesh Telang: I was getting the same error on a Windows 2000 Advanced Server. The error was being generated every 2 minutes so I looked at the scheduled tasks and there were a couple of tasks that were running every two minutes. All of them were running under a local admin account and one of them was running under a domain account. I disabled all of them and started each of them to narrow down on the error and the service running under the domain account was the one generating the errors. The domain account was valid (had not expired or been disabled) and I could login using that id on a test machine. I deleted the profile (use the utility delprof from the 2000 resource kit) on the server and started the scheduled task. It started generating the errors again at the 2 minute interval. So I deleted the profile off the domain controller (and local copy from the server) and this time it fixed the problem.

Wees consequent, maar niet altijd


  • Ook
  • Registratie: September 2000
  • Laatst online: 14-07 16:25

Ook

Yes I can!

Topicstarter
Om het verhaal even compleet te maken, ik heb er dus maar een format tegenaan gegooid.. Dat heeft al met al minder gekost dan dat graven op internet (en in me registry) en alles loopt weer lekker gladjes..

Mocht iemand ooit hetzelfde tegenkomen en een oplossing hebben dan ben ik nog steeds wel benieuwd..

Wees consequent, maar niet altijd