Toon posts:

Sonoff Zigbee 3.0 dongle op Synlogy

Pagina: 1
Acties:

Vraag


  • Faece
  • Registratie: Augustus 2007
  • Laatst online: 03-02 19:22
Ik heb deze dongle geflashed ( geprobeerd via het booten en via het python script), maar mijn dongle wordt niet gevonden op mijn synology server (en eigenlijk ook niet op mijn windows pc). Iemand enig idee wat zou kunnen misgaan of wat ik nog kan gaan proberen ?

Beste antwoord (via Faece op 28-01-2023 06:13)


  • jj85
  • Registratie: Januari 2002
  • Laatst online: 08:52
Laatste versie ook geprobeerd?
Specifiek, deze is voor DSM 6.2 cedarview

Alle reacties


  • Wylana
  • Registratie: April 2009
  • Laatst online: 03-02 19:18
Is het flashen succesvol gelukt? Gaf hij dit ook aan?
Heb je al meerdere usb poorten geprobeerd?
Drivers handmatig installeren al geprobeerd?

Ik ben steenrijk....ik heb een grindpad!


  • JukeboxBill
  • Registratie: Juni 2003
  • Nu online
Ik was mij ook aan het oriënteren op het updaten van mijn ConbeeII zigbee stick.
De meest betrouwbare methode zou zijn om het rechtstreeks op een PC te doen en niet op een server met scripts e.d..

Soms ben ik bijna gelukkig


  • Faece
  • Registratie: Augustus 2007
  • Laatst online: 03-02 19:22
ja, eigenlijk leek alles gelukt te zijn, en als ik kijk bij apparaatbeheer staat er "silicon labs cp210x usb to uart bridge", dus ik zou gaan denken dat het gelukt is

  • Faece
  • Registratie: Augustus 2007
  • Laatst online: 03-02 19:22
JukeboxBill schreef op woensdag 25 januari 2023 @ 18:55:
Ik was mij ook aan het oriënteren op het updaten van mijn ConbeeII zigbee stick.
De meest betrouwbare methode zou zijn om het rechtstreeks op een PC te doen en niet op een server met scripts e.d..
eerste methode was de stick openen, de bootknop indrukken terwijl je het in de usb steekt en dan via flashsoftware update. Heb ik gedaan en leek gelukt. Maar op mijn synology zie ik niks (ttyACM0 of 1 wordt niet geactiveerd). Dus ik dacht dat het aan mijn syno lag. Maar nu heb ik een zwave stick ingestoken en daar komt ttyACM0 wel tevoorschijn.

Andere methode was via een python script. Dit leek ook gelukt, maar eigenlijk hetzelfde resultaat...

  • Gizz
  • Registratie: Maart 2001
  • Nu online

Gizz

Dunder-Mifflin, Inc.

@Faece heb je de cp210-driver geïnstalleerd op je Synology?

Github

[Voor 38% gewijzigd door Gizz op 25-01-2023 20:08]

Canon EOS 5Dm3 + 5D + 7D + 300D + 1000FN + EF 17-40 4L + EF 35 1.4L + EF 50 1.8 + EF 80-200 2.8L + 550EX


  • Faece
  • Registratie: Augustus 2007
  • Laatst online: 03-02 19:22
Gizz schreef op woensdag 25 januari 2023 @ 20:07:
@Faece heb je de cp210-driver geïnstalleerd op je Synology?

Github
Het is niet mijn syno die het probleem is, want als ik een zwave stick insteek, heb ik wel een ttyacm0

  • Gizz
  • Registratie: Maart 2001
  • Nu online

Gizz

Dunder-Mifflin, Inc.

@Faece gebruikt die z-wave stick ook de cp210-chipset voor de communicatie? Anders zegt het niet zoveel dat die stick het wel doet, als ie een compleet andere chip en drivers gebruikt :)

Je moet deze driver echt los installeren. Heb je dat nog nooit gedaan op je Synology, dan ontbreekt hij gegarandeerd.

[Voor 24% gewijzigd door Gizz op 25-01-2023 21:19]

Canon EOS 5Dm3 + 5D + 7D + 300D + 1000FN + EF 17-40 4L + EF 35 1.4L + EF 50 1.8 + EF 80-200 2.8L + 550EX


  • Faece
  • Registratie: Augustus 2007
  • Laatst online: 03-02 19:22
Gizz schreef op woensdag 25 januari 2023 @ 21:18:
@Faece gebruikt die z-wave stick ook de cp210-chipset voor de communicatie? Anders zegt het niet zoveel dat die stick het wel doet, als ie een compleet andere chip en drivers gebruikt :)

Je moet deze driver echt los installeren. Heb je dat nog nooit gedaan op je Synology, dan ontbreekt hij gegarandeerd.
Ja ik heb al heel wat drivers geinstalleerd, ook die van op de synocommunity

  • septillion
  • Registratie: Januari 2009
  • Laatst online: 09:29

septillion

Moderator Wonen & Mobiliteit
Misschien niet direct nuttig, maar er zitten enorme verschillen tussen de ZBDongle-P en ZBDongle-E, welke heb je?

  • jj85
  • Registratie: Januari 2002
  • Laatst online: 08:52
Faece schreef op donderdag 26 januari 2023 @ 07:40:
[...]


Ja ik heb al heel wat drivers geinstalleerd, ook die van op de synocommunity
Indien je de P-versie hebt van de dongle, check of je deze driver hebt
/lib/modules/cp210x.ko

Zie ook mijn post (jj85 in "Zigbee2mqtt - open source zigbee bridge - Deel 2") hoe je daar in Synology DSM een 'draai' aan kunt geven.

[Voor 21% gewijzigd door jj85 op 26-01-2023 09:51]


  • Faece
  • Registratie: Augustus 2007
  • Laatst online: 03-02 19:22
septillion schreef op donderdag 26 januari 2023 @ 09:11:
Misschien niet direct nuttig, maar er zitten enorme verschillen tussen de ZBDongle-P en ZBDongle-E, welke heb je?
de p

  • Faece
  • Registratie: Augustus 2007
  • Laatst online: 03-02 19:22
jj85 schreef op donderdag 26 januari 2023 @ 09:51:
[...]

Indien je de P-versie hebt van de dongle, check of je deze driver hebt
/lib/modules/cp210x.ko
Ja, ik heb hem staan :(

  • Wylana
  • Registratie: April 2009
  • Laatst online: 03-02 19:18
En misschien een heel vreemde vraag. Maar heb je al eens een USB verlengkabel gebruikt?

Ikzelf had namelijk issues dat mijn stick wel wilde installeren in Home Assistant, maar dat ik geen devices zag verbinden. Dit kwam door de interferentie vanaf de USB port.

Misschien dat deze interferentie zo erg is, dat hij je stick nu helemaal niet wilt starten/detecteren?

Ik ben steenrijk....ik heb een grindpad!


  • The Zep Man
  • Registratie: Oktober 2003
  • Laatst online: 00:38
Wylana schreef op donderdag 26 januari 2023 @ 16:12:
Misschien dat deze interferentie zo erg is, dat hij je stick nu helemaal niet wilt starten/detecteren?
Bij stoorsignalen zou de stick wel herkend moeten worden door de PC.

[Voor 3% gewijzigd door The Zep Man op 26-01-2023 16:13]


  • Faece
  • Registratie: Augustus 2007
  • Laatst online: 03-02 19:22
Wylana schreef op donderdag 26 januari 2023 @ 16:12:
En misschien een heel vreemde vraag. Maar heb je al eens een USB verlengkabel gebruikt?

Ikzelf had namelijk issues dat mijn stick wel wilde installeren in Home Assistant, maar dat ik geen devices zag verbinden. Dit kwam door de interferentie vanaf de USB port.

Misschien dat deze interferentie zo erg is, dat hij je stick nu helemaal niet wilt starten/detecteren?
Heb ik nog niet gedaan. Maar ik had het al eens ergens gelezen en vond het wat nonsens, maar nu ik nog eens bevestiging heb van jou, test ik dit misschien beter ook eens...

  • Wylana
  • Registratie: April 2009
  • Laatst online: 03-02 19:18
The Zep Man schreef op donderdag 26 januari 2023 @ 16:13:
[...]


Bij stoorsignalen zou de stick wel herkend moeten worden door de PC.
Dat verwacht ik ook ja, maar goed in mijn ruim 20+ jaar IT heb ik de gekste dingen meegemaakt.

Ik ben steenrijk....ik heb een grindpad!


  • Wylana
  • Registratie: April 2009
  • Laatst online: 03-02 19:18
Faece schreef op donderdag 26 januari 2023 @ 16:14:
[...]

Heb ik nog niet gedaan. Maar ik had het al eens ergens gelezen en vond het wat nonsens, maar nu ik nog eens bevestiging heb van jou, test ik dit misschien beter ook eens...
Ik heb dagen lopen klooien en dacht eerst dat het aan mijn stick lag.
Toen toch maar eens uitgesloten omdat ik niks anders meer kon bedenken en frappant....in ene werden al mijn devices gevonden. 8)7

Ik ben steenrijk....ik heb een grindpad!


  • The Zep Man
  • Registratie: Oktober 2003
  • Laatst online: 00:38
@Faece

Overweeg ook dit.

[edit]
Ook hier wordt het e.e.a. besproken qua unbricken.

[Voor 39% gewijzigd door The Zep Man op 26-01-2023 16:21]


  • jj85
  • Registratie: Januari 2002
  • Laatst online: 08:52
Neem aan dat je de driver ook activeert?
code:
1
sudo insmod /lib/modules/cp210x.ko

  • Faece
  • Registratie: Augustus 2007
  • Laatst online: 03-02 19:22
jj85 schreef op vrijdag 27 januari 2023 @ 08:51:
[...]

Neem aan dat je de driver ook activeert?
code:
1
sudo insmod /lib/modules/cp210x.ko
als ik dit command uitvoer krijg ik
insmod: ERROR: could not insert module /lib/modules/cp210x.ko: Invalid module format

  • jj85
  • Registratie: Januari 2002
  • Laatst online: 08:52
Faece schreef op vrijdag 27 januari 2023 @ 14:51:
[...]

als ik dit command uitvoer krijg ik
insmod: ERROR: could not insert module /lib/modules/cp210x.ko: Invalid module format
Wat als je eerst deze uitvoert:
code:
1
sudo insmod /lib/modules/usbserial.ko

en vervolgens
code:
1
sudo insmod /lib/modules/cp210x.ko

  • Faece
  • Registratie: Augustus 2007
  • Laatst online: 03-02 19:22
jj85 schreef op vrijdag 27 januari 2023 @ 15:05:
[...]

Wat als je eerst deze uitvoert:
code:
1
sudo insmod /lib/modules/usbserial.ko

en vervolgens
code:
1
sudo insmod /lib/modules/cp210x.ko
bij het eerste commando :
insmod: ERROR: could not insert module /lib/modules/usbserial.ko: File exists

  • jj85
  • Registratie: Januari 2002
  • Laatst online: 08:52
Mogelijk is de aanwezige cp210x.ko driver niet de juiste versie voor jouw systeem?

Je zult de juiste driver moeten downloaden en installeren, hangt dus af van je Synology model.

https://github.com/robert...drivers/tree/main/modules

[Voor 3% gewijzigd door jj85 op 27-01-2023 15:47]


  • Faece
  • Registratie: Augustus 2007
  • Laatst online: 03-02 19:22
jj85 schreef op vrijdag 27 januari 2023 @ 15:47:
Mogelijk is de aanwezige cp210x.ko driver niet de juiste versie voor jouw systeem?

Je zult de juiste driver moeten downloaden en installeren, hangt dus af van je Synology model.

https://github.com/robert...drivers/tree/main/modules
ik heb een dsm713+, draait op 6.2 en heeft linux kernel versie "cedarview", maar ik kan precies niet meer vinden waar ik die drivers gevonden heb :(

  • jj85
  • Registratie: Januari 2002
  • Laatst online: 08:52

  • Faece
  • Registratie: Augustus 2007
  • Laatst online: 03-02 19:22
Het jammere is , dat ik 6.2 draaien heb.
Kan ik terug naar 6.1 ?

  • Gizz
  • Registratie: Maart 2001
  • Nu online

Gizz

Dunder-Mifflin, Inc.

Ik verwacht dat je gewoon de 6.1 driver kunt gebruiken in 6.2. De regel begint ook met "DSM 6.x:", dus gewoon drivers voor 6 ongeacht of het nou 6.0/6.1/6.2/6.123456 is :)

Canon EOS 5Dm3 + 5D + 7D + 300D + 1000FN + EF 17-40 4L + EF 35 1.4L + EF 50 1.8 + EF 80-200 2.8L + 550EX


  • Faece
  • Registratie: Augustus 2007
  • Laatst online: 03-02 19:22
ik had die al draaien, dus dit is eigenlijk ook de oplossing niet :(

Acties:
  • Beste antwoord
  • +1Henk 'm!

  • jj85
  • Registratie: Januari 2002
  • Laatst online: 08:52
Laatste versie ook geprobeerd?
Specifiek, deze is voor DSM 6.2 cedarview

  • Faece
  • Registratie: Augustus 2007
  • Laatst online: 03-02 19:22
jj85 schreef op vrijdag 27 januari 2023 @ 21:45:
Laatste versie ook geprobeerd?
Specifiek, deze is voor DSM 6.2 cedarview
nu geeft sudo insmod /lib/modules/cp210x.ko geen error, en krijg ik een ttyUSB0 te zien!
Het zal dus inderdaad de foute driver zijn geweest

Allen, bedankt voor jullie tijd. Ik hoop ooit iets terug te kunnen doen, maar met mijn gebrek aan kennis vrees ik hier wat voor >:)

  • Faece
  • Registratie: Augustus 2007
  • Laatst online: 03-02 19:22
Nu nog zoeken hoe ik hem actief krijg in HA, want hij wordt niet automatisch herkend...

  • jj85
  • Registratie: Januari 2002
  • Laatst online: 08:52
Hoe draai je HA? VM, docker of...

  • Faece
  • Registratie: Augustus 2007
  • Laatst online: 03-02 19:22
jj85 schreef op zaterdag 28 januari 2023 @ 18:55:
Hoe draai je HA? VM, docker of...
Docker.

Het is echt al een lijdensweg geweest die sonoff dongle...

  • jj85
  • Registratie: Januari 2002
  • Laatst online: 08:52
@Faece Je zult het usb-device moeten toevoegen in je docker config.

Even als voorbeeld mijn zigbee2mqtt docker compose:
YAML:
1
2
3
4
5
6
7
8
9
10
version: '3.8'
services:
  zigbee2mqtt:
    container_name: zigbee2mqtt
    image: koenkk/zigbee2mqtt  
    privileged: true 
    volumes:
      - /run/udev:/run/udev:ro
    devices:   
      - /dev/ttyUSB0:/dev/ttyUSB0


Relevant zijn dan regel 9 en 10. En in mijn geval had ik ook 6, 7 en 8 nodig op mijn Synology.
Denk dat je voor HA iets soortgelijks kan toepassen.

  • Faece
  • Registratie: Augustus 2007
  • Laatst online: 03-02 19:22
jj85 schreef op zondag 29 januari 2023 @ 07:00:
@Faece Je zult het usb-device moeten toevoegen in je docker config.

Even als voorbeeld mijn zigbee2mqtt docker compose:
YAML:
1
2
3
4
5
6
7
8
9
10
version: '3.8'
services:
  zigbee2mqtt:
    container_name: zigbee2mqtt
    image: koenkk/zigbee2mqtt  
    privileged: true 
    volumes:
      - /run/udev:/run/udev:ro
    devices:   
      - /dev/ttyUSB0:/dev/ttyUSB0


Relevant zijn dan regel 9 en 10. En in mijn geval had ik ook 6, 7 en 8 nodig op mijn Synology.
Denk dat je voor HA iets soortgelijks kan toepassen.
Eerst Mqtt opnieuw installeren blijkbaar want de log zegt dat hij nie kan connecteren. Maar daar heb al goede YouTube guides voor gevonden. Indien het niet lukt kom ik terug hier aankloppen ;)

edit : mqtt en zigbee2mqtt up and running

[Voor 3% gewijzigd door Faece op 29-01-2023 18:43]

Pagina: 1


Tweakers maakt gebruik van cookies

Tweakers plaatst functionele en analytische cookies voor het functioneren van de website en het verbeteren van de website-ervaring. Deze cookies zijn noodzakelijk. Om op Tweakers relevantere advertenties te tonen en om ingesloten content van derden te tonen (bijvoorbeeld video's), vragen we je toestemming. Via ingesloten content kunnen derde partijen diensten leveren en verbeteren, bezoekersstatistieken bijhouden, gepersonaliseerde content tonen, gerichte advertenties tonen en gebruikersprofielen opbouwen. Hiervoor worden apparaatgegevens, IP-adres, geolocatie en surfgedrag vastgelegd.

Meer informatie vind je in ons cookiebeleid.

Sluiten

Toestemming beheren

Hieronder kun je per doeleinde of partij toestemming geven of intrekken. Meer informatie vind je in ons cookiebeleid.

Functioneel en analytisch

Deze cookies zijn noodzakelijk voor het functioneren van de website en het verbeteren van de website-ervaring. Klik op het informatie-icoon voor meer informatie. Meer details

janee

    Relevantere advertenties

    Dit beperkt het aantal keer dat dezelfde advertentie getoond wordt (frequency capping) en maakt het mogelijk om binnen Tweakers contextuele advertenties te tonen op basis van pagina's die je hebt bezocht. Meer details

    Tweakers genereert een willekeurige unieke code als identifier. Deze data wordt niet gedeeld met adverteerders of andere derde partijen en je kunt niet buiten Tweakers gevolgd worden. Indien je bent ingelogd, wordt deze identifier gekoppeld aan je account. Indien je niet bent ingelogd, wordt deze identifier gekoppeld aan je sessie die maximaal 4 maanden actief blijft. Je kunt deze toestemming te allen tijde intrekken.

    Ingesloten content van derden

    Deze cookies kunnen door derde partijen geplaatst worden via ingesloten content. Klik op het informatie-icoon voor meer informatie over de verwerkingsdoeleinden. Meer details

    janee