Toon posts:

Excel: vert.zoeken jokerteken

Pagina: 1
Acties:

Onderwerpen

Vraag


  • kimmeuwissen
  • Registratie: Januari 2023
  • Laatst online: 12-01 15:02
Ik heb een vraag over een formule in Excel.

De formule die ik nu heb:
=X.zoeken(A1;E:E;F;F)
Dus: als A1 gelijk is met kolom E, dan moet er komen te staan wat in kolom F staat.

Maar als cel A1 maar een gedeelte bevat van kolom E, doet die het niet meer.
Hiervoor moet er een jokter teken toegevoegd worden.
Weten jullie waar ik dit joker teken moet zetten? wat de nieuwe formule wordt?


Zie de afbeelding hieronder.

Alle reacties


  • dix-neuf
  • Registratie: Juli 2018
  • Niet online
Het jokerteken kun je gebruiken als kolom A slechts een gedeelte bevat van de tekst die je in kolom E wil zoeken. Maar bij jou is het omgekeerd als het om A3 gaat: kolom E bevat slechts een gedeelte van de tekst in A3. Voorbeeld:
Als in a3 "Bakker" zou staan en in E2 "Bakkerij", dan zou je kunnen gebruiken:
=vert.zoeken(A3&"*";E1:F9;2;0) of: =vert.zoeken(A3&"??";E1:F9;2;0), of hetzelfde met X.Zoeken
Nu het te zoeken woord in kolom E langer is dan dat in kolom A, zou je dit kunnen gebruiken:
=vert.zoeken(links(A5;6)&"*";E1:F9;2;0)
maar dan moet je vooraf weten dat in het te zoeken woord minstens de eerste 6 letters overeenkomen met dat in kolom A.
In plaats van of samen met het sterretje (of vraagtekens) ná het woord kun je ook een sterretje (of vraagteken(s) vóór het te zoeken woord plaatsen. Een vraagteken staat voor 1 teken, een sterretje voor meerdere.

  • kimmeuwissen
  • Registratie: Januari 2023
  • Laatst online: 12-01 15:02
Dank u.
Ik ben een stuk wijzer geworden.

In onderstaande afbeelding heb ik cel C8 geselecteerd.
Bij een leeg veld, pakt die de bovenste regel. Zou ik hier ook wat mee kunnen?



In onderstaande afbeelding heb ik kolom E15 geselecteerd.
Zou u mij een voorbeeld kunnen geven als ik niet links maar rechts wil?



Zou ik bij deze ook nog zo'n zelf formule kunnen toevoegen?
Dus niet alleen "grootboek", maar bij "grootboek" en "test".


  • dix-neuf
  • Registratie: Juli 2018
  • Niet online
Met jouw formule bij de eerste afbeelding =VERT.ZOEKEN("*"&C8&"*";H$3:J$8;2;0)
zoek je in H3:H8 naar "Tekst 1" met evt. tekst er voor en/of erna. Maar in H$3:H$8 komt "Tekst 1" niet voor, vandaar dat je formule een foutmelding oplevert (#N/B).

Met je formule bij de 2e afbeelding: =VERT.ZOEKEN(LINKS(B15;6)&"*";H$10:J$15;2;0)
zoek je in H$10:H$15 naar "Test G" met evt. tekst er na. Ook hier geldt: omdat "Test G" in H$10:H$15 niet voorkomt, is het resultaat een foutmelding (#N/B). Als je in deze formule H$10 zou vervangen door H$3 (waardoor je zoekt in H$3:H$15), dan zou het resulaat "Tekst 5" zijn, dat in i7 staat.

Bij de laatste afbeelding zou je kunnen kiezen voor een formule die "Klopt wel" als resultaat geeft als 1 van de twee teksten ("Grootboek" of "Tekst") voorkomt, maar ik weet niet of dat je bedoeling is. De formule in F3 wordt dan (let op dat achteraan "Klopt wel" en "Klopt niet" zijn verwisseld in vergelijking met jouw formule):

=als(isfout(of(vind.alles("Grootboek";B3);vind.alles("test";B3)));"Klopt wel";"Klopt niet")


Tweakers maakt gebruik van cookies

Tweakers plaatst functionele en analytische cookies voor het functioneren van de website en het verbeteren van de website-ervaring. Deze cookies zijn noodzakelijk. Om op Tweakers relevantere advertenties te tonen en om ingesloten content van derden te tonen (bijvoorbeeld video's), vragen we je toestemming. Via ingesloten content kunnen derde partijen diensten leveren en verbeteren, bezoekersstatistieken bijhouden, gepersonaliseerde content tonen, gerichte advertenties tonen en gebruikersprofielen opbouwen. Hiervoor worden apparaatgegevens, IP-adres, geolocatie en surfgedrag vastgelegd.

Meer informatie vind je in ons cookiebeleid.

Sluiten

Toestemming beheren

Hieronder kun je per doeleinde of partij toestemming geven of intrekken. Meer informatie vind je in ons cookiebeleid.

Functioneel en analytisch

Deze cookies zijn noodzakelijk voor het functioneren van de website en het verbeteren van de website-ervaring. Klik op het informatie-icoon voor meer informatie. Meer details

janee

    Relevantere advertenties

    Dit beperkt het aantal keer dat dezelfde advertentie getoond wordt (frequency capping) en maakt het mogelijk om binnen Tweakers contextuele advertenties te tonen op basis van pagina's die je hebt bezocht. Meer details

    Tweakers genereert een willekeurige unieke code als identifier. Deze data wordt niet gedeeld met adverteerders of andere derde partijen en je kunt niet buiten Tweakers gevolgd worden. Indien je bent ingelogd, wordt deze identifier gekoppeld aan je account. Indien je niet bent ingelogd, wordt deze identifier gekoppeld aan je sessie die maximaal 4 maanden actief blijft. Je kunt deze toestemming te allen tijde intrekken.

    Ingesloten content van derden

    Deze cookies kunnen door derde partijen geplaatst worden via ingesloten content. Klik op het informatie-icoon voor meer informatie over de verwerkingsdoeleinden. Meer details

    janee