Toon posts:

Plex installatie op Linux (Mint)

Pagina: 1
Acties:

Vraag


  • SMGGM
  • Registratie: Januari 2006
  • Laatst online: 04-02 22:45
Momenteel draait mijn Plex media server onder een Windows 7 machine en (hoewel dit prima draait) besef ik dat deze ooit eens gemigreerd moet worden. Ik wil daarom overstappen naar Linux omdat het toch gaat om een wat oudere computer.
Helaas krijg ik Plex media server maar niet werkend. Heb al een aantal handleidingen gevolgd, maar momenteel lijkt geen te werken terwijl ik wel allerlei parameters aan het wijzigen ben (zonder eigenlijk te beseffen wat ik aan het doen ben), vandaar deze vraag hier.
Wat moet ik wel en niet uitvoeren?

De situatie is als volgt:
Heb gekozen voor Linux Mint, de media zelf staat op een HDD onder NTFS. Plex zelf werkt.

Het probleem begint wanneer ik media wil toevoegen aan Plex. Daar lijkt Plex geen rechten te hebben op de media.
Op internet kan ik terugvinden dat ik de user "plex" moest toevoegen aan mijn groep. Resultaat van onder welke groepen de "plex" en ikzelf zit.
code:
1
2
3
4
5
groups plex
plex : plex video render mygroup

groups myuser
myuser : mygroup adm cdrom sudo dip plugdev lpadmin sambashare plex


De machtigingen van de media (/media/myuser/media/) zelf is als volgt (en dit is voor alle bestanden en mappen hieronder):
code:
1
drwxrwxrwx 1 myuser mygroup ....


Hieruit concludeer ik toch dat iedereen rechten heeft op die locatie.
Ga ik naar Plex en kies ik om een map toe te voegen, dan stopt de locatie aan /media/myuser/
Wat doe ik fout of moet ik nog doen om Plex die mappen te laten zien? Of ligt het aan nog iets anders (misschien omdat het een NTFS schijf is)?

Hopelijk iemand wijze raad.

Alle reacties


  • Hero of Time
  • Registratie: Oktober 2004
  • Laatst online: 19:20

Hero of Time

Moderator LNX

There is only one Legend

Het is idd een dingetje als je met NTFS werkt onder Linux. Het kan werken, als je idd weet wat je doet en moet doen. Als je systeem toch niets meer doet dan Plex en dat feitelijk de enige actieve gebruiker op de schijf om er te schrijven, ben je veel beter af om de data erop tijdelijk elders te plaatsen, de partitie of schijf te formatteren naar een Linux native file system zoals ext4 of xfs en de eigenaar van de map waar je alles in wilt zetten op plex zetten.

Wanneer je de data terug hebt gezet, kan je de eigenaar wijzigen via het chown commando. Gebruik dan iets als dit, waarbij het de mount point is van je schijf:
sudo chown -R plex: /media/plex/media


Dankzij de standaard rechten die bestanden krijgen wanneer wat geschreven wordt, zou jij als non-plex gebruiker gewoon alles moeten kunnen lezen voor bijvoorbeeld backups. De rechten zijn namelijk dat de eigenaar in principe mag wijzigen en de groep mag alleen lezen, evenals alle andere gebruikers. Afhankelijk van andere omstandigheden en specifieke eigenschappen kan de groep of overige gebruikers (other) meer of minder.

Commandline FTW | Tweakt met mate


  • SMGGM
  • Registratie: Januari 2006
  • Laatst online: 04-02 22:45
@Hero of Time
Bedankt voor je reactie, maar dit werkt precies niet.

Schijf is geformatteerd onder ext4
Locatie is /media/gebruikersnaam/Media/Films
De gebruiker "Plex" is eigenaar van de map "Films"
Navigeer ik naar de map in Plex, dan stopt die vanaf /media/gebruikersnaam/

Op zich snap ik wel waarom, de gebruiker "plex" heeft immers geen rechten op de folder /media/gebruikersnaam/
Maar ik ben een te grote Linux amateur om te weten hoe ik dit moet oplossen. Gewoon in Plex de volledige locatie noteren werkt niet.


Maar dat is niet het enige probleem met deze migratie.
Deze pc moet volledig unattendend werken en Linux mount die drives niet automatisch waardoor de locatie onbereikbaar wordt na een herstart. De PC die gaat uit wanneer niet in gebruik.
Daarnaast moeten de mappen ook gedeeld worden zodat er een sync kan gebeuren (doel is immers dat er foto's, video's, muziek enz op geraakt).
Die mappen kan ik ook niet meer delen want ben geen eigenaar meer van de map



Update:
Ik heb inmiddels de optie gevonden om automatisch te mounten. Nu staat de folder die ik in Plex wil toevoegen onder /mnt/media/Music/
Maar het probleem van de rechten zijn hiermee niet opgelost. Navigeren via Plex naar /mnt/media/ geeft een lege map terwijl hier weldegelijk iets zit.

Hoe krijg ik die wel zichtbaar en hou ik de optie om die mappen ook te delen via het netwerk. Dat "moet" geen Samba share zijn, maar dat leek me het eenvoudigst (ftp is ook prima).

[Voor 37% gewijzigd door SMGGM op 30-12-2022 18:05]


  • DeTeraarist
  • Registratie: November 2000
  • Laatst online: 18:35

DeTeraarist

#Boots2Asses

De optie die jij gebruikt is inderdaad alleen bedoeld om persoonlijke mappen te delen.
Gelukkig is er smb.conf waar je je shares kunt configureren, met als bonus dat je veel meer opties hebt dan wat dit schermpje bied.

Soms, als ik heel stil ben, kan ik de zon horen schijnen


  • Thralas
  • Registratie: December 2002
  • Laatst online: 09:15
SMGGM schreef op vrijdag 30 december 2022 @ 17:40:
Maar het probleem van de rechten zijn hiermee niet opgelost. Navigeren via Plex naar /mnt/media/ geeft een lege map terwijl hier weldegelijk iets zit.
Ik heb wel een vermoeden. Controleer eens het filesystem type en de mount options door middel van het commando mount. Vermoedelijk gebruik je ntfs-3g, dat is een FUSE filesystem. Dat kent wat eigenaardigheden, namelijk dat het standaard z'n eigen permissiechecks doet buiten de reguliere linuxpermissies om.

Zie mount.fuse3(8) onder het kopje security:
No other user (including root) can access the contents of the mounted filesystem.
De oplossing is om het filesystem te mounten met de optie allow_other (zie elders in de man page).

  • SMGGM
  • Registratie: Januari 2006
  • Laatst online: 04-02 22:45
Resultaat van mount:
code:
1
/dev/sdb1 on /mnt/movies type ext4 (rw,nosuid,nodev,relatime,x-gvfs-show)


De rest van de comments snap ik niet. (sorry, Linux beginner hier...).
Ik werk op een test systeempje en moet alles wat er gedaan wordt opnieuw doen op het echte systeem. Als ik dus geen flauw benul heb van wat helpt en wat niet kan ik het niet herhalen op het feitelijk systeem.

  • Thralas
  • Registratie: December 2002
  • Laatst online: 09:15
SMGGM schreef op vrijdag 30 december 2022 @ 20:00:
Ik werk op een test systeempje en moet alles wat er gedaan wordt opnieuw doen op het echte systeem.
Dan zul je de output van mount op je 'echte' systeem moeten halen, want je testsysteem is op dit vlak blijkbaar niet representatief (ext4 mount terwijl je over ntfs spreekt in je TS).

  • SMGGM
  • Registratie: Januari 2006
  • Laatst online: 04-02 22:45
Het test systeem is identiek aan het werkelijke. Het is hier louter een andere SSD terwijl de W7 SSD ontkoppeld is.
De NTFS schijf met de media erop is geformatteerd zoals gevraagd in de eerste reactie naar ext4.

  • Hero of Time
  • Registratie: Oktober 2004
  • Laatst online: 19:20

Hero of Time

Moderator LNX

There is only one Legend

Je moet je wat meer inlezen in de rechtenstructuur van Linux en de file systems er van. Ik noemde eerder al het chown commando, dat zet de eigenaar en groep op mappen en bestanden. Daarnaast is er het chmod commando, iets wat je overigens niet nodig zou moeten hebben, dus als je iets ziet met 'chmod 777' sluit dan direct de pagina en zoek naar iets wat wél uitlegt hoe het zit en hoort.

Mounts worden opgegeven in /etc/fstab. Daarin staat welke schijf met welke opties en wat het filesystem zou moeten zijn op welke locatie te vinden is, zoals dus je /mnt/media. Wat trouwens ook gelijk duidelijk maakt wat er aan de hand is bij je. Je zegt dat Plex niets ziet in /mnt/media, maar de regel van het mount commando laat zien dat je wat op /mnt/movies hebt gekoppeld.

Zoals gezegd, je hebt heel veel om te lezen en leren. Je bent Windows gewend en dat doet zo'n beetje alles via een grafische interface. De zaken waar je nu mee te maken hebt gaan beter via een terminal, omdat je configuratiebestanden moet bewerken. Er zijn niet echt degelijke grafische tools hiervoor, anders dan een kladblok zeg maar.

Commandline FTW | Tweakt met mate


  • SMGGM
  • Registratie: Januari 2006
  • Laatst online: 04-02 22:45
Vermoedelijk onbedoeld maar vond je reactie de typische reactie waarom mensen Linux snel opgeven. Het komt voor mij over van "blijf er maar vanaf wat je hebt nog veel te leren" wat bijdraagt aan het imago dat Linux niet voor het gewoon volk is.

Soit heb het inmiddels kunnen oplossen.
Tussen de regels door heb ik hier dan kunnen vinden hoe je een mount automatisch kan laten doen:
https://www.techhut.tv/auto-mount-drives-in-linux-fstab/

Verder heeft dit artikel uitgelegd welke rechten ik moet toewijzen:
https://support.plex.tv/a...-linux-permissions-guide/
Belangrijkste van heel dit artikel is eigenlijk dit
A good practice in permissions for media is 755 for directories and 644 for media files.
Het enige wat moest gedaan worden is "chmod 755 directoryname" op de gemounte dir.

Nadien is de Windows Share eigenlijk eenvoudig om aan te maken (hier gebruik ik dan toch de GUI voor in Nautilus).

  • Hero of Time
  • Registratie: Oktober 2004
  • Laatst online: 19:20

Hero of Time

Moderator LNX

There is only one Legend

SMGGM schreef op zondag 1 januari 2023 @ 11:19:
Vermoedelijk onbedoeld maar vond je reactie de typische reactie waarom mensen Linux snel opgeven. Het komt voor mij over van "blijf er maar vanaf wat je hebt nog veel te leren" wat bijdraagt aan het imago dat Linux niet voor het gewoon volk is.
Mijn intentie was het tegenovergestelde: "Je hebt nog veel te leren, je gaat fouten maken, maar laat je dat niet tegenhouden."
Soit heb het inmiddels kunnen oplossen.
Tussen de regels door heb ik hier dan kunnen vinden hoe je een mount automatisch kan laten doen:
https://www.techhut.tv/auto-mount-drives-in-linux-fstab/

Verder heeft dit artikel uitgelegd welke rechten ik moet toewijzen:
https://support.plex.tv/a...-linux-permissions-guide/
Belangrijkste van heel dit artikel is eigenlijk dit

[...]

Het enige wat moest gedaan worden is "chmod 755 directoryname" op de gemounte dir.

Nadien is de Windows Share eigenlijk eenvoudig om aan te maken (hier gebruik ik dan toch de GUI voor in Nautilus).
Heel goed dat je de informatie hebt gevonden waar ik naar heb gehint. :) Als je chmod recursief gaat gebruiken, let dan wel goed op dat je niet per ongeluk bestanden uitvoerbaar maakt.

Commandline FTW | Tweakt met mate

Pagina: 1


Tweakers maakt gebruik van cookies

Tweakers plaatst functionele en analytische cookies voor het functioneren van de website en het verbeteren van de website-ervaring. Deze cookies zijn noodzakelijk. Om op Tweakers relevantere advertenties te tonen en om ingesloten content van derden te tonen (bijvoorbeeld video's), vragen we je toestemming. Via ingesloten content kunnen derde partijen diensten leveren en verbeteren, bezoekersstatistieken bijhouden, gepersonaliseerde content tonen, gerichte advertenties tonen en gebruikersprofielen opbouwen. Hiervoor worden apparaatgegevens, IP-adres, geolocatie en surfgedrag vastgelegd.

Meer informatie vind je in ons cookiebeleid.

Sluiten

Toestemming beheren

Hieronder kun je per doeleinde of partij toestemming geven of intrekken. Meer informatie vind je in ons cookiebeleid.

Functioneel en analytisch

Deze cookies zijn noodzakelijk voor het functioneren van de website en het verbeteren van de website-ervaring. Klik op het informatie-icoon voor meer informatie. Meer details

janee

    Relevantere advertenties

    Dit beperkt het aantal keer dat dezelfde advertentie getoond wordt (frequency capping) en maakt het mogelijk om binnen Tweakers contextuele advertenties te tonen op basis van pagina's die je hebt bezocht. Meer details

    Tweakers genereert een willekeurige unieke code als identifier. Deze data wordt niet gedeeld met adverteerders of andere derde partijen en je kunt niet buiten Tweakers gevolgd worden. Indien je bent ingelogd, wordt deze identifier gekoppeld aan je account. Indien je niet bent ingelogd, wordt deze identifier gekoppeld aan je sessie die maximaal 4 maanden actief blijft. Je kunt deze toestemming te allen tijde intrekken.

    Ingesloten content van derden

    Deze cookies kunnen door derde partijen geplaatst worden via ingesloten content. Klik op het informatie-icoon voor meer informatie over de verwerkingsdoeleinden. Meer details

    janee