Vraag


  • Skating_vince
  • Registratie: Augustus 2004
  • Niet online
Mijn vraag:

Al jaren heb ik een Synology NAS in mijn netwerk draaien. Deze gebruik ik voor van alles en nog wat en wordt gebruikt door allerlei devices.

Recent draaide er een package niet lekker op de NAS, waardoor deze ontzettend traag werd. De interface laadde langzaam en files streamen ging niet meer. Ook vanaf mijn Windows 10 pc bleef Explorer een lange tijd laden tot hij uiteindelijk de melding 'Windows cannot acces \\192.168.1.3\Photo_archive' gaf.

Het probleem met de package op de NAS uiteindelijk opgelost en de NAS draait inmiddels al zo'n twee weken weer naar behoren. Nu is de NAS eigenlijk overal weer goed benaderbaar, behalve dat mijn Windows PC nog steeds dezelfde melding blijft geven als ik de netwerk map wil openen. Ik kan de NAS vanaf deze PC wel pingen, ik kan de UI browsen en ik kan via de 'mediaserver' de NAS benaderen. Ook vanaf andere Windows 10 machines in het netwerk kan ik de NAS normaal gebruiken. Daarom vermoed ik dat mijn Windows 10 machine ergens iets gecached heeft of in ieder geval het probleem in die PC zit....

De vraag: wat kan ik doen om Windows de netwerkschijf weer goed te laten benaderen?

Relevante software en hardware die ik gebruik:

Synology DiskStation DS420+
Windows 10 Pro build 19045
Intel(R) Wi-Fi 6 AX200 160Mhz netwerkadapter
Unifi USG met Unifi componenten

Wat ik al gevonden of geprobeerd heb:

NAS, Router, PC opnieuw opstarten
SMB service NAS opnieuw opstarten
SMB cache legen op NAS
Benaderen via hostname
Network resets op Windows 10 machine:
(ipconfig /flushdns
netsh int ipv4 reset
netsh int ipv6 reset
netsh winsock reset
nbtstat -R
nbtstat -RR
)
Ik zie niks in de SMB log van de NAS
Windows Diagnose geeft niks
Credentials en pad zijn correct
Virusscanner/firewall uitzetten op zowel NAS als Windows PC

Wireshark trace tijdens het proberen te openen van de netwerk map geeft het volgende (192.168.1.3 is de NAS - die gek genoeg alleen voorkomt in de source..):



Op zowel de Windows 10 machine, de router en de NAS zijn geen instellingen gewijzigd of updates gedaan op het moment dat de problemen begonnen.

Iemand enig idee wat ik nog kan proberen?

[Voor 13% gewijzigd door Skating_vince op 21-12-2022 11:27]

Alle reacties


  • lier
  • Registratie: Januari 2004
  • Laatst online: 23:51

lier

MikroTik nerd

Welke SMB versie draai je op je NAS?

Eerst het probleem, dan de oplossing


  • Skating_vince
  • Registratie: Augustus 2004
  • Niet online
lier schreef op woensdag 21 december 2022 @ 10:59:
Welke SMB versie draai je op je NAS?
Het SMB bereik is SMB2, SMB2 en large MTU, SMB3

  • lier
  • Registratie: Januari 2004
  • Laatst online: 23:51

lier

MikroTik nerd

Krijg je een folder structuur te zien als je in explorer \\192.168.1.3 gebruikt?
Is het jouw pc of is deze van je werkgever (mijn werkgever heeft met policies "voorkomen" dat je naar een NAS kan vanuit explorer)?

Eerst het probleem, dan de oplossing


  • Skating_vince
  • Registratie: Augustus 2004
  • Niet online
lier schreef op woensdag 21 december 2022 @ 11:23:
Krijg je een folder structuur te zien als je in explorer \\192.168.1.3 gebruikt?
Is het jouw pc of is deze van je werkgever (mijn werkgever heeft met policies "voorkomen" dat je naar een NAS kan vanuit explorer)?
Op dit moment krijg ik niks te zien als ik de NAS vanuit de explorer probeer te benaderen. Zowel \\192.168.1.3 als \\HostNameHere geeft dezelfde melding dat hij niet bereikt kan worden.

De PC is van mij en heeft tot het traag draaiende Docker package altijd goed gewerkt. Zover ik weet heb ik geen policies veranderd op dat moment.

  • lier
  • Registratie: Januari 2004
  • Laatst online: 23:51

lier

MikroTik nerd

Zegt het eventlog nog iets relevants?

Eerst het probleem, dan de oplossing


  • Skating_vince
  • Registratie: Augustus 2004
  • Niet online
lier schreef op woensdag 21 december 2022 @ 11:30:
Zegt het eventlog nog iets relevants?
Hmm, goede. Daar had ik nog niet gekeken, maar zie ik wel veel meldingen:



Die hoek ga ik even onderzoeken. Als zou DNS weer niks met rechtstreeks op IP browsen te maken moeten hebben, maar je weet nooit!

Update: DNS Cache uitgezet, na reboot komt de fout niet meer terug in de eventlog, maar het probleem bestaat helaas ook nog steeds...

[Voor 8% gewijzigd door Skating_vince op 21-12-2022 12:06]


  • Kabouterplop01
  • Registratie: Maart 2002
  • Laatst online: 23-01 08:52

Kabouterplop01

chown -R me base:all

En als je in je browser naar 192.168.1.3:5000 browst?

  • Skating_vince
  • Registratie: Augustus 2004
  • Niet online
Kabouterplop01 schreef op woensdag 21 december 2022 @ 22:03:
En als je in je browser naar 192.168.1.3:5000 browst?
Dat werkt prima, ook op hostname (zie OP). Het enige wat niet werkt is via de Windows explorer, dus ik denk dat het ergens in de SMB stack zit (volgens mij wordt CIFS in dit geval niet gebruikt).

  • Kabouterplop01
  • Registratie: Maart 2002
  • Laatst online: 23-01 08:52

Kabouterplop01

chown -R me base:all

dus als je een netwerkdrive mapt á la:

net use X: \\192.168.1.3\Photo_archive /persistent:yes

Dan werkt dat ook niet?

[Voor 2% gewijzigd door Kabouterplop01 op 21-12-2022 22:21. Reden: slashes verkeerde kant op]


  • Skating_vince
  • Registratie: Augustus 2004
  • Niet online
Kabouterplop01 schreef op woensdag 21 december 2022 @ 22:19:
dus als je een netwerkdrive mapt á la:

net use X: \\192.168.1.3\Photo_archive /persistent:yes

Dan werkt dat ook niet?
Nope, dan krijg ik na een tijdje de melding:

System error 67 has occurred.

The network name cannot be found.

Dat lijkt toch iets te maken te hebben met het DNS probleem van eerder of iets in de router (al lijkt dat me sterk, omdat de rest van het netwerk hem prima kan bereiken). Morgen ga ik daar eens wat verder induiken.

  • Kabouterplop01
  • Registratie: Maart 2002
  • Laatst online: 23-01 08:52

Kabouterplop01

chown -R me base:all

nee is geen DNS, er wordt in de net use command geen enkele name resolution gebruikt.

Als je je Nas kunt pingen op zowel naam als ip adres kun je er van uit gaan dat je DNS goed staat.
Binnen een lan wordt nooit DNS gebruikt.

Windows gebruikt tegenwoordig Ws-Discovery om devices in het Lan te vinden.
Dus controleer of je dat in je Nas hebt aangezet.

Toen smb1 ofwel Cifs nog werd gebruikt werd dat met netbios gedaan, maar Window heeft tegenwoordig smb 1 uitgeschakeld.

All truth passes through three stages: First it is ridiculed, second it is violently opposed and third it is accepted as being self-evident.


  • Skating_vince
  • Registratie: Augustus 2004
  • Niet online
Ben(V) schreef op woensdag 21 december 2022 @ 23:43:
Binnen een lan wordt nooit DNS gebruikt.

Windows gebruikt tegenwoordig Ws-Discovery om devices in het Lan te vinden.
Dus controleer of je dat in je Nas hebt aangezet.

Toen smb1 ofwel Cifs nog werd gebruikt werd dat met netbios gedaan, maar Window heeft tegenwoordig smb 1 uitgeschakeld.
Ws-Discovery staat aan op de NAS. Ik vermoed echt dat het iets in mijn PC is, aangezien andere PCs prima kunnen verbinden met de NAS.
Heb je de PC soms een fixed ipadres gegeven en niet via dhcp?
Als dat zo is moet je waarschijnlijk de netbios over tcp ook met de hand aanzetten.

Of beter een vast ipadres door de dhcp server van je router laten uitdelen.

Die wireshark trace filter je op het ipadres van je Nas dus dat zie je alleen en de Nas antwoordt en dat doet hij met een broadcast (192.168.1.255 is het broadcast adres van je subnet)
Het kan dus ook zijn dat er ergens die broadcast tegengehouden worden(soms ergens een router of switch met een broadcast storm filter?)

All truth passes through three stages: First it is ridiculed, second it is violently opposed and third it is accepted as being self-evident.


  • W1ck1e
  • Registratie: Februari 2008
  • Laatst online: 22:14
Ben(V) schreef op woensdag 21 december 2022 @ 23:43:
Binnen een lan wordt nooit DNS gebruikt. ...
??
mijn pihole is mijn dns server
mijn devices benader ik op naam
ik zie dat mijn pihole wordt gebruikt als dns server
ook vanaf windows apparaten
DNS wordt normaal gesproken gebruikt voor name resolving op het internet.
Uiteraard kun je hem ook gebruiken voor name resolving binnen je Lan maar dan moet je de devices op volledige naam benaderen.

Als je gewoon een ipadres of een hostname wilt gebruiken of gewoon wilt browsen met de explorer zal Windows niet de DNS server gebruiken.

All truth passes through three stages: First it is ridiculed, second it is violently opposed and third it is accepted as being self-evident.


  • Skating_vince
  • Registratie: Augustus 2004
  • Niet online
Inmiddels wat tijd verder en helaas nog geen oplossing. Ik heb nog een heleboel extra dingen geprobeerd, maar nog niets heeft geholpen.

Netwerkadapter opnieuw geinstalleerd
Andere ethernet aansluiting geprobeerd
Via Wi-Fi geprobeerd
IPv6 uitgezet
Hostname NAS gewijzigd
IP NAS gewijzigd
Hostname PC gewijzigd

De backups van mijn onderneming worden nu niet gemaakt en het is ook onhandig voor allerlei andere dingen, dus ik hoop dat iemand het magische antwoord heeft.

Wel zie ik Wireshark nu nieuwe dingen tevoorschijn komen. Iemand daarover nog een goed idee?
Vooral de regels met ERR_ACCESS vind ik verdacht.... Ik word er alleen niet direct wijs uit.



Voor de zekerheid ook een plaatje van de melding die ik krijg (alles uit de TS geldt nog steeds, dus browser, ping, FTP - alles werkt verder vanaf dezelfde machine en vanaf andere machines werkt SMB ook prima):

[Voor 17% gewijzigd door Skating_vince op 09-01-2023 21:14]


  • HMaster_II
  • Registratie: December 2015
  • Laatst online: 15:40
https://thegeekpage.com/error-code-0x80070043-windows-cannot-access/

Dit al bekeken?


En DNS gebruik je ook gewoon binnen je eigen netwerk. Puur voor nameresolving van je pc's en servers. Dus die opmerking hier verder boven moet je gewoon negeren.

The S in IOT stands for security.

DNS binnen je eigen lan wordt alleen gebruikt als je een eigen DNS server opzet en anders echt helemaal niet.
En als TS een DNS server in z'n lan had draaien dan had hij dat wel vermeld.
En DNS is een vertaler van hostnamen naar ipadresse en als hij een lokale DNS server zou hebben en daar het probleem zat, dan zou bij gebruik van het ipadres helt probleem niet optreden.

Dus deze opmerking van @HMaster_II kun je beter gewoon negeren.

Heb je de firewall van de Nas gecontroleerd ( en misschien van Windows ook)..
Want in je wire shark zie ik dat hij wel communiceert met 192.168.1.3 maar dat een mount mislukt.
Hij kan die Nas dus wel vinden, maar mag geen share mounten, meestal is dat een firewall issue.

All truth passes through three stages: First it is ridiculed, second it is violently opposed and third it is accepted as being self-evident.


  • Mijzelf
  • Registratie: September 2004
  • Niet online
Ben(V) schreef op dinsdag 10 januari 2023 @ 09:58:
DNS binnen je eigen lan wordt alleen gebruikt als je een eigen DNS server opzet en anders echt helemaal niet.
Iedere consumenten router die dnsmasq gebruikt als gecombineerde DHCP server en DNS relay (en dat zijn er veel) doet dat.
Bijna geen enkele consumenten router gebruikt dnsmasq en zeker de routers van de providers niet.

All truth passes through three stages: First it is ridiculed, second it is violently opposed and third it is accepted as being self-evident.


  • Skating_vince
  • Registratie: Augustus 2004
  • Niet online
HMaster_II schreef op dinsdag 10 januari 2023 @ 09:21:
https://thegeekpage.com/error-code-0x80070043-windows-cannot-access/

Dit al bekeken?


En DNS gebruik je ook gewoon binnen je eigen netwerk. Puur voor nameresolving van je pc's en servers. Dus die opmerking hier verder boven moet je gewoon negeren.
Bedankt voor de link! De meeste dingen heb ik al geprobeerd, maar ik zal de andere zaken uitproberen. Mijn installatie volledig herstellen doe ik liever niet ;).

De DNS Cache service start na de foutmelding gewoon op, dus ik denk dat daar het probleem inderdaad niet zit. Binnen het netwerk wordt volgens mij Netbios gebruikt. Maar deze discussie lost helaas mijn probleem niet op ;).

Iemand een idee waar die ERR_ACCESS vandaan kan komen?

  • nelizmastr
  • Registratie: Maart 2010
  • Laatst online: 21:51

nelizmastr

Goed wies kapot

Die err-access komt doordat je de share photo_archive probeert te mounten middels smbv3 en dat niet lukt. Nee dat helpt je inderdaad niet verder.

Wat is mis in de reacties is of er een andere PC aanwezig of te testen is met deze NAS.
Check ook of in de Synology misschien de firewall aan staat en iets met SMB klooit (TCP 445).

I reject your reality and substitute my own


  • Mijzelf
  • Registratie: September 2004
  • Niet online
Ben(V) schreef op dinsdag 10 januari 2023 @ 10:10:
Bijna geen enkele consumenten router gebruikt dnsmasq en zeker de routers van de providers niet.
Grappig dat je dat zo zegt. Heb je inside informatie die ik niet heb? De provider routers die ik ken zijn dusdanig dichtgetimmerd dat je niet kan zien wat er in draait, maar soms kun je via de seriele poort een shell krijgen. Daarvan heb ik er twee bekeken, een ZyXEL P2812-HNU, zoals Telfort die leverde bij hun xDSL abonnementen. Die draaide dnsmasq. Verder een ExperiaBox v8, wat een rebranded Astoria networks VGV7519 is, en die draait ook dnsmasq. De echt dichtgetimmerde zijn lastiger. Hier vind je het verslag van iemand die de nand chips van een ZTE H368N (Experiabox v9) heeft losgesoldeerd en uitgelezen. De inhoud van het squashfs vind je in post #5, en ook die bevat dnsmasq.
En waarom ook niet? Je hebt een DHCP server nodig, en een DNS relay voelt sneller dan een upstream DNS server. Dnsmasq voldoet prima, is stabiel, vrij, en redelijk zuinig met resources. De licentie is een beetje akelig, GPL 2 of 3, dus je zou eigenlijk op verzoek de broncode moeten leveren, maar goed, als je daar schijt aan hebt en sowieso de broncode van de aangepaste Linuxkernel niet meelevert, met als smoes dat je de router in bruikleen hebt en dus geen recht op de GPL sources, is dat ook al geen issue.

  • rens-br
  • Registratie: December 2009
  • Laatst online: 23:56

rens-br

Admin IN & Moderator Mobile
@Mijzelf nuttige informatie en leesstof, maar een beetje offtopic voor @Skating_vince. Graag vanaf nu weer ontopic. :)
Skating_vince schreef op dinsdag 10 januari 2023 @ 10:41:
[...]


Bedankt voor de link! De meeste dingen heb ik al geprobeerd, maar ik zal de andere zaken uitproberen. Mijn installatie volledig herstellen doe ik liever niet ;).

De DNS Cache service start na de foutmelding gewoon op, dus ik denk dat daar het probleem inderdaad niet zit. Binnen het netwerk wordt volgens mij Netbios gebruikt. Maar deze discussie lost helaas mijn probleem niet op ;).

Iemand een idee waar die ERR_ACCESS vandaan kan komen?
Heb je zoals ik al had gezegd de Nas en Windows firewall gecheckt?

En heb je de (Nas)gebruiker waarmee je vanaf je PC probeert de Nas te benaderen rechten gegeven om smb te gebruiken(control panel applications) en heeft die gebruiker rechten op de shared folder die je probeert te mounten?

All truth passes through three stages: First it is ridiculed, second it is violently opposed and third it is accepted as being self-evident.


  • Skating_vince
  • Registratie: Augustus 2004
  • Niet online
nelizmastr schreef op dinsdag 10 januari 2023 @ 21:41:
Die err-access komt doordat je de share photo_archive probeert te mounten middels smbv3 en dat niet lukt. Nee dat helpt je inderdaad niet verder.

Wat is mis in de reacties is of er een andere PC aanwezig of te testen is met deze NAS.
Check ook of in de Synology misschien de firewall aan staat en iets met SMB klooit (TCP 445).
Staat in de TS, vanaf andere Windows 10 en 11 PCs gaat het prima (zelfde mappen, zelfde gebruiker). Firewall van Syno zelfs tijdelijk uitgezet.
Ben(V) schreef op woensdag 11 januari 2023 @ 10:47:
[...]


Heb je zoals ik al had gezegd de Nas en Windows firewall gecheckt?

En heb je de (Nas)gebruiker waarmee je vanaf je PC probeert de Nas te benaderen rechten gegeven om smb te gebruiken(control panel applications) en heeft die gebruiker rechten op de shared folder die je probeert te mounten?
Zeker. Alle firewalls op de PC en de NAS ook tijdelijk uitgezet, maar geen verschil.

Ik gebruik vanaf alle andere Windows PCs in het netwerk dezelfde gebruiker en vanaf die machines gaat het prima. Het is alleen mijn PC die een tijdje timeouts heeft gekregen toen de NAS te druk was en die daarin is blijven hangen....

Zou het ergens in mijn router (Unifi USG) vast kunnen lopen? Of zou dat niet kunnen, omdat je in de Wireshark traces ziet dat 192.168.1.3 (de NAS) en .83 (mijn PC) communiceren? Lijkt me dat het verkeer dan niet in de router wordt tegengehouden.

[Voor 36% gewijzigd door Skating_vince op 11-01-2023 11:08. Reden: Extra quote.]

Nee lokaal verkeer doet niets met de router.
In de wireshark dump zie je dat hij wel communiceert met je Nas maar dat op het moment dat hij probeert de share te mounten.

Maar ik zie dat je PC probeert port 892 te gebruiken en dat is een nfs poort.
De smb poort is 445.
Heb je nfs soms op je PC aanstaan en probeert hij daarmee de share te mounten?

All truth passes through three stages: First it is ridiculed, second it is violently opposed and third it is accepted as being self-evident.


  • deHakkelaar
  • Registratie: Februari 2015
  • Laatst online: 27-01 01:04
Ben(V) schreef op dinsdag 10 januari 2023 @ 09:58:
DNS binnen je eigen lan wordt alleen gebruikt als je een eigen DNS server opzet en anders echt helemaal niet.
Ben(V) schreef op dinsdag 10 januari 2023 @ 10:10:
Bijna geen enkele consumenten router gebruikt dnsmasq en zeker de routers van de providers niet.
Mijzelf schreef op dinsdag 10 januari 2023 @ 22:23:
Daarvan heb ik er twee bekeken, een ZyXEL P2812-HNU, zoals Telfort die leverde bij hun xDSL abonnementen. Die draaide dnsmasq. Verder een ExperiaBox v8, wat een rebranded Astoria networks VGV7519 is, en die draait ook dnsmasq. De echt dichtgetimmerde zijn lastiger. Hier vind je het verslag van iemand die de nand chips van een ZTE H368N (Experiabox v9) heeft losgesoldeerd en uitgelezen. De inhoud van het squashfs vind je in post #5, en ook die bevat dnsmasq.
Hier is er nog een voor het lijstje:
deHakkelaar in "Netwerk splitsen voor o.a. Home Assistant"

En hier hoe oa dnsmasq werkt met het opvoeren van DNS records voor client hostnamen die worden geadverteerd via DHCP:
deHakkelaar in "Hulp gevraagd met netwerk probleempje op een Pi"

Tjemig wat eigenwijs!

There are only 10 types of people in the world: those who understand binary, and those who don't


  • Skating_vince
  • Registratie: Augustus 2004
  • Niet online
Ben(V) schreef op woensdag 11 januari 2023 @ 13:26:
Nee lokaal verkeer doet niets met de router.
In de wireshark dump zie je dat hij wel communiceert met je Nas maar dat op het moment dat hij probeert de share te mounten.

Maar ik zie dat je PC probeert port 892 te gebruiken en dat is een nfs poort.
De smb poort is 445.
Heb je nfs soms op je PC aanstaan en poort hij daarmee de share te mounten?
Bedankt voor je reactie. Ik had inderdaad NFS geïnstalleerd om te kijken of dat een alternatief was, maar uiteindelijk niet gebruikt. Ik heb het weer uitgezet en zal een nieuwe wireshark trace maken.

Wel ontdekt dat het echt aan mijn PC ligt: hij kan andere SMB shares op andere machines ook niet bereiken - die prima te bereiken zijn vanaf de rest van het netwerk.

Inmiddels ook ontdekt dat het aan de Windows implementatie ligt, want met een alternatieve SMB client op dezelfde PC (http://www.mucommander.com) kan ik de SMB shares wel prima bereiken! Dat betekent dat ik het netwerk verder wel kan uitsluiten. Er zit echt iets niet goed in de SMB instellingen/software op mijn PC.

Iemand enig idee wat ik daar nog mee kan doen?
Pagina: 1


Tweakers maakt gebruik van cookies

Tweakers plaatst functionele en analytische cookies voor het functioneren van de website en het verbeteren van de website-ervaring. Deze cookies zijn noodzakelijk. Om op Tweakers relevantere advertenties te tonen en om ingesloten content van derden te tonen (bijvoorbeeld video's), vragen we je toestemming. Via ingesloten content kunnen derde partijen diensten leveren en verbeteren, bezoekersstatistieken bijhouden, gepersonaliseerde content tonen, gerichte advertenties tonen en gebruikersprofielen opbouwen. Hiervoor worden apparaatgegevens, IP-adres, geolocatie en surfgedrag vastgelegd.

Meer informatie vind je in ons cookiebeleid.

Sluiten

Toestemming beheren

Hieronder kun je per doeleinde of partij toestemming geven of intrekken. Meer informatie vind je in ons cookiebeleid.

Functioneel en analytisch

Deze cookies zijn noodzakelijk voor het functioneren van de website en het verbeteren van de website-ervaring. Klik op het informatie-icoon voor meer informatie. Meer details

janee

    Relevantere advertenties

    Dit beperkt het aantal keer dat dezelfde advertentie getoond wordt (frequency capping) en maakt het mogelijk om binnen Tweakers contextuele advertenties te tonen op basis van pagina's die je hebt bezocht. Meer details

    Tweakers genereert een willekeurige unieke code als identifier. Deze data wordt niet gedeeld met adverteerders of andere derde partijen en je kunt niet buiten Tweakers gevolgd worden. Indien je bent ingelogd, wordt deze identifier gekoppeld aan je account. Indien je niet bent ingelogd, wordt deze identifier gekoppeld aan je sessie die maximaal 4 maanden actief blijft. Je kunt deze toestemming te allen tijde intrekken.

    Ingesloten content van derden

    Deze cookies kunnen door derde partijen geplaatst worden via ingesloten content. Klik op het informatie-icoon voor meer informatie over de verwerkingsdoeleinden. Meer details

    janee