• tK0wnZ
  • Registratie: December 2003
  • Laatst online: 08:37
Recent ben ik overgestapt van KPN glasvezel (1gbit) naar Solcon glasvezel (500mbit) en waar ik voorheen een upload had van ongeveer 900mbit, haal ik nu slechts 200/250 mbit.

De oorzaak zit hem in de combinatie van mijn Zyxel XS1930 en de nieuwe router van Solcon, een FRITZ!Box 7530. Zonder mijn Zyxel ertussen (maar wel op hetzelfde poortje op de Fritz box) haal ik de normale upload snelheid van 500mbit, maar met de Zyxel ertussen dus niet. Terwijl met de router van KPN ik hier geen problemen mee had.

Heb al een factory reset gedaan van de switch en router, maar dat helpt helaas niet.
Omdat het een managed switch betreft zijn er redelijk wat opties in te stellen, maar de meeste staan gewoon standaard uit en heb geen idee welke ik aan zou moeten zetten om dit probleem op te lossen.

-edit

Zojuist een test gedaan door mijn PC aan te sluiten op de Fritz!box, en iets op te halen van mijn NAS die op de Zyxel zit. Van NAS > PC = 125mbit, van PC > NAS = 1gbit. (wanneer beide op de Zyxel zitten haal ik 5gbit beide kanten op)

[Voor 13% gewijzigd door tK0wnZ op 11-12-2022 14:54]


  • chrisborst
  • Registratie: April 2004
  • Laatst online: 06-02 21:38
@tK0wnZ Misschien een gekke vraag, maar waarom heb je een switch van 500 euro? Blijkbaar weet je er te weinig vanaf om hem goed in te stellen en hij verbruikt 44 watt.
Is het niet verstandiger om dat ding te verkopen en gewoon een simpele "domme" switch te kopen?

  • tK0wnZ
  • Registratie: December 2003
  • Laatst online: 08:37
chrisborst schreef op zondag 11 december 2022 @ 11:16:
@tK0wnZ Misschien een gekke vraag, maar waarom heb je een switch van 500 euro? Blijkbaar weet je er te weinig vanaf om hem goed in te stellen en hij verbruikt 44 watt.
Is het niet verstandiger om dat ding te verkopen en gewoon een simpele "domme" switch te kopen?
Alle routers die 8 10gbit poorten hebben zijn duur, en destijds was dit de beste keus.

Daarnaast, ik ben wel redelijk bekend met netwerken, maar omdat de meeste managed opties uit staan, vraag ik mij dus af wat het dan kan zijn.

  • Thralas
  • Registratie: December 2002
  • Laatst online: 09:15
tK0wnZ schreef op zondag 11 december 2022 @ 11:09:
Zojuist een test gedaan door mijn PC aan te sluiten op de Fritz!box, en iets op te halen van mijn NAS die op de Zyxel zit. Van NAS > PC = 125mbit, van PC > NAS = 1gbit. (wanneer beide op de Zyxel zitten haal ik 5gbit beide kanten op)
Uit je tekst valt af te leiden dat je NAS en PC een 10G interface hebben, en je Zyxel een 1G uplink naar de Fritzbox. Dat laatste is je probleem.

In het beschreven scenario (NAS > PC) ga je van 10G naar 1G in de Zyxel. Dat soort link rate conversies zijn verre van triviaal, Google maar eens op packet buffer sizes en 10G switches. Goedkope switches (zoals de Zyxel) leveren vaak problemen op. Forceer alle link rates maar eens naar 1G en je probleem is als sneeuw voor de zon verdwenen.
Omdat het een managed switch betreft zijn er redelijk wat opties in te stellen, maar de meeste staan gewoon standaard uit en heb geen idee welke ik aan zou moeten zetten om dit probleem op te lossen.
Je kunt flow control proberen aan te zetten op de desbetreffende poorten.

De link rate naar 1G forceren werkt natuurlijk ook. Ik vrees dat 10G je meer problemen oplevert dan de snelheidswinst die je denkt nodig te hebben ;)

Dan rest nog de vraag waarom je dit problem eerder niet had. Dat kan ik niet verklaren, want de beperkende factor zou toch vooral in de (buffers van de) Zyxel moeten zitten.

  • tK0wnZ
  • Registratie: December 2003
  • Laatst online: 08:37
@Thralas Zojuist geprobeerd de poort van mijn PC (p6) en die richting de router (p8) vast gezet op 1gbit, maar ook dan blijft het probleem bestaan. Ongeacht of flow control aanslaat of niet.

Het klopt wat je zegt, mijn NAS en PC hebben beide een 10gbit aansluiting en zitten daarom standaard ook beide op de Zyxel, die via poort 8 naar de router loopt. Met de router van KPN die ik hiervoor had (Experia Box V10A) had ik dit issue niet (die was ook via poort 8 aangesloten), en die heeft ook maar 1gbit netwerkpoorten.


  • Thralas
  • Registratie: December 2002
  • Laatst online: 09:15
tK0wnZ schreef op zondag 11 december 2022 @ 16:55:
@Thralas Zojuist geprobeerd de poort van mijn PC (p6) en die richting de router (p8) vast gezet op 1gbit, maar ook dan blijft het probleem bestaan. Ongeacht of flow control aanslaat of niet.
Je vergeet de NAS in bovenstaand screenshot. Daar heb je nog steeds een 10 Gb/s-poort in het pad (sterker nog, dat is de enige die echt uitmaakt).

Ofwel (voor de zekerheid): zowel PC, NAS als uplink op 1 Gb/s en nogmaals testen, daarna 10 Gb/s met flow control aan en weer testen.

  • tK0wnZ
  • Registratie: December 2003
  • Laatst online: 08:37
Thralas schreef op zondag 11 december 2022 @ 19:47:
[...]


Je vergeet de NAS in bovenstaand screenshot. Daar heb je nog steeds een 10 Gb/s-poort in het pad (sterker nog, dat is de enige die echt uitmaakt).

Ofwel (voor de zekerheid): zowel PC, NAS als uplink op 1 Gb/s en nogmaals testen, daarna 10 Gb/s met flow control aan en weer testen.
Klopt die heb ik ook getest (zie hieronder) met hetzelfde resultaat. Alle overige poorten staan uit.
De internet download snelheid is daarnaast met deze configuratie (zoals afbeelding) ook 100mbit lager (550 auto vs. 420 op 1gbit). Met deze 3 poorten op Auto en Flow control aan is er geen verschil t.o.v. flow control uit.


  • Tortelli
  • Registratie: Juli 2004
  • Laatst online: 05-02 18:00

Tortelli

mixing gas and haulin ass

Thralas schreef op zondag 11 december 2022 @ 16:24:
[...]


Uit je tekst valt af te leiden dat je NAS en PC een 10G interface hebben, en je Zyxel een 1G uplink naar de Fritzbox. Dat laatste is je probleem.

In het beschreven scenario (NAS > PC) ga je van 10G naar 1G in de Zyxel. Dat soort link rate conversies zijn verre van triviaal, Google maar eens op packet buffer sizes en 10G switches. Goedkope switches (zoals de Zyxel) leveren vaak problemen op. Forceer alle link rates maar eens naar 1G en je probleem is als sneeuw voor de zon verdwenen.


[...]


Je kunt flow control proberen aan te zetten op de desbetreffende poorten.

De link rate naar 1G forceren werkt natuurlijk ook. Ik vrees dat 10G je meer problemen oplevert dan de snelheidswinst die je denkt nodig te hebben ;)

Dan rest nog de vraag waarom je dit problem eerder niet had. Dat kan ik niet verklaren, want de beperkende factor zou toch vooral in de (buffers van de) Zyxel moeten zitten.
Ik heb dezelfde Zyxel XS1930 in gebruik in een unifi netwerk met de volgende hardware:
uitvoering: Ubiquiti Unifi Security Gateway (USG)
uitvoering: Ubiquiti UniFi Switch Gen 2 (24-poorts 95W PoE+)
uitvoering: ZyXEL XS1930-10


USG zit aan de 24 poorts switch. Die zit met 2xGbit (SFP) aangesloten op de Zyxel. Haal netjes 930Mbit up en download op mijn PC / NAS.

22x330Wp Oost-Zuid-West, 24x360Wp Oost-West, Total 15.900Wp


  • ElCondor
  • Registratie: Juni 2001
  • Laatst online: 12:43

ElCondor

Geluk is Onmisbaar

Als je dan ook even aangeeft hoe je dit in de Zyxel hebt ingesteld, dan heeft TS er ook nog iets aan :)

Hay 365 dias en un año y 366 occasiones para festejar (Boliviaans spreekwoord)


  • Thralas
  • Registratie: December 2002
  • Laatst online: 09:15
Gezien het forceren naar 1 Gbit/s niet helpt ligt het probleem blijkbaar toch ergens anders.

TS kan het beste met iperf aan de slag, om eventuele invloed van software/protocollen zo goed als mogelijk uit te sluiten. En dan testen over het LAN, aangezien het probleem daar blijkbaar ook speelt en een stap naar het internet nog véél meer variabelen introduceert.

iperf op de PC, iperf op de NAS (of een andere PC) en testen maar (ook in reverse mode). Met rate conversions in je netwerkpad kan er dan nog vanalles misgaan (zoals eerder beschreven), maar met alles naar gigabit geforceerd is er echt iets heel vreemds aan de hand als je dan geen volledige gigabit haalt.
Pagina: 1


Tweakers maakt gebruik van cookies

Tweakers plaatst functionele en analytische cookies voor het functioneren van de website en het verbeteren van de website-ervaring. Deze cookies zijn noodzakelijk. Om op Tweakers relevantere advertenties te tonen en om ingesloten content van derden te tonen (bijvoorbeeld video's), vragen we je toestemming. Via ingesloten content kunnen derde partijen diensten leveren en verbeteren, bezoekersstatistieken bijhouden, gepersonaliseerde content tonen, gerichte advertenties tonen en gebruikersprofielen opbouwen. Hiervoor worden apparaatgegevens, IP-adres, geolocatie en surfgedrag vastgelegd.

Meer informatie vind je in ons cookiebeleid.

Sluiten

Toestemming beheren

Hieronder kun je per doeleinde of partij toestemming geven of intrekken. Meer informatie vind je in ons cookiebeleid.

Functioneel en analytisch

Deze cookies zijn noodzakelijk voor het functioneren van de website en het verbeteren van de website-ervaring. Klik op het informatie-icoon voor meer informatie. Meer details

janee

    Relevantere advertenties

    Dit beperkt het aantal keer dat dezelfde advertentie getoond wordt (frequency capping) en maakt het mogelijk om binnen Tweakers contextuele advertenties te tonen op basis van pagina's die je hebt bezocht. Meer details

    Tweakers genereert een willekeurige unieke code als identifier. Deze data wordt niet gedeeld met adverteerders of andere derde partijen en je kunt niet buiten Tweakers gevolgd worden. Indien je bent ingelogd, wordt deze identifier gekoppeld aan je account. Indien je niet bent ingelogd, wordt deze identifier gekoppeld aan je sessie die maximaal 4 maanden actief blijft. Je kunt deze toestemming te allen tijde intrekken.

    Ingesloten content van derden

    Deze cookies kunnen door derde partijen geplaatst worden via ingesloten content. Klik op het informatie-icoon voor meer informatie over de verwerkingsdoeleinden. Meer details

    janee