Toon posts:

Excel , zoeken in kolom datum en vergelijk ander kolom

Pagina: 1
Acties:

Vraag


  • pascalbianca
  • Registratie: December 2021
  • Laatst online: 01-01-2022
Mijn vraag
Ik heb in kolom A allemaal datums staan van het jaar 2021.
In kolom B heb ik bv staan terecht, onterecht, of in behandeling.
Nu zou ik graag willen dat hij dus in Kolom A kijkt wat allemaal in Januari valt en mij alles van terecht, onterecht, of in behandeling optelt.
Zodanig dat dit ook werkt als het 2022 is en meer of minder datums heeft.

Relevante software en hardware die ik gebruik
Excel

Wat ik al gevonden of geprobeerd heb
Ik kom niet verder als dat ik de cellen zelf selecteert die hij moet optellen.: =AANTAL.ALS($A$1:$A$10;"Justified")
Hier zijn het 10 cellen waarvan de datum in maand januari vallen van 2021, maar 2022 kan ook bv 22 cellen, dit is namelijk nog onbekend.
Wil eigenlijk dat het formulier neutraler word en de formule niet hoeft aangepast te worden steeds.
Weet niet of dit eigenlijk wel mogelijk is.

Beste antwoord (via pascalbianca op 29-12-2021 16:12)


  • DappereDodo
  • Registratie: Juni 2001
  • Laatst online: 08:08
Het makkelijkst is om een hulpkolom toevoegen waarin je jaar+maand in zet (=JAAR(A1)*100+MAAND(A1)). Als je dat in bv. kolom C zet dan wordt de formule iets als:
=AANTALLEN.ALS($A:$A;"Justified";$C:$C;202101)

Syntax moet je ff checken, doe het uit m'n hoofd.

Alle reacties


Acties:
  • Beste antwoord
  • +1Henk 'm!

  • DappereDodo
  • Registratie: Juni 2001
  • Laatst online: 08:08
Het makkelijkst is om een hulpkolom toevoegen waarin je jaar+maand in zet (=JAAR(A1)*100+MAAND(A1)). Als je dat in bv. kolom C zet dan wordt de formule iets als:
=AANTALLEN.ALS($A:$A;"Justified";$C:$C;202101)

Syntax moet je ff checken, doe het uit m'n hoofd.

  • indexample
  • Registratie: April 2002
  • Niet online
Typische case voor een draaitabel / pivot table

  • dix-neuf
  • Registratie: Juli 2018
  • Niet online
[pascalbianca] ,
Een draaitabel is hier inderdaad zeer geschikt voor.
Wil je die niet gebruiken, dan kan het bv. met AANTALLEN.ALS
Selecteren moet je niets, wel moet je in je formule het bereik opgeven.
De formule die jij gebruikte: =AANTAL.ALS($A$1:$A$10;"Justified") kijkt naar de aantallen "Justified" in kolom A, maar "Justified" staat (wel of niet) in kolom B !
Het kan bv. als volgt om het aantal "Justified" te tellen in het jaar 2021:
code:
1
=AANTALLEN.ALS(B1:B100;"Justified";A1:A100;">31-12-2020";A1:A100;"<01-01-2022")

Ook mogelijk, maar in te voeren via Ctrl-Shift-Enter:
code:
1
=AANTAL(ALS(JAAR(A1:A100)=2021;ALS(B1:B100="Justified";A1:A100)))

[Voor 14% gewijzigd door dix-neuf op 29-12-2021 11:31]



Tweakers maakt gebruik van cookies

Tweakers plaatst functionele en analytische cookies voor het functioneren van de website en het verbeteren van de website-ervaring. Deze cookies zijn noodzakelijk. Om op Tweakers relevantere advertenties te tonen en om ingesloten content van derden te tonen (bijvoorbeeld video's), vragen we je toestemming. Via ingesloten content kunnen derde partijen diensten leveren en verbeteren, bezoekersstatistieken bijhouden, gepersonaliseerde content tonen, gerichte advertenties tonen en gebruikersprofielen opbouwen. Hiervoor worden apparaatgegevens, IP-adres, geolocatie en surfgedrag vastgelegd.

Meer informatie vind je in ons cookiebeleid.

Sluiten

Toestemming beheren

Hieronder kun je per doeleinde of partij toestemming geven of intrekken. Meer informatie vind je in ons cookiebeleid.

Functioneel en analytisch

Deze cookies zijn noodzakelijk voor het functioneren van de website en het verbeteren van de website-ervaring. Klik op het informatie-icoon voor meer informatie. Meer details

janee

    Relevantere advertenties

    Dit beperkt het aantal keer dat dezelfde advertentie getoond wordt (frequency capping) en maakt het mogelijk om binnen Tweakers contextuele advertenties te tonen op basis van pagina's die je hebt bezocht. Meer details

    Tweakers genereert een willekeurige unieke code als identifier. Deze data wordt niet gedeeld met adverteerders of andere derde partijen en je kunt niet buiten Tweakers gevolgd worden. Indien je bent ingelogd, wordt deze identifier gekoppeld aan je account. Indien je niet bent ingelogd, wordt deze identifier gekoppeld aan je sessie die maximaal 4 maanden actief blijft. Je kunt deze toestemming te allen tijde intrekken.

    Ingesloten content van derden

    Deze cookies kunnen door derde partijen geplaatst worden via ingesloten content. Klik op het informatie-icoon voor meer informatie over de verwerkingsdoeleinden. Meer details

    janee