Toon posts:

Excel. Waarde in een cel gebruiken als bereik in een formule

Pagina: 1
Acties:

Onderwerpen

Vraag


  • KroontjesPen
  • Registratie: Juli 2001
  • Laatst online: 03-01 21:03
In =SOM(O13:O332) zou ik graag van Q332 de 332 laten bepalen door een waarde uit een andere cel

Wanneer ik op zoek ga krijg ik voorbeelden van tabellen voor appels een peren of totalen van producten in maanden.
Door alle verwijzingen in maar ook een gebrek aan kennis over de voorbeelden kom ik er niet uit.

De reden voor de vraag is dat de hoeveelheid data die ik in een draaitabel in lees sterk kan wisselen.
Waar de data start krijg ik uit =RIJ(A12). Het aantal uit =AANTAL.ALS(Experiment[Date];B13).
Samen geven zij het einde van de juiste aantal rijen dat de =SOM(O13:Oxxx) zou moeten krijgen.
Nu is die 332 de maximum die ik een keer binnen moest halen en die laat ik nu dus staan.

(y)

May the Force be with you

Laat uw stem niet stelen.
Stem blanco!

Beste antwoord (via KroontjesPen op 19-12-2021 20:32)


  • Lustucru
  • Registratie: Januari 2004
  • Niet online

Lustucru

26 03 2016

KroontjesPen schreef op zondag 19 december 2021 @ 16:54:
@Lustucru
Helaas kom ik niet uit de voorbeelden.
Ze hebben een verschillend aantal items nl 4 en 5
Geen idee wat er er mis gaat, maar hier zie je drie manieren om hetzelfde te bereiken, nl de eerste B1 getallen van kolom A op te tellen. In kolom c zie je de gebruikte formules. Zie ook de variant met indirect voor het hele bereik: dan zie je direct achter som() dat het een indirect bereik is. Vind ik mooier.
Verder ontbreek er een bereik in mijn mening.

Een voorbeeld van Microsoft heeft dat wel.
=SOM(VERSCHUIVING(D3:F5;3;-2;3;3))
Een bereik van één cel is ook een bereik. :)

De oever waar we niet zijn noemen wij de overkant / Die wordt dan deze kant zodra we daar zijn aangeland

Alle reacties


  • g0tanks
  • Registratie: Oktober 2008
  • Laatst online: 04:10

g0tanks

Moderator CSA
De functie die je zoekt is INDIRECT, functie

Ultrawide gaming setup: AMD Ryzen 7 2700X | NVIDIA GeForce RTX 2080 | Dell Alienware AW3418DW


  • KroontjesPen
  • Registratie: Juli 2001
  • Laatst online: 03-01 21:03
Dat klopt @g0tanks.
Maar op een of andere manier kom ik er niet uit.
Dan ga ik het nog maar eens daar goed naar kijken.

May the Force be with you

Laat uw stem niet stelen.
Stem blanco!


  • g0tanks
  • Registratie: Oktober 2008
  • Laatst online: 04:10

g0tanks

Moderator CSA
Wij denken graag mee als je een voorbeeld plaatst van wat je hebt geprobeerd, ook al werkt het nog niet. ;)

Ultrawide gaming setup: AMD Ryzen 7 2700X | NVIDIA GeForce RTX 2080 | Dell Alienware AW3418DW


  • KroontjesPen
  • Registratie: Juli 2001
  • Laatst online: 03-01 21:03
@g0tanks
De INDIRECT functie snap ik nu. Hier wordt het =SOM(O13:INDIRECT("O"&MaxSom)).
Uit de voorbeelden werd geadviseerd de cel met de waarde een naam te geven vandaar "MaxSom"

Mijn twijfels over de INDIRECT functie zijn misschien de volgende redenen.
Bij =SOM(O13:O332) zie je de hele kolom zichtbaar worden.
Met de INDIRECT functie niet tot waar je het verwacht.

Niet goed opgelet met het kopiëren naar de volgende kolommen.
Die "O" veranderd niet mee.
Een keer goed neerzetten dan hoef je niet steeds te kijken tot waar de juiste data zit en dat aan passen.


(y)

May the Force be with you

Laat uw stem niet stelen.
Stem blanco!


  • Lustucru
  • Registratie: Januari 2004
  • Niet online

Lustucru

26 03 2016

Je berekent eerst het aantal rijen, dat tel je op bij de beginrij en dat resultaat zet je in de cel met de naam 'Maxsom'? Het werkt, maar het kan m.i. mooier.

In tegenstelling tot velen ben ik niet zo gecharmeerd van de indirect() oplossing in combinatie met het samenvoegen van tekstwaarden. Je kunt namelijk ook direct het optelbereik definieren met 'verschuiven'. Je ziet dan meteen in de formule wat er gebeurt:

code:
1
=SOM(VERSCHUIVING(O13;0;0;AANTAL.ALS(Experiment[Date];B13)))


Tel op: een bereik dat begint in O13 (de twee nullen geven aan dat het beginpunt niet verschuift) en verander het aantal rijen in het bereik in het aantal experimenten.

of als je wel een tussencel wilt gebruiken:
code:
1
=SOM(VERSCHUIVING(O13;0;0;AantalSom))

[Voor 5% gewijzigd door Lustucru op 19-12-2021 19:04. Reden: sluithaakje toegevoegd]

De oever waar we niet zijn noemen wij de overkant / Die wordt dan deze kant zodra we daar zijn aangeland


  • KroontjesPen
  • Registratie: Juli 2001
  • Laatst online: 03-01 21:03
@Lustucru
Ook dat ga ik zeker onderzoeken. (y)
Mooie afleiding.

De opmerking over indirect() was ik al eerder tegengekomen en daardoor het misschien te vroeg losgelaten.
Nu ik die wel weet kan ik die verschuiving() beter volgen.

May the Force be with you

Laat uw stem niet stelen.
Stem blanco!


  • KroontjesPen
  • Registratie: Juli 2001
  • Laatst online: 03-01 21:03
@Lustucru
Helaas kom ik niet uit de voorbeelden.
Ze hebben een verschillend aantal items nl 4 en 5

AANTAL.ALS(Experiment[Date];B13) en "MaxSom" zijn verschillende waarde.
Record met geldige datum tegen de Rij() waar de kop of de draaitabel begint.

Beide formules geven geen resultaat. Ook niet met nog een ) op het einde van de laatste
Verder ontbreek er een bereik in mijn mening.

Een voorbeeld van Microsoft heeft dat wel.
=SOM(VERSCHUIVING(D3:F5;3;-2;3;3))

Nu moet ik even laten rusten zolang intensief achter het scherm..

May the Force be with you

Laat uw stem niet stelen.
Stem blanco!


Acties:
  • Beste antwoord
  • 0Henk 'm!

  • Lustucru
  • Registratie: Januari 2004
  • Niet online

Lustucru

26 03 2016

KroontjesPen schreef op zondag 19 december 2021 @ 16:54:
@Lustucru
Helaas kom ik niet uit de voorbeelden.
Ze hebben een verschillend aantal items nl 4 en 5
Geen idee wat er er mis gaat, maar hier zie je drie manieren om hetzelfde te bereiken, nl de eerste B1 getallen van kolom A op te tellen. In kolom c zie je de gebruikte formules. Zie ook de variant met indirect voor het hele bereik: dan zie je direct achter som() dat het een indirect bereik is. Vind ik mooier.
Verder ontbreek er een bereik in mijn mening.

Een voorbeeld van Microsoft heeft dat wel.
=SOM(VERSCHUIVING(D3:F5;3;-2;3;3))
Een bereik van één cel is ook een bereik. :)

De oever waar we niet zijn noemen wij de overkant / Die wordt dan deze kant zodra we daar zijn aangeland


  • KroontjesPen
  • Registratie: Juli 2001
  • Laatst online: 03-01 21:03
(y)

Het had dus =AANTAL.ALS(Experiment[Date];B13) of in het kort B11 moeten zijn.

Dan is =SOM(VERSCHUIVING(O13;0;0;$B$11)) de winnende oplossing.

Was natuurlijk weer vergeten om B11 in $B$11 te gebruiken.

[Voor 251% gewijzigd door KroontjesPen op 19-12-2021 20:32. Reden: Verkeerde waarde in formule gebruikt]

May the Force be with you

Laat uw stem niet stelen.
Stem blanco!

Pagina: 1


Tweakers maakt gebruik van cookies

Tweakers plaatst functionele en analytische cookies voor het functioneren van de website en het verbeteren van de website-ervaring. Deze cookies zijn noodzakelijk. Om op Tweakers relevantere advertenties te tonen en om ingesloten content van derden te tonen (bijvoorbeeld video's), vragen we je toestemming. Via ingesloten content kunnen derde partijen diensten leveren en verbeteren, bezoekersstatistieken bijhouden, gepersonaliseerde content tonen, gerichte advertenties tonen en gebruikersprofielen opbouwen. Hiervoor worden apparaatgegevens, IP-adres, geolocatie en surfgedrag vastgelegd.

Meer informatie vind je in ons cookiebeleid.

Sluiten

Toestemming beheren

Hieronder kun je per doeleinde of partij toestemming geven of intrekken. Meer informatie vind je in ons cookiebeleid.

Functioneel en analytisch

Deze cookies zijn noodzakelijk voor het functioneren van de website en het verbeteren van de website-ervaring. Klik op het informatie-icoon voor meer informatie. Meer details

janee

    Relevantere advertenties

    Dit beperkt het aantal keer dat dezelfde advertentie getoond wordt (frequency capping) en maakt het mogelijk om binnen Tweakers contextuele advertenties te tonen op basis van pagina's die je hebt bezocht. Meer details

    Tweakers genereert een willekeurige unieke code als identifier. Deze data wordt niet gedeeld met adverteerders of andere derde partijen en je kunt niet buiten Tweakers gevolgd worden. Indien je bent ingelogd, wordt deze identifier gekoppeld aan je account. Indien je niet bent ingelogd, wordt deze identifier gekoppeld aan je sessie die maximaal 4 maanden actief blijft. Je kunt deze toestemming te allen tijde intrekken.

    Ingesloten content van derden

    Deze cookies kunnen door derde partijen geplaatst worden via ingesloten content. Klik op het informatie-icoon voor meer informatie over de verwerkingsdoeleinden. Meer details

    janee