Toon posts:

KPN/XS4ALL FTTH met eigen Cisco 892FSP: iptv issues

Pagina: 1
Acties:

Vraag


  • svbeek
  • Registratie: September 2004
  • Laatst online: 31-08-2021
Ik heb een fiber aansluiting van XS4ALL (dus eigenlijk tegenwoordig KPN) en wil de fritzbox vervangen door een eigen Cisco 892FSP. Met de onderstaande config heb ik internet via NAT werkend. Alleen iptv geeft nog problemen. Het lijkt er op dat de STB wel een IP krijgt, maar daarna stopt het (de foutmeldingen zijn er onduidelijk, dus ben niet zeker van de exacte oorzaak). Ik twijfel met name over of de IGMP proxy instellingen goed zijn. Staat deze op de juiste interface? En moet ik die tegelijkertijd gebruiken met PIM?
Heb natuurlijk al even gegoogeld en wat voorbeelden gevonden. Alleen gebruiken die vaak de oudere bridged setup. Heb gebegrepen dat je eigenlijk routed iptv wilt, om bijv ook netflix goed te laten werken.

Hieronder mijn config:

code:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
hostname router

ip dhcp excluded-address 192.168.1.1 192.168.1.20
ip domain name sandervanbeek.nl
ip name-server 1.1.1.1
ip multicast-routing

ip dhcp pool ThuisPool
 import all
 network 192.168.1.0 255.255.255.0
 default-router 192.168.1.1
 dns-server 1.1.1.1
 option 60 ascii IPTV_RG
 option 28 ip 192.168.1.255
 exit
!
interface range GigabitEthernet0-7
switchport mode access 
switchport access vlan 1
exit
!
interface Vlan1
description *** Private Vlan ***
ip address 192.168.1.1 255.255.255.0
ip pim sparse-mode
ip igmp helper-address 213.75.119.1
ip nat inside
service dhcp 
exit
!
interface GigabitEthernet9
description *** naar media converter ***
mtu 1508
no ip address
exit
!
interface GigabitEthernet9.4
description *** ITV ***
encapsulation dot1Q 4
ip dhcp client default-router distance 255
no ip dhcp client request domain-name
no ip dhcp client request dns-nameserver
ip dhcp client request classless-static-route
ip dhcp client class-id IPTV_RG
ip address dhcp
ip pim sparse-mode
ip nat outside
ip igmp query-interval 125
ip igmp proxy-service
exit
!
interface GigabitEthernet9.6
description *** Internet ***
encapsulation dot1Q 6
pppoe enable group global
pppoe-client dial-pool-number 1
exit
!
interface Dialer1
description XS4ALL PPPoE Connection
ip address negotiated
ip nat outside
encapsulation ppp
dialer pool 1
dialer-group 1
ppp pap sent-username FB7590@xs4all.nl password xs4all
ppp ipcp mask request
ppp ipcp address accept
exit
!
ip access-list extended itv 
permit ip 192.168.1.0 0.0.0.255 213.75.112.0 0.0.7.255
permit ip 192.168.1.0 0.0.0.255 10.59.184.0 0.0.7.255
exit
!
ip access-list extended inet
permit ip 192.168.1.0 0.0.0.255 any
exit
!
ip igmp snooping
ip igmp snooping vlan 1 immediate-leave
ip pim rp-address 213.75.119.1
ip nat inside source list itv interface GigabitEthernet9.4 overload
ip nat inside source list inet interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1


Ziet iemand wat er fout kan zijn, of zijn er manieren om het eea te kunnen debuggen?

Alle reacties


  • wernerd
  • Registratie: Mei 2008
  • Laatst online: 07-07 21:46
Hoi,

IK heb het bij mij thuis volledig werkend met een Cisco 2900 router en ben tijdens de configuratie van IPTV ook tegen deze problemen aangelopen. Tijdens het troubleshooten bleek dat er TCP fragmentatie optrad omdat de PPPoE sessie enkele bytes van de MTU size afsnoept, om dit op te lossen was bij mij de oplossing om aan de binnenzijde ip tcp adjust-mss 1452 op het interface te configureren waarachter de STB aangesloten zit.

Bij mij ziet het er zo uit:

interface GigabitEthernet0/1.5
description LOCAL_IPTV_LAN
encapsulation dot1Q 5
ip address 192.168.2.254 255.255.255.0
ip pim sparse-mode
ip nat inside
ip virtual-reassembly in
ip virtual-reassembly out
ip tcp adjust-mss 1452
ip igmp helper-address 213.75.119.1
end

Succes.


Tweakers maakt gebruik van cookies

Tweakers plaatst functionele en analytische cookies voor het functioneren van de website en het verbeteren van de website-ervaring. Deze cookies zijn noodzakelijk. Om op Tweakers relevantere advertenties te tonen en om ingesloten content van derden te tonen (bijvoorbeeld video's), vragen we je toestemming. Via ingesloten content kunnen derde partijen diensten leveren en verbeteren, bezoekersstatistieken bijhouden, gepersonaliseerde content tonen, gerichte advertenties tonen en gebruikersprofielen opbouwen. Hiervoor worden apparaatgegevens, IP-adres, geolocatie en surfgedrag vastgelegd.

Meer informatie vind je in ons cookiebeleid.

Sluiten

Toestemming beheren

Hieronder kun je per doeleinde of partij toestemming geven of intrekken. Meer informatie vind je in ons cookiebeleid.

Functioneel en analytisch

Deze cookies zijn noodzakelijk voor het functioneren van de website en het verbeteren van de website-ervaring. Klik op het informatie-icoon voor meer informatie. Meer details

janee

    Relevantere advertenties

    Dit beperkt het aantal keer dat dezelfde advertentie getoond wordt (frequency capping) en maakt het mogelijk om binnen Tweakers contextuele advertenties te tonen op basis van pagina's die je hebt bezocht. Meer details

    Tweakers genereert een willekeurige unieke code als identifier. Deze data wordt niet gedeeld met adverteerders of andere derde partijen en je kunt niet buiten Tweakers gevolgd worden. Indien je bent ingelogd, wordt deze identifier gekoppeld aan je account. Indien je niet bent ingelogd, wordt deze identifier gekoppeld aan je sessie die maximaal 4 maanden actief blijft. Je kunt deze toestemming te allen tijde intrekken.

    Ingesloten content van derden

    Deze cookies kunnen door derde partijen geplaatst worden via ingesloten content. Klik op het informatie-icoon voor meer informatie over de verwerkingsdoeleinden. Meer details

    janee