Cookies op Tweakers

Tweakers is onderdeel van DPG Media en maakt gebruik van cookies, JavaScript en vergelijkbare technologie om je onder andere een optimale gebruikerservaring te bieden. Ook kan Tweakers hierdoor het gedrag van bezoekers vastleggen en analyseren. Door gebruik te maken van deze website, of door op 'Cookies accepteren' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt? Bekijk dan ons cookiebeleid.

Meer informatie

Vraag


  • Barbapapaman
  • Registratie: maart 2012
  • Laatst online: 08:21
Mijn vraag
Ik heb afgelopen weekend de Motorola G5 Plus van mijn moeder voorzien van een custom rom. (ArrowOS)
Op zich werkt dit prima, alleen zien we dat de dataverbinding 'blijft steken' op H+ oftewel 3G. Voor het flashen, op de stock rom, deed 4G het wel. Dit is in lijn met wat Ben aangeeft dat het abonnement zou moeten bieden. Die stock rom was al een paar jaar niet meer geüpdate door de leverancier, dus teruggaan doe ik liever niet, maar we willen wel graag 4G kunnen gebruiken.

Relevante software en hardware die ik gebruik
Hardware:
Motorola Moto G5 Plus (potter) xt1685
Simkaart van Ben
Prepaid datasimkaart voor in Nieuw-Zeeland (staat uit)

Software:
ArrowOS (GApps build, dus met vooringebakken Google Services etc)
Versie: v11.0
Releasedatum: 2020-11-29

Wat ik al gevonden of geprobeerd heb
1. Reset APN-gegevens
Dit geeft 3 APNs met dezelfde instellingen (1x Ben (grotendeels conform de instellingen op de Ben-website, 2x T-mobile)

2. Op het punt 'Drager' binnen de APN-instellingen wijken de instellingen van de telefoon en de Ben-website van elkaar af. Deze zou volgens ben op 'LTE' moeten staan. Doe ik dit, dan verlies ik überhaupt de dataverbinding (dus ook geen H+/3G meer)

3. In de instellingen van de simkaart kan ik een voorkeursverbindingstype kiezen. Kies ik hier voor alleen LTE, dan gebeurt hetzelfde en heb ik ook geen dataverbinding meer.

4. Op bijv. XDA lees ik dat het vaker voorkomt dat na het flashen van deze rom op dit apparaat er uberhaupt geen dataverbinding mogelijk zijn (2G/3G/4G), maar dat lijkt iets anders te zijn dan dat specifiek een LTE/4G verbinding niet mogelijk is.

Heeft iemand van jullie een idee in welke richting ik een oplossing zou kunnen zoeken? Ik ben geen Android-flash-veteraan, dus mijn ideeën zijn enigszins op. O-)
Alvast bedankt voor het meedenken!

Alle reacties


  • FooLsKi
  • Registratie: augustus 2005
  • Laatst online: 12:12

FooLsKi

Prutz0r 4 Life

Ik vermoed dat de LTE-stack in die ROM niet geschikt is voor Ben/T-Mobile. Hèt risico van custom ROMs flashen.

Hoezo, ik zit je raar aan te kijken? Zo kijk ik altijd!


  • GtrCraft
  • Registratie: januari 2014
  • Laatst online: 15:07
Je modem is mogelijk beschadigd, dat kan gebeuren als je custom installeerd op Moto G5 Plus.
Probeer eens de laatste stock te flashen dmv van Lenovo Smart Assistant (liefst vanuit fastboot, betekend wel dat er een factory reset wordt gedaan):
https://support.lenovo.com/nl/nl/downloads/ds101291

EDIT: Je kan ook deze xda thread lezen voor meer info en fixes:
https://forum.xda-develop...ion-requirements.3825147/

[Voor 22% gewijzigd door GtrCraft op 19-03-2021 13:24]


  • Barbapapaman
  • Registratie: maart 2012
  • Laatst online: 08:21
FooLsKi schreef op vrijdag 19 maart 2021 @ 12:44:
Ik vermoed dat de LTE-stack in die ROM niet geschikt is voor Ben/T-Mobile. Hèt risico van custom ROMs flashen.
Is er een manier om dit te checken en eventueel te fixen, zonder zelf de hele ROM opnieuw te builden?
GtrCraft schreef op vrijdag 19 maart 2021 @ 13:22:
Je modem is mogelijk beschadigd, dat kan gebeuren als je custom installeerd op Moto G5 Plus.
Probeer eens de laatste stock te flashen dmv van Lenovo Smart Assistant (liefst vanuit fastboot, betekend wel dat er een factory reset wordt gedaan):
https://support.lenovo.com/nl/nl/downloads/ds101291
Bedoel je puur om te checken of het een hardware issue is? Ik zou namelijk liever niet teruggaan naar de stock rom, ik denk dat ik dan liever een trage mobiele dataverbinding met een meer up-to-date security heb. Of mis ik iets?
Dat lijkt niet het issue te zijn, ik heb wel een IMEI (twee zelfs ;) )

  • GtrCraft
  • Registratie: januari 2014
  • Laatst online: 15:07
Barbapapaman schreef op vrijdag 19 maart 2021 @ 15:13:

[...]


Bedoel je puur om te checken of het een hardware issue is? Ik zou namelijk liever niet teruggaan naar de stock rom, ik denk dat ik dan liever een trage mobiele dataverbinding met een meer up-to-date security heb. Of mis ik iets?
Ja, en soms als je daarna weer custom rom flashed werkt het ook daarop.

  • Barbapapaman
  • Registratie: maart 2012
  • Laatst online: 08:21
Ik heb een volledige back-up van de stock situatie. Kan ik (leunend op de XDA post, misschien zeg ik iets geks) daar de persist-partitie van naar de huidige situatie halen? Heeft dat hetzelfde effect?

  • Borromini
  • Registratie: januari 2003
  • Niet online

Borromini

Mislukt misantroop

Je kan in principe ook alleen de radio-data terugflashen. Met fastboot kan je met wat geluk alleen die partitie overschrijven.

Als die partitie bv. 'radio' heet en je kan je backup van die partitie apart uitpakken, dan kan je die zo terugzetten:

# fastboot flash radio $radio.img


Als het TWRP is kan je de backups normaal gezien ook op je PC uitpakken (al gaat Linux of OS X daar wel wat makkelijker voor werken dan Windows denk ik), bv.:

https://android.stackexch...wrp-backups-made-with-adb

[Voor 70% gewijzigd door Borromini op 19-03-2021 15:46]

Got Leenucks? | Debian Buster x86_64 / ARM | OpenWrt: Empower your router | Blogje

Pagina: 1


Apple iPad Pro (2021) 11" Wi-Fi, 8GB ram Microsoft Xbox Series X LG CX Google Pixel 5a 5G Sony XH90 / XH92 Samsung Galaxy S21 5G Sony PlayStation 5 Nintendo Switch Lite

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2021 Hosting door True