Toon posts:

Ubuntu 20.04 + Intel audio. Na elke reboot geluidskaart weg.

Pagina: 1
Acties:

Onderwerpen

Vraag


  • vlaaing peerd
  • Registratie: mei 2008
  • Laatst online: 19:25
Mijn vraag
Onlangs een PC geupdate naar Ubuntu 20.04. Direct na de upgrade ging de output van audio over de HDMI van de grafische kaart ipv de onboard Intel geluidschip.

Via lspci is de geluidskaart te zien, maar in Alsamixer of Pavucontrol was ie verdwenen als output device.

Relevante software en hardware die ik gebruik
OS en apps die geluid maken.

Wat ik al gevonden of geprobeerd heb
Na wat klooien bleek het herinstalleren en force reload van Alsa het te verhelpen, Na reboot was de geluidskaart weer zichtbaar en in te stellen als output device.

sudo apt-get install --reinstall alsa-base pulseaudio
sudo alsa force-reload

Maar als ik hierna opnieuw boot, is de intel weer foetsie en moet ik dezelfde stappen opnieuw doen om de intel weer zichtaar te maken en in te stellen als audio device.

stukjes uit lspci output:

00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
-> deze moet dus de primaire output zijn.

01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Caicos HDMI Audio [Radeon HD 6450 / 7450/8450/8490 OEM / R5 230/235/235X OEM]
-> dit de de HDMI out die na elke reboot default is.

Nu dacht ik dat er misschien ergens een conf file is waar ik de Intel kan instellen als primaire geluidskaart, maar dan moet ik ook forced reload van Alsa elke reboot uitvoeren. Dat lijkt me niet de bedoeling.

Iemand enig idee hoe ik dit het beste kan aanpakken?

Alle reacties


  • synoniem
  • Registratie: april 2009
  • Niet online
Je zou dit kunnen proberen.
code:
1
2
3
4
5
6
7
8
9
10
11
cat /proc/asound/modules

Dit zou ongeveer het antwoord moeten zijn wat je krijgt:

0 snd_hda_amd
1 snd_hda_intel

Dat kun je dit opnemen in /etc/modprobe.d/alsa-base.conf

options snd_hda_intel index= 0
options snd_hda_amd index= 1

  • vlaaing peerd
  • Registratie: mei 2008
  • Laatst online: 19:25
bedankt voor je reactie!

Dat is vreemd, want zowel als ie op HDMI gaat als na de force reload zie ik 2x Intel, terwijl ie echt op de HDMI van de ATI/AMD kaart zit af te spelen.

cat /proc/asound/modules

0 snd_hda_intel
1 snd_hda_intel

Ik heb de conf aangepast om iig de Intel te nemen, ff rebooten, zo terug.

  • vlaaing peerd
  • Registratie: mei 2008
  • Laatst online: 19:25
@synoniem
*reboot*

Het heeft niet geholpen en pakt nu ook de hdmi niet en heb helemaal geen geluid. Als ik kijk welke kaart zit af te spelen zie ik 'dummy output', weird.

In elk geval die conf weer herstellen. Mocht je nog tips hebben da hoor ik het graag.

  • Hero of Time
  • Registratie: oktober 2004
  • Laatst online: 16:47

Hero of Time

Moderator NOS

There is only one Legend

HDMI audio module blacklisten. Niet laden = geen output om potentieel heen te gaan.

Commandline FTW | Tweakt met mate


  • synoniem
  • Registratie: april 2009
  • Niet online
Kun je met je originele asound.conf eens aplay -l doen en die hier posten?

  • vlaaing peerd
  • Registratie: mei 2008
  • Laatst online: 19:25
Dat kan, bij deze:


# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2

  • synoniem
  • Registratie: april 2009
  • Niet online
Ik zou meer iets verwachten van:

**** List of PLAYBACK Hardware Devices ****
card 0: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
Subdevices: 0/1
Subdevice #0: subdevice #0
card 0: Generic [HD-Audio Generic], device 7: HDMI 1 [HDMI 1]
Subdevices: 1/1
Subdevice #0: subdevice #0

  • vlaaing peerd
  • Registratie: mei 2008
  • Laatst online: 19:25
oh, my bad. Hier alsnog de playback devices.


~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC887-VD Analog [ALC887-VD Analog]
Subdevices: 0/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: ALC887-VD Digital [ALC887-VD Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
Subdevices: 0/1
Subdevice #0: subdevice #0

  • vlaaing peerd
  • Registratie: mei 2008
  • Laatst online: 19:25
@Hero of Time bedankt voor je reactie

Blacklisten zou ik dan zo in deze conf moeten zetten, toch?

/etc/modprobe.d/blacklist.conf

blacklist snd_hda_*de HDMI kaart*

Probleempje is alleen dat ik de naam niet kan vinden, want hieronder laat ie alleen de Intel zien.

cat /proc/asound/modules

0 snd_hda_intel
1 snd_hda_intel


Edit:Ik kan wel even gokken dat ie snd_hda_ATI_HDMI heet en blacklisten. Zal het even proberen en hier laten weten.

[Voor 14% gewijzigd door vlaaing peerd op 19-03-2021 09:16]


  • synoniem
  • Registratie: april 2009
  • Niet online
vlaaing peerd schreef op vrijdag 19 maart 2021 @ 09:05:
oh, my bad. Hier alsnog de playback devices.


~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC887-VD Analog [ALC887-VD Analog]
Subdevices: 0/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: ALC887-VD Digital [ALC887-VD Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
Subdevices: 0/1
Subdevice #0: subdevice #0
Er vanuitgaande dat Digital de HDMI aansluiting is zou je dit in je /etc/asound.conf kunnen opnemen:
code:
1
2
defaults.pcm.device 1
defaults.ctl.device 1

  • Hero of Time
  • Registratie: oktober 2004
  • Laatst online: 16:47

Hero of Time

Moderator NOS

There is only one Legend

synoniem schreef op zaterdag 20 maart 2021 @ 11:13:
[...]

Er vanuitgaande dat Digital de HDMI aansluiting is zou je dit in je /etc/asound.conf kunnen opnemen:
code:
1
2
defaults.pcm.device 1
defaults.ctl.device 1
Kijk eens goed naar de regel waar 'Digital' staat:
card 0: PCH [HDA Intel PCH], device 1: ALC887-VD Digital [ALC887-VD Digital]
Ziet er voor mij toch wel heel erg naar uit dat dit de onboard geluidskaart is, en niet de HDMI output. Want die is ook duidelijk omschreven:
card 1: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
Ik denk dus niet dat je device 1 als default wilt zetten. Want hiermee zet je juist de standaard op HDMI, wat de TS niet wil. ;)

Commandline FTW | Tweakt met mate


  • synoniem
  • Registratie: april 2009
  • Niet online
Hero of Time schreef op zaterdag 20 maart 2021 @ 11:49:
[...]

Kijk eens goed naar de regel waar 'Digital' staat:

[...]

Ziet er voor mij toch wel heel erg naar uit dat dit de onboard geluidskaart is, en niet de HDMI output. Want die is ook duidelijk omschreven:

[...]

Ik denk dus niet dat je device 1 als default wilt zetten. Want hiermee zet je juist de standaard op HDMI, wat de TS niet wil. ;)
Kan zijn dat ik het verkeerd lees maar dit is de vraag:
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05) -> deze moet dus de primaire output zijn.

  • Hero of Time
  • Registratie: oktober 2004
  • Laatst online: 16:47

Hero of Time

Moderator NOS

There is only one Legend

@vlaaing peerd, op mijn PC heb ik mijn HDMI output niet beschikbaar, terwijl ik wel een videokaart heb hiermee. Dit is wat ik in een .conf heb gezet in /etc/modprobe.d. De naam kan van alles zijn, noem hem iets als 'blacklist-hdmi.conf'.
code:
1
2
3
4
5
6
# ditch the hdmi audio, but also disables onboard sound
#blacklist snd-hda-intel
blacklist snd_hda_codec_hdmi
blacklist snd-hda-codec-hdmi

options snd_hda_intel enable=1,0

Omdat ik niet wist of de module nou met - of _ geschreven werd, heb ik ze er allebei in staan. De eerste module die genoemd wordt, snd-hda-intel, wordt NIET uitgesloten, zie namelijk het # ervoor.

Ooit, lang geleden, had ik alleen blacklist snd-hda-codec-hdmi in een blacklist staan. Het systeem heeft er blijkbaar vorig jaar bovenstaande van gemaakt.



@synoniem, ja, dat is de onboard geluidskaart. Maar jij geeft de digitale output aan ipv de analoge.
De TS heeft 2 geluidskaarten en 3 uitvoer kanalen. Card0 is onboard, waarvan device0 analoog is en device1 digitaal. Card1 heeft alleen device3 en is de HDMI out. In alle gevallen gaat jouw 'oplossing' niet werken, want het gaat naar de digitale uitvoer ipv analoog.

[Voor 3% gewijzigd door Hero of Time op 20-03-2021 11:59]

Commandline FTW | Tweakt met mate


  • synoniem
  • Registratie: april 2009
  • Niet online
Hero of Time schreef op zaterdag 20 maart 2021 @ 11:58:
@synoniem, ja, dat is de onboard geluidskaart. Maar jij geeft de digitale output aan ipv de analoge.
De TS heeft 2 geluidskaarten en 3 uitvoer kanalen. Card0 is onboard, waarvan device0 analoog is en device1 digitaal. Card1 heeft alleen device3 en is de HDMI out. In alle gevallen gaat jouw 'oplossing' niet werken, want het gaat naar de digitale uitvoer ipv analoog.
Zoals gezegd haal ik dat niet uit de vraag. Maar goed het getal achter device (nu 1) is degene die je als default wilt hebben. Dus wil hij analoog dan kiest hij 0 en wil hij de AMD dan kiest hij 3.

  • vlaaing peerd
  • Registratie: mei 2008
  • Laatst online: 19:25
Bedankt voor de reacties, zal pas morgen weer achter de betreffende PC zitten en me dan weer even terugmelden.

Voor de duidelijkheid, de ALC887 is de onboard realtek chip die door Intel voor audio gebruikt wordt, dat is dus niet de HDMI die ik wil uitschakelen (of in elk geval de Intel instellen als primair/default).

  • vlaaing peerd
  • Registratie: mei 2008
  • Laatst online: 19:25
@synoniem @Hero of Time Sorry het duurde even voorat ik weer achter de desbetreffende PC kwam zitten.

Het blacklisten werkt niet, waarschijnlijk omdat ik de naam van de AMD/ATI HDMI device niet kan vinden. Bij een test de Intel geblacklist en dat werkte.

Nou zag ik dat je in Pavucontrol (console van Pulse Audio) de HDMI kan uitzetten, dat heb ik gedaan en inderdaad is de HDMI nu niet meer de default audio.

De Intel is dat echter ook niet en zit nu na elke opstart zonder geluid en de geluidskaart is 'dummy sound'. Pas na:

sudo alsa force-reload

Is de onboard geluidskaart weer terug. Ik heb ook even opgestart vanaf een Debian USB stick en daar werkt het geluid direct zoals het moet. Er is dus echt wel iets gebeurd bij de upgrade naar 20.04 en dat heeft zitten klooien met de audioconfiguratie.

Ik ben in elk geval 1 stap verder (van de HDMI af), maar moet nog steeds Alsa na elke boot reloaden om geluid te krijgen.

  • synoniem
  • Registratie: april 2009
  • Niet online
vlaaing peerd schreef op maandag 29 maart 2021 @ 17:08:
@synoniem @Hero of Time Sorry het duurde even voorat ik weer achter de desbetreffende PC kwam zitten.

Het blacklisten werkt niet, waarschijnlijk omdat ik de naam van de AMD/ATI HDMI device niet kan vinden. Bij een test de Intel geblacklist en dat werkte.

Nou zag ik dat je in Pavucontrol (console van Pulse Audio) de HDMI kan uitzetten, dat heb ik gedaan en inderdaad is de HDMI nu niet meer de default audio.

De Intel is dat echter ook niet en zit nu na elke opstart zonder geluid en de geluidskaart is 'dummy sound'. Pas na:

sudo alsa force-reload

Is de onboard geluidskaart weer terug. Ik heb ook even opgestart vanaf een Debian USB stick en daar werkt het geluid direct zoals het moet. Er is dus echt wel iets gebeurd bij de upgrade naar 20.04 en dat heeft zitten klooien met de audioconfiguratie.

Ik ben in elk geval 1 stap verder (van de HDMI af), maar moet nog steeds Alsa na elke boot reloaden om geluid te krijgen.
Wat dacht je van een pragmatische benadering? Zet in rc.local voor de laatste regel met exit 0, de regel /sbin/alsa force-reload

Dan hoef je waarschijnlijk het niet meer met de hand in te geven.

  • Hero of Time
  • Registratie: oktober 2004
  • Laatst online: 16:47

Hero of Time

Moderator NOS

There is only one Legend

vlaaing peerd schreef op maandag 29 maart 2021 @ 17:08:
@synoniem @Hero of Time Sorry het duurde even voorat ik weer achter de desbetreffende PC kwam zitten.

Het blacklisten werkt niet, waarschijnlijk omdat ik de naam van de AMD/ATI HDMI device niet kan vinden. Bij een test de Intel geblacklist en dat werkte.
Mijn PC heeft niets van Intel. De onboard geluidskaart is van Realtek en de videokaart is nVidia. Processor is AMD, mocht je daar nog aan twijfelen. ;) Had je mijn stukje exact overgenomen of ben je zelf met de modulenamen gaan rommelen?
Nou zag ik dat je in Pavucontrol (console van Pulse Audio) de HDMI kan uitzetten, dat heb ik gedaan en inderdaad is de HDMI nu niet meer de default audio.

De Intel is dat echter ook niet en zit nu na elke opstart zonder geluid en de geluidskaart is 'dummy sound'. Pas na:

sudo alsa force-reload

Is de onboard geluidskaart weer terug. Ik heb ook even opgestart vanaf een Debian USB stick en daar werkt het geluid direct zoals het moet. Er is dus echt wel iets gebeurd bij de upgrade naar 20.04 en dat heeft zitten klooien met de audioconfiguratie.

Ik ben in elk geval 1 stap verder (van de HDMI af), maar moet nog steeds Alsa na elke boot reloaden om geluid te krijgen.
Dat herladen zou helemaal niet nodig moeten zijn. Je kan nogmaals goed kijken naar de modules die je systeem laadt bij het opstarten (geen van je posts laat ook maar iets zien van lsmod uitvoer) of je doet een clean install van Ubuntu, in de hoop van dit gedoe af te zijn.

Had je al wel je eerdere wijzigingen teruggedraaid? Die kunnen mogelijk ook nog in de weg zitten.

Commandline FTW | Tweakt met mate

Pagina: 1


Nintendo Switch (OLED model) Apple iPhone 13 LG G1 Google Pixel 6 Call of Duty: Vanguard Samsung Galaxy S21 5G Apple iPad Pro (2021) 11" Wi-Fi, 8GB ram Nintendo Switch Lite

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2021 Hosting door True

Tweakers maakt gebruik van cookies

Bij het bezoeken van het forum plaatst Tweakers alleen functionele en analytische cookies voor optimalisatie en analyse om de website-ervaring te verbeteren. Op het forum worden geen trackingcookies geplaatst. Voor het bekijken van video's en grafieken van derden vragen we je toestemming, we gebruiken daarvoor externe tooling die mogelijk cookies kunnen plaatsen.

Meer informatie vind je in ons cookiebeleid.

Sluiten

Forum cookie-instellingen

Bekijk de onderstaande instellingen en maak je keuze. Meer informatie vind je in ons cookiebeleid.

Functionele en analytische cookies

Deze cookies helpen de website zijn functies uit te voeren en zijn verplicht. Meer details

janee

    Cookies van derden

    Deze cookies kunnen geplaatst worden door derde partijen via ingesloten content en om de gebruikerservaring van de website te verbeteren. Meer details

    janee