Toon posts:

Cel invullen op voorwaarde

Pagina: 1
Acties:

Onderwerpen

Vraag


  • Richard Ven
  • Registratie: Maart 2021
  • Laatst online: 16-04-2021
Hoi!,

Ik ben op dit moment bezig in Excel om projecten door te rekenen. Ik loop stuk op een bepaalde functie in Excel. Ik vind het lastig mijn probleem te formuleren, maar ik ga het zo exact mogelijk proberen.

Ik heb 3 opties: asfalt (A2), elementenverharding (A3) en berm(A4). Ik heb een dropdownmenu in B1 opgesteld met deze opties. Als ik in het menu kies "asfalt" dan wil ik dat B3 en B4 op "N.v.t." komen te staan. Als ik kies "elementenverharding" wil ik dat B2 en B4 op "N.v.t." komt te staan. B3 moet hierin dan variabel zijn en te vullen zijn door de gebruiker.

Het mooiste is natuurlijk dat rij 2 en 4 in het laatste geval ook nog verborgen worden, maar die hoop heb ik een beetje opgegeven. Wat ik geprobeerd heb is deze functie in B2: =ALS(B1="asfalt"; ""). Als ik asfalt selecteer in B1 wil ik in B2 een waarde in kunnen vullen, maar dat lukt niet omdat de formule daar natuurlijk staat.

Ik hoor graag wat er mogelijk is.

Groet R

Alle reacties


  • g0tanks
  • Registratie: Oktober 2008
  • Laatst online: 02:21

g0tanks

Moderator CSA
Richard Ven schreef op vrijdag 12 maart 2021 @ 16:42:
Het mooiste is natuurlijk dat rij 2 en 4 in het laatste geval ook nog verborgen worden, maar die hoop heb ik een beetje opgegeven.
Zonder VBA-code gaat dat inderdaad niet zomaar.
Richard Ven schreef op vrijdag 12 maart 2021 @ 16:42:
Wat ik geprobeerd heb is deze functie in B2: =ALS(B1="asfalt"; ""). Als ik asfalt selecteer in B1 wil ik in B2 een waarde in kunnen vullen, maar dat lukt niet omdat de formule daar natuurlijk staat.
Ik zou dan kolom C gebruiken voor eigen input en in kolom D een formule stoppen die de waarde uit B of C ophaalt afhankelijk van welke is ingevuld. Dan heb je alsnog een kolom waarin alles staat.

edit: Te snel gelezen. Ik zie nu dat het om regels gaat, maar het idee blijft natuurlijk hetzelfde.

[Voor 5% gewijzigd door g0tanks op 12-03-2021 16:51]

Ultrawide gaming setup: AMD Ryzen 7 2700X | NVIDIA GeForce RTX 2080 | Dell Alienware AW3418DW




Google Pixel 7 Sony WH-1000XM5 Apple iPhone 14 Samsung Galaxy Watch5, 44mm Sonic Frontiers Samsung Galaxy Z Fold4 Insta360 X3 Nintendo Switch Lite

Tweakers is samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer onderdeel van DPG Media B.V.
Alle rechten voorbehouden © 1998 - 2022 Hosting door True

Tweakers maakt gebruik van cookies

Tweakers plaatst functionele en analytische cookies voor het functioneren van de website en het verbeteren van de website-ervaring. Deze cookies zijn noodzakelijk. Om op Tweakers relevantere advertenties te tonen en om ingesloten content van derden te tonen (bijvoorbeeld video's), vragen we je toestemming. Via ingesloten content kunnen derde partijen diensten leveren en verbeteren, bezoekersstatistieken bijhouden, gepersonaliseerde content tonen, gerichte advertenties tonen en gebruikersprofielen opbouwen. Hiervoor worden apparaatgegevens, IP-adres, geolocatie en surfgedrag vastgelegd.

Meer informatie vind je in ons cookiebeleid.

Sluiten

Toestemming beheren

Hieronder kun je per doeleinde of partij toestemming geven of intrekken. Meer informatie vind je in ons cookiebeleid.

Functioneel en analytisch

Deze cookies zijn noodzakelijk voor het functioneren van de website en het verbeteren van de website-ervaring. Klik op het informatie-icoon voor meer informatie. Meer details

janee

    Relevantere advertenties

    Dit beperkt het aantal keer dat dezelfde advertentie getoond wordt (frequency capping) en maakt het mogelijk om binnen Tweakers contextuele advertenties te tonen op basis van pagina's die je hebt bezocht. Meer details

    Tweakers genereert een willekeurige unieke code als identifier. Deze data wordt niet gedeeld met adverteerders of andere derde partijen en je kunt niet buiten Tweakers gevolgd worden. Indien je bent ingelogd, wordt deze identifier gekoppeld aan je account. Indien je niet bent ingelogd, wordt deze identifier gekoppeld aan je sessie die maximaal 4 maanden actief blijft. Je kunt deze toestemming te allen tijde intrekken.

    Ingesloten content van derden

    Deze cookies kunnen door derde partijen geplaatst worden via ingesloten content. Klik op het informatie-icoon voor meer informatie over de verwerkingsdoeleinden. Meer details

    janee