Cookies op Tweakers

Tweakers is onderdeel van DPG Media en maakt gebruik van cookies, JavaScript en vergelijkbare technologie om je onder andere een optimale gebruikerservaring te bieden. Ook kan Tweakers hierdoor het gedrag van bezoekers vastleggen en analyseren. Door gebruik te maken van deze website, of door op 'Cookies accepteren' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt? Bekijk dan ons cookiebeleid.

Meer informatie
Toon posts:

Muis/keyboard freezes

Pagina: 1
Acties:

Vraag


  • Dwarlorf
  • Registratie: juni 2016
  • Laatst online: 08:13

Dwarlorf

Elitaire muziek connaisseur

Topicstarter
Mijn vraag
Ik heb mei vorig jaar 2e hands hardware gekocht (zie overzicht hieronder). Ik kreeg helaas freezes met muis (en toetsenbord) aangesloten. Ik heb toen de boel aan de kant gelegd omdat ik er niet uit kwam. (Ik heb toen niet heel gestructureerd het proberen op te lossen) Nu heb ik gister het maar weer eens geprobeerd maar het probleem blijft zich aanhouden.

Relevante software en hardware die ik gebruik

Aangeschafte 2e handse hardware:
#CategoryProductPrijsSubtotaal
1ProcessorsIntel Core i5-3470 Boxed€ 0,-€ 0,-
1MoederbordenGigabyte GA-H77N-WIFI€ 0,-€ 0,-
1VideokaartenPNY GeForce GTX 1650 XLR8 Gaming Overclocked Edition€ 0,-€ 0,-
1Geheugen internCorsair XMS3 CMX8GX3M2A1600C9€ 45,57€ 45,57
1VoedingenCorsair SF450€ 85,75€ 85,75


Hardware die ik zelf al had:

#CategoryProductPrijsSubtotaal
1MonitorenIiyama G-Master GE2488HS-B1 Zwart€ 0,-€ 0,-
1Geheugen internKingston HyperX Fury blu HX316C10F/8€ 53,68€ 53,68
1Geheugen internKingston HyperX Fury white HX316C10FW/8€ 53,68€ 53,68
1VoedingenCorsair SF450€ 85,75€ 85,75
1VoedingenFractal Design Tesla R2 Wit 650W€ 0,-€ 0,-
Totaal€ 238,68


Voor de volledigheid. Als ik dit combineer met mijn pricewatch: Gigabyte GA-Z77MX-D3H en pricewatch: Intel Core i5 2500 Boxed dan werkt het prima. (dit is mijn oude pc voordat ik een amd systeem kocht)

Wat ik al gevonden of geprobeerd heb:
Wat er eigenlijk gebeurt is dat zodra een os wordt geladen/is ingeladen de boel vastloopt. Als ik Ubuntu vers op een usb stick flash/installeer (ubuntu-20.04.2.0-desktop-amd64.iso met Balena Etcher) dan wil hij meestal het os wel laden maar uiteindelijk krijg ik een freeze en vanaf dat moment gebeurt eigenlijk het volgende:

Als ik Ubuntu op een stick installeer en dan run vanaf die stick dan gaat ie naar het scherm waar je de taal in kan stellen maar dan freezed de computer (meestal). Een aantal keren is het gebeurt dat Ubuntu wel opstartte maar dan bevroor hij vrij snel daarna wel. Als ik dan herstart en Ubuntu weer wil laten opstarten krijg ik (nadat de hij de bios voorbij is) op een gegeven moment van 'de Ubuntu stick' de melding: VMX disabled by bios. Daar blijft ie een poos op steken waarna een herstart volgt en hetzelfde riedeltje zich weer voordoet.

Dus ik heb in de bios VTX (als ik me niet vergis is dat hetzelfde) enabled. Als ik dat doe dan blijft hij na de bios eerst een poosje steken op het moederbord logo en daaronder de tekst Ubuntu en gaat ie automatisch herstarten. Dan herhaalt zich bovenstaand scenario dus de OS wordt nooit meer opgestart.

Wat ik verder heb gedaan is het volgende:
  • Meerdere keren een nieuwe ubuntu stick geflasht
  • Twee verschillende stick gebruikt
  • Twee verschillende voedingen gebruikt.
  • Verschillende RAM (2 verschillende merken) strips geprobeerd (zowel een enkele of 2). De ene set komt van mijn oude 2500k pc en die werken gewoon prima. De andere had ik bij het moederbord aangeschaft dus daar kan ik niet 100% van uitgaan dat ze goed zijn maar aangezien het probleem het ook voordoet met mijn oude ram denk ik dat het ram ook niet het probleem is. Ter verduidelijking: Ik heb ze alle 4 los van elkaar uitgeprobeerd. Dus elke een keer een individuele single ram stick.
  • Zonder muis opgestart.
  • Verschillende USB poorten uitgeprobeerd.
  • In mijn vorige pogingen heb ik het ook met windows geprobeert en toen kreeg ik ook freezes.
A. Het lijkt er op dat de stick op een gegeven moment corrupted raakt en dat het aan het moederbord ligt. Misschien dat de usb connectors niet goed werken? Aan de andere kant leveren muis en keybord in de bios geen probleem op.

B. Tijdens het schrijven van dit bericht heb ik opnieuw een usb stick met Ubuntu geflasht en opnieuw geprobeerd op te starten (zonder muis aangesloten). Ik kwam in het ubuntu taalselectie menu en toen ik verder Ubuntu wou opstarten kreeg ik dit (en hier staat ie nu al de hele tijd op):



Dat lijkt (op basis van mijn beperkte kennis) me toch op een moederbordprobleem aangaande USB. Zie laatste regel (van de afbeelding). Heeft iemand enig idee? Kan ik nog iets proberen of is het mobo kapot?

C. Bij een poging (na B.) met een andere ubuntu stick krijg ik deze melding:

[Voor 5% gewijzigd door Dwarlorf op 10-03-2021 08:03]

“The mind commands the body and it obeys. The mind orders itself and meets resistance.”

Alle reacties


  • 99ruud99
  • Registratie: december 2018
  • Laatst online: 16:46
Werk eerst eens met maar 1 merk sticks, IPV sticks te combineren.

  • Dwarlorf
  • Registratie: juni 2016
  • Laatst online: 08:13

Dwarlorf

Elitaire muziek connaisseur

Topicstarter
99ruud99 schreef op woensdag 10 maart 2021 @ 07:49:
Werk eerst eens met maar 1 merk sticks, IPV sticks te combineren.
Voor de duidelijkheid, ik combineer ze niet. Ik heb ze alle 4 los van elkaar uitgeprobeerd. Dus elke een keer een individuele single ram stick.

“The mind commands the body and it obeys. The mind orders itself and meets resistance.”


  • 99ruud99
  • Registratie: december 2018
  • Laatst online: 16:46
Ah excuses, en werkt de pc wel zonder muis en toetsenbord ingeplugd? Of hebben die er eigenlijk totaal niets mee te maken?

  • Dwarlorf
  • Registratie: juni 2016
  • Laatst online: 08:13

Dwarlorf

Elitaire muziek connaisseur

Topicstarter
99ruud99 schreef op woensdag 10 maart 2021 @ 08:02:
Ah excuses, en werkt de pc wel zonder muis en toetsenbord ingeplugd? Of hebben die er eigenlijk totaal niets mee te maken?
Dat is even de vraag waar ik ook niet helemaal uit ben. Als ik ze beide heb aangesloten en ik blijf in de bios dan is het sowieso geen probleem.

Voor zover ik kan beoordelen geeft het toetsenbord alleen geen probleem maar dit zal ik nog een keer uitproberen. Dat geeft wel een probleem, ik zie net dat ik alleen het keybord er in had zitten.

En dan zal ik het ik voor de volledigheid met de muis alleen uitproberen. Dat laatste heb ik uberhaupt nog niet uitgeprobeert bedenk ik me nu. Edit: Ok, met alleen muis loopt ie vast bij het ubuntu taal selectiescherm.

Zodra muis en toetsenbord zijn aangesloten en een OS geladen moet worden (in dit geval Ubuntu maar het was eerst ook met windows) dan gaat het geheid freezen.

[Voor 9% gewijzigd door Dwarlorf op 10-03-2021 08:12]

“The mind commands the body and it obeys. The mind orders itself and meets resistance.”


  • Dwarlorf
  • Registratie: juni 2016
  • Laatst online: 08:13

Dwarlorf

Elitaire muziek connaisseur

Topicstarter
Ok, wat verder geexperimenteerd. Zonder input device blijft ie sowieso steken op dit scherm (met een ps/2 keyboard gebeurt dit ook):




Nu net had ik de muis er alleen weer in en toen ging ie wel voorbij het ubuntu taalselectiescherm maar krijg ik (weer) het volgende scherm waarna er niks meer gebeurd:



Dit is dus wat ik bij de bullet points heb besproken.

Na een reset herstart ie en loopt ie vast op dit scherm:



Aanvulling: na verloop van tijd reset ie weer en dan krijg ik weer die VMX melding.
Ik heb het nu al de hele tijd aan staan hij blijft proberen ubuntu te laden, nu doet ie weer een check op de stick. En na verloop van tijd gaat ie weer automatisch resetten en komt ie in deze loop terecht.

Ik krijg toch steeds het idee dat er iets mis is met het hele USB gebeuren, mogelijk dat de ubuntu stick zelf ook op een gegeven moment corrupted wordt ( dit is slechts een vermoeden)

[Voor 31% gewijzigd door Dwarlorf op 10-03-2021 09:35]

“The mind commands the body and it obeys. The mind orders itself and meets resistance.”


  • 99ruud99
  • Registratie: december 2018
  • Laatst online: 16:46
Kan je er eens Windows op zetten? Dat kan ook zonder licentie code

  • Dwarlorf
  • Registratie: juni 2016
  • Laatst online: 08:13

Dwarlorf

Elitaire muziek connaisseur

Topicstarter
99ruud99 schreef op woensdag 10 maart 2021 @ 10:03:
Kan je er eens Windows op zetten? Dat kan ook zonder licentie code
Ik heb momenteel alleen de usb stick om van te booten. Ik zie dat ik wel (omslachtig) een bootable usb met windows kan maken maar ik krijg zometeen bezoek dus dat wordt allemaal wat krap qua tijd.

Ik heb heb vanochtend vroeg een ssd bij een medetweaker besteld. Zodra die binnen is (hopelijk morgen) zal ik daar windows op installeren. Ik denk dat het handiger is dat zodra ik dat gedaan heb ik er op terug kom.

Tot zover in ieder geval heel erg bedankt. Je hulp wordt zeer gewaardeerd.

[Voor 3% gewijzigd door Dwarlorf op 10-03-2021 10:17]

“The mind commands the body and it obeys. The mind orders itself and meets resistance.”


  • Eftalou
  • Registratie: april 2004
  • Niet online
Ik had een tijdje geleden een soortgelijk probleem. Computer liep random vast na het inpluggen van een usb toetsenbord/muis. Soms liep hij al vast bij het opstarten van Windows, soms pas na het inpluggen. In de BIOS had ik geen problemen. Na van alles geprobeerd te hebben heb ik uiteindelijk de processor uit het socket gehaald. Wat bleek, er zat een klein beetje koelpasta aan de onderkant van de processor. Nadat ik deze goed had schoongemaakt en het socket had gecontroleerd deed hij het weer prima.

Ik zou je aanraden om je processor en socket even na te kijken of er geen vuil of iets anders aan de hand is wat het contact tussen het socket en de processor kan verstoren.

"There's no place like 127.0.0.1"


  • Dwarlorf
  • Registratie: juni 2016
  • Laatst online: 08:13

Dwarlorf

Elitaire muziek connaisseur

Topicstarter
Eftalou schreef op donderdag 11 maart 2021 @ 19:28:
Ik had een tijdje geleden een soortgelijk probleem. Computer liep random vast na het inpluggen van een usb toetsenbord/muis. Soms liep hij al vast bij het opstarten van Windows, soms pas na het inpluggen. In de BIOS had ik geen problemen. Na van alles geprobeerd te hebben heb ik uiteindelijk de processor uit het socket gehaald. Wat bleek, er zat een klein beetje koelpasta aan de onderkant van de processor. Nadat ik deze goed had schoongemaakt en het socket had gecontroleerd deed hij het weer prima.

Ik zou je aanraden om je processor en socket even na te kijken of er geen vuil of iets anders aan de hand is wat het contact tussen het socket en de processor kan verstoren.
Dit zou zo maar eens het euvel kunnen zijn geweest. Er zat wel een soort van imperfectie op de processor. Hij heeft nu nog geen vastloper en ik zit in Ubuntu (vanaf stick) Te vroeg gejuigd. Hij liep toch vast, maar ik kwam wel verder dan ooit. Beetje apart.

Ik zal van het weekend ff verder experimenteren, dan is hopelijk de ssd ook binnen. Ik heb helaas de stock intel fan gemold dus daar moet ik nog even wat op zien te vinden.

[Voor 3% gewijzigd door Dwarlorf op 12-03-2021 12:01]

“The mind commands the body and it obeys. The mind orders itself and meets resistance.”


  • Eftalou
  • Registratie: april 2004
  • Niet online
Wat voor oneffenheid bedoel je precies en heb je dat kunnen oplossen? Als het een fysieke oneffenheid is dan zou dat nog steeds het probleem kunnen zijn.

Mocht je tijd hebben en Windows hebben geinstalleerd dan zou ik je aanraden om eens Intel Processor Diagnotic Tool (link:https://downloadcenter.intel.com/download/19792) te downloaden om te kijken of je processor niet defect is. En anders is het advies om toch even een ander moederbord of processor proberen om verdere fysieke defecten uit te sluiten. ;)

"There's no place like 127.0.0.1"


  • Dwarlorf
  • Registratie: juni 2016
  • Laatst online: 08:13

Dwarlorf

Elitaire muziek connaisseur

Topicstarter
Eftalou schreef op zaterdag 13 maart 2021 @ 10:10:
Wat voor oneffenheid bedoel je precies en heb je dat kunnen oplossen? Als het een fysieke oneffenheid is dan zou dat nog steeds het probleem kunnen zijn.

Mocht je tijd hebben en Windows hebben geinstalleerd dan zou ik je aanraden om eens Intel Processor Diagnotic Tool (link:https://downloadcenter.intel.com/download/19792) te downloaden om te kijken of je processor niet defect is. En anders is het advies om toch even een ander moederbord of processor proberen om verdere fysieke defecten uit te sluiten. ;)
Nee, het was een soort van grijzig vlekje, later zag ik een zelfde soort grijzige waas over een groot deel van de onderkant vd processor. Ik denk niet dat het wat is maar meer hoe het licht er op valt. Ik kan het moelijk uitleggen en een fatsoenlijke foto maken lukte niet. Ik heb de processor met isopropanol schoongemaakt. Ik zag geen imperfecties aan de socket.

Mijn stappenplan is als volgt:

De SSD zou gister bezorgd zijn maar die heb ik niet ontvangen, hopelijk komt ie vandaag (brievenbuspakketje). Alleen is de CPU fan kapot, en de vervanger (althans een intel bracket voor een AM4 Noctua die ik nog heb liggen) komt pas maandag. Dus ik wacht waarschijnlijk tot maandag om verder te gaan (anders moet ik gaan klooien met een kapotte fan).

Zodra dit allemaal binnen is zal ik windows gaan installeren en kijken wat er gebeurt. Als dat nog steeds problemen geeft dan had ik inderdaad bedacht om de processor in mn andere PC te steken om te zien of het aan de processor ligt. En dan run ik dan voor de zekerheid de diagnostics tool (goeie tip!). Als dat niet het geval is dan lijkt het me toch een moederbord probleem.

Als dat het geval is neem ik mijn verlies en ga ik het waarschijnlijk opgeven. Ik heb al teveel geld aan deze oude rommel uitgegeven.

“The mind commands the body and it obeys. The mind orders itself and meets resistance.”


  • Dwarlorf
  • Registratie: juni 2016
  • Laatst online: 08:13

Dwarlorf

Elitaire muziek connaisseur

Topicstarter
SSD aangesloten. Windows geprobeerd te installeren maar ook nu op random momenten (tijdens het installatieproces) freezes.

Verder heb ik (daarna) met de biosinstelligen gespeeld:
Xhci pre boot disabled en na een vastloper weer enabled
Os type op Windows 8 gezet ipv OS maar mocht niet baten

En ik heb een andere muis gebruikt.

En zonet deze melding:

Ik denk dat de usb hardware gewoon kapot is en nu ook de stick heeft gecorrumpeerd. De Ubuntu stick had ook na verloop van tijd integriteitsproblemen.

Morgen maar weer verder.

“The mind commands the body and it obeys. The mind orders itself and meets resistance.”


  • Dwarlorf
  • Registratie: juni 2016
  • Laatst online: 08:13

Dwarlorf

Elitaire muziek connaisseur

Topicstarter
Eftalou schreef op zaterdag 13 maart 2021 @ 10:10:
Mocht je tijd hebben en Windows hebben geinstalleerd dan zou ik je aanraden om eens Intel Processor Diagnotic Tool (link:https://downloadcenter.intel.com/download/19792) te downloaden om te kijken of je processor niet defect is. En anders is het advies om toch even een ander moederbord of processor proberen om verdere fysieke defecten uit te sluiten. ;)
Goed, ik heb CPU's uitgewisseld.
De i5 2500 zit nu op de Gigabyte GA-H77N-WIFI.
De i5-3470 zit nu op de Gigabyte GA-Z77MX-D3H.
Op beide PC's staat nu Windows 10.

De systemen zien er daardoor als volgt uit:

#CategoryProductPrijsSubtotaal
1ProcessorsIntel Core i5-3470 Boxed€ 0,-€ 0,-
1MoederbordenGigabyte GA-Z77MX-D3H€ 0,-€ 0,-
1VideokaartenSapphire R9 280X 3GB GDDR5 Vapor-X€ 0,-€ 0,-
1BehuizingenFractal Design Define R5 Wit Window€ 79,-€ 79,-
1Geheugen internKingston HyperX Fury blu HX316C10F/8€ 53,90€ 53,90
1Geheugen internKingston HyperX Fury white HX316C10FW/8€ 63,37€ 63,37
1VoedingenFractal Design Tesla R2 Wit 650W€ 0,-€ 0,-
1Solid state drivesCrucial m4 CT128M4SSD2 128GB€ 0,-€ 0,-


#CategoryProductPrijsSubtotaal
1ProcessorsIntel Core i5 2500 Boxed€ 0,-€ 0,-
1MoederbordenGigabyte GA-H77N-WIFI€ 0,-€ 0,-
1VideokaartenPNY GeForce GTX 1650 XLR8 Gaming Overclocked Edition€ 0,-€ 0,-
1Geheugen internCorsair XMS3 CMX8GX3M2A1600C9€ 50,64€ 50,64
1VoedingenCorsair SF450€ 94,99€ 94,99
1Solid state drivesSamsung 840 Pro 128GB€ 60,90€ 60,90

Ik heb de Intel CPU diagnostic tool 2x op beide PC's laten draaien en in beide gevallen zijn er geen problemen gevonden. Ik heb sindsdien ook geen freezes meer ondervonden. Het lijkt haast alsof de i5-3470 en GA-H77N-WIFI niet volledig compatible zijn.
Eftalou schreef op zaterdag 13 maart 2021 @ 10:10:
Wat voor oneffenheid bedoel je precies en heb je dat kunnen oplossen? Als het een fysieke oneffenheid is dan zou dat nog steeds het probleem kunnen zijn.
De grijze waas (oneffenheid) zag ik ook op de 2500 dus ik ga er van uit dat dit inderdaad een optisch effect is.

[Voor 4% gewijzigd door Dwarlorf op 16-03-2021 07:30]

“The mind commands the body and it obeys. The mind orders itself and meets resistance.”


  • Dwarlorf
  • Registratie: juni 2016
  • Laatst online: 08:13

Dwarlorf

Elitaire muziek connaisseur

Topicstarter
Ik heb nu op beide pc's Passmark en Burnin gedraait en dit gaf ook geen problemen.

Ik zie nu dat op de PC met de Gigabyte GA-H77N-WIFI de/een driver voor de PCI Simple Communications Controller mist en 1 voor een Unknown Device. Zou het kunnen dat dit problemen heeft opgeleverd tijdens die freezes en mislukte installaties? Maarja, waarom is het installeren nu met een cpu swap wel opgelost?

Voor de PC PCI Simple Communications Controller heb ik de drivers kunnen downloaden via de gigabyte website.
De Unknown device was de Intel bluetooth device. Maar drivers ervoor installeren lukte niet. Een zoektocht op internet leek te duiden op het feit dat de basic bluetooth drivers van windows niet geinstalleerd zijn en daardoor kunnen juiste Intel drivers ook niet geinstalleerd. Inmiddels heb ik dat met Driver Booster opgelost.

Alles lijkt nu te werken, maar wat nou de oplossing is. Geen idee. :)

[Voor 3% gewijzigd door Dwarlorf op 16-03-2021 14:21]

“The mind commands the body and it obeys. The mind orders itself and meets resistance.”


  • Eftalou
  • Registratie: april 2004
  • Niet online
Dwarlorf schreef op dinsdag 16 maart 2021 @ 14:18:
Ik heb nu op beide pc's Passmark en Burnin gedraait en dit gaf ook geen problemen.

Ik zie nu dat op de PC met de Gigabyte GA-H77N-WIFI de/een driver voor de PCI Simple Communications Controller mist en 1 voor een Unknown Device. Zou het kunnen dat dit problemen heeft opgeleverd tijdens die freezes en mislukte installaties? Maarja, waarom is het installeren nu met een cpu swap wel opgelost?

Voor de PC PCI Simple Communications Controller heb ik de drivers kunnen downloaden via de gigabyte website.
De Unknown device was de Intel bluetooth device. Maar drivers ervoor installeren lukte niet. Een zoektocht op internet leek te duiden op het feit dat de basic bluetooth drivers van windows niet geinstalleerd zijn en daardoor kunnen juiste Intel drivers ook niet geinstalleerd. Inmiddels heb ik dat met Driver Booster opgelost.
Drivers kunnen soms het probleem zijn van vastlopers, echter denk ik niet dat dit bij jou het geval was omdat je al vastlopers had voordat drivers uberhaupt zijn geladen. Ik neig toch te denken dat het een hardwarematig probleem is. Waren er ook geen pinnetjes verbogen in de USB aansluiting op het moederbord?

Heb je van beide moederborden de nieuwste bios geïnstalleerd?
Eftalou schreef op zaterdag 13 maart 2021 @ 10:10:
Wat voor oneffenheid bedoel je precies en heb je dat kunnen oplossen? Als het een fysieke oneffenheid is dan zou dat nog steeds het probleem kunnen zijn.

De grijze waas (oneffenheid) zag ik ook op de 2500 dus ik ga er van uit dat dit inderdaad een optisch effect is.
Was het socket verder ook in orde?

"There's no place like 127.0.0.1"


  • Dwarlorf
  • Registratie: juni 2016
  • Laatst online: 08:13

Dwarlorf

Elitaire muziek connaisseur

Topicstarter
Eftalou schreef op woensdag 17 maart 2021 @ 20:21:
Drivers kunnen soms het probleem zijn van vastlopers, echter denk ik niet dat dit bij jou het geval was omdat je al vastlopers had voordat drivers uberhaupt zijn geladen. Ik neig toch te denken dat het een hardwarematig probleem is.
Ik denk ook dat het hardwarematig is. Maar worden er nog geen drivers geladen zodra je een os wil gaan installeren?
Eftalou schreef op woensdag 17 maart 2021 @ 20:21:
Waren er ook geen pinnetjes verbogen in de USB aansluiting op het moederbord?
Heb ik niet op gelet maar dan zou ik ze per ongeluk weer recht hebben geduwd.
Eftalou schreef op woensdag 17 maart 2021 @ 20:21:
Heb je van beide moederborden de nieuwste bios geïnstalleerd?
Volgens mij heeft de matx moederbord wel de meest recente bios. De ander weet ik niet zeker maar ik heb de biossen niet veranderd nav deze problemen.
Eftalou schreef op woensdag 17 maart 2021 @ 20:21:
Was het socket verder ook in orde?
Ja, ik zag niks raars.

Eigenlijk zou ik de cpu's nu weer moet omwisselen om te kijken of het weer problemen geeft. Maar nu het allemaal in elkaar zit en werkt voel ik er niet veel voor om dat nu weer te gaan doen.

Misschien dat er iets van stof in de socket zat ofzo.

“The mind commands the body and it obeys. The mind orders itself and meets resistance.”

Pagina: 1


Apple iPad Pro (2021) 11" Wi-Fi, 8GB ram Microsoft Xbox Series X LG CX Google Pixel 5a 5G Sony XH90 / XH92 Samsung Galaxy S21 5G Sony PlayStation 5 Nintendo Switch Lite

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2021 Hosting door True