Toon posts:

Fotoalbum 404?

Pagina: 1
Acties:

Acties:
  • +1Henk 'm!

  • t_captain
  • Registratie: juli 2007
  • Laatst online: 10:16

t_captain

Moderator General Chat
Topicstarter
Probeerde iets te uploaden naar mijn album, kreeg een 404. Werkte deze week nog.

https://tweakers.net/my.tnet/fotoalbum/

  • crisp
  • Registratie: februari 2000
  • Laatst online: 11:13

crisp

Devver

Pixelated

We gaan er naar kijken :)

Intentionally left blank


  • Devian
  • Registratie: juni 2000
  • Laatst online: 11:11
Heb het zelfde probleem hier.

  • crisp
  • Registratie: februari 2000
  • Laatst online: 11:13

crisp

Devver

Pixelated

Zou inmiddels weer moeten werken :)

Intentionally left blank


Acties:
  • +10Henk 'm!

  • DaFeliX
  • Registratie: december 2002
  • Laatst online: 07:44

DaFeliX

Tnet Devver
Ik had wat changes gedaan in onze apache config, en daar ging iets mis.

We gebruiken her-en-der .htaccess-files in de code. Deze .htaccess-files zijn eigenlijk bedoeld voor shared-hosting waar je geen volledige controle hebt over de Apache configuratie zelf. Het is aan te raden om de .htaccess-files te verplaatsen naar je Apache config (oa voor performance redenen), als dat kan.

Aangezien we onze eigen webservers prima kunnen beheren, heb ik daarom afgelopen periode een aantal van deze .htaccess bestanden omgezet naar configuratie in Apache. Daarbij heb ik gebruik gemaakt van onze eigen ontwikkelde tests voor het end-to-end testen van bepaalde URLs, maar ik had daar de link naar 't fotoalbum verkeerd in gezet (zeg maar, de bestandsnaam hoe 't op de schijft staat, maar niet de URL die we gebruiken).

Vanmorgen had ik deze changes gereleased op 1 webserver. Daarna hield ik de logs in de gaten om te kijken of er niet ineens een hoop 404's werden teruggegeven. Dat leek niet het geval, en heb ik de change uitgerolt over de andere servers. De reden dat ik de fotoalbum fouten niet zag is dat verhoudingsgewijs er natuurlijk veel minder verkeer op deze endpoint binnenkomt dan op alle andere punten, dus viel dit simpelweg niet op.

Wat ik nu heb gedaan is de configuratie voor dit deel teruggezet, zodat het gewoon weer werkt zoals vroeger. Ik kan dan op m'n gemak kijken waarom mijn eerste change niet heeft gewerkt, en die in alle gemak even testen. Zo kan iedereen het fotoalbum weer gebruiken, en hoef ik mij niet te haasten met het fixen.
Tevens heb ik de test aangepast zodat deze nu de juiste endpoint test, dus zelfs al zou iemand mijn vorige change ineens terugdraaien, dan faalt die test en kan die change niet gereleased worden. Dit specifieke probleem zou dus niet meer voor (mogen) komen :)

maar da's geen garantie dat ik iets anders stukmaak natuurlijk >:)

Einstein: Mijn vrouw begrijpt me niet


  • t_captain
  • Registratie: juli 2007
  • Laatst online: 10:16

t_captain

Moderator General Chat
Topicstarter
Ik kan bevestigen dat het weer werkt.

  • AW_Bos
  • Registratie: april 2002
  • Nu online

AW_Bos

Waar ga je heen? ☀

Thanx voor de leerzame verduidelijking. :)

Ik had zelf het vermoeden dat het met jullie Symfony framework te maken had met de routing. Maar zo te horen is het nog een stukje obsolete legacy code. ;)

[Voor 3% gewijzigd door AW_Bos op 09-03-2021 19:16. Reden: oeps, dat bedoelde ik dus....]

Waar ga je heen?


Acties:
  • +1Henk 'm!

  • crisp
  • Registratie: februari 2000
  • Laatst online: 11:13

crisp

Devver

Pixelated

AW_Bos schreef op dinsdag 9 maart 2021 @ 18:28:
Thanx voor de leerzame verduidelijking. :)

Ik had zelf het vermoeden dat het met jullie Symfony framework te maken had met de routing. Maar zo te horen is het nog een stukje obsolete code. ;)
Niet obsolete, maar wel legacy ;) Het fotoalbum zit inderdaad nog niet in Symfony.

Intentionally left blank


Acties:
  • +2Henk 'm!

  • DaFeliX
  • Registratie: december 2002
  • Laatst online: 07:44

DaFeliX

Tnet Devver
AW_Bos schreef op dinsdag 9 maart 2021 @ 18:28:
Thanx voor de leerzame verduidelijking. :)

Ik had zelf het vermoeden dat het met jullie Symfony framework te maken had met de routing. Maar zo te horen is het nog een stukje obsolete code. ;)
Graag gedaan, leuk om te lezen dat je 't leuk vind. Dat vind ik dan leuk.

Het is niet zozeer obsolete, het wordt immers nog gebruikt, maar zeker wel legacy. Dit maakt zulke taken dan ook juist ingewikkeld, want juist de code die je niet vaak aanraakt, is code die net wat anders in elkaar steekt. Daarom heb je 't risico dat je 't juist daar foutloopt (minder focus, en grotere kans dat 't niet werkt). Als ik de frontpage had gesloopt, dan was mij dit heus wel opgevallen :+ .

Het voordeel van zulke taken uitvoeren is dan wel dat je attent wordt op dit soort legacy zaken die anders in elkaar steken; dus kun je er mooi je tests/documentatie op aanpassen.

Einstein: Mijn vrouw begrijpt me niet

Pagina: 1


Nintendo Switch (OLED model) Apple iPhone 13 LG G1 Google Pixel 6 Call of Duty: Vanguard Samsung Galaxy S21 5G Apple iPad Pro (2021) 11" Wi-Fi, 8GB ram Nintendo Switch Lite

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2021 Hosting door True

Tweakers maakt gebruik van cookies

Bij het bezoeken van het forum plaatst Tweakers alleen functionele en analytische cookies voor optimalisatie en analyse om de website-ervaring te verbeteren. Op het forum worden geen trackingcookies geplaatst. Voor het bekijken van video's en grafieken van derden vragen we je toestemming, we gebruiken daarvoor externe tooling die mogelijk cookies kunnen plaatsen.

Meer informatie vind je in ons cookiebeleid.

Sluiten

Forum cookie-instellingen

Bekijk de onderstaande instellingen en maak je keuze. Meer informatie vind je in ons cookiebeleid.

Functionele en analytische cookies

Deze cookies helpen de website zijn functies uit te voeren en zijn verplicht. Meer details

janee

    Cookies van derden

    Deze cookies kunnen geplaatst worden door derde partijen via ingesloten content en om de gebruikerservaring van de website te verbeteren. Meer details

    janee