Toon posts:

Dynamische X.ZOEKEN functie

Pagina: 1
Acties:

Onderwerpen

Vraag


  • Ronald19822
  • Registratie: Juni 2015
  • Laatst online: 06-03-2021
Ik heb de volgende formule gemaakt voor een rooster op het werk:

=X.ZOEKEN($A$39;TabelMedewerkers[[#Alles];[Medewerkers X]];TabelMedewerkers[[#Alles];[ma-o]])

Het stukje aan het eind van de formule dat vet gedrukt is wil ik dynamisch hebben zodat hij uit de tabel de juiste kolom pakt i.v.m. verschil tussen even en oneven weken. Ik heb daarom de volgende formule gemaakt.

="["&$Q$17&"-"&ALS(IS.ONEVEN(RECHTS($Q$16;2))=WAAR;"o";"e")&"]]"

In Q16 staat het weeknummer
In Q 17 staat "Ma".

Als ik die formule in een losse cel zet geeft hij als uitkomst precies de waarde zoals vetgedrukt aan het eind van de eerste formule. Maar de vetgedrukte tekst vervangen door de formule blijkt dus niet te werken. Indirect leken mij ook niet de oplossing. Voor de zekerheid beide wel wat geprobeerd maar zonder het gewenste resultaat.

Dit moet toch gewoon simpel kunnen? Wat vergeet ik hier?

Alle reacties


  • g0tanks
  • Registratie: Oktober 2008
  • Laatst online: 00:39

g0tanks

Moderator CSA
Ronald19822 schreef op dinsdag 2 maart 2021 @ 20:43:
="["&$Q$17&"-"&ALS(IS.ONEVEN(RECHTS($Q$16;2))=WAAR;"o";"e")&"]]"
Ik heb niet zoveel ervaring met gestructureerde verwijzingen in Excel, maar ik vind het raar dat je de square brackets hier als tekst hebt staan ("[" en "]]" aan het begin en eind). Dat lijkt mij niet de juiste manier van verwijzen.

Ultrawide gaming setup: AMD Ryzen 7 2700X | NVIDIA GeForce RTX 2080 | Dell Alienware AW3418DW


  • dixet
  • Registratie: Februari 2010
  • Laatst online: 20:23
Ik snap niet helemaal hoe je de functie X.ZOEKEN hier gebruikt
code:
1
X.ZOEKEN(item; zoekbereik; ophaalbereik;[alternatief]; [Overeenkomstmodus]; [zoekmodus])


code:
1
=X.ZOEKEN($A$39;TabelMedewerkers[[#Alles];[Medewerkers X]];TabelMedewerkers[[#Alles];[ma-o]])


$A$39 is de waarde die je zoekt
TabelMedewerkers[[#Alles] is de reeks waarbinnen je zoekt
[Medewerkers X] is de reeks waaruit je de overeenkomende waarde terug wilt hebben
TabelMedewerkers[[#Alles] is de waarde die je wilt tonen als er geen overeenkomst is gevonden
[ma-o]] is de overeenkomst modus: zoek je een exacte overeenkomst of niet. Deze parameter mag alleen de waardes 0, -1, 1 of 2 hebben.

Geeft die functie wel het gewenste resultaat in je 1e voorbeeld?

  • Ronald19822
  • Registratie: Juni 2015
  • Laatst online: 06-03-2021
Dank voor de reacties. Ik snap het punt van de overeenkomst modus. Vreemde is wel dat de functie in het eerste voorbeeld het gewenste resultaat geeft en als ik de "ma-o" verander in "di-o" dat ook echt het juiste zoekresultaat van de dinsdag i.p.v. de maandag wordt opgehaald.

Ik ga nog eens verder proberen :-)


Tweakers maakt gebruik van cookies

Tweakers plaatst functionele en analytische cookies voor het functioneren van de website en het verbeteren van de website-ervaring. Deze cookies zijn noodzakelijk. Om op Tweakers relevantere advertenties te tonen en om ingesloten content van derden te tonen (bijvoorbeeld video's), vragen we je toestemming. Via ingesloten content kunnen derde partijen diensten leveren en verbeteren, bezoekersstatistieken bijhouden, gepersonaliseerde content tonen, gerichte advertenties tonen en gebruikersprofielen opbouwen. Hiervoor worden apparaatgegevens, IP-adres, geolocatie en surfgedrag vastgelegd.

Meer informatie vind je in ons cookiebeleid.

Sluiten

Toestemming beheren

Hieronder kun je per doeleinde of partij toestemming geven of intrekken. Meer informatie vind je in ons cookiebeleid.

Functioneel en analytisch

Deze cookies zijn noodzakelijk voor het functioneren van de website en het verbeteren van de website-ervaring. Klik op het informatie-icoon voor meer informatie. Meer details

janee

    Relevantere advertenties

    Dit beperkt het aantal keer dat dezelfde advertentie getoond wordt (frequency capping) en maakt het mogelijk om binnen Tweakers contextuele advertenties te tonen op basis van pagina's die je hebt bezocht. Meer details

    Tweakers genereert een willekeurige unieke code als identifier. Deze data wordt niet gedeeld met adverteerders of andere derde partijen en je kunt niet buiten Tweakers gevolgd worden. Indien je bent ingelogd, wordt deze identifier gekoppeld aan je account. Indien je niet bent ingelogd, wordt deze identifier gekoppeld aan je sessie die maximaal 4 maanden actief blijft. Je kunt deze toestemming te allen tijde intrekken.

    Ingesloten content van derden

    Deze cookies kunnen door derde partijen geplaatst worden via ingesloten content. Klik op het informatie-icoon voor meer informatie over de verwerkingsdoeleinden. Meer details

    janee