Toon posts:

Dynamische X.ZOEKEN functie

Pagina: 1
Acties:

Onderwerpen

Vraag


  • Ronald19822
  • Registratie: juni 2015
  • Laatst online: 06-03 08:24
Ik heb de volgende formule gemaakt voor een rooster op het werk:

=X.ZOEKEN($A$39;TabelMedewerkers[[#Alles];[Medewerkers X]];TabelMedewerkers[[#Alles];[ma-o]])

Het stukje aan het eind van de formule dat vet gedrukt is wil ik dynamisch hebben zodat hij uit de tabel de juiste kolom pakt i.v.m. verschil tussen even en oneven weken. Ik heb daarom de volgende formule gemaakt.

="["&$Q$17&"-"&ALS(IS.ONEVEN(RECHTS($Q$16;2))=WAAR;"o";"e")&"]]"

In Q16 staat het weeknummer
In Q 17 staat "Ma".

Als ik die formule in een losse cel zet geeft hij als uitkomst precies de waarde zoals vetgedrukt aan het eind van de eerste formule. Maar de vetgedrukte tekst vervangen door de formule blijkt dus niet te werken. Indirect leken mij ook niet de oplossing. Voor de zekerheid beide wel wat geprobeerd maar zonder het gewenste resultaat.

Dit moet toch gewoon simpel kunnen? Wat vergeet ik hier?

Alle reacties


  • g0tanks
  • Registratie: oktober 2008
  • Laatst online: 15:52

g0tanks

Moderator CSA
Ronald19822 schreef op dinsdag 2 maart 2021 @ 20:43:
="["&$Q$17&"-"&ALS(IS.ONEVEN(RECHTS($Q$16;2))=WAAR;"o";"e")&"]]"
Ik heb niet zoveel ervaring met gestructureerde verwijzingen in Excel, maar ik vind het raar dat je de square brackets hier als tekst hebt staan ("[" en "]]" aan het begin en eind). Dat lijkt mij niet de juiste manier van verwijzen.

Ultrawide gaming setup: AMD Ryzen 7 2700X | NVIDIA GeForce RTX 2080 | Dell Alienware AW3418DW


  • dixet
  • Registratie: februari 2010
  • Nu online
Ik snap niet helemaal hoe je de functie X.ZOEKEN hier gebruikt
code:
1
X.ZOEKEN(item; zoekbereik; ophaalbereik;[alternatief]; [Overeenkomstmodus]; [zoekmodus])


code:
1
=X.ZOEKEN($A$39;TabelMedewerkers[[#Alles];[Medewerkers X]];TabelMedewerkers[[#Alles];[ma-o]])


$A$39 is de waarde die je zoekt
TabelMedewerkers[[#Alles] is de reeks waarbinnen je zoekt
[Medewerkers X] is de reeks waaruit je de overeenkomende waarde terug wilt hebben
TabelMedewerkers[[#Alles] is de waarde die je wilt tonen als er geen overeenkomst is gevonden
[ma-o]] is de overeenkomst modus: zoek je een exacte overeenkomst of niet. Deze parameter mag alleen de waardes 0, -1, 1 of 2 hebben.

Geeft die functie wel het gewenste resultaat in je 1e voorbeeld?

  • Ronald19822
  • Registratie: juni 2015
  • Laatst online: 06-03 08:24
Dank voor de reacties. Ik snap het punt van de overeenkomst modus. Vreemde is wel dat de functie in het eerste voorbeeld het gewenste resultaat geeft en als ik de "ma-o" verander in "di-o" dat ook echt het juiste zoekresultaat van de dinsdag i.p.v. de maandag wordt opgehaald.

Ik ga nog eens verder proberen :-)


Nintendo Switch (OLED model) Apple iPhone 13 LG G1 Google Pixel 6 Call of Duty: Vanguard Samsung Galaxy S21 5G Apple iPad Pro (2021) 11" Wi-Fi, 8GB ram Nintendo Switch Lite

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2021 Hosting door True

Tweakers maakt gebruik van cookies

Bij het bezoeken van het forum plaatst Tweakers alleen functionele en analytische cookies voor optimalisatie en analyse om de website-ervaring te verbeteren. Op het forum worden geen trackingcookies geplaatst. Voor het bekijken van video's en grafieken van derden vragen we je toestemming, we gebruiken daarvoor externe tooling die mogelijk cookies kunnen plaatsen.

Meer informatie vind je in ons cookiebeleid.

Sluiten

Forum cookie-instellingen

Bekijk de onderstaande instellingen en maak je keuze. Meer informatie vind je in ons cookiebeleid.

Functionele en analytische cookies

Deze cookies helpen de website zijn functies uit te voeren en zijn verplicht. Meer details

janee

    Cookies van derden

    Deze cookies kunnen geplaatst worden door derde partijen via ingesloten content en om de gebruikerservaring van de website te verbeteren. Meer details

    janee