Toon posts:

Audio crackle bij PCI-E Link downclock

Pagina: 1
Acties:

Acties:
  • +1Henk 'm!

  • MerlijnD
  • Registratie: Januari 2011
  • Laatst online: 05-08 13:56
Tweakers,

Vorige week heb ik mijn moederbord en cpu uitgewisseld voor een ander exemplaar (beide Z390 chipsets). Nu heb ik op mijn USB audio dac na het wisselen hiervan constant audio crackle. Ik kan dit forceren door bijvoorbeeld een zware youtube video op 1440p60 of hoger af te spelen.

Moederbord in kwestie is Z390 Aorus master.
Videokaart betreft een Sapphire r9 290x.
Usb dac niet van groot belang; (meerdere dac's getest allemaal zelfde probleem).
Onboarding audio (realtek) geeft geen crackle

Lang gezocht maar heb het kunnen vinden wat de oorzaak is:
- Bij gemiddelde GPU belasting (1440p/60 video youtube = constant crackle)
- Bij lage GPU belasting (720/480p video weinig/tot geen crackle)
- Bij hoge GPU belasting (1440p/60 video youtube + render test draaien in achtergrond = geen crackle).

Ik durf geen uitspraken te doen maar het lijkt alsof het te maken heeft met de pci-e lane downclock/handshake? (van 3.0 naar 1.1 en omgekeerd).

Ik kan dit helaas niet verifiëren (behalve door rendertest te draaien zodat het op 3.0 loopt dan geen crackle!).

Ter info; de video in kwestie waarbij ik constante crackle kan forceren https://www.youtube.com/watch?v=k0xlk2dcvIc

Weet iemand hoe ik permanent 3.0 kan forceren, zodat ik mijn test kan uitvoeren?
Wat ik gecheckt heb binnen de PCI-E link scope:
- Powerplan settings, link state management (nog steeds downlock).
- Bios DMI/PEG/PCH power saving uit/aan/auto (nog steeds downlock).
- C states (?) uit (nog steeds downlock)
- Alle overige bios opties die ook maar iets met power te maken hebben.
- Bios biedt geen optie om link speed te forceren (zoals bij aorus board op ryzen)

Buiten de scope:
USB kabels/poorten/andere dacs
Cpu overclock/geen overclock/voltages etc.
Default bios settings
Turbo/Speedstep etc
Kabels repluggen etc etc etc

Zonder GPU drivers ook geen crackle (DDU etc ook geprobeerd, oude drivers etc)

[Voor 4% gewijzigd door MerlijnD op 02-03-2021 13:25]


  • DMZ
  • Registratie: December 2010
  • Laatst online: 26-07 01:52
BIOS zou toch echt een menutke moeten hebben met een keuze voor de juiste PCIe versie die je dan handmatig kunt instellen. Echter, je kunt ook een 'force' doen door je videokaart constant een lage 3D load te laten uitvoeren, dan clockt ie niet terug naar 1.1 snelheden.

  • MerlijnD
  • Registratie: Januari 2011
  • Laatst online: 05-08 13:56
Versie ja, maar niet link speed. Je 2e opmerking is al beschreven in de main post. Dit gezegd kan ik hiermee niet verifiëren of het daadwerkelijk de link speed betreft of een ander type gpu load. Daarom vraag ik ook of ik of ik de link speed ergens vast kan zetten zonder dat ik gpu load toepas.

  • Umbrah
  • Registratie: Mei 2006
  • Nu online

Umbrah

The Incredible MapMan

Voor mij (Soundblaster XG6, niet echt een mega-dac oid) waren een hoop gekkigheden opgelost toen ik een USB-HUB er tussen zette. Mijn ervaring met USB audio equipment is dat het vaak nét iets meer power slurpt uit de poort dan de spec toestaat, en als de poort 'strict' is dan gaat je audio equipment gek doen (zonder dat je dat als statuscodes terug ziet...).

De data bus dus scheiden van de voeding was voor mij de gouden greep. En tsja... mega goedkoop: de USB-Hub van m'n monitor deed precies dat ;)

  • DMZ
  • Registratie: December 2010
  • Laatst online: 26-07 01:52
MerlijnD schreef op dinsdag 2 maart 2021 @ 15:10:
Versie ja, maar niet link speed. Je 2e opmerking is al beschreven in de main post. Dit gezegd kan ik hiermee niet verifiëren of het daadwerkelijk de link speed betreft of een ander type gpu load. Daarom vraag ik ook of ik of ik de link speed ergens vast kan zetten zonder dat ik gpu load toepas.
Mijn Z77 Extreme4 heeft dus _beide_ opties in het BIOS, daarom zeg ik dit. Link speed kunt je ook instellen.

De GPU load kwestie is simpel: kijk of je whine hebt met die kleine load, daarna heb je een baseline om te testen.

  • MerlijnD
  • Registratie: Januari 2011
  • Laatst online: 05-08 13:56
Umbrah schreef op dinsdag 2 maart 2021 @ 15:15:
Voor mij (Soundblaster XG6, niet echt een mega-dac oid) waren een hoop gekkigheden opgelost toen ik een USB-HUB er tussen zette. Mijn ervaring met USB audio equipment is dat het vaak nét iets meer power slurpt uit de poort dan de spec toestaat, en als de poort 'strict' is dan gaat je audio equipment gek doen (zonder dat je dat als statuscodes terug ziet...).

De data bus dus scheiden van de voeding was voor mij de gouden greep. En tsja... mega goedkoop: de USB-Hub van m'n monitor deed precies dat ;)
Kan het is proberen, blijf het gek vinden; letterlijk zelfde componenten alleen mobo en cpu uitgewisseld.
Wel ter opmerking; je spreekt over data bus en voeding. De voeding van de usb wordt niet gebruikt, de dacs hebben externe voedingen.

[Voor 8% gewijzigd door MerlijnD op 02-03-2021 16:02]


  • MerlijnD
  • Registratie: Januari 2011
  • Laatst online: 05-08 13:56
USB hub heeft niet geholpen. Kamp nog met het probleem.

  • Zinvol
  • Registratie: Februari 2012
  • Laatst online: 12:18
Het zou kunnen zijn dat je system latency te hoog wordt bij bepaalde loads, hierdoor kan ook crackling ontstaan, heb je al eens daar naar gekeken met een tool als LatencyMon?
Ik weet niet of het een optie is, maar je zou de sample rate eens lager kunnen zetten om te kijken of het dan nogsteeds gebeurt.

( dit kan beide door hardware of software komen, maar met het bovenstaande programma krijg je iig inzicht naar waar het vandaan komt als het een latency issue is. )

[Voor 46% gewijzigd door Zinvol op 05-03-2021 00:05]


  • MerlijnD
  • Registratie: Januari 2011
  • Laatst online: 05-08 13:56
Ja hoor, er is geen latency.

Ook al veel dieper gekeken met windows performance analyzer, ook daar geen latency.
Evt installeer ik dit weekend een frisse windows op een extra ssd; mocht het probleem dan nog bestaan dan gok ik meer richting een hardware probleem.

[Voor 39% gewijzigd door MerlijnD op 05-03-2021 09:35]


  • MerlijnD
  • Registratie: Januari 2011
  • Laatst online: 05-08 13:56
Met een nieuwe videokaart is het probleem weg. Opgelost dus, erg vreemd.
Pagina: 1



Nintendo Switch (OLED model) Apple iPhone SE (2022) LG G1 Google Pixel 6 Call of Duty: Vanguard Samsung Galaxy S22 Garmin fēnix 7 Nintendo Switch Lite

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2022 Hosting door True

Tweakers maakt gebruik van cookies

Tweakers plaatst functionele en analytische cookies voor het functioneren van de website en het verbeteren van de website-ervaring. Deze cookies zijn noodzakelijk. Om op Tweakers relevantere advertenties te tonen en om ingesloten content van derden te tonen (bijvoorbeeld video's), vragen we je toestemming. Via ingesloten content kunnen derde partijen diensten leveren en verbeteren, bezoekersstatistieken bijhouden, gepersonaliseerde content tonen, gerichte advertenties tonen en gebruikersprofielen opbouwen. Hiervoor worden apparaatgegevens, IP-adres, geolocatie en surfgedrag vastgelegd.

Meer informatie vind je in ons cookiebeleid.

Sluiten

Toestemming beheren

Hieronder kun je per doeleinde of partij toestemming geven of intrekken. Meer informatie vind je in ons cookiebeleid.

Functioneel en analytisch

Deze cookies zijn noodzakelijk voor het functioneren van de website en het verbeteren van de website-ervaring. Klik op het informatie-icoon voor meer informatie. Meer details

janee

    Relevantere advertenties

    Dit beperkt het aantal keer dat dezelfde advertentie getoond wordt (frequency capping) en maakt het mogelijk om binnen Tweakers contextuele advertenties te tonen op basis van pagina's die je hebt bezocht. Meer details

    Tweakers genereert een willekeurige unieke code als identifier. Deze data wordt niet gedeeld met adverteerders of andere derde partijen en je kunt niet buiten Tweakers gevolgd worden. Indien je bent ingelogd, wordt deze identifier gekoppeld aan je account. Indien je niet bent ingelogd, wordt deze identifier gekoppeld aan je sessie die maximaal 4 maanden actief blijft. Je kunt deze toestemming te allen tijde intrekken.

    Ingesloten content van derden

    Deze cookies kunnen door derde partijen geplaatst worden via ingesloten content. Klik op het informatie-icoon voor meer informatie over de verwerkingsdoeleinden. Meer details

    janee