Cookies op Tweakers

Tweakers is onderdeel van DPG Media en maakt gebruik van cookies, JavaScript en vergelijkbare technologie om je onder andere een optimale gebruikerservaring te bieden. Ook kan Tweakers hierdoor het gedrag van bezoekers vastleggen en analyseren. Door gebruik te maken van deze website, of door op 'Cookies accepteren' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt? Bekijk dan ons cookiebeleid.

Meer informatie
Toon posts:

SOM formule geeft 0 aan

Pagina: 1
Acties:

Onderwerpen

Vraag


  • bebudding
  • Registratie: maart 2021
  • Laatst online: 02-03 10:21
Hoi, ik heb een SOM-formule die ik vaker in mijn worksheet heb gebruikt, welke de uitkomsten van som-formules van 4 andere cellen optelt. De formule is heel simpel:

=SOM(F36+F39+F41+F44)

Als ik op de formule knop klik geeft hij ook de juiste uitkomst, alleen in de cel toont hij het getal 0.

Iemand enig idee hoe dit kan. Ik heb al andere formules (die ook zo werkten) gekopieerd en geplakt. Ik heb de formule in een andere cel gezet. Maar hij blijft 0 geven. Alle cellen hebben eigenschap 'getal'.

Hopelijk kan iemand mij hiermee helpen
...

Alle reacties


  • Blauwschaap
  • Registratie: december 2012
  • Laatst online: 20:48
Excel geeft verder geen errors aan (zo'n uitroeptekentje in de cel)?

Weet je zeker dat alle cellen dezelfde eigenschappen hebben?

Tel je hele getallen bij elkaar op of zitten er ook fracties bij?

Check ook even of je niet per ongeluk handmatig berekenen aan hebt staan. Met F9 kun je forceren dat alle formules gaan herberekenen.

[Voor 25% gewijzigd door Blauwschaap op 02-03-2021 10:07]


  • g0tanks
  • Registratie: oktober 2008
  • Laatst online: 00:11

g0tanks

Moderator CSA
bebudding schreef op dinsdag 2 maart 2021 @ 09:51:
Als ik op de formule knop klik geeft hij ook de juiste uitkomst, alleen in de cel toont hij het getal 0.
Wat bedoel je eigenlijk met 'de formule knop'?

Ultrawide gaming setup: AMD Ryzen 7 2700X | NVIDIA GeForce RTX 2080 | Dell Alienware AW3418DW


  • bebudding
  • Registratie: maart 2021
  • Laatst online: 02-03 10:21
Excel geeft geen foutmelding idd.

Ja, alle cellen hebben eigenschap getal met twee decimalen

Het zijn drie getallen met cijfers achter de komma en 1 heel getal. Het probleem trad ook pas op toen ik de vierde cel (het hele getal) toevoegde aan de SOM formule. Maar die cel heeft wel eigenschap getal en wordt in de cel ook met twee nullen achter de komma getoond. Alleen in de formule zie ik dat dat excel het weergeeft als alleen het hele getal, zonder de nullen achter de komma.

  • Patrick_6369
  • Registratie: april 2010
  • Laatst online: 21:31
Zet eens een screenshot van je werkblad hier neer, dan zien we misschien wat meer.

Offtopic:De formule =SOM(A1+A3+A5) is een beetje dubbelop. De nette Excel-syntaxis is:
code:
1
2
3
4
5
=SOM(A1;A3;A5)

[b]OF[/b]

=A1+A3+A5

Maar doet niks af aan het feit dat het in principe wel zou moeten werken zoals jij de formule hebt opgebouwd.

[Voor 6% gewijzigd door Patrick_6369 op 02-03-2021 10:11]

Hier zou een handtekening kunnen staan.



Apple iPad Pro (2021) 11" Wi-Fi, 8GB ram Microsoft Xbox Series X LG CX Google Pixel 5a 5G Sony XH90 / XH92 Samsung Galaxy S21 5G Sony PlayStation 5 Nintendo Switch Lite

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2021 Hosting door True