Toon posts:

formule met als

Pagina: 1
Acties:

Onderwerpen

Vraag


  • Peter Dreves
  • Registratie: februari 2021
  • Laatst online: 01-03 18:37
Mijn vraag
...met de formule

als(A1=B1;"klopt";"klopt niet")

als ik in cel A1 een getal groter dan 7,77 in typ krijg ik de waarde vals terug ( cel B1 maak ik kloppend.)

Of ik moet een getal in A! groter dan 207,78 intypen dan krijg ik de waarde waar terug wederom maak ik cel
B1 kloppend.

waar ligt dat aan.

Relevante software en hardware die ik gebruik

EXEL

Wat ik al gevonden of geprobeerd heb
...

Beste antwoord (via F_J_K op 25-02-2021 21:40)


  • Peter Dreves
  • Registratie: februari 2021
  • Laatst online: 01-03 18:37
dank jullie wel ik gebruik nu de formule

=ALS(ABS(F1-L1)<0,001;"klopt";"klopt niet")

die werkt wel

Alle reacties


  • g0tanks
  • Registratie: oktober 2008
  • Laatst online: 17:09

g0tanks

Moderator CSA
Peter Dreves schreef op woensdag 24 februari 2021 @ 20:32:
Mijn vraag
...met de formule

als(A1=B1;"klopt";"klopt niet")

als ik in cel A1 een getal groter dan 7,77 in typ krijg ik de waarde vals terug ( cel B1 maak ik kloppend.)

Of ik moet een getal in A! groter dan 207,78 intypen dan krijg ik de waarde waar terug wederom maak ik cel
B1 kloppend.

waar ligt dat aan.

Relevante software en hardware die ik gebruik

EXEL

Wat ik al gevonden of geprobeerd heb
...
Welkom op Tweakers. :)

Ik moet eerlijk zeggen dat ik je post niet begrijp. Het is onduidelijk wat je wil bereiken en wat nou de waarde van B1 is. Kan je het nog een keer proberen te formuleren?

Ultrawide gaming setup: AMD Ryzen 7 2700X | NVIDIA GeForce RTX 2080 | Dell Alienware AW3418DW


  • Peter Dreves
  • Registratie: februari 2021
  • Laatst online: 01-03 18:37
€ 3,00 = cel A1

klopt niet als(A1=B1:"klopt;"klopt niet;)

€ 3,00 = cel B1

ik krijg de waarde vals (niet waar) maar het is waar

  • g0tanks
  • Registratie: oktober 2008
  • Laatst online: 17:09

g0tanks

Moderator CSA
Peter Dreves schreef op woensdag 24 februari 2021 @ 21:48:
€ 3,00 = cel A1

klopt niet als(A1=B1:"klopt;"klopt niet;)

€ 3,00 = cel B1

ik krijg de waarde vals (niet waar) maar het is waar
Als beide cellen gelijk zijn zou je dat inderdaad niet moeten krijgen. Weet je zeker dat ze gelijk zijn? Krijg je het ook als je letterlijk B1 kopiëert naar A1? Kan je een screenshot van je Excelbestand plaatsen?

Ultrawide gaming setup: AMD Ryzen 7 2700X | NVIDIA GeForce RTX 2080 | Dell Alienware AW3418DW


  • sypie
  • Registratie: oktober 2000
  • Niet online
Je moet denk ik beter kijken naar de aanhalingstekens/puntkomma in plaats van dubbele punt.

Net even een test gedaan.
Cel A1 = 3
Cel B1 = 3
Cel C1 bevat deze formule:
code:
1
=ALS(A1=B1;"waar";"niet waar")


Hiermee krijg je 'm wel goed.

[Voor 11% gewijzigd door sypie op 24-02-2021 22:27]


  • Peter Dreves
  • Registratie: februari 2021
  • Laatst online: 01-03 18:37
=ALS(F1=L1;"klopt";"klopt niet")

dit is de formule die ik gebruik

  • sypie
  • Registratie: oktober 2000
  • Niet online
Bij mij klopt die zoals je 'm hier geplakt hebt. Excel versie 16.46 (21021202) voor de Mac.

Doet die het bij jou ook of krijg je nog steeds gekke dingen?

  • g0tanks
  • Registratie: oktober 2008
  • Laatst online: 17:09

g0tanks

Moderator CSA
Peter Dreves schreef op woensdag 24 februari 2021 @ 22:30:
=ALS(F1=L1;"klopt";"klopt niet")

dit is de formule die ik gebruik
Met de formule is niks mis. Het ligt dus aan de manier waarop je F1 en L1 invult. Zonder een screenshot te delen wordt het voor ons lastig om te zeggen wat er mis is.

Ultrawide gaming setup: AMD Ryzen 7 2700X | NVIDIA GeForce RTX 2080 | Dell Alienware AW3418DW


  • D-Three
  • Registratie: oktober 2001
  • Laatst online: 14:13
Peter Dreves schreef op woensdag 24 februari 2021 @ 22:30:
=ALS(F1=L1;"klopt";"klopt niet")

dit is de formule die ik gebruik
Dit gebeurt soms in excel, heb ik ook nog gehad. Het komt omdat de getallen op een heleboel cijfers na de komma toch niet gelijk zijn. Waarschijnlijk is het getal in F1 of L1 een berekende waarde ofzo?

Doe eens
=ABS(F1-L1)*1000000
Er is een kans dat die uitkomst niet 0 is

Waarschijnlijk werkt dit wel:
=ALS(AFRONDEN(F1;2)=AFRONDEN(F1;2);"klopt";"klopt niet")

  • F_J_K
  • Registratie: juni 2001
  • Niet online

F_J_K

Moderator CSA/PB

Front verplichte underscores

Met screenshot trouwens ook lastig. Je zult zelf driedubbel moeten checken dat het inderdaad identiek is. Ook zonder afronding, zelfde datatype, etc. Er is bijv een kleine kans dat er afrondfoutjes ontstaan als je berekeningen doet. Excel rekent niet met (letterlijk) oneindige precisie.

In dergelijke gevallen wil je niet checken of A1=B1, maar bij. Of het minder dan één promille verschilt.

Edit: zeg ik een seconde te laat :P zie ook hierboven

[Voor 6% gewijzigd door F_J_K op 24-02-2021 23:50]

'Multiple exclamation marks,' he went on, shaking his head, 'are a sure sign of a diseased mind' (Terry Pratchett, Eric)


  • Wild Chocolate
  • Registratie: januari 2014
  • Laatst online: 07-09 21:31
Is één van de cellen de uitkomst van een berekening? Wellicht dat er dan in de decimalen nog een verschil zit. Als je slechts 2 decimalen laat zien (zoals bij bedragen), rekent Excel wel met de decimalen die daarna komen. Om je regel te laten kloppen, moeten beide waarden wel exact gelijk zijn.

Als dit het geval is, zou je dit kunnen voorkomen door de functie AFRONDEN te gebruiken. Zet daar als "getal" je oude berekening in, en na de ; het aantal decimalen (2 bij bedragen).

EDIT: Ik bedoelde dat je de oorspronkelijke berekening(en) zou laten afronden, zoals @D-Three het aangeeft, laat je de oorspronkelijke berekening intact en gebruik je afronden alleen voor de vergelijking. Dat is een charmantere oplossing (zeker als je later nog verder wilt rekenen met de bedragen).

[Voor 23% gewijzigd door Wild Chocolate op 24-02-2021 23:53]

iRacing Profiel


  • D-Three
  • Registratie: oktober 2001
  • Laatst online: 14:13
Bijna 3 dezelfde antwoorden binnen 1 minuut :P
F_J_K schreef op woensdag 24 februari 2021 @ 23:49:
In dergelijke gevallen wil je niet checken of A1=B1, maar bij. Of het minder dan één promille verschilt.
Zoiets bedoel je dan?
=ALS(ABS(F1-L1)<0,001;"klopt";"klopt niet")
Iets korter dan mijn formule, ik vind het beter ;)

[Voor 82% gewijzigd door D-Three op 24-02-2021 23:59]


  • Wild Chocolate
  • Registratie: januari 2014
  • Laatst online: 07-09 21:31
D-Three schreef op woensdag 24 februari 2021 @ 23:55:
Bijna 3 dezelfde antwoorden binnen 1 minuut :P

[...]

Zoiets bedoel je dan?
=ALS(ABS(F1-L1)<0,001;"klopt";"klopt niet")
Iets korter dan mijn formule, ik vind het beter ;)
Daar heb ik ook over nagedacht, maar typisch wil je dan ook weten of F1-L1 tussen 0,001 en -0,001 is. Dus dan moet je die formule alweer ingewikkelder maken. Met afronden doe je in feite hetzelfde wanneer je kiest om op 3 decimalen af te ronden.

[Voor 4% gewijzigd door Wild Chocolate op 25-02-2021 13:09]

iRacing Profiel


  • Valen_76
  • Registratie: oktober 2009
  • Laatst online: 17-08 18:38
Wild Chocolate schreef op donderdag 25 februari 2021 @ 13:08:
[...]


Daar heb ik ook over nagedacht, maar typisch wil je dan ook weten of F1-L1 tussen 0,001 en -0,001 is. Dus dan moet je die formule alweer ingewikkelder maken. Met afronden doe je in feite hetzelfde wanneer je kiest om op 3 decimalen af te ronden.
ABS resulteert altijd in een positief getal. Dus ABS(A1-B1)<0,001 detecteert of beide getallen maximaal minder dan 1 duizendste verschillen.

Dat is echter nog niet een promille zoals F_J_K voorstelt. Want dat is een relatief verhoudingsgetal. Dan zou het worden (ABS(A1/B1)-1)<0,001 . In andere woorden, tussen 99.9% en 100,1%

[Voor 3% gewijzigd door Valen_76 op 25-02-2021 15:18]


  • Wild Chocolate
  • Registratie: januari 2014
  • Laatst online: 07-09 21:31
Overigens lijkt een nauwkeurigheid op hele centen mij voldoende wanneer het zoals hier om bedragen gaat. Ga je op tiende centen afronden, dan houd je het probleem van TS in stand... Je ziet dezelfde bedragen maar de formule zegt dat ze niet gelijk zijn.

iRacing Profiel


Acties:
  • Beste antwoord
  • +2Henk 'm!

  • Peter Dreves
  • Registratie: februari 2021
  • Laatst online: 01-03 18:37
dank jullie wel ik gebruik nu de formule

=ALS(ABS(F1-L1)<0,001;"klopt";"klopt niet")

die werkt wel
Pagina: 1


Nintendo Switch (OLED model) Apple iPhone 13 LG G1 Google Pixel 6 Call of Duty: Vanguard Samsung Galaxy S21 5G Apple iPad Pro (2021) 11" Wi-Fi, 8GB ram Nintendo Switch Lite

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2021 Hosting door True

Tweakers maakt gebruik van cookies

Bij het bezoeken van het forum plaatst Tweakers alleen functionele en analytische cookies voor optimalisatie en analyse om de website-ervaring te verbeteren. Op het forum worden geen trackingcookies geplaatst. Voor het bekijken van video's en grafieken van derden vragen we je toestemming, we gebruiken daarvoor externe tooling die mogelijk cookies kunnen plaatsen.

Meer informatie vind je in ons cookiebeleid.

Sluiten

Forum cookie-instellingen

Bekijk de onderstaande instellingen en maak je keuze. Meer informatie vind je in ons cookiebeleid.

Functionele en analytische cookies

Deze cookies helpen de website zijn functies uit te voeren en zijn verplicht. Meer details

janee

    Cookies van derden

    Deze cookies kunnen geplaatst worden door derde partijen via ingesloten content en om de gebruikerservaring van de website te verbeteren. Meer details

    janee