Cookies op Tweakers

Tweakers is onderdeel van DPG Media en maakt gebruik van cookies, JavaScript en vergelijkbare technologie om je onder andere een optimale gebruikerservaring te bieden. Ook kan Tweakers hierdoor het gedrag van bezoekers vastleggen en analyseren. Door gebruik te maken van deze website, of door op 'Cookies accepteren' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt? Bekijk dan ons cookiebeleid.

Meer informatie

Vraag


  • silent785
  • Registratie: juli 2012
  • Laatst online: 30-05 09:54
Mijn vraag
Ik heb een nieuwe pc en heb daarop de laatste versie van PopOS geinstalleerd (20.04 LTS) maar de resolutie kan ik niet veranderen (staat op 1024 x 768).

Relevante software en hardware die ik gebruik
PopOS 20.04 LTS
AMD RX6800
AMD Ryzen 5 5600X
32GB RAM

Wat ik al gevonden of geprobeerd heb
- Deze driver van de officiele AMD site heb ik proberen te installeren:

Maar die geeft een foutmelding:
amdgpu-dkms is not configured yet
Dat blijkt iets met kernel te maken(popos heeft kernel 5.6 en drivers ondersteunen die niet :? ) en heb online gevonden dat ze aanraden om naar mainline kernel te switchen maar dat is een developer/debugging versie en dat gaat me wss conflicten geven met andere software (Docker enzo).
- Heb ook gewoon Ubuntu 20.04 LTS geprobeerd maar die geeft dezelfde foutmelding als bij PopOS.
- Manjaro geprobeerd en die werkt wel out of the box maar na een update boot hij niet meer (blijft vastzitten op boot logo)

[Voor 3% gewijzigd door silent785 op 20-02-2021 19:22]

Beste antwoord (via silent785 op 21-02-2021 21:30)


  • Hero of Time
  • Registratie: oktober 2004
  • Laatst online: 10-06 23:02

Hero of Time

Moderator NOS

There is only one Legend

silent785 schreef op zaterdag 20 februari 2021 @ 22:33:
Als ik `apt show amdvlk` uitvoer dan zie ik dat hij wel geinstalleerd is:
Dat is hetzelfde zeggen dat je voor Windows DirectX 12 hebt geïnstalleerd. Je moet het nog wel kunnen gebruiken en daar zorgt de driver voor.
[...]

Heb ook getest met Ubuntu 20.10 en daarmee werkt het ook niet.
Dat kan wel kloppen, want standaard is daar kernel 5.8 aanwezig. En hierboven is door @Compizfox aangegeven dat je minimaal 5.9 moet hebben.

Wil je het verschil zien? Installeer dan Debian Stable en activeer de backports repository. Daar vind je kernel 5.10. Helaas is de versie van de amdgpu driver voor Xorg iets ouder dan wat je bij Ubuntu hebt. Als de standaard versie van Debian Stable niet werkt, kan je besluiten om alvast te upgraden naar Bullseye (momenteel nog testing, maar de releasedatum is dichtbij).

Wil je al deze moeite niet, zoek dan hoe je de Ubuntu mainline kernel kan installeren. Er is een aparte ppa voor die je met Google zo gevonden kan hebben.
[...]

LTS is stabiel, heb niet de nieuwste features/gimmicks nodig.
Nee, LTS betekent langer ondersteuning. Ubuntu 20.10 is ook gewoon stabiel. Wat niet als stabiel gezien wordt, is 21.04 omdat die nog in 'ontwikkeling' is.

Commandline FTW | Tweakt met mate

Alle reacties


  • Hero of Time
  • Registratie: oktober 2004
  • Laatst online: 10-06 23:02

Hero of Time

Moderator NOS

There is only one Legend

Je kan zoeken naar de HWE kernel packages, daarmee krijg je kernel 5.8. Wellicht dat die beter werken.

De melding 'amdgpu-dkms is not configured yet' komt omdat er iets mist. Je geeft echter niet wat het nog mist, die melding is eerder getoond. Dat kan het package dkms zelf zijn, of de Linux headers om kernel modules te kunnen bouwen, of iets heel anders. Kijk dus even iets verder naar de meldingen die langs komen.

En in principe zou de Ubuntu repo de amdgpu driver moeten hebben. Maar je kaart kan te nieuw zijn voor de versie die beschikbaar is. Dat is een beetje het nadeel van een Ubuntu afgeleide distro nemen die alleen de LTS release neemt als basis. De nieuwste hardware wordt dan vaak niet ondersteund, omdat die veel later dan de distro release wordt uitgebracht.

Commandline FTW | Tweakt met mate


  • Kaspers
  • Registratie: juni 2004
  • Laatst online: 07-06 13:41
Ik zou eerst eens kijken of je het voor elkaar krijgt met de opensource drivers.

Ik heb even voor je gezocht.
Kaart RX6800 = RX 6000 series = RDNA 2 architecture



AMDGPU Driver: https://wiki.archlinux.org/index.php/AMDGPU

Hier vind je build+install instructies, ook voor ubuntu: https://github.com/GPUOpen-Drivers/AMDVLK, probeer dat eerst eens.

  • Shinji
  • Registratie: februari 2002
  • Laatst online: 22:52
Hero of Time schreef op zaterdag 20 februari 2021 @ 21:02:
Dat is een beetje het nadeel van een Ubuntu afgeleide distro nemen die alleen de LTS release neemt als basis. De nieuwste hardware wordt dan vaak niet ondersteund, omdat die veel later dan de distro release wordt uitgebracht.
Er is ook gewoon een Pop_Os 20.10 welke voor zover ik weet gewoon op Ubuntu 20.10 gebaseerd is maar ik kan het mis hebben. Misschien wil TS per se op LTS blijven aangezien er ook met Ubuntu 20.04 is geprobeerd en niet met 20.10.

  • Hero of Time
  • Registratie: oktober 2004
  • Laatst online: 10-06 23:02

Hero of Time

Moderator NOS

There is only one Legend

Shinji schreef op zaterdag 20 februari 2021 @ 21:35:
[...]

Er is ook gewoon een Pop_Os 20.10 welke voor zover ik weet gewoon op Ubuntu 20.10 gebaseerd is maar ik kan het mis hebben. Misschien wil TS per se op LTS blijven aangezien er ook met Ubuntu 20.04 is geprobeerd en niet met 20.10.
Ik houd niet bij hoeveel van de miljoenmiljard Ubuntu clones welke versie van Ubuntu ze gebruiken. Ik weet alleen dat Mint op de LTS bouwt omdat het gewoon teveel tijd kostte om elke release mee te lopen.
Pop_OS kan natuurlijk minder werk intensief zijn en wel gewoon elke 6 maanden mee komen. Dat lijkt je vermelding van het bestaan van Pop_OS 20.10 te suggereren. Zou gek zijn om een andere versienummer te gebruiken dan de basis.

Commandline FTW | Tweakt met mate


  • silent785
  • Registratie: juli 2012
  • Laatst online: 30-05 09:54
Kaspers schreef op zaterdag 20 februari 2021 @ 21:09:
Ik zou eerst eens kijken of je het voor elkaar krijgt met de opensource drivers.

Ik heb even voor je gezocht.
Kaart RX6800 = RX 6000 series = RDNA 2 architecture

[Afbeelding]

AMDGPU Driver: https://wiki.archlinux.org/index.php/AMDGPU

Hier vind je build+install instructies, ook voor ubuntu: https://github.com/GPUOpen-Drivers/AMDVLK, probeer dat eerst eens.
Ik heb de pre-built driver geinstalleerd maar ik merk geen verschil, kan nog steeds niet m'n resolutie kiezen na een reboot.
Als ik sudo lshw -c video uitvoer dan krijg ik het volgende te zien:
code:
1
2
3
4
5
6
7
8
9
10
11
12
  *-display UNCLAIMED       
       description: VGA compatible controller
       product: Advanced Micro Devices, Inc. [AMD/ATI]
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 0
       bus info: pci@0000:0c:00.0
       version: c3
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi vga_controller bus_master cap_list
       configuration: latency=0
       resources: memory:d0000000-dfffffff memory:e0000000-e01fffff ioport:e000(size=256) memory:fcc00000-fccfffff memory:c0000-dffff


Als ik `apt show amdvlk` uitvoer dan zie ik dat hij wel geinstalleerd is:
Hero of Time schreef op zaterdag 20 februari 2021 @ 21:02:
Je kan zoeken naar de HWE kernel packages, daarmee krijg je kernel 5.8. Wellicht dat die beter werken.

De melding 'amdgpu-dkms is not configured yet' komt omdat er iets mist. Je geeft echter niet wat het nog mist, die melding is eerder getoond. Dat kan het package dkms zelf zijn, of de Linux headers om kernel modules te kunnen bouwen, of iets heel anders. Kijk dus even iets verder naar de meldingen die langs komen.

En in principe zou de Ubuntu repo de amdgpu driver moeten hebben. Maar je kaart kan te nieuw zijn voor de versie die beschikbaar is. Dat is een beetje het nadeel van een Ubuntu afgeleide distro nemen die alleen de LTS release neemt als basis. De nieuwste hardware wordt dan vaak niet ondersteund, omdat die veel later dan de distro release wordt uitgebracht.
Heb ook getest met Ubuntu 20.10 en daarmee werkt het ook niet.
Shinji schreef op zaterdag 20 februari 2021 @ 21:35:
[...]


Er is ook gewoon een Pop_Os 20.10 welke voor zover ik weet gewoon op Ubuntu 20.10 gebaseerd is maar ik kan het mis hebben. Misschien wil TS per se op LTS blijven aangezien er ook met Ubuntu 20.04 is geprobeerd en niet met 20.10.
LTS is stabiel, heb niet de nieuwste features/gimmicks nodig.

  • pporrio
  • Registratie: februari 2010
  • Laatst online: 12-06 17:08
Misschien heb je iets aan deze link:
https://forum.level1techs...d-runing-guide-wip/164137

Mijn platencollectie


  • Compizfox
  • Registratie: januari 2009
  • Laatst online: 01:32

Compizfox

Bait for wenchmarks

Je hoeft niets te downloaden (en zeker niet van een website).

Drivers voor Radeon GPUs zijn vrij en zitten mainlined (ingebakken) in de kernel. Daar hoef je dus niets extra's voor te installeren. Je hebt alleen een userspace-gedeelte nodig voor OpenGL/Vulkan: dat zit in Mesa.

Hiervoor is het wel handig als je distributie draait die een beetje een recente kernel levert, zeker als je zo'n nieuwe GPU hebt.

Linux 5.6 is dat niet; je hebt minstens Linux 5.9 nodig voor RX6000. Ik zou je aanraden om juist geen LTS-distro te draaien. Pak wat moderns (we zitten op Linux 5.11 tegenwoordig) en het zou out-of-the-box moeten werken.


silent785 schreef op zaterdag 20 februari 2021 @ 22:33:
Als ik `apt show amdvlk` uitvoer dan zie ik dat hij wel geinstalleerd is:
[Afbeelding]
AMDVLK is een userspacedriver voor Vulkan. Daar moet je het niet bij zoeken.
[...]
LTS is stabiel, heb niet de nieuwste features/gimmicks nodig.
Nou, jawel. De nieuwste feature die je nodig hebt in dit geval is support voor je vrij recente GPU (in AMDGPU in de kernel).

TL;DR: De kernel die je hebt is te oud voor je GPU. Installeer een nieuwere kernel mits mogelijk, of update je distro naar een up-to-date versie die by default een recente kernel meelevert (dat betekent niet LTS).

[Voor 44% gewijzigd door Compizfox op 20-02-2021 23:33]


Acties:
  • Beste antwoord
  • +1Henk 'm!

  • Hero of Time
  • Registratie: oktober 2004
  • Laatst online: 10-06 23:02

Hero of Time

Moderator NOS

There is only one Legend

silent785 schreef op zaterdag 20 februari 2021 @ 22:33:
Als ik `apt show amdvlk` uitvoer dan zie ik dat hij wel geinstalleerd is:
Dat is hetzelfde zeggen dat je voor Windows DirectX 12 hebt geïnstalleerd. Je moet het nog wel kunnen gebruiken en daar zorgt de driver voor.
[...]

Heb ook getest met Ubuntu 20.10 en daarmee werkt het ook niet.
Dat kan wel kloppen, want standaard is daar kernel 5.8 aanwezig. En hierboven is door @Compizfox aangegeven dat je minimaal 5.9 moet hebben.

Wil je het verschil zien? Installeer dan Debian Stable en activeer de backports repository. Daar vind je kernel 5.10. Helaas is de versie van de amdgpu driver voor Xorg iets ouder dan wat je bij Ubuntu hebt. Als de standaard versie van Debian Stable niet werkt, kan je besluiten om alvast te upgraden naar Bullseye (momenteel nog testing, maar de releasedatum is dichtbij).

Wil je al deze moeite niet, zoek dan hoe je de Ubuntu mainline kernel kan installeren. Er is een aparte ppa voor die je met Google zo gevonden kan hebben.
[...]

LTS is stabiel, heb niet de nieuwste features/gimmicks nodig.
Nee, LTS betekent langer ondersteuning. Ubuntu 20.10 is ook gewoon stabiel. Wat niet als stabiel gezien wordt, is 21.04 omdat die nog in 'ontwikkeling' is.

Commandline FTW | Tweakt met mate


  • silent785
  • Registratie: juli 2012
  • Laatst online: 30-05 09:54
Bedankt, heb kernel geupdate naar 5.10.17 (stable versie volgens kernel.org) en nu is alles in orde. Heb deze stappen gevolgd:
https://www.how2shout.com...5-10-on-ubuntu-20-04-lts/
Pagina: 1


Apple iPad Pro (2021) 11" Wi-Fi, 8GB ram Microsoft Xbox Series X LG CX Google Pixel 5a 5G Sony XH90 / XH92 Samsung Galaxy S21 5G Sony PlayStation 5 Nintendo Switch Lite

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2021 Hosting door True