Cookies op Tweakers

Tweakers is onderdeel van DPG Media en maakt gebruik van cookies, JavaScript en vergelijkbare technologie om je onder andere een optimale gebruikerservaring te bieden. Ook kan Tweakers hierdoor het gedrag van bezoekers vastleggen en analyseren. Door gebruik te maken van deze website, of door op 'Cookies accepteren' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt? Bekijk dan ons cookiebeleid.

Meer informatie

Vraag


  • rdfeij
  • Registratie: september 2001
  • Laatst online: 19:36
In een bepaalde setup hebben we fysieke (windows2012R2 / 2016) servers hangen met een storage uitbreiding middels iSCSI (Free/Truenas).
Dit werkt voor het doel perfect. Het probleem zit hem erin als de netwerkverbinding met de iSCSI targets verbroken wordt. Na herstel van de verbinding blijven de targets/luns offline in de Windows omgevingen.

De iSCSI initiator in Windows blijft op dat moment hangen op reconnecting of disconnected en lijkt niet opnieuw verbinding te willen opbouwen.
Als ik in de de target initiator de betreffende target opzoek en op connect klik dan is alles in no-time weer online.

Het internet staat vol met het niet opnieuw willen verbinden nadat de Windows server herstart is, maar dat is hier dus niet aan de orde. De server blijft online, verbinding met iSCSI target valt weg en komt niet automatisch terug.

In mijn testomgeving ook getest met Windows target, geeft hetzelfde gedrag, dus het probleem lijkt hem in de Windows iSCSI-initiator te zitten. Deze test met Windows10, 2012r2 en 2019 iSCSI initiator. Dit geeft bij alle Windows versie hetzelfde resultaat.

Zijn er hier 'ervaringsdeskundigen'?

Alle reacties


  • Hero of Time
  • Registratie: oktober 2004
  • Laatst online: 17:09

Hero of Time

Moderator NOS

There is only one Legend

Wij hadden een server met 2012R2 die een iSCSI LUN had van een Synology diskstation. Als deze DS herstart werd, vanwege update of een power cycle, had Windows in 9 van de 10 gevallen de verbinding weer zelf hersteld. Omdat ik deze verbinding niet zelf heb opgezet, kan ik je niet vertellen of er speciale instellingen voor zijn gedaan. Wat het nu is kan ik helaas voor jou ook niet opzoeken, want het LUN is ondertussen verwijdert.

Maar mijn, an sich beperkte, ervaring is dat Windows het wel zelf kan herstellen.

Commandline FTW | Tweakt met mate


  • Question Mark
  • Registratie: mei 2003
  • Laatst online: 15:50

Question Mark

Moderator SWS/WOS

F7 - Nee - Ja

Maak eens een scsi-target aan op je Windows Server 2016 systeem, en kijk eens of het reconnecten vanaf de Windows 2012 machine dan wel goed gaat? (even één van beide Nic's disablen).

Dan kun je alvast uitsluiten of het probleem in Free/TrueNAS zit of in Windows.

MCSE NT4/2K/2K3, MCTS, MCITP, CCA, CCEA, CCEE, CCIA, CCNA, CCDA, CCNP, CCDP, VCP, CEH + zwemdiploma A & B


  • Brahiewahiewa
  • Registratie: oktober 2001
  • Laatst online: 19:12

Brahiewahiewa

boelkloedig

rdfeij schreef op dinsdag 2 februari 2021 @ 14:12:
... De server blijft online, verbinding met iSCSI target valt weg en komt niet automatisch terug...
Gebruik je een iSNS server?

QnJhaGlld2FoaWV3YQ==


  • HKLM_
  • Registratie: februari 2009
  • Laatst online: 23:12
rdfeij schreef op dinsdag 2 februari 2021 @ 14:12:
In een bepaalde setup hebben we fysieke (windows2012R2 / 2016) servers hangen met een storage uitbreiding middels iSCSI (Free/Truenas).
Dit werkt voor het doel perfect. Het probleem zit hem erin als de netwerkverbinding met de iSCSI targets verbroken wordt. Na herstel van de verbinding blijven de targets/luns offline in de Windows omgevingen.

De iSCSI initiator in Windows blijft op dat moment hangen op reconnecting of disconnected en lijkt niet opnieuw verbinding te willen opbouwen.
Als ik in de de target initiator de betreffende target opzoek en op connect klik dan is alles in no-time weer online.

Het internet staat vol met het niet opnieuw willen verbinden nadat de Windows server herstart is, maar dat is hier dus niet aan de orde. De server blijft online, verbinding met iSCSI target valt weg en komt niet automatisch terug.

In mijn testomgeving ook getest met Windows target, geeft hetzelfde gedrag, dus het probleem lijkt hem in de Windows iSCSI-initiator te zitten. Deze test met Windows10, 2012r2 en 2019 iSCSI initiator. Dit geeft bij alle Windows versie hetzelfde resultaat.

Zijn er hier 'ervaringsdeskundigen'?
Ik heb dit gehad met een HPE MSA SAN en heb dit gefixt binnen iSCSI manager. Ik zal morgen op kantoor voor je kijken hoe en wat dat heb ik nu op de bank niet 100% scherp :P

⛔Trackers of betalen...⛔


  • rdfeij
  • Registratie: september 2001
  • Laatst online: 19:36
Question Mark schreef op dinsdag 2 februari 2021 @ 15:33:
Maak eens een scsi-target aan op je Windows Server 2016 systeem, en kijk eens of het reconnecten vanaf de Windows 2012 machine dan wel goed gaat? (even één van beide Nic's disablen).

Dan kun je alvast uitsluiten of het probleem in Free/TrueNAS zit of in Windows.
Nee zoals ik aal aangaf maakt het niet uit of ik naar een TrueNas of Windows target verbind. De iSCSI-connector blijft niet opnieuw verbinden.
Nee. Per server hangen 2 iSCSI targets direct gekoppeld. Deze targets hebben verder geen ander doel dan die ene server meer schijfruimte geven (is voor een CCTV storage systeem. Er hangen 4 storage servers met elk 20TB aan storage. Elke server heeft op zijn 2e nic 2 extra targets van beiden 25TB hangen om 90 dagen recordings te halen.)
HKLM_ schreef op dinsdag 2 februari 2021 @ 20:26:
[...]


Ik heb dit gehad met een HPE MSA SAN en heb dit gefixt binnen iSCSI manager. Ik zal morgen op kantoor voor je kijken hoe en wat dat heb ik nu op de bank niet 100% scherp :P
Ik ben benieuwd. Hoor graag van je ! _/-\o_

  • HKLM_
  • Registratie: februari 2009
  • Laatst online: 23:12
@rdfeij Ik heb wel een dac cable waarbij ik de IQN / properties / MCS hard aan mijn target heb gekoppeld. Misschien kan je dat eens proberen binnen de manager.

⛔Trackers of betalen...⛔


  • rdfeij
  • Registratie: september 2001
  • Laatst online: 19:36
HKLM_ schreef op woensdag 3 februari 2021 @ 15:20:
@rdfeij Ik heb wel een dac cable waarbij ik de IQN / properties / MCS hard aan mijn target heb gekoppeld. Misschien kan je dat eens proberen binnen de manager.
Ik begrijp niet precies wat je bedoelt? DAC dus 10Gb direct aan elkaar??. Maar dat lost nog steeds mijn probleem niet op vermoed ik.

  • ElCondor
  • Registratie: juni 2001
  • Laatst online: 21-06 13:51

ElCondor

Geluk is Onmisbaar

rdfeij schreef op dinsdag 2 februari 2021 @ 21:05:

[...]

Nee. Per server hangen 2 iSCSI targets direct gekoppeld. Deze targets hebben verder geen ander doel dan die ene server meer schijfruimte geven (is voor een CCTV storage systeem. Er hangen 4 storage servers met elk 20TB aan storage. Elke server heeft op zijn 2e nic 2 extra targets van beiden 25TB hangen om 90 dagen recordings te halen.)
[...]
Ik weet zeker dat het werkt met een iSNS servertje. Dit is gewoon een standaard onderdeel van Windows (extra feature) en je moet dan in iedere connector de iSNS server opgeven. Daarna worden alle beschikbare iSCSI targets op de clients automatisch gevonden en en reconnecten ze bij uitval van de netwerk verbinding. Dat deden ze bij mij eerst ook niet zonder iSNS. Het inrichten daarvan is vrij eenvoudig en als een NAS iSCSI functionaltieit biedt, dan hebben ze meestal ook de mogelijkheid om de beschikbare targets te registreren bij een iSNS service. Je meest zeker oplossingsrichting, voor zover ik weet.

Hay 365 dias en un año y 366 occasiones para festejar (Boliviaans spreekwoord)

Pagina: 1


Apple iPad Pro (2021) 11" Wi-Fi, 8GB ram Microsoft Xbox Series X LG CX Google Pixel 5a 5G Sony XH90 / XH92 Samsung Galaxy S21 5G Sony PlayStation 5 Nintendo Switch Lite

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2021 Hosting door True