Cookies op Tweakers

Tweakers is onderdeel van DPG Media en maakt gebruik van cookies, JavaScript en vergelijkbare technologie om je onder andere een optimale gebruikerservaring te bieden. Ook kan Tweakers hierdoor het gedrag van bezoekers vastleggen en analyseren. Door gebruik te maken van deze website, of door op 'Cookies accepteren' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt? Bekijk dan ons cookiebeleid.

Meer informatie
Toon posts:

Remote desktop werkt over wifi, maar niet via kabel...

Pagina: 1
Acties:

  • bnwgraaf
  • Registratie: oktober 2008
  • Laatst online: 21-06 00:20
Ik werk nu alweer een tijd vanuit huis, maar heb het volgende probleem:

Achtergrond:
Ik werk via een VPN verbinding en neem daarbij mijn CAD workstation op de zaak over; de Lenovo laptop waarop ik dat doe is niet sterk genoeg om de CAD software lokaal te draaien.
Ik heb vier opties:
- TeamViewer
- Google Remote Desktop
- Windows RDP
- HP Remote Graphics (RGS)

Deze vier opties heb ik werkend via mijn wifi verbinding thuis.

Ik heb uiteindelijk gekozen voor de HP RGS software, welke bij de workstations wordt mee geleverd. De reden daarvoor is, dat die software standaard het gebruik van de 3DConnexion 3D muis ondersteund.


Probleem:
Mijn wifi verbinding op de laptop zakt regelmatig tot onder 5 Mbps, zodat de remote desktop zo goed als onbruikbaar wordt. Overigens hebben al mijn andere wifi apparaten dit probleem niet, maar dat terzijde.
Ik wil nu proberen verbinding via de kabel te maken om te kijken of de verbindingssnelheid op de laptop dan wel stabiel blijft.
De laptop (een Lenovo van de zaak) heeft geen ethernet poort, dus heb ik een USB-ethernet dongle van Eminent aangesloten.
Internet verbinding werkt en ik kan de VPN verbinding maken.

Het vreemde is alleen dat de remote desktop niet werkt.
Google Remote Desktop, Windows RDP en HP RGS kunnen geen van alle verbinding maken met de workstation op kantoor. Het lukt me alleen nog via TeamViewer...

Windows RDP geeft als melding:
"De computer kon geen verbinding maken met een andere consolesessie op de externe computer omdat er al een consolesessie wordt uitgevoerd"

De HP software geeft de volgende melding:
"Unable to connect to Sender. The receiver resolved the specified hostname or IP address, but cannot connect to the sender.Verify that the system is accessible on your network and that the Remote Graphics Sender service has been started. Be sure the sender is listening on a public IP address and is not blocked by a firewall."


Nogmaals: via de wifi verbinding lukt het wel!
Ik maak verbinding via het IP adres.
Ik kan de remote workstation vinden via een Ping commando.

Volgens Windows zijn de drivers up-to-date, en ik kan via internet geen nieuwere driver vinden. Ook Windows (10) is helemaal bijgewerkt.

  • jadjong
  • Registratie: juli 2001
  • Laatst online: 22:30
Als je wisselt tussen wifi en draad, log je dan uit op de remote computer of die je een disconnect?

  • powerboat
  • Registratie: december 2003
  • Laatst online: 19:52
Misschien contact opnemen met de beheerder :+ ?

  • bnwgraaf
  • Registratie: oktober 2008
  • Laatst online: 21-06 00:20
jadjong schreef op maandag 1 februari 2021 @ 20:31:
Als je wisselt tussen wifi en draad, log je dan uit op de remote computer of die je een disconnect?
Dat is een goede, daar had ik nog niet aan gedacht!

Als test heb ik het systeem op kantoor herstart, zodat die dus ook is afgemeld.
Ondertussen ook de laptop thuis een herstart gegeven en via de kabel weer contact met mijn router gemaakt en daarna met de VPN.
Tot daaraan toe geen probleem, maar rdp en rgs krijgen nog altijd geen verbinding als ik op de kabel zit....
powerboat schreef op maandag 1 februari 2021 @ 20:38:
Misschien contact opnemen met de beheerder :+ ?
Ook een goed idee, maar die komt er ook nog niet uit, dus ik hoopte dat hier iemand een geniale ingeving zou hebben....

  • RobbyTown
  • Registratie: april 2007
  • Laatst online: 21:39

RobbyTown

Grootmeester

Enige wat ik zo kan bedenken is het volgende

Op welke type staat je bekabelde verbinding? Private of Public? Mocht hij public staan verander naar private wellicht opgelost.

Je wifi zal dan al op private staan aangezien daar dus werkt.

  • jadjong
  • Registratie: juli 2001
  • Laatst online: 22:30
RobbyTown schreef op dinsdag 2 februari 2021 @ 01:51:

Op welke type staat je bekabelde verbinding? Private of Public? Mocht hij public staan verander naar private wellicht opgelost.
Dat is een goede! Misschien dat firewall profielen roet in het eten gooien. Disable de firewall tijdelijk even compleet om die uit te sluiten.

  • bnwgraaf
  • Registratie: oktober 2008
  • Laatst online: 21-06 00:20
Dank jullie weer voor je reacties.

Firewall had ik al uit staan om te proberen.
Ik heb de netwerkkabel op "Private" gezet, helaas zonder resultaat.

Ik loop toch tegen wat typische dingetjes aan.
Normaal ben ik gewend, dat wanneer je de netwerk kabel in de computer steekt, dat je automatisch een bekabelde verbinding krijgt, maar dat gebeurt niet; Ook als je de wifi verbinding uit zet, pakt hij de kabel verbinding niet op.
Wanneer ik verbinding via de kabel heb, en ik trek de kabel los, pakt hij ook niet automatisch wifi op. Sterker nog, als ik dan handmatig probeer de wifi te verbinden, lukt dat ook niet goed.
Het systeem herstarten lost dit dan weer op.

  • powerboat
  • Registratie: december 2003
  • Laatst online: 19:52
... USB-ethernet dongle van Eminent aangesloten. ...
Tja ... :+, effin zonder gekheid....

- Heb je gekeken of je LAN adapter een ip adres krijgt uit je (thuis)netwerk reeks?
- Heb je daarna gekeken of je een VPN connectie krijgt en je VPN adapter een ip adres krijgt uit de VPN reeks?
- Mocht je kunnen connecteren naar je VPN en een IP adres krijgt, doe dan eens een tracert (traceroute) naar je workstation en kijken of ie ergens blijft hangen;

Ik heb weleens met een IPSec verbinding achter NAT gehad dat de VPN tunnel wel werd opgezet maar
dat ik er met geen mogelijkheid verkeer er doorheen kon routeren.

  • Enforcer
  • Registratie: februari 2001
  • Niet online
Zou je eens het verschil kunnen posten tussen de twee situaties (bekabeld en via wifi) met het volgende in een DOS Prompt (OpdrachtPrompt), zodra je verbonden bent met de VPN.

code:
1
ipconfig /all


Ik vermoed dat je via WiFi de Gateway van je VPN gebruikt (full-tunneling) en via bekabeld gewoon de gateway van je eigen thuisnetwerk (split-tunneling), dan kan één en ander weleens mis gaan in de routes die het moet afleggen.

Daarnaast kun je ook nog eens in een DOS Prompt (OpdrachtPrompt), het volgende commando gebruiken bij beide situaties:

code:
1
route print


Ook kun je daarnaast nog eens hetzelfde uitvoeren met een traceroute actie zodat je weet over welke verbindingen de route loopt:

code:
1
tracert <ip-adres-van-je-werk-pc>

[Voor 41% gewijzigd door Enforcer op 02-02-2021 09:27]


  • Frogmen
  • Registratie: januari 2004
  • Niet online
Ik gok dat je budget Eminent oplossing misschien wel de boosdoener is, als het kan zou ik die eens uitwisselen. Snap dat voor het moment dat lastig is, heb je drivers moeten installeren of zijn die er?

Voor een Tweaker is de weg naar het resultaat net zo belangrijk als het resultaat.


  • jadjong
  • Registratie: juli 2001
  • Laatst online: 22:30
Frogmen schreef op dinsdag 2 februari 2021 @ 09:23:
Ik gok dat je budget Eminent oplossing misschien wel de boosdoener is, als het kan zou ik die eens uitwisselen. Snap dat voor het moment dat lastig is, heb je drivers moeten installeren of zijn die er?
Hij kan de host wel pingen he....

  • bnwgraaf
  • Registratie: oktober 2008
  • Laatst online: 21-06 00:20
Dank jullie voor al het meedenken!
Dankzij jullie bovenstaande ideeën heb ik het volgende ontdekt:

Via de wifi adapter kreeg het systeem het IP adres 192.168.2.100 toegewezen, maar via de netwerkadapter (kabel) het adres 192.168.2.9

En laat nou net dat IP adres het adres zijn van mijn desktop op kantoor waar ik verbinding mee wil maken!
Ik heb de USB adapter nu via de router een vast IP adres gegeven, 192.168.2.3

En nu kan ik weer wel de remote desktop gebruiken (HP RGS).

Maar..... daarmee is mijn oorspronkelijke probleem niet opgelost. Dat was namelijk de lage snelheid.

Ik heb wel iets ontdekt:
Als ik geen VPN verbinding heb, ligt die rond de 60 Mbps.
Maak ik de VPN verbinding en doe dan weer een speed test, dan zit ik nog maar rond 5Mbps!

Ik vermoed dat ik met deze nieuwe bevindingen toch nog maar eens bij de systeembeheerder moet aankloppen. Mogelijk zit er in de VPN iets neit helemaal okay.

Of hebben jullie nog zaken die ik lokaal kan nakijken?

  • Mijzelf
  • Registratie: september 2004
  • Niet online
Kun je het subnet thuis veranderen? Ik kan me levendig voorstellen dat je snelheid inzakt omdat je routing niet kan beslissen of een pakketje de LAN in moet, of de VPN. Ze zitten immers in hetzelfde subnet.

  • bnwgraaf
  • Registratie: oktober 2008
  • Laatst online: 21-06 00:20
Mijzelf schreef op dinsdag 2 februari 2021 @ 12:30:
Kun je het subnet thuis veranderen? Ik kan me levendig voorstellen dat je snelheid inzakt omdat je routing niet kan beslissen of een pakketje de LAN in moet, of de VPN. Ze zitten immers in hetzelfde subnet.
Hm, heb je het dan over de zogenaamde IP subnet mask instelling?

Daar heb ik nog nooit aan gezeten en ben niet bekend met de functie daarvan. Ik kan de instelling vinden in de router, maar gaan al mijn wifi apparaten in huis dan geen problemen met de verbinding krijgen? Mogelijk dat hier en daar in de instellingen van die apparaten de subnet ingesteld staat op 255.255.255.0

[Voor 30% gewijzigd door bnwgraaf op 02-02-2021 12:38]


  • Falcon
  • Registratie: februari 2000
  • Laatst online: 15:09

Falcon

Q.A. Engineer (.net/azure)

bnwgraaf schreef op dinsdag 2 februari 2021 @ 12:07:
Dank jullie voor al het meedenken!
Dankzij jullie bovenstaande ideeën heb ik het volgende ontdekt:

Via de wifi adapter kreeg het systeem het IP adres 192.168.2.100 toegewezen, maar via de netwerkadapter (kabel) het adres 192.168.2.9

En laat nou net dat IP adres het adres zijn van mijn desktop op kantoor waar ik verbinding mee wil maken!
Ik heb de USB adapter nu via de router een vast IP adres gegeven, 192.168.2.3

En nu kan ik weer wel de remote desktop gebruiken (HP RGS).

Maar..... daarmee is mijn oorspronkelijke probleem niet opgelost. Dat was namelijk de lage snelheid.

Ik heb wel iets ontdekt:
Als ik geen VPN verbinding heb, ligt die rond de 60 Mbps.
Maak ik de VPN verbinding en doe dan weer een speed test, dan zit ik nog maar rond 5Mbps!

Ik vermoed dat ik met deze nieuwe bevindingen toch nog maar eens bij de systeembeheerder moet aankloppen. Mogelijk zit er in de VPN iets neit helemaal okay.

Of hebben jullie nog zaken die ik lokaal kan nakijken?
Loopt jouw internetgateway via jouw bedrijf als je met VPN bent verbonden (ipconfig /all)?

"You never come second by putting other people first"


  • Mijzelf
  • Registratie: september 2004
  • Niet online
bnwgraaf schreef op dinsdag 2 februari 2021 @ 12:37:
[...]


Hm, heb je het dan over de zogenaamde IP subnet mask instelling?
Nee. Je huidige subnet is 192.168.2.0/24, of in oudere notatie 192.168.2.0 netmask 255.255.255.0. Dat is hetzelfde subnet als waar je PC op je werk instaat. Je zou je locale subnet kunnen veranderen in 192.168.3.0/24, of zo. De mask blijft gelijk.
gaan al mijn wifi apparaten in huis dan geen problemen met de verbinding krijgen?
Ja. In de eerste instantie zijn ze hun verbinding kwijt. (Ze houden hun 'oude' IP adres in het verkeerde subnet), maar met herverbinden wordt dat opgelost daar de DHCP server ze een nieuw IP adres toekent.

  • bnwgraaf
  • Registratie: oktober 2008
  • Laatst online: 21-06 00:20
Mijzelf schreef op dinsdag 2 februari 2021 @ 12:53:
[...]

Nee. Je huidige subnet is 192.168.2.0/24, of in oudere notatie 192.168.2.0 netmask 255.255.255.0. Dat is hetzelfde subnet als waar je PC op je werk instaat. Je zou je locale subnet kunnen veranderen in 192.168.3.0/24, of zo. De mask blijft gelijk.

[...]

Ja. In de eerste instantie zijn ze hun verbinding kwijt. (Ze houden hun 'oude' IP adres in het verkeerde subnet), maar met herverbinden wordt dat opgelost daar de DHCP server ze een nieuw IP adres toekent.
Okay, ik kreeg vanuit de systeembeheerder al eenzelfde hint.

Voordat ik me daaraan ga wagen:
- Ik verander de range.
- De apparaten waaraan ik in de router een vast ip adres gegeven heb, moet ik daar ook aanpassen.

Dan zou het weer moeten werken (eventueel na herverbinden).

Wel heb ik een aantal hobbyprojectjes met esp8266 wifi printjes, waar in de code een IP adres "hard gecodeerd" staat; die zal ik dan natuurlijk ook moeten aanpassen.

Maar verder zijn dat dan de stappen, vermoed ik?

  • Mijzelf
  • Registratie: september 2004
  • Niet online
bnwgraaf schreef op dinsdag 2 februari 2021 @ 12:58:
Maar verder zijn dat dan de stappen, vermoed ik?
Ja. Als je het subnet veranderd moeten alle apparaten in het netwerk een nieuw IP adres hebben. DHCP clients regelen dat zelf wel, op den duur, maar vaste IP adressen zul je met de hand moeten veranderen.

Overigens kan het handig zijn om eerst de vaste IP adressen te veranderen, nu je ze nog kunt bereiken, en dan pas het subnet aanpassen.

[Voor 15% gewijzigd door Mijzelf op 02-02-2021 13:03]


  • bnwgraaf
  • Registratie: oktober 2008
  • Laatst online: 21-06 00:20
Ik ga dat denk ik eens op mijn gemak één van de komende avonden omzetten.

Een iets offtopic vraagje:
Ik heb vanuit vroeger de meeste apparaten in mijn huis vanuit de router een vast ip adres mee gegeven en dat in een lijstje bij gehouden.

Ik twijfel echter of dat handig is of dat ik beter dynamische adressen kan doen? Sowieso is mijn range met vast ip adressen die ik kan instellen ondertussen vol, dus elk nieuw apparaat krijgt een dynamisch adres.

Is dat een kwestie van voorkeur of zijn er echt wel duidelijke redenen om voor een vast danwel dynamisch IP adres te kiezen?

Ik begrijp dat je voor port forwarding een vast ip adres nodig hebt en ik heb zelf schakelaars gemaakt voor Hue verlichting. Die maakt gebruik van ESP wifi printjes die in slaap stand gaan en pas ontwaken wanneer je de schakelaar bedient. Daarvan kan ik me ook voorstellen dat het fijn is om daar een v ast adres aan te hangen, zodat de verbinding misschien een fractie sneller gemaakt wordt?

Ik heb ook een nas, daarvan lijkt het me ook fijn daar een vast adres aan te hangen.

Maar zaken als telefoons en tablets? Kunnen die niet net zo makkelijk gebruik maken van een dynamisch adres?

[Voor 33% gewijzigd door bnwgraaf op 02-02-2021 13:30]


  • Enforcer
  • Registratie: februari 2001
  • Niet online
bnwgraaf schreef op dinsdag 2 februari 2021 @ 12:07:
Als ik geen VPN verbinding heb, ligt die rond de 60 Mbps.
Maak ik de VPN verbinding en doe dan weer een speed test, dan zit ik nog maar rond 5Mbps!
Dat is dus het verschil tussen full-tunneling en split-tunneling;
- Bij full-tunneling gaat al het internet verkeer op die computer via de VPN naar de gateway (=internetverbinding) van je werk, dus als die verbinding daar maar 5Mbps is dan krijg je inderdaad ook maar 5Mbps bij Speedtest (je zit immers op de internetverbinding van je werk te internetten).
- Bij split-tunneling gaat al het internetverkeer gewoon via je eigen internet verbinding en alleen het verkeer wat gerouteerd moet worden via de VPN zal over die VPN lijn gaan.

Het maakt het wat lastiger dat je nu in dezelfde reeks zit als van je werk maar anders had je gewoon een vinkje uit kunnen zetten bij je VPN eigenschappen namelijk "Standaardgateway in het externe netwerk gebruiken" uitvinken. Daarmee voorkom je dus dat de gateway van je werk als standaard wordt ingesteld tijdens het gebruik van de VPN.

-edit-
Eigenlijk moet je dus zorgen voor 2 dingen:
- Thuis intern je gehele subnet veranderen naar een andere reeks die niet bij je werk gebruikt wordt (192.168.10.0/24 bv).
- Het vinkje uitzetten van standaardgateway in het externe netwerk gebruiken.

Als dat is gebeurd gaat het goed.

of....

Vinkje uitzetten van standaardgateway EN een specifieke route toevoegen op je computer dat alleen je werk pc via de vpn gaat...
route add 192.168.2.100 MASK 255.255.255.255 <ip_adres_van_je_vpn_gateway>
...hiermee geef je dus aan dat alleen en specifiek het ipadres 192.168.2.100 via een andere gateway moet lopen.

[Voor 23% gewijzigd door Enforcer op 02-02-2021 13:48]


  • bnwgraaf
  • Registratie: oktober 2008
  • Laatst online: 21-06 00:20
Enforcer schreef op dinsdag 2 februari 2021 @ 13:30:
[...]

Eigenlijk moet je dus zorgen voor 2 dingen:
- Thuis intern je gehele subnet veranderen naar een andere reeks die niet bij je werk gebruikt wordt (192.168.10.0/24 bv).
- Het vinkje uitzetten van standaardgateway in het externe netwerk gebruiken.

Als dat is gebeurd gaat het goed.

of....

Een specifieke route toevoegen op je computer dat alleen je werk pc via de vpn gaat.
Dank je voor de uitleg, dit hele verhaal is nog aardig leerzaam voor me geworden! :)

Ik begrijp dus dat bij full-tunneling de internetverbinding op de zaak de snelheid van het internet bepaald op het systeem waarmee ik thuis werk?
Als ik (via de remote verbinding) een speed test doe op de workstation op de zaak (dus via de internet browser op die workstation), kom ik op ongeveer 80 Mbps. Of legt dat workstation mogelijk nog een andere weg af naar internet (buiten de vpn om)?

Die isntelling voor full/split tunneling moet ik op mijn eigen router instellen?

  • Enforcer
  • Registratie: februari 2001
  • Niet online
bnwgraaf schreef op dinsdag 2 februari 2021 @ 13:49:
Die isntelling voor full/split tunneling moet ik op mijn eigen router instellen?
Die instelling moet je op je eigen computer doen (adapteropties/tcpip/geavanceerd), google het eens :)
code:
1
2
3
4
5
6
7
8
Right-click the Windows 10 Start button and go to Network Connections.
Click Change adapter options.
Right-click your VPN connection and open Properties.
In the Networking tab, select Internet Protocol Version 4 (TCP/IPv4).
Click Advanced.
In the General tab, click Advanced.
Disable Use default gateway on remote network.
Restart your VPN connection.
Ik begrijp dus dat bij full-tunneling de internetverbinding op de zaak de snelheid van het internet bepaald op het systeem waarmee ik thuis werk?
Als ik (via de remote verbinding) een speed test doe op de workstation op de zaak (dus via de internet browser op die workstation), kom ik op ongeveer 80 Mbps. Of legt dat workstation mogelijk nog een andere weg af naar internet (buiten de vpn om)?
Er zijn verschillende scenario's denkbaar maar waar het om gaat bij full-tunneling is dat al je internet verkeer door de VPN tunnel heen gaat, die pakketjes moeten dus gecodeerd worden, door de tunnel heen, vervolgens weer gedecodeerd worden om zodoende weer goed afgeleverd te kunnen worden, dit (intensieve) proces daar merk je als eindgebruiker niks van maar heeft wel invloed op je snelheid. Terwijl bij je eigen internetverbinding dat hele (de)codeer spul er niet tussen hangt en dit dus niet van invloed is op je snelheid. Hoe strenger de VPN encryptie hoe meer invloed dit heeft op je snelheid.

[Voor 81% gewijzigd door Enforcer op 02-02-2021 14:10]


  • bnwgraaf
  • Registratie: oktober 2008
  • Laatst online: 21-06 00:20
Enforcer schreef op dinsdag 2 februari 2021 @ 13:54:
[...]

Die instelling moet je op je eigen computer doen (adapteropties/tcpip/geavanceerd), google het eens :)
Gelukt en de eerste test lijkt goed te zijn! Nu maar eens mee werken en kijken of het verbeterd is!

Bedankt weer en ik laat nog horen of het geholpen heeft.

  • Mijzelf
  • Registratie: september 2004
  • Niet online
bnwgraaf schreef op dinsdag 2 februari 2021 @ 13:17:
Ik ga dat denk ik eens op mijn gemak één van de komende avonden omzetten.

Een iets offtopic vraagje:
Ik heb vanuit vroeger de meeste apparaten in mijn huis vanuit de router een vast ip adres mee gegeven en dat in een lijstje bij gehouden.

Ik twijfel echter of dat handig is of dat ik beter dynamische adressen kan doen? Sowieso is mijn range met vast ip adressen die ik kan instellen ondertussen vol, dus elk nieuw apparaat krijgt een dynamisch adres.

Is dat een kwestie van voorkeur of zijn er echt wel duidelijke redenen om voor een vast danwel dynamisch IP adres te kiezen?
Een dynamisch adres is makkelijker. Je kunt dan zonder problemen je hele subnet wijzigen, als je wilt, en verder werkt de apparatuur direct als je hem in een ander netwerk hangt. (Mits er een DHCP server aanwezig is). Zelf vind ik het wel fijn dat mijn router een lijstje van aangesloten apparaten bijhoud (DHCP leases).
Ik begrijp dat je voor port forwarding een vast ip adres nodig hebt
Vast heb je ook nog in twee smaken. Je kunt ze instellen op het apparaat zelf, of in je DHCP server een reservering maken voor dat MAC adres. Het laatste is het beste van 2 werelden. Een vast adres om te forwarden, en een centrale plek voor de administratie.

Overigens hebben de meeste routers een DNS server die tevens de hostnames van de DHCP leases resolved. Je kunt dan dus je apparatuur via hostname bereiken, zonder je druk te hoeven maken over het IP adres.
ik heb zelf schakelaars gemaakt voor Hue verlichting. Die maakt gebruik van ESP wifi printjes die in slaap stand gaan en pas ontwaken wanneer je de schakelaar bedient. Daarvan kan ik me ook voorstellen dat het fijn is om daar een v ast adres aan te hangen, zodat de verbinding misschien een fractie sneller gemaakt wordt?
Misschien. DHCP adres aanvraag kost wat tijd, misschien wel een of twee seconden. Vaak gebruiken routers dnsmasq als DHCP/DNS server, en die doet altijd een ping voor hij een IP adres uitreikt, gewoon om te kijken of het echt vrij is. Dat kost wel extra tijd, natuurlijk.
Maar zaken als telefoons en tablets? Kunnen die niet net zo makkelijk gebruik maken van een dynamisch adres?
Uiteraard.
Pagina: 1


Apple iPad Pro (2021) 11" Wi-Fi, 8GB ram Microsoft Xbox Series X LG CX Google Pixel 5a 5G Sony XH90 / XH92 Samsung Galaxy S21 5G Sony PlayStation 5 Nintendo Switch Lite

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2021 Hosting door True