Cookies op Tweakers

Tweakers is onderdeel van DPG Media en maakt gebruik van cookies, JavaScript en vergelijkbare technologie om je onder andere een optimale gebruikerservaring te bieden. Ook kan Tweakers hierdoor het gedrag van bezoekers vastleggen en analyseren. Door gebruik te maken van deze website, of door op 'Cookies accepteren' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt? Bekijk dan ons cookiebeleid.

Meer informatie
Toon posts:

Apache 2.2.22 - hoe samesite=none zetten

Pagina: 1
Acties:

Vraag


  • Promy
  • Registratie: oktober 2002
  • Laatst online: 11-06 09:38
Ik heb enkele raspberry pi's draaien.
1 ervan is gebruik ik voor emoncms (openenergymonitor). Een andere draait als interne webserver voor m'n scriptjes die verschillende zaken aansturen (verlichting, weerstation,...).

In 1 van de pagina's op de webserver laad ik in een iframe de interface van emoncms in. Dat werkte altijd perfect tot google de samesite ea cookies begon te blokkeren.
Nu werkt het nog altijd in firefox maar niet in chrome. En belangrijker , niet in de standaard browser van m'n android telefoon.

Ik heb al gezocht via google, maar ik kan niet terugvinden waar ik dat kan veranderen, of op welke van beide pi's ik iets zou moeten veranderen :(

Weet er iemand wat ik kan aanpassen omdat het terug zou werken op een android telefoon? _/-\o_

Alle reacties


  • Jaaap
  • Registratie: februari 2000
  • Niet online
Draait de parent frame op https?
Draait de iframe op https?
Sinds wanneer werkt het niet meer?
Wat is de foutmelding die je krijgt?
Laadt het iframe helemaal niet meer in of gedeeltelijk?
Heb je een screenshot?

Zure regen: vnl. zwaveldioxide (en stikstofoxiden en ammoniak), 89% minder sinds 1980: FIXED
Gat in ozonlaag: vnl. drijfgassen (CFK's), gat dicht in 2060: FIXED
Broeikaseffect: vnl. CO₂ (en methaan en lachgas), afbouw uitstoot begonnen


  • Promy
  • Registratie: oktober 2002
  • Laatst online: 11-06 09:38
@Jaaap
- de parent en de iframe draaien gewoon http (not secure, is binnen m'n eigen lan)
- het werkt zeker niet meer sinds september, misschien eerder
In emoncms kan je een dashboard als public instellen.
- als ik dit zo doe, dan laad het in maar komen de grafieken er niet in. ik krijg een foutmelding: "not configured or authentication not valid"
- als ik het niet public zet in emoncms dan vraagt hij om in te loggen, maar hij aanvaard de login niet.

In bv firefox werkt het wel zonder probleem. Als ik in chrome via chrome://flags/#same-site-by-default-cookies de "samesite by default cookies" op disabled EN "Cookies without SameSite must be secure" op disabled zet, dan werkt het ook in chrome. (slechts 1 van de 2 werkt niet)

  • Jaaap
  • Registratie: februari 2000
  • Niet online
"Cookies without SameSite must be secure" betekent dat het op https moet draaien dus dt zal stap 1 zijn.
Ik weet te weinig van emoncms om te zeggen hoe je de cookies aan moet passen voor stap 2.

Zure regen: vnl. zwaveldioxide (en stikstofoxiden en ammoniak), 89% minder sinds 1980: FIXED
Gat in ozonlaag: vnl. drijfgassen (CFK's), gat dicht in 2060: FIXED
Broeikaseffect: vnl. CO₂ (en methaan en lachgas), afbouw uitstoot begonnen



Apple iPad Pro (2021) 11" Wi-Fi, 8GB ram Microsoft Xbox Series X LG CX Google Pixel 5a 5G Sony XH90 / XH92 Samsung Galaxy S21 5G Sony PlayStation 5 Nintendo Switch Lite

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2021 Hosting door True