Toon posts:

TP-link Deco M5 met Sonos netwerk

Pagina: 1
Acties:

Vraag


  • jerry_k
  • Registratie: juni 2016
  • Laatst online: 30-05 12:40
Ik heb thuis een KPN v10 experia box, daarop aangesloten een Sonos Boost (met kabel) en 3 TP Link Deco M5 waar van 1 deco aangesloten met kabel op de router. De andere 2 deco’s staan op de 1e en 2e verdieping. Dit allemaal in de meterkast beneden.

Beneden heb ik verder een Sonos Playbar met 2 Sonos Ones als surroundspeakers.

Alles verbinden met de deco neterk in router mode werkt prima en overal prima verbinding. Het enige probleem is dat de Sonos bij het streamen van muziek (Spotify EN radio) vaak stopt en later weer verder gaat. Dit frustreert zo erg dat ik een Sonos Boost heb gekocht in de hoop om via dit netwerk probleemloos te streamen maar helaas. Ik weet alleen niet goed of ik de boost in de v10 of in de deco moet stoppen (bekabeld).
Ik heb de deco nu ook als accesspoint gezet maar dan weet ik niet of ik alles moet verbinden op de v10 of alsnog het deco netwerk. Ik zie namelijk beide in mijn wifi lijst.

Enige wanneer de sonos probleemloos streamt is als ik de deco ertussenuit haal en rechtstreeks verbind met de v10. Daarom heb ik dus de deco’s als accesspoints gezet in de hoop dat zij dus alleen de wifi van de v10 versterken. Ik weer dus alleen niet of ik dan moet verbinden met netwerk van v10 en alles daarop laten verbinden, of deco netwerk en daar alles op verbinden.

Liefst gebruik ik alles op het deco netwerk zoals het was maar dan stopt mijn Sonos dus soms. Probleem ligt dus aan de deco maar hoe kan ik dit fixen? Iemand tips?

Korte omschrijving netwerk:
KPN V10 router > TP Link deco (main) in accespoint
> Sonos Boost

Sonos Playbar met 2 Sonos One’s > verbonden op KPN V10

Doel:
1. Alles vebinden op mesh netwerk van deco en alles daarop verbinden en met elkaar communiceren ipv de Sonos apart op de V10 ivm het storen van streamen.

Of

2. Alles verbinden op het V10 netwerk met de deco’s als accespoints (versterkers).

Mocht mijn netwerkomschrijving niet duidelijk zijn laat het me weten, dan probeer ik het beter uit te leggen.

Mvg,
Jerry

Alle reacties


  • dion_b
  • Registratie: september 2000
  • Laatst online: 03:50

dion_b

Moderator Harde Waren

say Baah

Vuistregel bij Sonos: max 1 Sonos-apparaat bedraad aansluiten op een netwerk.

Alle Sonos-apparaten vormen onderling een eigen WiFi-netwerk (met hidden SSID), en hebben nul bescherming tegen netwerklussen. Zodra je dat netwerk op meer dan een plek koppelt aan je eigen netwerk gaat het mis en krijg je een lus. Mogelijk dat je eigen hardware loop detection / Spanning Tree doet, maar ga er maar niet vanuit. Netwerklussen leiden tot allerlei ongein, met name dat je router het ongelofelijk zwaar krijgt en vroeg of laat onderuit gaat en een reboot nodig heeft. Voor die tijd kunnen de ARP-storms timing-sensitive verkeer hinderen, en dat zou wel eens oorzaak kunnen zijn van wat je hier beschrijft.

Het is mogelijk om de WiFi in Sonos-apparaten uit te schakelen, maar dat moet handmatig via CLI... heb je daar geen zin in, gewoon max 1 bedraad aansluiten en de rest onderling laten werken. Debiel, maar dat is hoe Sonos het geengineerd heeft |:(

Soittakaa Paranoid!


  • jerry_k
  • Registratie: juni 2016
  • Laatst online: 30-05 12:40
Thanks voor je reactie! De Sonos Boost is aangesloten op de V10. Die zorgt voor dat netwerk en alle Sonossen zijn ook prima met dat netwerk verbonden. Staan namelijk allemaal op WM:0 bij ‘over mijn systeem’.
Ik weer dus alleen niet of ik die boost moet aansluiten op de V10 of Deco. Aangezien hij via deco netwerk hapert heb ik nu alles omgezet naar V10. Maar de deco’s lijken weinig te doen qua accespoints want boven heb ik amper bereik terwijl daar ook een deco staat (via wifi).

  • dion_b
  • Registratie: september 2000
  • Laatst online: 03:50

dion_b

Moderator Harde Waren

say Baah

jerry_k schreef op zondag 24 januari 2021 @ 08:50:
Thanks voor je reactie! De Sonos Boost is aangesloten op de V10. Die zorgt voor dat netwerk en alle Sonossen zijn ook prima met dat netwerk verbonden. Staan namelijk allemaal op WM:0 bij ‘over mijn systeem’.
Ik weer dus alleen niet of ik die boost moet aansluiten op de V10 of Deco. Aangezien hij via deco netwerk hapert heb ik nu alles omgezet naar V10. Maar de deco’s lijken weinig te doen qua accespoints want boven heb ik amper bereik terwijl daar ook een deco staat (via wifi).
Klinkt alsof je meerdere problemen hebt. Begin eens met ze allemaal los van elkaar te zien en een voor een aan te pakken.

"Boven amper bereik" vind ik een erg vreemde - of jij verwoordt het onhandig. "Mesh" is niets meer dan een hip woord voor repeater: apparaten die performance inleveren ten gunste van dekking/bereik. Met een M5 node boven draadloos aangesloten zou ik exact omgekeerde verwachten van wat je beschrijft: fantastische dekking, maar mogelijk flink tegenvallende prestaties op die dekking.

Eerste vraag dus: wat bedoel je exact met "bereik"? Hoe meet je dat? En welke waarde meet je?

Als je daadwerkelijk weinig signaal in de lucht (RSSI, gemeten in dBm, of als dat niet lukt in procenten (Windows) of desnoods "streepjes") is boven, dan functioneert die node niet, of hij is niet verbonden met je nodes beneden.

Heb je daaretegen vol signaal, maar slechte performance (in dat geval: wees aub nauwkeuriger/duidelijker in je beschrijving :o ) dan functioneert je Deco prima en hoef je hooguit naar plaatsing te kijken.

Als we even aannemen dat dat laatste klopt: dan moet je naar de plaatsing van de M5 nodes kijken. Met 3 nodes en 3 verdiepingen ligt het redelijk voor de hand dat je er eentje per verdieping plaatst, de vraag is vooral waar je dat doet. Zo'n Deco node kan niet toveren, het moet verbonden zijn met goed signaal met de vorige node, en clients op de verdieping moeten er goed mee kunnen verbinden. Als je een huis hebt met betonnen vloeren kun je bij benadering stellen dat er nul signaal door de vloer zelf heen gaat en alle signaal van beneden naar boven (en omgekeerd) door het trapgat moet.

Vuistregel bij dit soort apparaat in NL (waar sinds jaren '60 betonnen vloeren standaard zijn) is dat je alles in of zo dicht mogelijk bij het trapgat moet plaatsen. Is dat nu niet het geval? Probeer het in ieder geval met de apparaten op 1e en 2e verdieping. Beneden kan lastiger zijn, afhankelijk van waar je meterkast is tov trapgat. Maar je Deco beneden zit op kabeltje. Gebruik die kabel om het in ieder geval aan buitenzijde meterkast te hangen, liefst met vrij zicht op trapgat.

Wil je meer hulp op dit vlak? Dan hebben we meer informatie nodig. Een schematische tekening van het huis, met meterkast, trapgat en waar de M5 nodes nu staan kan erg verhelderend zijn.

Ook ben ik benieuwd naar harde meetwaardes boven waar je zogezegd geen "bereik" hebt. Heb je een laptop? Loop daarmee naar een plek zonder "bereik" en draai in de command line het volgende:
code:
1
netsh wlan show interface


Die info zal in ieder geval aangeven waar het probleem te zoeken.

Soittakaa Paranoid!


  • Booth
  • Registratie: augustus 2001
  • Laatst online: 08-08 23:00

Booth

¯¯¯¯¯¯

Heb je de router in bridge mode gezet?

Ik heb namelijk ook veel geneuzel gehad met m'n P7 Decos, en dat was allemaal opgelost zodra ik de router op bridge mode had gezet.

  • jerry_k
  • Registratie: juni 2016
  • Laatst online: 30-05 12:40
Als ik de Deco in router modus zet, heb ik overal prima internet. Ook alles Sonos apparaten werken en hebben verbinding, maar valt deze dus regelmatig even uit als ik muziek aan het streamen ben.
Daarom had ik dus de Deco in bridge modus gezet en alle apparaten inclusief Sonos apparaten op mijn V10 verbonden zodat de Deco's alleen als 'antenne' zouden werken. Maar ook dan werkt het niet.
Ook heb ik geprobeerd om de Deco's in bridge modus te zetten en dan alsnog alles te verbinden met de Deco's maar ook dan heb ik haperingen.
Daarna heb ik die Boost aangeschaft maar ook dan heb ik haperingen. Weet ook niet goed of ik deze moet aansluiten op de V10 of Deco.

Nogmaals huidige setup:
Beneden (meterkast): KPN V10 - kabel - Deco (nu weer in router stand en alle apparaten op deco netwerk verbonden)
De overige 2 deco's staan op de 1e verdieping in de slaapkamer en op zolder. In router modus en alles daarop verbonden heb ik prima bereik en snelheid. Alleen dus haperingen met Sonos tijdens muziek streamen.
Als ik de deco's in bridge modus zet ook, en heb ik boven minder bereik en minder snelheid. Dit meet ik door snelheid test en heb dan op mijn iPhone 1 of 2 streepjes wifi. Dus het lijkt daarom dat de Deco's niet echt hun werk doen.

Mijn opties zijn dus een beetje op voor mijn gevoel.
Pagina: 1


Nintendo Switch (OLED model) Apple iPhone 13 LG G1 Google Pixel 6 Call of Duty: Vanguard Samsung Galaxy S21 5G Apple iPad Pro (2021) 11" Wi-Fi, 8GB ram Nintendo Switch Lite

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2021 Hosting door True

Tweakers maakt gebruik van cookies

Bij het bezoeken van het forum plaatst Tweakers alleen functionele en analytische cookies voor optimalisatie en analyse om de website-ervaring te verbeteren. Op het forum worden geen trackingcookies geplaatst. Voor het bekijken van video's en grafieken van derden vragen we je toestemming, we gebruiken daarvoor externe tooling die mogelijk cookies kunnen plaatsen.

Meer informatie vind je in ons cookiebeleid.

Sluiten

Forum cookie-instellingen

Bekijk de onderstaande instellingen en maak je keuze. Meer informatie vind je in ons cookiebeleid.

Functionele en analytische cookies

Deze cookies helpen de website zijn functies uit te voeren en zijn verplicht. Meer details

janee

    Cookies van derden

    Deze cookies kunnen geplaatst worden door derde partijen via ingesloten content en om de gebruikerservaring van de website te verbeteren. Meer details

    janee