Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Vraag


  • TheFes
  • Registratie: juni 2001
  • Laatst online: 10:35
Mijn vraag:
Ik heb sinds kort een home-server die draait op Proxmox. Ik heb daarin een Debian VM waar ik via docker compose Emby heb draaien. Voor Emby zou ik graag gebruik willen maken van de iGPU van mijn CPU. Ik krijg dat echter niet aan de gang.

Relevante software en hardware die ik gebruik
Hardware:Sofware:
  • Proxmox 6.3-3
  • Debian Buster (VM)
  • Emby (in VM, via docker-compose)
Wat ik al gevonden of geprobeerd heb:
  • Vt-d staat aan in de bios
  • https://packages.debian.org/buster/intel-media-va-driver ge├»nstalleerd
  • Ik heb via deze guide geprobeerd de iGPU als vGPU in de VM te gebruiken: https://cetteup.com/216/h...treaming-in-a-proxmox-vm/
    Helaas lijkt het mis te gaan als ik "lspci -nnv | grep VGA" uitvoer, ik zou daar een vermelding van de intel HD 630 verwachten, maar die krijg ik dus niet
    code:
    1
    2
    
    root@pve:~# lspci -nnv | grep VGA
    00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:9bc8] (rev 03) (prog-if 00 [VGA controller])
  • Als ik daarna toch gewoon het PCI device (0000:00:02.0) probeer toe te wijzen aan de VM, dan mis ik de MDEV types.[/li]
  • Ik heb ook de stappen in deze reddit post proberen te volgen, maar ook daar stopt het voor mij bij de mdev types https://www.reddit.com/r/...tm_medium=web2x&context=3
Mis ik ergens iets, zijn er nog dingen die ik kan proberen? Ik heb overigens wel gewoon beeld als ik een monitor aansluit, dus hij lijkt me niet kapot.

Alle reacties


  • Guru Evi
  • Registratie: januari 2003
  • Laatst online: 27-02 23:44
Gebruikt je computer niet de iGPU om te booten? Hoogstwaarschijnlijk heeft de host een claim op de iGPU die je moet oplossen ofwel met een tweede GPU of volledig 'op zwart' booten en via SSH configureren.

Een degelijke wandeling doorheen de veranderingen:
https://www.reddit.com/r/...guide_to_gpu_passthrough/

Pandora FMS - Open Source Monitoring - pandorafms.org


  • prutser001
  • Registratie: oktober 2004
  • Laatst online: 02-03 17:17

prutser001

Vaak zit het tegen en soms zi

Om een GPU te gebruiken in een VM via passthrough moet je een Nvidia Quadro kaart hebben of een AMD kaart (schijnt met alle AMD kaarten te kunnen?)

Asus Z390 Maximus IX Hero, Intel 9900K, RTX2080, 32GB DDR4 3000, 1TB NVME, Samsung 850Evo 1TB, 4 x 8TB Toshiba, Be Quiet SB 801, Samsung 34"



Apple iPhone 12 Microsoft Xbox Series X LG CX Google Pixel 5 Sony XH90 / XH92 Samsung Galaxy S21 5G Sony PlayStation 5 Nintendo Switch Lite

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2021 Hosting door True