Cookies op Tweakers

Tweakers is onderdeel van DPG Media en maakt gebruik van cookies, JavaScript en vergelijkbare technologie om je onder andere een optimale gebruikerservaring te bieden. Ook kan Tweakers hierdoor het gedrag van bezoekers vastleggen en analyseren. Door gebruik te maken van deze website, of door op 'Cookies accepteren' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt? Bekijk dan ons cookiebeleid.

Meer informatie
Toon posts:

Image voor WDS aanmaken?

Pagina: 1
Acties:

Vraag


  • theduke1989
  • Registratie: september 2008
  • Laatst online: 15-06 05:30
Hallo allen,

Ik zit met een vraag.

Wat is de beste manier om een IMAGE te maken voor WDS met daarbij dus de correct drivers en software?

We hebben een aantal laptops nu ontvangen, maar moeten deze via WDS doen. Dus wil van 1 laptop die dezelfde hardware heeft als de rest met de correcte drivers installeren en software zoals icons, Adobe etc. En daar een WIN image van maken, en deze importeren in WDS.

Wat is de beste manier? Het gaat om de Lenovo X390laptops. ook heb ik de SCCM mdt gevonden (https://support.lenovo.com/lu/en/downloads/ds542252) heb al een driver group aangemaakt in WDS. met daarin de drivers.

De BusinessUnit werkt nog met WDS en de gene die het heeft opgezet, is er niet meer. Maar er staat van alles tussen. Wat ik nu moet bekijken om te verwijderen of niet.

Daarnaast is er een DeploymentWorkbench actief, en heb gezien dat daar ook van alle tussen staat.

[Voor 16% gewijzigd door theduke1989 op 10-07-2020 09:24]

Alle reacties


Acties:
  • +1Henk 'm!

  • HKLM_
  • Registratie: februari 2009
  • Laatst online: 11:26
Je (moet) MDT erbij installeren op je wds server en vanuit daar een task sequence maken die de deployment samen met wds regelt. Via mdt kan je alles instellen wat je maar wilt.

Maakt het aanpassen ook makkelijker aangezien je geen image hebt maar alles verwekt zit in taken die je kan aanpassen.

[Voor 25% gewijzigd door HKLM_ op 10-07-2020 09:12]

⛔Trackers of betalen...⛔


  • theduke1989
  • Registratie: september 2008
  • Laatst online: 15-06 05:30
Er is een DeploymentWorkBench actief.

Maar er is zoveel gedaan voor mij, dat ik niet weet wat wat meer is. En dus moet oplossen. Deze BU gebruikt nog de oude WDS. Vandaar dat het niet meer actief is.
Dit staat er nu ongeveer.


Heb de drivers toegevoegd. Nu moet ik het OS goed invoegen, en dan alle oude meuk er af gooien.

[Voor 6% gewijzigd door theduke1989 op 10-07-2020 09:23]


  • theduke1989
  • Registratie: september 2008
  • Laatst online: 15-06 05:30
Is dit een correcte link: https://www.anoopcnair.co...image-creation-using-mdt/ of kan het nog beter.

  • nextware
  • Registratie: mei 2002
  • Laatst online: 14:23
De volgende stappen uitvoeren:

- OS importeren (heb je al gedaan)
- Applicatie klaarzetten onder de tab applications

Daarna ga je naar Advanced Configuration -> Database -> Roles

Daar maak je een role aan en in deze rol definieer je de applicaties welke geïnstalleerd moeten worden tijdens je imaging proces (let goed op een eventuele volgorde waarin je apps laat installeren).

Hierna maak je onder je Task Sequences een taak aan waarin je aangeeft welke OS Image file geïnstalleerd moet worden en verdere benodigde stappen (domain join, etc).

En wanneer je een device toevoegt, bepaal je onder het tabblad "Roles" de eerder aangemaakte Role waarmee de benodigde apps worden geïnstalleerd.

[Voor 9% gewijzigd door nextware op 10-07-2020 10:01]


  • theduke1989
  • Registratie: september 2008
  • Laatst online: 15-06 05:30
@nextware de OS moet ik nog importeren want de getoonde OS is volgens mij niet correct.
Want wanneer je een PXE BOOT uitvoert krijg je de volgende melding:

pci ven_8086&dev_15BE&SUBSYS_228617AA&REV_30

Dus wil daarom een nieuwe IMAGE importeren, dan de Lenovo Update tool gebruiken compleet updaten.
En dan de IMAGE aanmaken. of is dit te veel werk en voor niks?

Als dit allemaal goed funktioneert, alles weggooien en opnieuw alles aanmaken.

  • nextware
  • Registratie: mei 2002
  • Laatst online: 14:23
Dit is een kwestie van een ontbrekende driver in je PXE file. Het importeren van een nieuw OS bestand zal dit niet oplossen.

Bij het toevoegen van een nieuw merk / model in MDT is het advies om je PXE file te updaten met de drivers van dit specieke merk / model.

[Voor 60% gewijzigd door nextware op 10-07-2020 10:45]


  • theduke1989
  • Registratie: september 2008
  • Laatst online: 15-06 05:30
@nextware het probleem is dat het naar een ''image'' verwijst wat niet meer gebruikt wordt de Lenovo T580.wim. Vandaar dat ik dacht ik wil alles opnieuw doen. Dus met de juiste settings en alles.

  • Nogne
  • Registratie: november 2011
  • Laatst online: 14:12
@theduke1989 hierboven word al het goeie antwoord gegeven, maar ik zou nooit adviseren om je drivers in de basis image te zetten. Want dan zorg je er voor dat de image maar voor 1 apparaat gaat werken. Het is handiger om een generale image te maken, en dan via de task sequence de drivers te injecteren voordat je Windows opstart op de client.

XBL: Nogne


  • theduke1989
  • Registratie: september 2008
  • Laatst online: 15-06 05:30
Ik probeer het al een tijdje,
maar als ik dit doe

Dan wanneer ik weer boot in PXE krijg ik die foutmelding, ik voeg de mdt van Lenovo voor X390toe.

[Voor 36% gewijzigd door theduke1989 op 10-07-2020 17:03]


  • MOOS
  • Registratie: april 2019
  • Laatst online: 14:45
theduke1989 schreef op vrijdag 10 juli 2020 @ 17:03:
Ik probeer het al een tijdje,
maar als ik dit doe
Dan wanneer ik weer boot in PXE krijg ik die foutmelding, ik voeg de mdt van Lenovo voor X390toe.
Zorg ervoor dat je de laatste ADK gebruikt:
https://docs.microsoft.co...e/get-started/adk-install

Drivers heb je al toegevoegd, dat is goed. Nu kan je eventueel een "Selection profile" maken voor deze laptop.

En zo maak je een nieuwe boot image:
  1. Klik rechts op de deployment share en daarna "Properties".
  2. Ga naar "Windows PE" en dan "Drivers and Patches".
  3. Selecteer je nieuwe selection profile of kies "All drivers".
  4. Apply, OK.
  5. Klik weer rechts op de deployment share en daarna "Update Deployment Share".
  6. Kies "Completely regenerate boot images" en volg de wizard.
  7. Als laatste moet je je nieuwe boot image(s) nog importeren in WDS.
Ik zelf heb maar enkele (noodzakelijke) drivers in MDT en stop ze allemaal in mijn boot image (geen selection profiles etc.). Zodoende heb ik maar 1 boot image om te onderhouden. Probeer sowieso je boot images zo klein mogelijk te houden.

Succes! (y)

  • theduke1989
  • Registratie: september 2008
  • Laatst online: 15-06 05:30
@MOOS ga dat proberen.

het probleem is ik heb dit niet opgesteld, dus alles is nu door elkaar weet niet wat wat is.

Maar 1 vraag, waarom kan ik niet de juiste drivers vinden?

want dit had ik handmatig toegevoegd met de correcte drivers. Nu heb ik het gevoel dat hij dus niet de juiste drivers gaat zien.

[Voor 5% gewijzigd door theduke1989 op 14-07-2020 15:11]


  • MOOS
  • Registratie: april 2019
  • Laatst online: 14:45
theduke1989 schreef op dinsdag 14 juli 2020 @ 15:10:
@MOOS ga dat proberen.

het probleem is ik heb dit niet opgesteld, dus alles is nu door elkaar weet niet wat wat is.

Maar 1 vraag, waarom kan ik niet de juiste drivers vinden?
want dit had ik handmatig toegevoegd met de correcte drivers.
Omdat je geen "selection profile" hebt aangemaakt.
Ga in de linker kolom naar "Advanced Configuration" en daarna "Selection Profiles".

  • Xelefim
  • Registratie: maart 2019
  • Laatst online: 03-06 21:07
weet iemand of de windows op een laptop die 'in een winkel is gekocht' geactiveerd blijft nadat er een image is op geplaatst via wds/mdt?

- BSc TI + CCNA R&S (Expired ofcourse) + CCNA SEC (Also expired ofc)-


Acties:
  • +1Henk 'm!

  • HKLM_
  • Registratie: februari 2009
  • Laatst online: 11:26
Xelefim schreef op dinsdag 14 juli 2020 @ 15:18:
weet iemand of de windows op een laptop die 'in een winkel is gekocht' geactiveerd blijft nadat er een image is op geplaatst via wds/mdt?
als het dezelfde versie is is dit geen probleem

⛔Trackers of betalen...⛔


  • theduke1989
  • Registratie: september 2008
  • Laatst online: 15-06 05:30
@MOOS ik ga maar eens een nieuwe deployment share aanmaken. Want ik krijg precies dezelfde error message als voorheen.

Waar moet ik op letten? Welke Windows moet ik uiteindelijk gebruik. Ik zag dat ze een bootstrap.ini file hebben wat dus het ook direct koppelt aan het domein. Kan ik dezelfde strap gebruiken of moet ik een nieuwe aanmaken?

Ga compleet vanaf het begin beginnen. Wil eigenlijk alles verwijderen wat er nu staat. En dan opnieuw. En dan kijken waar het fout gaat. WDS moet gebruikt worden neem ik aan voor de image ?

Van een schonelij beginnen is het beste denk ik.

[Voor 25% gewijzigd door theduke1989 op 15-07-2020 05:33]


  • theduke1989
  • Registratie: september 2008
  • Laatst online: 15-06 05:30
Is dit een goede howto: https://www.google.com/am...ndows-server-2012-r2/amp/

Of kan het beter? Wil namelijk de MAK gebruiken ook. Want ze moeten geactiveerd worden.

  • johnkeates
  • Registratie: februari 2008
  • Laatst online: 08-04 10:01
Ben je hier bedrijfsmatig/zakelijk verantwoordelijk voor of is het gewoon wat test/leerwerk?

  • theduke1989
  • Registratie: september 2008
  • Laatst online: 15-06 05:30
@johnkeates moet voor werk dit doen. We hebben helaas geen budget dus moeten alles doen wat "gratis" is dus met meegeleverde software. De gene die hiervoor dit heeft gedaan heeft van alles en nog wat er op gegooid. Weet niet waarom maar WDS werd gebruikt voor 2 type machines. Hier heb ik er 10 staan.

Acties:
  • +1Henk 'm!

  • MOOS
  • Registratie: april 2019
  • Laatst online: 14:45
Xelefim schreef op dinsdag 14 juli 2020 @ 15:18:
weet iemand of de windows op een laptop die 'in een winkel is gekocht' geactiveerd blijft nadat er een image is op geplaatst via wds/mdt?
Direct na de installatie is Windows niet meer geactiveerd. Je kan onderstaand script gebruiken om Windows opnieuw te activeren met de OEM productcode.

code:
1
2
3
4
$ProductKey = (Get-WmiObject -Class SoftwareLicensingService).OA3xOriginalProductKey
iex "cscript /b C:\Windows\System32\slmgr.vbs -ipk $Productkey" 
Start-Sleep 5
iex "cscript /b C:\Windows\System32\slmgr.vbs -ato"

  • hhoekstra
  • Registratie: maart 2008
  • Laatst online: 10:49
Je moet na het toevoegen van de drivers wel je boot image opnieuw opbouwen (rechter muisknop update iimage.. of iets dergelijks)

Deze moet je dan opnieuw importeren in je WDS tool.

  • Starke
  • Registratie: juli 2009
  • Laatst online: 08-06 21:38
MOOS schreef op woensdag 15 juli 2020 @ 08:28:
[...]


Direct na de installatie is Windows niet meer geactiveerd. Je kan onderstaand script gebruiken om Windows opnieuw te activeren met de OEM productcode.

code:
1
2
3
4
$ProductKey = (Get-WmiObject -Class SoftwareLicensingService).OA3xOriginalProductKey
iex "cscript /b C:\Windows\System32\slmgr.vbs -ipk $Productkey" 
Start-Sleep 5
iex "cscript /b C:\Windows\System32\slmgr.vbs -ato"
Dit zou niet meer nodig moeten zijn tegenwoordig (in ieder geval vanaf Windows 10) doet deze om de zoveel tijd (indien er al een geactiveerde versie op heeft gestaan of de key zich in de UEFI bevind) en dezelfde (juiste) versie is geïnstalleerd een activering verzoek en wordt Windows automagisch geactiveerd (indien er netwerk/internet verbinding is).

  • MOOS
  • Registratie: april 2019
  • Laatst online: 14:45
Starke schreef op woensdag 15 juli 2020 @ 08:51:
[...]

Dit zou niet meer nodig moeten zijn tegenwoordig (in ieder geval vanaf Windows 10) doet deze om de zoveel tijd (indien er al een geactiveerde versie op heeft gestaan of de key zich in de UEFI bevind) en dezelfde (juiste) versie is geïnstalleerd een activering verzoek en wordt Windows automagisch geactiveerd (indien er netwerk/internet verbinding is).
Als je hem nieuw uit de doos gelijk PXE boot dan is dit zeker wel nodig.

  • theduke1989
  • Registratie: september 2008
  • Laatst online: 15-06 05:30
@MOOS @Starke we doen inderdaad zoals ik zag een nieuwe image installeren. wat niet meegeleverd is met Windows van de fabrikant.

  • theduke1989
  • Registratie: september 2008
  • Laatst online: 15-06 05:30
Even een korte update.

Ik heb een nieuwe deployment share aangemaakt. En een image toegevoegd. Deze weer vervolgens enabled in WDS. Maar krijg alsnog dezelfde error message als hierboven.

  • MOOS
  • Registratie: april 2019
  • Laatst online: 14:45
theduke1989 schreef op donderdag 16 juli 2020 @ 05:36:
Even een korte update.

Ik heb een nieuwe deployment share aangemaakt. En een image toegevoegd. Deze weer vervolgens enabled in WDS. Maar krijg alsnog dezelfde error message als hierboven.
Heb je ook de boot images opnieuw aangemaakt en in WDS geïmporteerd?

  • theduke1989
  • Registratie: september 2008
  • Laatst online: 15-06 05:30
Ja, nadat ik de workbench met de juiste drivers en alles heb toegevoegd in WDS boot image toegevoegd en op de pxe boot zie je het naar de correcte gaan. Maar alsnog dezelfde fout error

  • theduke1989
  • Registratie: september 2008
  • Laatst online: 15-06 05:30
er gaat iets de hele tijd fout merk ik.

Ik heb alles eraf gegooid. nieuwe update geinstalleerd.
Nieuwe share aangemaakt.
OS toegevoegd.
Task sequence toegevoegd
Drivers toegevoegd.
Deze vervolgens in WDS onder boot toegevoegd.

Maar niet elke laptop gaat er goed mee overweg, een oudere laptop T480 waarvoor de drivers niet eens bedoeld zijn komt een stap vooruit. Maar de X390 die krijgt een zwart scherm nadat het 100% de .wim file heeft geladen.

nu ongeveer weet ik hoe het default zou moeten werken, moet nog ook uitvogelen andere dingen.
Keyboard layout aanpassen, taal aanpassen, computername aanpassen, join domain aanpassen en dat soort dingen. Maar nu die denk ik wat de meest simpele ding hoor te zijn lukt niet.
Pagina: 1


Apple iPad Pro (2021) 11" Wi-Fi, 8GB ram Microsoft Xbox Series X LG CX Google Pixel 5a 5G Sony XH90 / XH92 Samsung Galaxy S21 5G Sony PlayStation 5 Nintendo Switch Lite

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2021 Hosting door True