Cookies op Tweakers

Tweakers is onderdeel van DPG Media en maakt gebruik van cookies, JavaScript en vergelijkbare technologie om je onder andere een optimale gebruikerservaring te bieden. Ook kan Tweakers hierdoor het gedrag van bezoekers vastleggen en analyseren. Door gebruik te maken van deze website, of door op 'Cookies accepteren' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt? Bekijk dan ons cookiebeleid.

Meer informatie
Toon posts:

Afbeelding in review verdwijnt na opslaan

Pagina: 1
Acties:

  • dixet
  • Registratie: februari 2010
  • Laatst online: 18-06 23:06
Wanneer ik meerdere afbeeldingen na elkaar invoeg in een review verdwijnen ze allemaal op de laatste na. Dit gebeurt alleen wanneer de afbeeldingen elkaar direct opvolgen, niet wanneer er andere tekens (regeleinde, of zelfs een spatie) tussenstaan.

In de preview zijn de afbeeldingen wel zichtbaar, maar wanneer ik de review aanpas is zijn de [img] tags verdwenen.

Reproductiestappen
  1. Maak een review met daarin meerdere [img] tags direct achter elkaar
  2. Sla de review op als preview
  3. Bekijk de review; de afbeeldingen worden getoond zoals verwacht
  4. Bewerk de review: er staat maar 1 [img] tag meer
Er is dus een workaround, door een spatie achter de [img] tag te zetten verandert er visueel niets maar blijven de tags wel staan.
Alleen irritant als je er niet op verdacht bent ;)

Voorbeelden:
Dit gaat fout:
code:
1
[img=250,183]undefinedjF4HavyS[/IMG][img=250,159]undefinedBrNdQzEO[/IMG]

En hier blijven beide afbeeldingen wel staan:
code:
1
[img=250,183]undefinedjF4HavyS[/IMG] [img=250,159]undefinedBrNdQzEO[/IMG]

  • crisp
  • Registratie: februari 2000
  • Nu online

crisp

Devver

Pixelated

Die 'undefined' hoort sowieso niet in die tag te staan, dus er gaat daar al ergens iets mis zo te zien. We gaan er naar kijken :)

[Voor 5% gewijzigd door crisp op 11-06-2020 19:27]

Intentionally left blank


  • crisp
  • Registratie: februari 2000
  • Nu online

crisp

Devver

Pixelated

Ik heb de veroorzaker gevonden en gefixed; zal dat morgenochtend online zetten. Waar de 'undefined' in je voorbeelden vandaan komt heb ik echter niet kunnen achterhalen; ik kon dat niet reproduceren...

Intentionally left blank


  • dixet
  • Registratie: februari 2010
  • Laatst online: 18-06 23:06
crisp schreef op donderdag 11 juni 2020 @ 20:10:
Ik heb de veroorzaker gevonden en gefixed; zal dat morgenochtend online zetten. Waar de 'undefined' in je voorbeelden vandaan komt heb ik echter niet kunnen achterhalen; ik kon dat niet reproduceren...
Dat is snel, super!
Dat undefined zou zomaar een knip-en-plak foutje van mij zijn, dus daar zou ik geen aandacht aan besteden :D


Apple iPad Pro (2021) 11" Wi-Fi, 8GB ram Microsoft Xbox Series X LG CX Google Pixel 5a 5G Sony XH90 / XH92 Samsung Galaxy S21 5G Sony PlayStation 5 Nintendo Switch Lite

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2021 Hosting door True