Cookies op Tweakers

Tweakers is onderdeel van DPG Media en maakt gebruik van cookies, JavaScript en vergelijkbare technologie om je onder andere een optimale gebruikerservaring te bieden. Ook kan Tweakers hierdoor het gedrag van bezoekers vastleggen en analyseren. Door gebruik te maken van deze website, of door op 'Cookies accepteren' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt? Bekijk dan ons cookiebeleid.

Meer informatie
Toon posts:

Blender probleem

Pagina: 1
Acties:

Acties:
  • +1Henk 'm!

  • Gps4l
  • Registratie: juli 2010
  • Laatst online: 23-05 19:24
Ik ben sinds een paar dagen aan het stoeien met blender en loop vast.

Wat ik uiteindelijk wil is een loop video, voor bij me muziek.
Heb natuurlijk al wat tutorials gevolgd.

Verder ervaring met 3D cad, een programma om maps te maken voor een spel en ooit een beetje 3D studio max.

Ik moet erg wennen aan de manier waarop blender werkt, maar dat komt wel goed.

Nu mijn concrete probleem.

https://i.imgur.com/yoMfaTU.png

Ik wil een texture aan brengen en weet in middels dat je dan eerst een unwrap moet doen.
En daar gaat het fout, blender is blijkbaar niet blij met mijn geometrie.
Dat unwrappen gaat niet goed.

Iemand een idee wat het probleem is, en of een goede plaats om dit soort vragen te stellen ?

Wat ik gedaan heb, vanaf de standaard box, verschaalt over de y as.
Daarna 3 faces gedelete, toen subdivide en select random.
Daarna extrude faces, waar ik blender vertel de oorsprong van elk individueel face te gebruiken en niet de oorsprong van het hele deel.

Acties:
  • +1Henk 'm!

  • MR501
  • Registratie: juli 2018
  • Laatst online: 14:40
Heb je al creases gemaakt?.
Wat het ook kan zijn is dat het wel één object is, maar dat niet alles "aan elkaar vast zit" de makkelijkste manier om hier achter te komen is: edit mode > p > by loose parts, als ze hierna worden opgesplitst in losse objecten weet je dat je fout zit, je kunt als dit het geval is wel gewoon de texture toepassen bij één object en daarna de rest linken aan materials als ze dezelfde geometrie hebben

Acties:
  • 0Henk 'm!

  • Gps4l
  • Registratie: juli 2010
  • Laatst online: 23-05 19:24
Bedankt.

Ik heb het even geprobeerd, en het lijkt er op dat het wel één geheel is.

Ik ga even uit zoeken wat creases zijn. :)

Acties:
  • 0Henk 'm!

  • Gps4l
  • Registratie: juli 2010
  • Laatst online: 23-05 19:24
Ik heb gekeken en snap niet wat creases hier mee te maken heeft ? :)

Misschien moet ik wel negeren wat ik denk dat fout gaat.

Ik zie voorbeelden van een kubus en als ze dan unwrap doen, zie je een uitslag van de kubus.

Bij mij zie ik op de texture geen uitslag maar een bende van zwarte lijntje.
Me gevoel zegt dat er iets niet goed gaat.
Misschien moet ik een screen shot maken ?

Acties:
  • 0Henk 'm!

  • Gps4l
  • Registratie: juli 2010
  • Laatst online: 23-05 19:24
Ik begin me af te vragen of het probleem door de texture komt.

( en dus eigenlijk niets met unwrap te maken heeft )

Als ik een standaard blender texture gebruik dan gaat het wel goed. ( brick texture )

Edit:
De texture die ik gebruikte is voor de vleugel van een ruimteschip.

Dat bleek dus geen goede keuze te zijn. |:(

Verder denk ik dat ik begin te begrijpen hoe ik een texture kan tilen in Blender.
Geen idee hoe je in het Nederlands zegt.

[Voor 38% gewijzigd door Gps4l op 10-06-2020 02:42]


  • Charango
  • Registratie: juni 2001
  • Laatst online: 23:14
Gps4l schreef op dinsdag 9 juni 2020 @ 16:38:
Ik heb gekeken en snap niet wat creases hier mee te maken heeft ? :)
Ik vermoed dat MR501 seams bedoelde in plaats van creases; deze geven aan welke edges losgeknipt mogen worden bij het unwrappen.

  • Gps4l
  • Registratie: juli 2010
  • Laatst online: 23-05 19:24
Nu begrijp ik het wel. Ik heb ook een tutorial gevonden dat uilegd hoe je de uitslag kan beïnvloeden door edges te selecteren.

Ik volg vooral nog tutorials, en kom elke dag iets verder.

Het zal nog wel even duren voor ik het gevoel heb dat ik blender echt begrijp.

Het werkt totaal anders als de 3D cad programma's die ik gewend ben.

Ik zoek me constant een slag in de rondte, naar bepaalde opties.
Soms zeer frustrerend, maar vooral een kwestie van niet opgeven.

Op het moment voelt het nog alsof blender geweldig goed is in verbergen van bepaalde opties.

Zo zat ik al dagen te kloten met insert faces, dat soms wel doet wat ik wil maar soms ook niet.
Door me 3D cad achtergrond begrijp ik vaak wel wat er mis gaat, maar kan vaak de juiste instellingen niet vinden.

Never give up never surrender.

  • Gps4l
  • Registratie: juli 2010
  • Laatst online: 23-05 19:24
Misschien dat dit andere kan helpen.

Als je commando actief hebt en je drukt i , dan zie je de opties die ik vaak niet vinden kan.

shift+tab+ spacebar geeft een commando overzicht.


De GUI en ik zijn nog geen vriendjes, maar dat was met de oudere GUI nog veel erger.
Geen idee hoe nieuw de GUI van 2.8 is, maar ik vind het wel een stap vooruit.

Ik krijg op dit moment nog wel hoofdpijn van het feit, dat soms als ik met een commando bezig ben ik links onderin een panel zie, maar soms ook niet.

  • k995
  • Registratie: november 2002
  • Laatst online: 12-06 00:42
Gps4l schreef op dinsdag 9 juni 2020 @ 14:10:
Ik ben sinds een paar dagen aan het stoeien met blender en loop vast.

Wat ik uiteindelijk wil is een loop video, voor bij me muziek.
Heb natuurlijk al wat tutorials gevolgd.

Verder ervaring met 3D cad, een programma om maps te maken voor een spel en ooit een beetje 3D studio max.

Ik moet erg wennen aan de manier waarop blender werkt, maar dat komt wel goed.

Nu mijn concrete probleem.

https://i.imgur.com/yoMfaTU.png

Ik wil een texture aan brengen en weet in middels dat je dan eerst een unwrap moet doen.
En daar gaat het fout, blender is blijkbaar niet blij met mijn geometrie.
Dat unwrappen gaat niet goed.

Iemand een idee wat het probleem is, en of een goede plaats om dit soort vragen te stellen ?

Wat ik gedaan heb, vanaf de standaard box, verschaalt over de y as.
Daarna 3 faces gedelete, toen subdivide en select random.
Daarna extrude faces, waar ik blender vertel de oorsprong van elk individueel face te gebruiken en niet de oorsprong van het hele deel.
Hoe doe je de uv unwrap? Hier zou je gewoon in edit mode alles selecteren en "smart uv project" kunnen gebruiken.

  • Gps4l
  • Registratie: juli 2010
  • Laatst online: 23-05 19:24
Dat is wat ik deed, maar ik kreeg een vreemde uitslag, over de texture.

Als dat gebeurd dan kan je Blender helpen, door aan te geven waar het model gesplit moet (kan) worden.

Maar of dat voor dit specifiek model gaat werken? Het grootste probleem was echter de texture zelf.
De texture die ik gedownload had kan je niet zomaar tilen. Dat gaat er raar uitzien.

De texture is voor een vleugel van een ruimteschip, en heeft daarom aan de romp kant een zwart gedeelte.
Dat was de reden dat het er raar uit zag, niet zo zeer dat blender een probleem heeft om de uitslag van mij model te maken.

Ik vond deze tutorial, en die legt het duidelijk uit.

YouTube: YouTube

Ik ga wel even opzoek naar smart uv project, dat zegt me nog even niets.

Acties:
  • +1Henk 'm!

  • Wolfos
  • Registratie: oktober 2010
  • Laatst online: 18:44
Als je op U drukt krijg je verschillende opties om te unwrappen. Ik zou ze allemaal eens proberen, kijken wat voor jou het beste resultaat geeft. Anders misschien een keer naar triplanar mapping kijken, volgens mij kan Blender dat ook namelijk en dan heb je geen UVs nodig. Dat werkt goed voor tiled textures.

  • Gps4l
  • Registratie: juli 2010
  • Laatst online: 23-05 19:24
Ik heb het via één van de opties gedaan, die je ziet als je U drukt.
Nu ging dat unwrappen wel goed.

Ik begin Blender (het moddelen) een beetje door te krijgen, maar er iets is wat ik niet snap.
Ik hoop dat ik iets fout doe.

https://imgur.com/dxQcfEg

Dat paneel met de instellingen waar ik een rood vierkant omheen getekend heb.

Ik snap niet dat ik dat pas zie als ik me model al vervormd heb, door het gele plus teken te slepen.
Dat moet toch anders kunnen ?

Hoe kom ik bij die instelling voor ik me model al verandert heb? :?

[Voor 68% gewijzigd door Gps4l op 15-06-2020 00:44]


Acties:
  • +1Henk 'm!

  • Wolfos
  • Registratie: oktober 2010
  • Laatst online: 18:44
Als je meteen klikt zonder je muis te bewegen dan pas je niks aan en kan je alsnog bij dat menu. Door je muis te bewegen pas je alleen de optie 'thickness' hier aan. Als je deze weer naar z'n standaardwaarde wil dan kan je 'm alsnog handmatig op 0 zetten.

  • Gps4l
  • Registratie: juli 2010
  • Laatst online: 23-05 19:24
Dank je wel.

Dit is wat ik nu heb, steeds een stapje verder, maar heb wel een texture / kleur probleem.

https://i.imgur.com/ge1uMep.png


Hoe maak ik de ene pijp rood en de ander blauw.

Moet ik eerst pijp textures gaan downloaden?

Ik heb de pijpen al wel afzonderlijk gemaakt. (selection separate) maar ik krijg het niet voor elkaar om de pijp te selecteren en dan de kleur aan te passen. ( één van de dingen die er mis gaat, is dat als ik denk de kleur van me pijp te veranderen, me hele model rood word, dus ook de rest van de geometrie.


Ik zie veel texture tutorials maar die hebben maar 1 object in de scene, en ik vermoed dat mijn probleem daar mee te maken heeft.

Hoe pak ik dit aan ?

  • Wolfos
  • Registratie: oktober 2010
  • Laatst online: 18:44
Ik denk dat al jouw objecten hetzelfde materiaal hebben. Dus even op het minnetje klikken en dan 'new' om een nieuw materiaal toe te voegen. Het is ook goed om je materialen verschillende namen te geven.


  • Gps4l
  • Registratie: juli 2010
  • Laatst online: 23-05 19:24
Bedankt.
Ik ga eerst maar eens de materials een verschillende naam geven., dan kan ik ook makkelijker zien of ze het zelfde materiaal hebben.

I dacht dat ik, al de meeste verwijderd had, maar blijkbaar toch niet.

Het viel me wel op dat emmision aanstond bij die pijp. Niet de bedoeling maar ik begrijp wel hoe dat komt.
Eerst nu even opruimen dus.

Edit:

Het probleem is precies wat je zegt, plus dat de rode lampen en de omtrek van de gang één onderdeel waren.
Die heb ik nu dus al eerste maar even afgesplitst, en toen cube 4 een andere naam gegeven, namelijk red lights.
Dat moet ik mezelf dus aanleren als ik nieuws maak, gelijk een duidelijke naam geven. :)

[Voor 31% gewijzigd door Gps4l op 18-06-2020 16:50]


  • Gps4l
  • Registratie: juli 2010
  • Laatst online: 23-05 19:24
Helemaal blij. Wat o.a. nodig was, alle materails verwijderen en een nieuwe toevoegen.
Heb nu niets meer wat cube heet. Ik heb nu pipes 2x, hull 1 keer en metal mesh 1 keer, en red light 1 keer.

https://i.imgur.com/QnpZHUz.png

  • Gps4l
  • Registratie: juli 2010
  • Laatst online: 23-05 19:24
Nieuwe vraag, weet niet of ik er een nieuw topic voor moet beginnen?

Wat ik wil is een hoek maken in de gang, met stappen van. 22.5 of 30 graden. (3 of 4 stappen dus voor 90 graden)

In een Cad programma zou ik dan copy en rotate doen.

Hoe doe ik dat in blender, of is het beter om een hoekstuk te moddeleren ? ( van 22.5 of 30 graden )

Als ik een extrude doe onder een hoek, dan gaat dat volgens mij mis, omdat ik dan de breedte van de gang veranderd?

Hoop dat me vraag duidelijk is.

Edit:
Ik vond een tutorial over de spin functie. Dat is misschien wat ik zoek.
YouTube: Blender 2.8 - Spin Tool - Tutorial

Spin, zoals ik die tool begrijp moet dat met me gang ook lukken.
Nou wil ik een scherpe hoek en geen ronde hoek, maar ik ga eens kijken wat de tool precies doet.

Edit 2 opgelost.
Spin tool was wat ik zocht, even opletten waar je de oorsprong van de spin neerzet, dan het aantal stappen op 1, edges selecteren, de hoek op 22.5 of 30 graden, en je hebt een recht gedeelte onder 22.5 of 30 graden.

[Voor 37% gewijzigd door Gps4l op 17-07-2020 18:00]

Pagina: 1


Apple iPad Pro (2021) 11" Wi-Fi, 8GB ram Microsoft Xbox Series X LG CX Google Pixel 5a 5G Sony XH90 / XH92 Samsung Galaxy S21 5G Sony PlayStation 5 Nintendo Switch Lite

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2021 Hosting door True