Cookies op Tweakers

Tweakers is onderdeel van DPG Media en maakt gebruik van cookies, JavaScript en vergelijkbare technologie om je onder andere een optimale gebruikerservaring te bieden. Ook kan Tweakers hierdoor het gedrag van bezoekers vastleggen en analyseren. Door gebruik te maken van deze website, of door op 'Cookies accepteren' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt? Bekijk dan ons cookiebeleid.

Meer informatie
Toon posts:

[W10] Zoeken naar gewijzigde apparaten "snelkoppeling"

Pagina: 1
Acties:

Vraag


Acties:
  • 0Henk 'm!

  • JdM
  • Registratie: februari 2002
  • Laatst online: 10:40
Mijn vraag
In twee systemen hier heb ik al tijden het probleem dat de netwerkadapter niet direct wordt gedetecteerd bij de eerste keer opstarten van Windows.
Zodra ik in apparaatbeheer "zoeken naar gewijzigde apparaten" aanklik, is er direct een netwerkverbinding en werkt alles naar behoren. Opnieuw opstarten helpt ook.

De werkelijke vraag:
Bestaat er een directe link (script) naar de opdracht "zoeken naar gewijzigde apparaten" zoals deze in apparaatbeheer zichtbaar is?
Ik voer deze dan gewoonweg in in een taakplanneropdracht, zodra een gebruiker zich aanmeldt. Dan werkt de netwerkverbinding wel en is het gevolg van het probleem wat mij betreft voldoende opgelost. Ik heb het opgegeven dat ik Windows zelf aan zijn verstand kan brengen dat er wel degelijk een netwerkkaart beschikbaar is en dat deze correct is geïnstalleerd.
Zoeken naar alternatieve reparaties/oplossingen is wat mij betreft dus niet nodig, aangezien deze oplossing voldoende is voor mij.

Relevante software en hardware die ik gebruik
Windows 10 pro (1909)
- Acer Veriton L4610G

Wat ik al gevonden of geprobeerd heb
Heb al gezocht naar (alternatieve) drivers voor de netwerkkaart, zonder succes.
Er staan hier 4 Veriton systemen, waarvan dit probleem bij 2 stuks voorkomt. Dit zijn twee systemen die niet zijn uitgerust met een DPpoort (L4610G), wat niets met het netwerk te maken heeft, maar wel aantoont dat er mogelijk andere hardware in het systeem zit waardoor het probleem specifiek bij deze twee systemen optreedt. Bij de L4620G systemen treedt het probleem niet op.
Ook heb ik al gezocht naar het script waar ik hier omn vraag, maar het is me niet gelukt dat te vinden. Vermoedelijk staat het vast ergens, maar dit zal het gevolg zijn denk ik van de zoekcriteria die ik opgeef, mijn programmeertaal/kennis is nihil.

[Voor 7% gewijzigd door JdM op 01-07-2020 23:42]

N54 powered

Beste antwoord (via JdM op 16-06-2020 09:46)


  • Nielson
  • Registratie: juni 2001
  • Laatst online: 12:24
Je kunt devcon gebruiken:

https://ss64.com/nt/devcon.html

Of met de standaard aanwezig wmic:

https://docs.microsoft.co...t-pesky-right-click-tools

Alle reacties


Acties:
  • Beste antwoord
  • +1Henk 'm!

  • Nielson
  • Registratie: juni 2001
  • Laatst online: 12:24
Je kunt devcon gebruiken:

https://ss64.com/nt/devcon.html

Of met de standaard aanwezig wmic:

https://docs.microsoft.co...t-pesky-right-click-tools

Acties:
  • 0Henk 'm!

  • JdM
  • Registratie: februari 2002
  • Laatst online: 10:40
De WMIC zou het kunnen zijn, weet jij zo welke trigger code ik dan nodig heb?

N54 powered


Acties:
  • 0Henk 'm!

  • Nielson
  • Registratie: juni 2001
  • Laatst online: 12:24
Ik ging uit van die bovenste (hardware inventory) maar twijfel nu of dit is wat jij zoekt. Als je een recente W10 hebt kun je ook de standaard pnputil.exe gebruiken:

https://docs.microsoft.co...st/pnputil-command-syntax

[Voor 4% gewijzigd door Nielson op 08-06-2020 14:19]


Acties:
  • 0Henk 'm!

  • JdM
  • Registratie: februari 2002
  • Laatst online: 10:40
Ik ben blij met je hulp, maar het ontgaat me wat ik dan als regel moet aanmaken. Win 10 is versie 1909

[Voor 12% gewijzigd door JdM op 08-06-2020 14:34]

N54 powered


Acties:
  • 0Henk 'm!

  • mhoogendam
  • Registratie: oktober 2002
  • Laatst online: 22-06 15:53
Je kan eens proberen om de netwerk kaart te uit te zetten en daarna weer aan te zetten.
Pas de naam aan van je netwerk adapter om de juiste te pakken.
PowerShell:
1
2
Disable-NetAdapter -Name "Ethernet" -Confirm:$false
Enable-NetAdapter -Name "Ethernet" -Confirm:$false


Voor je Scheduled Task of desktop snelkoppeling commandline:
code:
1
C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe -executionpolicy bypass -file "C:\Scripts\Fix Network.ps1"

Delerium Steam Profile BF4 profile


Acties:
  • 0Henk 'm!

  • JdM
  • Registratie: februari 2002
  • Laatst online: 10:40
mhoogendam schreef op maandag 8 juni 2020 @ 14:41:
Je kan eens proberen om de netwerk kaart te uit te zetten en daarna weer aan te zetten.
Pas de naam aan van je netwerk adapter om de juiste te pakken.
PowerShell:
1
2
Disable-NetAdapter -Name "Ethernet" -Confirm:$false
Enable-NetAdapter -Name "Ethernet" -Confirm:$false


Voor je Scheduled Task of desktop snelkoppeling commandline:
code:
1
C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe -executionpolicy bypass -file "C:\Scripts\Fix Network.ps1"
Netwerkkaart uit en inschakelen heb ik eerder al geprobeerd, dan blijft de verbinding verbroken helaas. Alleen wanneer ik de knop "zoeken naar gewijzigde apparaten" aanklik functioneert alles spontaan.

[Voor 6% gewijzigd door JdM op 08-06-2020 14:46]

N54 powered


Acties:
  • 0Henk 'm!

  • ffha
  • Registratie: februari 2011
  • Laatst online: 23-06 18:11
https://superuser.com/que...devices-in-device-manager

En als dat werkt, kun je iets in Google typen van 'powershell script shortcut' of 'run powershell script on startup'.

Acties:
  • 0Henk 'm!

  • JdM
  • Registratie: februari 2002
  • Laatst online: 10:40
ffha schreef op maandag 8 juni 2020 @ 15:28:
https://superuser.com/que...devices-in-device-manager

En als dat werkt, kun je iets in Google typen van 'powershell script shortcut' of 'run powershell script on startup'.
Creatief ;) , maar ook daarmee gaat de netwerkkaart helaas niet werken

N54 powered


Acties:
  • 0Henk 'm!

  • JdM
  • Registratie: februari 2002
  • Laatst online: 10:40
Dit gaat hem waarschijnlijk wel worden, ben even aan het testen hiermee

N54 powered


Acties:
  • 0Henk 'm!

  • Batch
  • Registratie: mei 2014
  • Laatst online: 12:26
Wat je ook nog kan proberen:

Ga naar Start->Instellingen->Status->Netwerk opnieuw instellen->Nu opnieuw instellen.

Vervolgens reboot je de pc.

Acties:
  • 0Henk 'm!

  • JdM
  • Registratie: februari 2002
  • Laatst online: 10:40
Batch schreef op maandag 8 juni 2020 @ 21:21:
Wat je ook nog kan proberen:

Ga naar Start->Instellingen->Status->Netwerk opnieuw instellen->Nu opnieuw instellen.

Vervolgens reboot je de pc.
Heb je überhaupt de startpost gelezen?

N54 powered


Acties:
  • 0Henk 'm!

  • Batch
  • Registratie: mei 2014
  • Laatst online: 12:26
Jazeker heb ik die gelezen. Hetzelfde probleem als jou heb ik n.l. ook al een keer gehad en toen was het hiermee opgelost. Geeft natuurlijk geen garantie dan het bij jou ook werkt, maar niet geschoten is altijd mis. ;)

Acties:
  • 0Henk 'm!

  • Batch
  • Registratie: mei 2014
  • Laatst online: 12:26
Wat ik dus bedoel: je wilt liever dat het gewoon opgelost is en je niet zo'n workaround moet doen.

Acties:
  • 0Henk 'm!

  • JdM
  • Registratie: februari 2002
  • Laatst online: 10:40
Oh, je bedoelde het als eenmalig en dan in de hoop dat het een oplossing voor altijd zou zijn :+ zal het morgen eens proberen, maar ik kan me niet voorstellen dat ik dat niet al geprobeerd heb.

N54 powered


Acties:
  • 0Henk 'm!

  • JdM
  • Registratie: februari 2002
  • Laatst online: 10:40
Batch schreef op maandag 8 juni 2020 @ 21:21:
Wat je ook nog kan proberen:

Ga naar Start->Instellingen->Status->Netwerk opnieuw instellen->Nu opnieuw instellen.

Vervolgens reboot je de pc.
Heeft geen effect gehad
Devcon uitvoeren in de taakplanner met een rescan werkt prima maar.........
De prompt is niet direct als administrator uitvoerbaar, waardoor het alsnog niet werkt.
Ik heb een snelkoppeling van cmd.exe gemaakt met adminrechten en de gebruikersaccountinstellingen van Windows zo ingesteld dat er geen extra controle komt op de als admin uitvoerbare programma's; helaas neemt het systeem de adminrechten niet mee over in de snelkoppeling waardoor het nog niet functioneert |:(

De Devcon oplossing is dus bijna gemaakt, nu de volgende workaround om cmd.exe via een opdrachtregel direct als admin te laten starten. Ik ga ook eens kijken of ik een programma kan vinden wat de opdrachtprompt vervangt, misschien nog via PowerShell, maar dat is nieuw voor mij, komende uit het DOS tijdperk O-)

[Voor 7% gewijzigd door JdM op 09-06-2020 13:00]

N54 powered


Acties:
  • 0Henk 'm!

  • Nielson
  • Registratie: juni 2001
  • Laatst online: 12:24
Start je taakplanner wel als Administrator? Want dan kun je een taak aanmaken waarbij het programma onder een bepaald (administrator) account uitgevoerd wordt.

Acties:
  • 0Henk 'm!

  • Rensjuh
  • Registratie: juli 2007
  • Laatst online: 06:36

  • JdM
  • Registratie: februari 2002
  • Laatst online: 10:40
Heb even een en ander getest en op beide systemen waar ik het probleem heb, heb ik de taakplanner-opdracht aangemaakt.
Op beide systemen met een admin-account en op beide systemen wil het niet uitgevoerd worden.
Het vreemde is dat ook cmd gewoonweg niet wordt opgestart in de taakplanner, wat duidt op een ander probleem, mogelijk met machtigingen. Dit zoek ik verder uit als ik de taakplanner opdracht eerst werkend krijg.

Daarop het volgende geprobeerd op een systeem wat in de basis dit probleem al niet heeft (Veriton L4620G).
Met een admin-account dezelfde taak aangemaakt en als ik hier de taak start vanuit de taakplanner, opent er werkelijk een cmd scherm.
De taak devcon.exe rescan wordt echter niet automatisch uitgevoerd.

Om eerst een systeem te hebben waarop ik de taak geautomatiseerd aan de gang heb daarom de vraag nog of jullie kunnen zien wat ik verkeerd heb staan in de parameters?
Want onderstaande taakplanner instelling:


Levert alleen een CMD scherm op:


Waarin ik wel devcon.exe rescan werkend krijg als ik het dan alsnog handmatig invoer:

[Voor 3% gewijzigd door JdM op 11-06-2020 15:25]

N54 powered


  • Nielson
  • Registratie: juni 2001
  • Laatst online: 12:24
Waarom heb je die cmd ervoor staan? Je kunjt gewoon bij programma linken naar devcon.exe en in de regel eronder de commandline optie (rescan).

  • JdM
  • Registratie: februari 2002
  • Laatst online: 10:40
Nielson schreef op donderdag 11 juni 2020 @ 16:23:
Waarom heb je die cmd ervoor staan? Je kunjt gewoon bij programma linken naar devcon.exe en in de regel eronder de commandline optie (rescan).
Ja goeie vraag, waarom gebruik ik CMD.exe nog? O-)
Direct Devcon.exe in de taakplanner en rescan als parameter, even afwachten of het probleem nu weg blijft.
Ik heb het ook op de systemen gezet die het probleem waren en het lijkt te werken _/-\o_


edit:
aanvullingen


Na enkele dagen testen en opnieuw opstarten blijkt devcon.exe de oplossing geweest te zijn _/-\o_

[Voor 11% gewijzigd door JdM op 16-06-2020 09:47]

N54 powered

Pagina: 1


Apple iPad Pro (2021) 11" Wi-Fi, 8GB ram Microsoft Xbox Series X LG CX Google Pixel 5a 5G Sony XH90 / XH92 Samsung Galaxy S21 5G Sony PlayStation 5 Nintendo Switch Lite

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2021 Hosting door True