Cookies op Tweakers

Tweakers is onderdeel van DPG Media en maakt gebruik van cookies, JavaScript en vergelijkbare technologie om je onder andere een optimale gebruikerservaring te bieden. Ook kan Tweakers hierdoor het gedrag van bezoekers vastleggen en analyseren. Door gebruik te maken van deze website, of door op 'Cookies accepteren' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt? Bekijk dan ons cookiebeleid.

Meer informatie
Toon posts:

HTTP-fout 401.3 - Unauthorized

Pagina: 1
Acties:

Vraag


  • Dennis013
  • Registratie: januari 2003
  • Laatst online: 07-06 20:21
Mijn vraag

Ik heb een nieuwe installatie IIS op windows 10 gezet voor wat classic ASP websites.
Ik loop meteen tegen een beveiligingserror aan, namelijk
HTTP-fout 401.3 - Unauthorized
U bent niet gemachtigd om deze map of pagina te bekijken vanwege de ACL-configuratie (Access Control List, toegangsbeheerlijst) of versleutelingsinstellingen voor deze bron op de webserver.
Nou heb ik uiteraard alle relevante gebruikers alle toegang gegeven maar toch blijft die fout aanhouden.

(Hier stond een afbeelding met allerlei gebruikers :))


Relevante software en hardware die ik gebruik
IIS WINDOWS 10

Wat ik al gevonden of geprobeerd heb
https://stackoverflow.com...1-3-unauthorized/12924617

heb ook deze pagina gevolgd met betrekking tot

[/quote]anonymous authentication user was set to someone else instead of ApplicationPoolIdentity[/quote]

[Voor 29% gewijzigd door Dennis013 op 03-06-2020 22:47]

Alle reacties


Acties:
  • +1Henk 'm!

  • RobIII
  • Registratie: december 2001
  • Laatst online: 13:54

RobIII

Admin Devschuur®

^ Romeinse Ⅲ ja!

Heb je ook 't default document op index.asp (of whatever het is) gezet? Uberhaupt de binding voor .asp ingesteld?

Overigens is alles-en-iedereen "Volledig beheer" geven natuurlijk vragen om problemen (en nogal met een atoombom schieten op een mug...)

offtopic:
Het doorstrepen in je afbeelding is vrij nutteloos op deze manier, het is nog prima leesbaar...

[Voor 90% gewijzigd door RobIII op 03-06-2020 22:48]

There are only two hard problems in distributed systems: 2. Exactly-once delivery 1. Guaranteed order of messages 2. Exactly-once delivery.

Roses are red Violets are blue, Unexpected ‘{‘ on line 32.

Over mij


  • Dennis013
  • Registratie: januari 2003
  • Laatst online: 07-06 20:21
RobIII schreef op woensdag 3 juni 2020 @ 22:44:
Heb je ook 't default document op index.asp (of whatever het is) gezet? Uberhaupt de binding voor .asp ingesteld?
Die link die geeft, komt overeen met mijn instellingen
En als ik via bladeren op een bestand klik, dan moet ie ook gewoon laden?
RobIII schreef op woensdag 3 juni 2020 @ 22:44:
Overigens is alles-en-iedereen "Volledig beheer" geven natuurlijk vragen om problemen (en nogal met een atoombom schieten op een mug...)
Ja dat is waar, maar als IUSR niet werkt en online krijg ik allerlei paginas te zien dat ik bijv. EVERYONE and nog wat andere users moet proberen, daarom deed ik dat

  • RobIII
  • Registratie: december 2001
  • Laatst online: 13:54

RobIII

Admin Devschuur®

^ Romeinse Ⅲ ja!

Dennis013 schreef op woensdag 3 juni 2020 @ 22:53:
En als ik via bladeren op een bestand klik, dan moet ie ook gewoon laden?
:? Ik neem aan dat je met een browser naar http://nogiets-bla/ gaat en niet "via bladeren"? 8)7

[Voor 3% gewijzigd door RobIII op 03-06-2020 22:55]

There are only two hard problems in distributed systems: 2. Exactly-once delivery 1. Guaranteed order of messages 2. Exactly-once delivery.

Roses are red Violets are blue, Unexpected ‘{‘ on line 32.

Over mij


  • Dennis013
  • Registratie: januari 2003
  • Laatst online: 07-06 20:21
via IIS heet het 'bladeren', vind t zelf ook stom een NL versie van IIS te gebruiken aangezien zo goed als alle verdere info op het internet in het engels is.

Maar ja, ik gia via inderdaad de browser, naar localhost en dan de index bekijken en ik klik dan op een .html .asp of .png enzovoort

  • RobIII
  • Registratie: december 2001
  • Laatst online: 13:54

RobIII

Admin Devschuur®

^ Romeinse Ⅲ ja!

Dennis013 schreef op woensdag 3 juni 2020 @ 22:56:
Maar ja, ik gia via inderdaad de browser, naar localhost en dan de index bekijken en ik klik dan op een .html .asp of .png enzovoort
Ik weet niet hoor, dit klinkt niet bepaald logisch... wat zie je als je in je browser naar localhost gaat dan en wat versta je onder "de index bekijken" en "klikken op een .asp of .png"? Volgens mij zit je gewoon naar een directory listing te kijken... Heb je anders een screenshot?

There are only two hard problems in distributed systems: 2. Exactly-once delivery 1. Guaranteed order of messages 2. Exactly-once delivery.

Roses are red Violets are blue, Unexpected ‘{‘ on line 32.

Over mij


  • Dennis013
  • Registratie: januari 2003
  • Laatst online: 07-06 20:21
elke willekeurig bestand, in de root van de website geeft deze error. Dus ja, ik zie idd de directory van de wwwroot, maar normaal gesproken zou je toch gewoon (bijv) de png html of asp file moeten zien in de browser?

ik heb in IIS ingesteld dat ik de wwwroot kan bekijken, misschien was dat onduidelijk?

[Voor 17% gewijzigd door Dennis013 op 03-06-2020 23:09]


  • RobIII
  • Registratie: december 2001
  • Laatst online: 13:54

RobIII

Admin Devschuur®

^ Romeinse Ⅲ ja!

En daarom (zie mijn eerste reactie in dit topic): heb je een default document ingesteld? Want daar lijkt 't niet bepaald op. En als je dat wél gedaan hebt (en zeker weet dat je 't juiste document hebt ingesteld) dan werkt je classic-ASP handler / binding / whatchamacallit niet.
Dennis013 schreef op woensdag 3 juni 2020 @ 23:06:
ik heb in IIS ingesteld dat ik de wwwroot kan bekijken, misschien was dat onduidelijk?
8)7 Je hebt directory browsing aangezet. Dat wil je nou net niet. Je maakt mij niet wijs dat je de link uit mijn eerste post helemaal hebt gevolgd.

[Voor 82% gewijzigd door RobIII op 03-06-2020 23:14]

There are only two hard problems in distributed systems: 2. Exactly-once delivery 1. Guaranteed order of messages 2. Exactly-once delivery.

Roses are red Violets are blue, Unexpected ‘{‘ on line 32.

Over mij


  • Dennis013
  • Registratie: januari 2003
  • Laatst online: 07-06 20:21
ik heb directory browsing uitgezet en het standaard bestand ingesteld op index.asp, (dat was inderdaad nog niet). Maar de error blijft. Ik snap ook niet wat het instellen van index.asp als standaard document te maken heeft met bijv. het niet kunnen inladen van een html of png file via de directory weergave?

  • RobIII
  • Registratie: december 2001
  • Laatst online: 13:54

RobIII

Admin Devschuur®

^ Romeinse Ⅲ ja!

Je moet begrijpen dat wij hier niet over je schouder kunnen meekijken en het dus met een fractie van de informatie die jij hebt moeten doen. Ik ken de applicatie niet, maar for-all-I-know horen die bestanden misschien wel via een .asp bestand geserveerd te worden.

Je hebt alles-en-iedereen en de rest van de wereld "Volledig beheer" gegeven dus daar zal je 401.3 niet vandaan komen. Wat 't dan wel is blijft gissen als je alleen maar wedervragen blijft stellen ipv met meer relevante informatie op de proppen te komen. Wat zeggen je logfiles bijvoorbeeld? Onder welke user draait je applicatie en je app-pool waar de applicatie in zit? Heb je dit of dit al eens geprobeerd?

En anders posts eens wat screenshots van wat/de relevante(!) settings zodat we kunnen "meekijken". Of beschrijf ze voor mijn part.

[Voor 17% gewijzigd door RobIII op 03-06-2020 23:55]

There are only two hard problems in distributed systems: 2. Exactly-once delivery 1. Guaranteed order of messages 2. Exactly-once delivery.

Roses are red Violets are blue, Unexpected ‘{‘ on line 32.

Over mij


  • Dennis013
  • Registratie: januari 2003
  • Laatst online: 07-06 20:21
Ben je zeer dankbaar voor de hulp :)

ik zal proberen alle info aan te leveren. Dit is een probleem wat ik alleen op deze nieuwe pc heb, voorheen kon ik wel zelf IIS instellen zonder deze error. Ik vermoed dat het ergens met een systeem instelling te maken heeft misschien, maar geen zekerheid daarover. Weet ook niet waar ik dat zou moeten zoeken

Ik heb de wwwroot wel in dropbox map staan, wellicht maakt dat uit?

Als ik de website opnieuw probeer te definieren in IIS dan krijg ik al een beveiligingsmelding. Lijkt me dat het daar ergens mee te maken heeft.


(ik probeer de website aan te maken met de specifieke gebruiker waarmee ik nu ingelogd ben, dat lijkt wel te lukken)

Deze website laat ik over poort 100 lopen omdat IIS aangeeft dat 80 al bezet was. De website (die over poort 80 loopt) kan ik nu wel eindelijk ASP files bekijken (ook met URL rewrite) maar de afbeeldingen hebben ook allemaal een verificatieprobleem met welke user toegang heeft. Met andere woorden, de afbeeldingen laden ook niet in terwijl ik die in map ook alle mogelijke gebruikers alle rechten heb gegeven op de bestanden.

Voor wat betreft de linkjes die je geeft. Anonieme verificatie tussen een specifieke gebruiker en id van groepstoepassingen, beiden geprobeerd. Krijg wel een andere error dan
HTTP/1.1 401 Fout: toegang is geweigerd.


Als ik de logfiles wil openen krijg ik ook een error (Vanuit IIS dan, heb t via de verkenner gevonden)?
C:\Inetpub\logs\logfiles is niet toegankelijk.

Toegang geweigerd.
Waar kan ik zien welke user de applicatie draait? Of app-pool in applicatie?

[Voor 26% gewijzigd door Dennis013 op 04-06-2020 11:31]


  • Woy
  • Registratie: april 2000
  • Niet online

Woy

Moderator Devschuur®
Welke authenticatie mechanismes heb je aanstaan op je site? Als je applicatie bijvoorbeeld integrated windows authenticatie nodig heeft, maar die module staat uit op je site zul je ook een Access Denied krijgen. Dus zorg ervoor dat je IIS configuratie (en geinstalleerde modules) overeenkomt met de geconfigureerde authenticatie in je web.config

[Voor 24% gewijzigd door Woy op 04-06-2020 11:38]

“Build a man a fire, and he'll be warm for a day. Set a man on fire, and he'll be warm for the rest of his life.”


  • Ezechiel
  • Registratie: augustus 2005
  • Laatst online: 18-06 13:14
Opgesomd vanuit een Engelse IIS10, ik ga er van uit dat je dit zelf (vrij) kan vertalen.

Als je onder Sites op de betreffende site klikt, ga aan de rechterkant naar Basic Settings en klik vervolgens op Connect As. Wat staat daar ingevuld? Een specifieke user of de Application user? In het geval van een specifieke user, bestaat die user, heeft de user de juiste rechten en klopt het ingegeven password? En werkt het wel als je de (standaard) Application user gebruikt?

| PoE | OnePlus 7 Pro bezitter |


Acties:
  • 0Henk 'm!

  • Dennis013
  • Registratie: januari 2003
  • Laatst online: 07-06 20:21
Woy schreef op donderdag 4 juni 2020 @ 11:37:
Welke authenticatie mechanismes heb je aanstaan op je site? Als je applicatie bijvoorbeeld integrated windows authenticatie nodig heeft, maar die module staat uit op je site zul je ook een Access Denied krijgen. Dus zorg ervoor dat je IIS configuratie (en geinstalleerde modules) overeenkomt met de geconfigureerde authenticatie in je web.config
IK ben nu ingelogd met wat volgens mij, mijn microsoft account is. Dus ik denk dat de authenticatie daar ook mee samen hangt, maar waar ik dat zou moeten instellen??? :?

Ik moet helaas inzien dat ik echt hopeloos achterloop met mijn kennis rondom het microsoft platform. Hoog tijd om er iets aan te doen :/

[Voor 10% gewijzigd door Dennis013 op 05-06-2020 14:17]

Pagina: 1


Apple iPad Pro (2021) 11" Wi-Fi, 8GB ram Microsoft Xbox Series X LG CX Google Pixel 5a 5G Sony XH90 / XH92 Samsung Galaxy S21 5G Sony PlayStation 5 Nintendo Switch Lite

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2021 Hosting door True