Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie
Toon posts:

Ethernet doesn't have a valid IP configuration

Pagina: 1
Acties:

Vraag


Acties:
  • 0Henk 'm!

  • MrRigorous
  • Registratie: juli 2019
  • Laatst online: 02-06 18:01
Mijn vraag
...

Ik heb sinds twee weken na negen jaar een nieuw systeem aangeschaft. De tweakers bestbuy pc bevalt prima op het internet na. Als ik de computer opstart heb ik geen internet connectie. Als ik op troubleshoot klik geeft hij 50/50 kans op: 'Fixed' of: ' Not fixed: Ethernet doesn't have a valid IP configuration'. Op mijn oude pc liep alles goed.

Op het moment dat hij 'fixed' zegt heb ik nog steeds problemen. Als ik google ping geeft hij om de 5 minuten een time out. Als ik iets download (steam/epicgames/blizzard/chromedownloads/utorrent) schiet de latency omhoog naar 100ms en geeft regelmatige time outs. Erg irritant tijdens competitief gamen.

Relevante software en hardware die ik gebruik
...
Het betreft een nieuwe windows 10 installatie met een gigabit ethernetpoort op een B450M-A moederbord.

Wat ik al gevonden of geprobeerd heb
...
Kabels gecontroleerd
Modem uit en aan gezet
PC herstarten
Provider bellen (modem was niets mis mee)
Ethernet adapter disabled en enabled
Ethernet adapter geuninstalled in gereinstalled
Ethernet drivers geupdated
Ethernet adapter automatisch ipv4 adres toe laten kennen
Ipv6 uitgeschakeld
De volgende commando's in command prompt ingevoerd: 'netsh winsock reset' en 'netsh int ip reset' (hij lijkt het dan bij eerstvolgende reboot te doen)
In command prompt ipconfig /release en ipconfig /renew ingevoerd


Erg veel weet ik niet van computers en ik kom er echt niet uit, zelfs niet met mensen in mijn omgeving. Ik ben ten einde raad en dus hoop ik dat jullie me kunnen helpen.

PS: ik ben nieuw en hoop dat ik het goede forum te pakken heb.

Alle reacties


Acties:
  • 0Henk 'm!

  • Falcon
  • Registratie: februari 2000
  • Laatst online: 08:57

Falcon

Q.A. Engineer (.net/azure)

Zet eens de uitkomst van een ipconfig /all hier neer tussen /code tag.

Probeer ook even de networkreset die genoemd wordt onderaan deze pagina: https://support.microsoft...network-connection-issues

[Voor 53% gewijzigd door Falcon op 29-05-2020 19:26]

"You never come second by putting other people first"


Acties:
  • 0Henk 'm!

  • MrRigorous
  • Registratie: juli 2019
  • Laatst online: 02-06 18:01
Heb networkreset gedaan. Na reboot werkt het internet. Ik zal nog eens herstarten om te zien of het blijvend is.

Acties:
  • 0Henk 'm!

  • MrRigorous
  • Registratie: juli 2019
  • Laatst online: 02-06 18:01
Na networkreset en herstarten van pc doet hij het. Daarna nog een keer geherstart en doet het niet. "Problem not fixed. Ethernet doesn't have a valid IP configuration"

Ipconfig /all

code:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
Windows IP Configuration

   Host Name . . . . . . . . . . . . : DESKTOP-IFH48BP
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : lan

Ethernet adapter Ethernet:

   Connection-specific DNS Suffix  . : lan
   Description . . . . . . . . . . . : Realtek PCIe GbE Family Controller
   Physical Address. . . . . . . . . : A8-5E-45-60-11-71
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::3d4f:3770:f64a:cd55%12(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.1.64(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : 29 May 2020 19:52:07
   Lease Expires . . . . . . . . . . : 30 May 2020 19:52:07
   Default Gateway . . . . . . . . . : 192.168.1.1
   DHCP Server . . . . . . . . . . . : 192.168.1.1
   DHCPv6 IAID . . . . . . . . . . . : 111697477
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-26-4D-64-53-A8-5E-45-60-11-71
   DNS Servers . . . . . . . . . . . : 192.168.1.1
   NetBIOS over Tcpip. . . . . . . . : Enabled

Acties:
  • 0Henk 'm!

  • FREAKJAM
  • Registratie: mei 2007
  • Laatst online: 06:57

FREAKJAM

"MAXIMUM"

Wat zegt je eventvwr?

Diagnostics-Networking: Expand Applications and Services Logs, then Microsoft, then Windows. Scroll down until you find Diagnostics-Networking.

is everything cool?


Acties:
  • 0Henk 'm!

  • MrRigorous
  • Registratie: juli 2019
  • Laatst online: 02-06 18:01
In de eventviewer staat dit: (geen warnings of errors,wel information)

Network Diagnostics Framework stopped because it completed the user initiated diagnostics session.

Result: Cancelled during diagnosis. [0]

Acties:
  • 0Henk 'm!

  • GeleFles
  • Registratie: augustus 2001
  • Niet online

GeleFles

What's in a bottle?

Zet ook eens pings open naar 8.8.8.8, 192.168.1.1 en naar 127.0.0.1.

Als alleen de ping naar 8.8.8.8 wegvalt zit het toch in je internet lijn.
Valt 192.168.1.1 ook weg, dan kan het je router of interne netwerk zijn.
Als 127.0.0.1 ook wegvalt, dan is de netwerk stack op je pc niet in orde en zit het ergens in Windows (drivers of netwerkstack)

Acties:
  • 0Henk 'm!

  • MrRigorous
  • Registratie: juli 2019
  • Laatst online: 02-06 18:01
8.8.8.8 stabiel tussen 22 en 26ms
192.168.1.1 stabiel onder 1 ms
127.0.0.1 stabiel onder 1 ms

Bedankt voor de hulp. Hopelijk kunnen jullie iets met deze informatie.

Acties:
  • 0Henk 'm!

  • MrRigorous
  • Registratie: juli 2019
  • Laatst online: 02-06 18:01
Ik heb een willekeurige download aangezet en krijg nu dit

code:
1
2
3
4
5
6
7
8
Request timed out.
Reply from 8.8.8.8: bytes=32 time=23ms TTL=55
Request timed out.
Reply from 8.8.8.8: bytes=32 time=78ms TTL=55
Reply from 8.8.8.8: bytes=32 time=64ms TTL=55
Request timed out.
Reply from 8.8.8.8: bytes=32 time=69ms TTL=55
Reply from 8.8.8.8: bytes=32 time=63ms TTL=55

Acties:
  • 0Henk 'm!

  • MrRigorous
  • Registratie: juli 2019
  • Laatst online: 02-06 18:01
EDIT: zodra ik de download uitzet wordt 8.8.8.8 weer 22-26ms

Acties:
  • 0Henk 'm!

  • True
  • Registratie: april 2011
  • Niet online

True

Dislecticus

Lijkt op een driver dingetje (als je ping timeouts krijgt tijdens downloaden), heb je zo'n 'Killer' ethernet of WiFi module?
Ik zou de site van de producent van je moederbord nog even napluizen op drivers voor LAN en WLAN (indien van toepassing).

Steam Profile


Acties:
  • 0Henk 'm!

  • Klippy
  • Registratie: oktober 2000
  • Laatst online: 10:17

Klippy

Still Game

Je zegt:
Ethernet adapter automatisch ipv4 adres toe laten kennen
Had je een vast IP dan?

Want dat zou ik willen voorstellen, stel eens een vast IP in (192.168.1.222 oid, iets dat vrij is in de 192.168.1 range en redelijk hoog).
https://support.microsoft...ws-change-tcp-ip-settings

Dat zou DHCP problemen of IP conflicten moeten uitsluiten. Packet loss kan optreden met een IP conflict.

Kans dat het dat niet is, maar dit is snel te proberen en sluit veel problemen al uit.

Steam | SXQncyBhbGwgZ29vZCwgbWFuISDwn5iO


Acties:
  • 0Henk 'm!

  • job
  • Registratie: februari 2002
  • Laatst online: 09:42
Ik heb met een ander moederbord met dezelfde nic (RTL8111H) niets dan gedonder met de netwerkverbinding.
Probeer een recente driver van de realtek site: https://www.realtek.com/e...rnet-pci-express-software


En schakel vervolgens bij device manager (apparaat beheer) > realtek pcie gbe > properties > advanced de volgende zaken uit:
energy-efficient ethernet
green internet


edit: ohja, en ik moest mijn bios op uefi/legacy zetten. Puur uefi gaf gegarandeerd netwerk problemen.

Dat zorgde bij mij voor een stabiele verbinding.

[Voor 14% gewijzigd door job op 29-05-2020 20:55. Reden: belangrijk detail vergeten]


Acties:
  • 0Henk 'm!

  • MrRigorous
  • Registratie: juli 2019
  • Laatst online: 02-06 18:01
@True Ik heb alle drivers met meerdere personen geprobeerd en dat lost niets op.

@Klippy Ik had geen vast ip. Er stond op een hulpsite dat soms het veranderen van vast naar automatisch de oplossing kon zijn. Ik ga het nu proberen met een statisch ip.

UPDATE:
Heb vast ip adres in gevuld (192.168.1.222) en hij pingt stabiel op +/- 23ms. Zodra ik een download aanzet stijgt de latency weer boven de 100 en krijg ik veel time outs.

Acties:
  • 0Henk 'm!

  • Klippy
  • Registratie: oktober 2000
  • Laatst online: 10:17

Klippy

Still Game

@MrRigorous Duidelijk, dan zal het geen IP conflict of DHCP issue zijn waarschijnlijk.

Dan zou ik het toch zoeken in de kabel of drivers, maar buiten een andere kabel (eventueel PC even naast modem zetten als je geen tweede lange kabel hebt) heb ik geen concrete ideeën.

Kijk ook of je kabel er goed in zit, ik heb het al eens gezien dat een pinnetje van het IO shield in de netwerk poort stak waardoor het leek of de kabel gewoon vastklikte, maar geen contact maakte.

Succes er mee.

[edit]Zegt Windows wel dat het een gigabit verbinding is? Of krijg je maar 100mb bijvoorbeeld?

[Voor 9% gewijzigd door Klippy op 29-05-2020 20:58]

Steam | SXQncyBhbGwgZ29vZCwgbWFuISDwn5iO


Acties:
  • 0Henk 'm!

  • MrRigorous
  • Registratie: juli 2019
  • Laatst online: 02-06 18:01
@Klippy ik heb de ethernetpoort nog even gecheckt. Niets mis mee. Probeerde internet weer te troubleshooten en ik kreeg ineens twee meldingen:'Ethernet doesn't have a valid IP configuration' en
'The default gateway is not available'. Die laatste is nieuw...

EDIT: wat bedoel je met of het een gigabit verbinding is en misschien maar 100mb? Hoe controleer ik dit?

[Voor 17% gewijzigd door MrRigorous op 29-05-2020 21:05]


Acties:
  • 0Henk 'm!

  • True
  • Registratie: april 2011
  • Niet online

True

Dislecticus

MrRigorous schreef op vrijdag 29 mei 2020 @ 21:04:
@Klippy ik heb de ethernetpoort nog even gecheckt. Niets mis mee. Probeerde internet weer te troubleshooten en ik kreeg ineens twee meldingen:'Ethernet doesn't have a valid IP configuration' en
'The default gateway is not available'. Die laatste is nieuw...
The default gateway is not available
Dan lijkt die niet te kunnen verbinden met je router, wat niet heel gek is als die geen valide IP configuratie heeft.
Ben je technisch genoeg onderlegd om een live-usb te maken voor een Linux distributie linkje? Dan kun je hier proberen of je dezelfde problemen ervaart, als je hier geen problemen hebt is het driver of netwerkinstelling die je verbinding in de soep helpt.

Steam Profile


Acties:
  • 0Henk 'm!

  • MrRigorous
  • Registratie: juli 2019
  • Laatst online: 02-06 18:01
@job Ik heb de adapter van energiezuinig en groen afgehaald, krijg nog steeds timeouts.

@True Ik zou niet weten hoe dat moet, maar ik heb hier een usb-tje van 16GB liggen. Morgen heb ik niets te doen en als het niet al te moeilijk is wil ik met een uitgebreide handleiding het wel proberen.

PS: iedereen heel erg bedankt voor het meedenken.

Acties:
  • 0Henk 'm!

  • kh65
  • Registratie: juni 2006
  • Laatst online: 09:54
Kan het niet je bekabeling zijn?
Heb op die kabel al wel eens een computer / laptop aangesloten gehad die het wel goed deed?
Indien niet --> Misschien moet je toch eens een Laptop zien te lenen met een ethernet aansluiting,
en daarmee kijken of het niet je kabel is?
Andere optie: Een USB (3) naar Ethernet adapter.. Maar dat is wel een beetje raar, een standaard ethernet verbinding zou het moeten doen...

Acties:
  • 0Henk 'm!

  • MrRigorous
  • Registratie: juli 2019
  • Laatst online: 02-06 18:01
@kh65 In de originele post zeg ik dat mijn oude pc geen problemen had. Exact hetzelfde netwerk. Het enige verschil is dat ik van windows 7 naar windows 10 ben gegaan.

Een USB/Ethernet adapter dacht ik ook aan, maar dat is omzeilen van het problem ipv het op te lossen.

@True Ik heb niet een killer wifi of wat je er ook mee bedoelt. Ik heb een asus B450M-A moederbord met een on board ethernetkaart. Die gebruik ik.

Acties:
  • 0Henk 'm!

  • Klippy
  • Registratie: oktober 2000
  • Laatst online: 10:17

Klippy

Still Game

MrRigorous schreef op vrijdag 29 mei 2020 @ 21:04:
@Klippy
EDIT: wat bedoel je met of het een gigabit verbinding is en misschien maar 100mb? Hoe controleer ik dit?
Typ "netwerkstatus" je startmenu, bij Ethernet klik je op eigenschappen en scroll naar beneden.
Bij Eigenschappen moet bij Snelheid van de verbinding (ontvangen/verzenden) 1000/1000 (Mbps) staan.

Steam | SXQncyBhbGwgZ29vZCwgbWFuISDwn5iO


Acties:
  • 0Henk 'm!

  • MrRigorous
  • Registratie: juli 2019
  • Laatst online: 02-06 18:01
Klippy schreef op vrijdag 29 mei 2020 @ 21:22:
[...]


Typ "netwerkstatus" je startmenu, bij Ethernet klik je op eigenschappen en scroll naar beneden.
Bij Eigenschappen moet bij Snelheid van de verbinding (ontvangen/verzenden) 1000/1000 (Mbps) staan.
Ik heb een Engelse windows. Kan niet vinden wat je bedoelt.

Acties:
  • 0Henk 'm!

  • Klippy
  • Registratie: oktober 2000
  • Laatst online: 10:17

Klippy

Still Game

MrRigorous schreef op vrijdag 29 mei 2020 @ 21:23:
[...]


Ik heb een Engelse windows. Kan niet vinden wat je bedoelt.
Ik extra zoeken hoe het heet in het Nederlands...
Klik op de knop hier https://support.microsoft...network-connection-status en dan op properties.

Steam | SXQncyBhbGwgZ29vZCwgbWFuISDwn5iO


Acties:
  • 0Henk 'm!

  • MrRigorous
  • Registratie: juli 2019
  • Laatst online: 02-06 18:01
Ah, helder. Hij geeft het volgende aan:

Link speed (Receive/transmit): 1000/1000 (Mbps)

Acties:
  • 0Henk 'm!

  • GeleFles
  • Registratie: augustus 2001
  • Niet online

GeleFles

What's in a bottle?

MrRigorous schreef op vrijdag 29 mei 2020 @ 20:34:
8.8.8.8 stabiel tussen 22 en 26ms
192.168.1.1 stabiel onder 1 ms
127.0.0.1 stabiel onder 1 ms

Bedankt voor de hulp. Hopelijk kunnen jullie iets met deze informatie.
Maar wat gebeurd er als je geen verbinding meer hebt? valt dan de ping naar de interne adressen ook weg?

Acties:
  • 0Henk 'm!

  • MrRigorous
  • Registratie: juli 2019
  • Laatst online: 02-06 18:01
Bedoel je voordat ik de troubleshoot start?

Acties:
  • 0Henk 'm!

  • GeleFles
  • Registratie: augustus 2001
  • Niet online

GeleFles

What's in a bottle?

MrRigorous schreef op vrijdag 29 mei 2020 @ 21:35:
Bedoel je voordat ik de troubleshoot start?
Ja, op het moment dat windows zegt dat er problemen zijn.

Acties:
  • 0Henk 'm!

  • MrRigorous
  • Registratie: juli 2019
  • Laatst online: 02-06 18:01
Moment. Moet ik even die situatie reproduceren.

Acties:
  • 0Henk 'm!

  • MrRigorous
  • Registratie: juli 2019
  • Laatst online: 02-06 18:01
Hmm ik reboot om de error te reproduceren maar heb gewoon verbinding. Moment ik probeer het nog eens.

Acties:
  • 0Henk 'm!

  • MrRigorous
  • Registratie: juli 2019
  • Laatst online: 02-06 18:01
UPDATE:

Als ik de computer reboot heeft hij plots wel verbinding. Maar als ik een download aanzet geeft hij time outs. Ik kan die situatie dus niet reproduceren, het spijt me.

Acties:
  • +1Henk 'm!

  • MarchelHoek
  • Registratie: juni 2007
  • Laatst online: 08:13
Ik heb dit nu meerdere keren zien gebeuren.
Lijkt te maken te hebben met een soort slaapstand waarin de pc komt als je shutdown geeft op je pc.

Een herstart van de pc geeft een andere optie aan het herstarten van de pc en lijkt na een "warme" herstart wel weer te functioneren.

Probeer eens bij de geavanceerde settings van het energiebeheer de optie fast-boot uit te zetten en dan te testen

Bla Bla Bla


Acties:
  • 0Henk 'm!

  • CuBras
  • Registratie: oktober 2011
  • Laatst online: 24-11 15:20
Met wat of van waar start je de download? Is dat in de browser of bv. Steam/Epic Games Launcher?

Acties:
  • 0Henk 'm!

  • MrRigorous
  • Registratie: juli 2019
  • Laatst online: 02-06 18:01
CuBras schreef op vrijdag 29 mei 2020 @ 21:44:
Met wat of van waar start je de download? Is dat in de browser of bv. Steam/Epic Games Launcher?
Lees de eerste post. Het gaat om alles behalve streams als youtube, twitch en netflix.

Ik heb fast-boot uitgezet. Even kijken wat er gebeurt.

Acties:
  • 0Henk 'm!

  • MrRigorous
  • Registratie: juli 2019
  • Laatst online: 02-06 18:01
Bij opstarten van de pc lijkt het probleem deels opgelost. Hij krijgt een ip en heeft gewoon verbinding.

Enige probleem dat rest is de time outs...

Acties:
  • 0Henk 'm!

  • FreakNL
  • Registratie: januari 2001
  • Laatst online: 10:35

FreakNL

Well do ya punk?

Begin met een andere kabel. Als je niet zo een lange kabel hebt zul je je PC even naar het modem moeten slepen en dan een kort kabeltje gebruiken.

Is het probleem dan opgelost ligt het aan je kabel
Is het probleem er nog steeds dan ligt het aan je driver/NIC.

Je zou ook een ander OS kunnen proberen (bijvoorbeeld een Linux Live CD).

Last resort:
USB adapter is niet zo’n hele beste oplossing, maar er zijn ook prima PCI NICs op de markt.
pricewatch: Intel Gigabit CT Desktop Adapter

[Voor 13% gewijzigd door FreakNL op 29-05-2020 21:53]


Acties:
  • 0Henk 'm!

  • MrRigorous
  • Registratie: juli 2019
  • Laatst online: 02-06 18:01
Voor vanavond houd ik het voor gezien. Morgen sluit ik hem met een korte kabel aan op de modem. Ik vraag me af: is het niet mogelijk dat het moederbord defect is?

Acties:
  • 0Henk 'm!

  • FreakNL
  • Registratie: januari 2001
  • Laatst online: 10:35

FreakNL

Well do ya punk?

Kan altijd natuurlijk.

Maar dan verwacht ik eerder dat de NiC helemaal niks doet..

Acties:
  • 0Henk 'm!

  • MrRigorous
  • Registratie: juli 2019
  • Laatst online: 02-06 18:01
Even uit interesse, wat is de NiC? Iemand anders had het er ook al over.

Acties:
  • 0Henk 'm!

  • True
  • Registratie: april 2011
  • Niet online

True

Dislecticus

MrRigorous schreef op vrijdag 29 mei 2020 @ 21:56:
Even uit interesse, wat is de NiC? Iemand anders had het er ook al over.
Wikipedia: NIC
Nummertje één ;)

Heb je al een andere poort geprobeerd op je modem/router/switch waar je computer heen gaat?

Steam Profile


Acties:
  • 0Henk 'm!

  • Klippy
  • Registratie: oktober 2000
  • Laatst online: 10:17

Klippy

Still Game

MarchelHoek schreef op vrijdag 29 mei 2020 @ 21:43:
Ik heb dit nu meerdere keren zien gebeuren.
Lijkt te maken te hebben met een soort slaapstand waarin de pc komt als je shutdown geeft op je pc.

Een herstart van de pc geeft een andere optie aan het herstarten van de pc en lijkt na een "warme" herstart wel weer te functioneren.

Probeer eens bij de geavanceerde settings van het energiebeheer de optie fast-boot uit te zetten en dan te testen
Dat is ook een mogelijkheid ja, fast boot zet ik zelf ook altijd uit, reboot is reboot :)
Het lijkt bij TS gerelateerd aan reboots, dus ik vind het een goede suggestie.

Steam | SXQncyBhbGwgZ29vZCwgbWFuISDwn5iO


Acties:
  • 0Henk 'm!

  • MrRigorous
  • Registratie: juli 2019
  • Laatst online: 02-06 18:01
True schreef op vrijdag 29 mei 2020 @ 22:13:
[...]

Wikipedia: NIC
Nummertje één ;)

Heb je al een andere poort geprobeerd op je modem/router/switch waar je computer heen gaat?
Ja, alle poorten.

@Klippy Fast-boot uitzetten werkt voor het opvragen van een ip-adres maar niet bij de time outs.

Acties:
  • 0Henk 'm!

  • MrRigorous
  • Registratie: juli 2019
  • Laatst online: 02-06 18:01
En NiC is gewoon de netwerkkaart dus. Helder. Ik googelde en kwam bij verschillende bedrijven terecht. Beetje slordig van me, sorry :)

Morgen ga ik alle suggesties nog eens langs en als het nog niet werkt heropen ik de thread.
Pagina: 1


Apple iPhone 12 Microsoft Xbox Series X LG CX Google Pixel 5 Black Friday 2020 Samsung Galaxy S20 4G Sony PlayStation 5 Nintendo Switch Lite

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2020 Hosting door True