Toon posts:

Kolom met cijfers uniform krijgen

Pagina: 1
Acties:

Onderwerpen

Vraag


  • Jackson6
  • Registratie: Oktober 2010
  • Niet online
Hoi,

Ik heb in Excel een kolom met veel cijfers bijvoorbeeld

Kolom1
8347
77347
38473


Nu ik wil ik dat uniform krijgen naar bijvoorbeeld:

11111.008347
11111.077347
11111.038473

Het achterstel gedeelte is me gelukt, dus vooraan aanvullen met nullen totdat er 6 cijfers staan, echter als ik het 11111. deel toevoeg dan werkt de formule niet meer, omdat deze alleen werkt met cijfers.

Is er een manier om dit alsnog voor elkaar te krijgen? De formule die ik heb gebruikt is: =TEKST(A2;"000000")

=TEKST(A2;"11111.000000") werkt dus niet.

Alvast dankt :)

Beste antwoord (via Jackson6 op 28-05-2020 14:12)


  • g0tanks
  • Registratie: Oktober 2008
  • Laatst online: 23:37

g0tanks

Moderator CSA
code:
1
="11111."&TEKST(A1,"000000")


Of denk ik dan te makkelijk?

Ultrawide gaming setup: AMD Ryzen 7 2700X | NVIDIA GeForce RTX 2080 | Dell Alienware AW3418DW

Alle reacties


Acties:
  • Beste antwoord
  • +1Henk 'm!

  • g0tanks
  • Registratie: Oktober 2008
  • Laatst online: 23:37

g0tanks

Moderator CSA
code:
1
="11111."&TEKST(A1,"000000")


Of denk ik dan te makkelijk?

Ultrawide gaming setup: AMD Ryzen 7 2700X | NVIDIA GeForce RTX 2080 | Dell Alienware AW3418DW


Acties:
  • +1Henk 'm!

  • Crahsystor
  • Registratie: Februari 2009
  • Laatst online: 26-09 13:51
@g0tanks Niet te makkelijk, dat werkt.

Ik zou ergens een cel hebben met je nullen en met je enen en daarnaar verwijzen in je formules. Veel makkelijker bij te werken als het toch een nulletje meer of minder moest zijn etc.

Dus bijvoorbeeld
A1 tekstopmaak cel gevuld met je nullen.
A2 gelijk met je enen.
Stel data begint op A3, dan in B3 "=$A$2&"."&(TEKST(A3;$A$1)"

Je zou het puntje ook bij de enen kunnen zetten of ook een losse verwijzing maken natuurlijk.

Addicted to silent computing


  • Jackson6
  • Registratie: Oktober 2010
  • Niet online
Het is gelukt @g0tanks , @Crahsystor ook bedankt voor de input!

Acties:
  • +1Henk 'm!

  • dix-neuf
  • Registratie: Juli 2018
  • Niet online
Ook mogelijk:
code:
1
="1111."&herhaling("0";6-lengte(A1))&A1

of, met alleen de punt tussen aanhalingstekens (maakt voor het resultaat geen verschil, die blijft tekst):
code:
1
=1111&"."&herhaling(0;6-lengte(A1))&A1

[Voor 54% gewijzigd door dix-neuf op 28-05-2020 16:30]




Google Pixel 7 Sony WH-1000XM5 Apple iPhone 14 Samsung Galaxy Watch5, 44mm Sonic Frontiers Samsung Galaxy Z Fold4 Insta360 X3 Nintendo Switch Lite

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2022 Hosting door True

Tweakers maakt gebruik van cookies

Tweakers plaatst functionele en analytische cookies voor het functioneren van de website en het verbeteren van de website-ervaring. Deze cookies zijn noodzakelijk. Om op Tweakers relevantere advertenties te tonen en om ingesloten content van derden te tonen (bijvoorbeeld video's), vragen we je toestemming. Via ingesloten content kunnen derde partijen diensten leveren en verbeteren, bezoekersstatistieken bijhouden, gepersonaliseerde content tonen, gerichte advertenties tonen en gebruikersprofielen opbouwen. Hiervoor worden apparaatgegevens, IP-adres, geolocatie en surfgedrag vastgelegd.

Meer informatie vind je in ons cookiebeleid.

Sluiten

Toestemming beheren

Hieronder kun je per doeleinde of partij toestemming geven of intrekken. Meer informatie vind je in ons cookiebeleid.

Functioneel en analytisch

Deze cookies zijn noodzakelijk voor het functioneren van de website en het verbeteren van de website-ervaring. Klik op het informatie-icoon voor meer informatie. Meer details

janee

    Relevantere advertenties

    Dit beperkt het aantal keer dat dezelfde advertentie getoond wordt (frequency capping) en maakt het mogelijk om binnen Tweakers contextuele advertenties te tonen op basis van pagina's die je hebt bezocht. Meer details

    Tweakers genereert een willekeurige unieke code als identifier. Deze data wordt niet gedeeld met adverteerders of andere derde partijen en je kunt niet buiten Tweakers gevolgd worden. Indien je bent ingelogd, wordt deze identifier gekoppeld aan je account. Indien je niet bent ingelogd, wordt deze identifier gekoppeld aan je sessie die maximaal 4 maanden actief blijft. Je kunt deze toestemming te allen tijde intrekken.

    Ingesloten content van derden

    Deze cookies kunnen door derde partijen geplaatst worden via ingesloten content. Klik op het informatie-icoon voor meer informatie over de verwerkingsdoeleinden. Meer details

    janee