Cookies op Tweakers

Tweakers is onderdeel van DPG Media en maakt gebruik van cookies, JavaScript en vergelijkbare technologie om je onder andere een optimale gebruikerservaring te bieden. Ook kan Tweakers hierdoor het gedrag van bezoekers vastleggen en analyseren. Door gebruik te maken van deze website, of door op 'Cookies accepteren' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt? Bekijk dan ons cookiebeleid.

Meer informatie

Vraag


Acties:
  • 0Henk 'm!

  • Atomstar
  • Registratie: juli 2002
  • Laatst online: 07:58

Vraag: kan managed switch niet bereiken, maar clients wel?

Ik heb een vraag over configureren van VLAN op mijn thuisnetwerk. Alles werkt goed, behalve dat ik de managed switch (Netgear GS180Ev3) niet kan bereiken wanneer verbonden via de router (Netgear R7800 met OpenWRT) (1), terwijl ik clients wél kan bereiken, en al tunnelend door SSH via die client (rpi3b, raspberry pi met Debian) ook weer de managed switch (2). Als ik meteen verbonden ben met de switch kan ik hem gewoon bereiken (3). Weet iemand wat er fout gaat? :?

Het feit dat ik clients kan bereiken op de switch betekent dat tot daar (voorbij de switch) VLAN goed gaat. Wat ik niet begrijp is dat de switch niet snapt. Misschien dat de switch niet weet op welke VLAN hij zelf zit? Maakt dit uit? Weet de router niet op welk VLAN de switch zit, en tagt deze de verkeerde VLAN (34 ipv 1)?





Configuratie netwerk

Configuratie switch (GS108)





Configuratie router (R7800)



Achtergrond

Ik gebruik VLAN tagging omdat ik mijn router in de woonkamer wil voor beter wifibereik, maar tegelijkertijd een switch in de meterkast om de rest van het huis van bedraad netwerk te voorzin, en dit verkeer over 1 kabel wil laten lopen naar de woonkamer. Ik ben zelf tot deze configuratie gekomen, maar weet niet goed hoe ik verder moet zonder mezelf buiten te sluiten :p

Oplossing

Het probleem leek te zijn dat de switch alleen gemanaged kan worden op untagged poorten, dus vanaf de wired clients werkt het wel (die zitten op untagged VLAN 1 poorten), maar via de trunk kon het niet (want die zat op een tagged VLAN 1 poort). Tussendoor heb ik OpenWRT geüpgraded en de juiste settings zien er als volgt uit:









[Voor 24% gewijzigd door Atomstar op 18-06-2020 21:30. Reden: VLAN config toegevoegd, router R7800 interfaces toegevoegd, dhcp config toegevoegd, oplossing toegevoegd]

Beste antwoord (via Atomstar op 18-06-2020 21:22)


  • Brahiewahiewa
  • Registratie: oktober 2001
  • Laatst online: 22:26

Brahiewahiewa

boelkloedig

Atomstar schreef op zondag 14 juni 2020 @ 17:51:
[...]
Dat lijkt me logisch, maar kan niet vinden waar dat in te stellen is. Enig idee?
https://community.netgear...ent-interface/td-p/971240

QnJhaGlld2FoaWV3YQ==

Alle reacties


Acties:
  • 0Henk 'm!

  • ijske
  • Registratie: juli 2004
  • Laatst online: 20:50
volgens wat gegoogle is je routerchip zelf eth0 en eth1

dus logischerwijs zou ik ervanuitgaan dat je die mag untaggen op een vlan naar keuze (en ook maar 1 vlan geven), en dat hij dan in dat vlan gaat zitten :-)

om toch een idee te hebben hoe jij je netwerk wil ..
je wil vlan 34 voor je WAN , en je vlan 1 voor je interne netwerk ?

in dat geval wil je op je switch untagged 34 binnenkomen, via trunk doorsturen naar bv netgear poort 1 (de uplink trunk)

dan is op je netgear poort 2 je untagged netwerk 34 (want daar komt dan je WAN netwerk terug uit), en die
prik terug je in de WAN in van je netgear... (of kan je virtueel een brug maken van vlan34 naar WAN ? zodat je geen kabeltje nodig hebt )

die maakt dan je intern netwerk aan (want dat mis ik precies in je opstelling, een DHCP server bv) , en die zet je netwerk aan in vlan 1...
vlan 1 gaat dan via je trunk terug naar je switch

[Voor 61% gewijzigd door ijske op 24-05-2020 15:10]


Acties:
  • 0Henk 'm!

  • synoniem
  • Registratie: april 2009
  • Niet online
Als ik je goed begrijp wil je je NTU tagged met 34 binnen laten komen op je switch. Dan een trunk naar je AP op de WAN port die tagged 1 en 34 doet. In dat geval zou je op VLAN 34 dhcp client moeten zetten om een extern ip te ontvangen en op VLAN 1 een dhcp server aan moeten zetten om op alle poorten een intern ip adres te krijgen. De switch zelf krijgt dan op VLAN 1 ook een IP adres.

Acties:
  • 0Henk 'm!

  • kosz
  • Registratie: juni 2001
  • Laatst online: 10:34
Zit je switch die je wilt bereiken in het subnet van vlan 1 of vlan 34 ? Zodra deze switches geen dhcp adres hebben verkregen gebruikt deze zijn eigen default adres 192.168.0.239, en dan is het wel verklaarbaar dat je in afbeelding 1 geen verbinding kan maken.

Acties:
  • 0Henk 'm!

  • Atomstar
  • Registratie: juli 2002
  • Laatst online: 07:58
ijske schreef op zondag 24 mei 2020 @ 14:39:
volgens wat gegoogle is je routerchip zelf eth0 en eth1

dus logischerwijs zou ik ervanuitgaan dat je die mag untaggen op een vlan naar keuze (en ook maar 1 vlan geven), en dat hij dan in dat vlan gaat zitten :-)
Maar als deze untagged is kan de router zelf niet meer onderscheiden tussen VLANs toch?
ijske schreef op zondag 24 mei 2020 @ 14:39:
om toch een idee te hebben hoe jij je netwerk wil ..
je wil vlan 34 voor je WAN , en je vlan 1 voor je interne netwerk ?
Ja klopt, WAN heeft VLAN34, LAN heeft VLAN1, dit heb ik toegevoegd in OP.
ijske schreef op zondag 24 mei 2020 @ 14:39:
in dat geval wil je op je switch untagged 34 binnenkomen, via trunk doorsturen naar bv netgear poort 1 (de uplink trunk)

dan is op je netgear poort 2 je untagged netwerk 34 (want daar komt dan je WAN netwerk terug uit), en die
prik terug je in de WAN in van je netgear... (of kan je virtueel een brug maken van vlan34 naar WAN ? zodat je geen kabeltje nodig hebt )

die maakt dan je intern netwerk aan (want dat mis ik precies in je opstelling, een DHCP server bv) , en die zet je netwerk aan in vlan 1...
vlan 1 gaat dan via je trunk terug naar je switch
Switch untagged 34: nee, WAN komt tagged binnen van Telfort, die ontvang ik op gs108 port 1. Deze wordt idd als trunk (VLAN34 & 1) via port 2 naar router r7800 op uplink port doorgestuurd. Welke netgeer bedoel je verder waar? De switch (gs108) en router (r7800) zijn beide netgear :p

DHCP draait als client op de router VLAN34 (ipv6 en ipv4) en als server op de andere interfaces, ook toegevoegd aan OP.

Acties:
  • 0Henk 'm!

  • Atomstar
  • Registratie: juli 2002
  • Laatst online: 07:58
synoniem schreef op zondag 24 mei 2020 @ 14:54:
Als ik je goed begrijp wil je je NTU tagged met 34 binnen laten komen op je switch. Dan een trunk naar je AP op de WAN port die tagged 1 en 34 doet. In dat geval zou je op VLAN 34 dhcp client moeten zetten om een extern ip te ontvangen en op VLAN 1 een dhcp server aan moeten zetten om op alle poorten een intern ip adres te krijgen. De switch zelf krijgt dan op VLAN 1 ook een IP adres.
Dit klopt helemaal en is ook zo ingesteld. Toch kan ik mijn switch (gs108) niet bereiken, maar clients wel wanneer ik met de router (r7800) ben verbonden. Enig idee?

Acties:
  • 0Henk 'm!

  • Atomstar
  • Registratie: juli 2002
  • Laatst online: 07:58
kosz schreef op zondag 24 mei 2020 @ 17:05:
Zit je switch die je wilt bereiken in het subnet van vlan 1 of vlan 34 ? Zodra deze switches geen dhcp adres hebben verkregen gebruikt deze zijn eigen default adres 192.168.0.239, en dan is het wel verklaarbaar dat je in afbeelding 1 geen verbinding kan maken.
De switch heeft nu een static IP in de dhcp (subnet) range van LAN. Dit staat volgens mij los van welke VLAN het is toch? Als het IP niet in het juiste subnet zou zitten zou ik ook geen clients verbonden aan de switch kunnen bereiken toch?

Acties:
  • 0Henk 'm!

  • synoniem
  • Registratie: april 2009
  • Niet online
Atomstar schreef op maandag 25 mei 2020 @ 13:57:
[...]


Dit klopt helemaal en is ook zo ingesteld. Toch kan ik mijn switch (gs108) niet bereiken, maar clients wel wanneer ik met de router (r7800) ben verbonden. Enig idee?
Het lijkt me goed geconfigureerd. Ik zit te denken aan een blokkade door de switch of AP omdat het MAC address van de AP hetzelfde MAC is als van de trunk of een DNS rebind rule op een van de twee. Iets anders kan ik zo snel niet verzinnen.

  • Atomstar
  • Registratie: juli 2002
  • Laatst online: 07:58
Na een wilde gok lijkt het te werken, maar ik begrijp nog steeds niet waarom, misschien heeft iemand een slim idee? Over de trunk (tussen switch en router waar VLAN34 en VLAN1 over lopen) heb ik VLAN1 untagged gemaakt (VLAN34 is nog steeds tagged), zodat de configuratie er zo uit ziet:





Iemand een idee waarom dit zo is? Ik heb heb het vermoeden dat de switch niet weet op welke VLAN die zit, of dat deze alleen untagged verkeer accepteert, hoe kan ik bijvoorbeeld instellen over welk VLAN de switch een DHCP verzoek doet? Er zijn twee servers: die van mijn ISP en die van mijn router. Hoe wee de switch welke te gebruiken?

Acties:
  • 0Henk 'm!

  • MasterL
  • Registratie: oktober 2003
  • Laatst online: 11-06 14:50
Misschien mis ik iets maar zit de kabel tussen de GS108 en de R7800 (in de R7800) op de WAN poort?
Zou het niet zo simpel kunnen zijn dat een client achter de R7800 in een ander subnet terecht komt (want de R7800 doet routing/nat etc) en dat er geen (static) route in de switch staat om de pakket terug naar de R7800 te routeren?

Acties:
  • +1Henk 'm!

  • hanhoo
  • Registratie: september 2005
  • Laatst online: 25-05 22:35
Even 8)7 maar heb je al naar het begrip 'management VLAN' gekeken. Vaak kan een switch maar vanaf 1 VLAN worden beheerd.

Acties:
  • 0Henk 'm!

  • Atomstar
  • Registratie: juli 2002
  • Laatst online: 07:58
MasterL schreef op vrijdag 29 mei 2020 @ 08:55:
Misschien mis ik iets maar zit de kabel tussen de GS108 en de R7800 (in de R7800) op de WAN poort?
Zou het niet zo simpel kunnen zijn dat een client achter de R7800 in een ander subnet terecht komt (want de R7800 doet routing/nat etc) en dat er geen (static) route in de switch staat om de pakket terug naar de R7800 te routeren?
Ja die zit in de WAN poort. Clients wired op de switch en op de router komen in hetzelfde subnet, dus volgens mij is dat het niet.
hanhoo schreef op vrijdag 29 mei 2020 @ 15:21:
Even 8)7 maar heb je al naar het begrip 'management VLAN' gekeken. Vaak kan een switch maar vanaf 1 VLAN worden beheerd.
Dat lijkt me logisch, maar kan niet vinden waar dat in te stellen is. Enig idee?

Acties:
  • 0Henk 'm!

  • Atomstar
  • Registratie: juli 2002
  • Laatst online: 07:58
Atomstar schreef op woensdag 27 mei 2020 @ 08:22:
Na een wilde gok lijkt het te werken, maar ik begrijp nog steeds niet waarom
Die wilde gok werkt toch niet, na deze wijziging heb ik opeens 10% packet loss van de router naar internet. Geen idee waarom, maar ik heb de setting maar teruggezet (en zit weer in de oorspronkelijke situatie)



Ik heb het inmiddels opgegeven, ik kan bij de switch via wired lan, het netwerk werkt, dus ik laat het maar zo :p Bedankt voor de suggesties! Mocht iemand nog een ingeving hebben hou ik me aanbevolen.

Acties:
  • Beste antwoord
  • 0Henk 'm!

  • Brahiewahiewa
  • Registratie: oktober 2001
  • Laatst online: 22:26

Brahiewahiewa

boelkloedig

Atomstar schreef op zondag 14 juni 2020 @ 17:51:
[...]
Dat lijkt me logisch, maar kan niet vinden waar dat in te stellen is. Enig idee?
https://community.netgear...ent-interface/td-p/971240

QnJhaGlld2FoaWV3YQ==


Acties:
  • 0Henk 'm!

  • Atomstar
  • Registratie: juli 2002
  • Laatst online: 07:58
Ok daar staat 'management VLAN kun je niet instellen, waarschijnlijk is het alle untagged verkeer op de management interface', dat is in overeenstemming met mijn situatie (wel via untagged wired verbinding, niet via tagged verbinding via router), maar dan snap ik niet waarom ik packet loss krijg van router naar internet als ik mijn trunk untagged/tagged maak. Enig idee?

Acties:
  • 0Henk 'm!

  • Jay-B
  • Registratie: mei 2007
  • Laatst online: 21:01
@Atomstar Zou port1 op je switch niet tagged moeten zijn?

[Voor 11% gewijzigd door Jay-B op 15-06-2020 20:43]


  • Atomstar
  • Registratie: juli 2002
  • Laatst online: 07:58
Het lijkt opgelost! Inmiddels tóch de trunk weer VLAN 1 untagged / VLAN 34 tagged gemaakt op suggestie van @Brahiewahiewa en ik kan de switch weer bereiken. Packet loss is ook weg, weet niet waar dat de eerste keer door kwam, maar tussendoor heb ik ook OpenWRT van 18 naar 19 geüpgraded, misschien dat dat wat deed. Bedankt! :)
Pagina: 1


Apple iPad Pro (2021) 11" Wi-Fi, 8GB ram Microsoft Xbox Series X LG CX Google Pixel 5a 5G Sony XH90 / XH92 Samsung Galaxy S21 5G Sony PlayStation 5 Nintendo Switch Lite

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2021 Hosting door True