Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Vraag


  • JustinoFTW
  • Registratie: mei 2011
  • Laatst online: 14-11 21:34
Mijn vraag:
Ik probeer een bestaand certificaat toe te voegen op onze Cisco 1941 router.
Tot op heden is mijn dit nog niet gelukt aangezien ik tegen een, waarschijnlijk, klein probleem aan aanloop.

Ik gebruik onderstaande commando's om de CA Certificates toe te voegen als trustpoints om daarna het certificaat zelf toe te voegen.
Extra kom ik bij de Intermediate secondary het commando keypair tegen, welke een error geeft:


code:
1
2
3
(ca-trustpoint)#keypair
                ^
% Invalid input detected at '^' marker.



Heeft iemand een idee of dit commando is vervangen of dat ik iets mis.
Ik ben het zelf in ieder geval even helemaal kwijt 8)7




Root trustpoint
code:
1
2
3
4
5
6
7
8
9
10
crypto ca trustpoint root
enrollment terminal PEM
chain-validation stop
revocation-check none
exit
crypto ca authenticate root
-----BEGIN CERTIFICATE-----

-----END CERTIFICATE-----
quit



Intermediate trustpoint
code:
1
2
3
4
5
6
7
8
9
10
crypto ca trustpoint intermediate-primary
enrollment terminal
chain-validation continue root
revocation-check none
exit
crypto ca authenticate intermediate-primary
-----BEGIN CERTIFICATE-----

-----END CERTIFICATE-----
quit



Intermediate secondary
code:
1
2
3
4
5
6
7
8
9
crypto ca trustpoint intermediate-secondary
enrollment terminal
keypair
chain-validation continue intermediate-primary
exit
crypto ca authenticate intermediate-secondary
-----BEGIN CERTIFICATE-----

-----END CERTIFICATE-----






Relevante software en hardware die ik gebruik:
Cisco 1941/K9 via SSH




Wat ik al gevonden of geprobeerd heb:
Heb vele cisco pagina's en google pagina's gelezen maar daarbij kom ik helaas niet verder op het punt waar ik vast zit.


Beste antwoord (via rens-br op 05-04-2019 16:29)


  • JustinoFTW
  • Registratie: mei 2011
  • Laatst online: 14-11 21:34
Probleem al gevonden!

Commando is nu "rsakeypair <key name>"
Deze moet van te voren wel aanwezig zijn, wat ik ook ben vergeten.

Alle reacties


Acties:
  • Beste antwoord
  • +3Henk 'm!

  • JustinoFTW
  • Registratie: mei 2011
  • Laatst online: 14-11 21:34
Probleem al gevonden!

Commando is nu "rsakeypair <key name>"
Deze moet van te voren wel aanwezig zijn, wat ik ook ben vergeten.


Apple iPhone 11 Nintendo Switch Lite LG OLED C9 Google Pixel 4 FIFA 20 Samsung Galaxy S10 Sony PlayStation 5 Auto

'14 '15 '16 '17 2018

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2019 Hosting door True