Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie
Toon posts:

RAID0 Volume met Win10Home boot niet na bios update

Pagina: 1
Acties:

Vraag


  • VladimirLudovic
  • Registratie: september 2011
  • Laatst online: 03-02 22:41
Hey tweakers!

Samenvatting:
Bootpartitie met Win10Home op 2xSSD in RAID0 boot niet. Kan (soms) wel booten door in bios manueel een boot override aan te te klikken. Krijg het niet opgelost helaas.

Data:
Moederbord: MSI Z77A-G45 .
2x Samsung 840 series 120GB. Via Intel RST (default op Mobo) in RAID0 array gehangen. Volume is okay, en heet "SYSTEMVOL". Zie screenshot.

Context:
Eergister had ik v2.11 bios versie. Heb al een tijdje gedoe met dat een Asaka Card reader niet wordt uitgelezen. Toen las ik over een fix voor deze dingen in de laatste bios versie. Nu v2.12 (v2.C). Heb ook meteen Windows ME geupdate denk ik.

Details:
Superraar probleem. Bios update ging zeker niet vanzelf, maar uiteindelijk gelukt (zonder errors, zo leek het) via een bootable usb stick met MS-Dos erop (lol, dat was lang geleden ;) ) Sindsdien boot pc niet meer fatsoenlijk.

Reboot ik PC gewoon, dan geeft bios aan geen bootable drive te kunnen vinden.
Bios opnieuw flashen met oude versie (2.11) lost (nieuwe) probleem niet op.
CMOS resetten ook niet.
Uiteindelijk nieuwste versie van bios er weer opgezet, zodat in elk geval m'n card reader niet zomaar uitvalt.

MasterBootRecord herstellen met BOOTREC ook niet. Dit geeft ook rare problemen:
Met /ScanOS of /RebuildBCD geeft ie aan dat BootRec überhaupt geen Windows installaties vinden kan?! (zie screenshot)
/FixBoot geeft "toegang gewijgerd". (Zie screenshot) Ik heb hier te weinig verstand van om hieruit een conclusie te kunnen trekken die hout snijd.
/FixMBR doet ie wel. Maar goed, daarbij worden alleen de records gekopieerd, en de MBT niet opnieuw ingedeeld (dacht ik).
Maar uiteindelijk geen resultaat.


Gekke is, wanneer ik de bios open, markeert hij een aanwezige schijf als UEFI bootable. (zie screenshot).
nu komt ie: soms herkent de bios een de systeem partitie wel ("SYSTEMVOL"). Deze partitie zou bootable moeten zijn). Wanneer is die selecteer om van te booten dan werkt het niet.
Soms herkent ie een partitie als "Windows Boot Manager" in de bios. Als ik daarvan probeer te booten, werkt het wel. Hij herkent dan óók de partitie "SYSTEMVOL".
Maar dat gaat nooit vanzelf. Moet altijd de bios in om daar een device te selecteren om van te booten met een override.
En oh ja, mn boot mode staat op legacy & uefi.


Heb eigenlijk geen zin om Windows weer opnieuw te moeten installeren.

Wie kan me raad geven?

VladimirLudovic wijzigde deze reactie 09-01-2019 20:43 (1%)
Reden: img links klopten niet

Beste antwoord (via VladimirLudovic op 10-01-2019 21:25)


  • F_J_K
  • Registratie: juni 2001
  • Niet online

F_J_K

Moderator CSA/PB

Front verplichte underscores

Misschien dat 'BIOS'+Windows de weg kwijt is over of nu CSM of UEFI wordt gebruikt. Kan je het op alleen legacy zetten? (Of als test alleen UEFI).

Al is dat 'soms' dat je noemt een vreemde..

Edit: zoals altijd: eerst backuppen, dan pas verder. Al is de vraag of er wel backupwaardige data op kan staan als je RAID0 gebruikt :+

F_J_K wijzigde deze reactie 09-01-2019 21:38 (27%)

'Multiple exclamation marks,' he went on, shaking his head, 'are a sure sign of a diseased mind' (Terry Pratchett, Eric)

Alle reacties


Acties:
  • Beste antwoord
  • 0Henk 'm!

  • F_J_K
  • Registratie: juni 2001
  • Niet online

F_J_K

Moderator CSA/PB

Front verplichte underscores

Misschien dat 'BIOS'+Windows de weg kwijt is over of nu CSM of UEFI wordt gebruikt. Kan je het op alleen legacy zetten? (Of als test alleen UEFI).

Al is dat 'soms' dat je noemt een vreemde..

Edit: zoals altijd: eerst backuppen, dan pas verder. Al is de vraag of er wel backupwaardige data op kan staan als je RAID0 gebruikt :+

F_J_K wijzigde deze reactie 09-01-2019 21:38 (27%)

'Multiple exclamation marks,' he went on, shaking his head, 'are a sure sign of a diseased mind' (Terry Pratchett, Eric)


  • VladimirLudovic
  • Registratie: september 2011
  • Laatst online: 03-02 22:41
Ik heb m op ONLY UEFI gezet (omdat dat naast UEFI+LEGACY de enige keus was 🤣) En tot nu toe werkt het! Maar echt begrijpen doe ik het niet. Vooral raar dat de hele situatie ontstond na een bios update. Als ik alle fast-boot opties aanzet, hoop ik in elk geval dat de bios het RAID volume blijft herkennen.

Maar, F_J_K, dank voor je tip 😁👌.

In op de SSD RAID0 configuratie is louter voor de OS en software, dus in die zin niets boeiends 😉.

  • Hero of Time
  • Registratie: oktober 2004
  • Laatst online: 15:45

Hero of Time

Moderator NOS/CSA

There is only one Legend

Na een BIOS update worden veel settings teruggezet naar default. Het is ook iets dat aangeraden wordt om te doen na een update, terug naar Optimized Defaults. Als je je systeem via UEFI laat opstarten en als je Legacy ernaast aan hebt, kan het eerder Legacy als default gaan proberen en dan faalt het, ipv dat het fatsoenlijk UEFI gebruikt als 'fallback'. Dat is dan wel afhankelijk van je moederbord en hoe ze dat in het BIOS hebben afgehandeld.

Spekkies | Commandline FTW


  • VladimirLudovic
  • Registratie: september 2011
  • Laatst online: 03-02 22:41
@Hero of Time : Logisch op zich, en duidelijke verklaring. Dank daarveur 👍.

Wat ik wel vreemd vond, was dat er een aantal keer tijdens het hele "Bios herkent OS niet debacle", een fout in de EUFI/bios setup optrad waarbij bepaalde opties niet te zien waren, en dat sterkte me in het idee dat m'n bios firmware flink overhoop was. Dat heb ik sinds de "set to UEFI only" verandering echter niet meer gezien. Dus, voorlopig opgelost ^_^.

  • johnkeates
  • Registratie: februari 2008
  • Laatst online: 03:11
Extra tip: SSDs in RAID0 voegt latency toe en maakt het slechts 'een beetje' sneller qua bandbreedte terwijl het risico op dataverlies verdubbelt. Als je geen speciale toepassing hebt zou het veiliger zijn geen RAID0 te gebruiken.

  • VladimirLudovic
  • Registratie: september 2011
  • Laatst online: 03-02 22:41
@johnkeates : Nouw ja, was meer een capacity issue. had eerst een 128 GB SSD, maar nadat ik wat AutoDesk software ging installeren, was ie zo vol 😅. Dus 2e toegevoegd. En er staat dus geen data op die gevoelig is. In het ergste geval installeer ik de zooi opnieuw. Valide redenering wat jouw betreft?

  • DukeBox
  • Registratie: april 2000
  • Laatst online: 15:57

DukeBox

Voor je 't weet wist je 't nie

VladimirLudovic schreef op zaterdag 12 januari 2019 @ 22:18:
@johnkeates : Nouw ja, was meer een capacity issue. had eerst een 128 GB SSD
Dacht eerst ook meteen raid0 wat nutteloos maar jouw redenatie is inderdaad zeer valide :)

Duct tape can't fix stupid, but it can muffle the sound.


  • Hero of Time
  • Registratie: oktober 2004
  • Laatst online: 15:45

Hero of Time

Moderator NOS/CSA

There is only one Legend

Gewoon de andere SSD er naast en die als instalatiedoel selecteren? Of heb je nog software dat hardcoded naar C: wijst om op te installeren en niet is aan te passen?

Spekkies | Commandline FTW


  • VladimirLudovic
  • Registratie: september 2011
  • Laatst online: 03-02 22:41
Nah, het leek me gewoon handig om al m'n software op één station te hebben. Niet echt een technisch overwogen keuze, behalve dat ik de chaos in mijn omgeving wil beperken en dus liefst zo min mogelijk verschillende stations heb.

Dat, en op moment van extra 128 GB SSD bijprikken was ik gewoon nieuwsgierig naar hoe RAID precies werkte. Aldus RAID0 config gedaan. Tot op dit moment geen problemen mee, maar zou inderdaad ook niet kunnen zeggen of m'n performance erdoor is verbeterd of verslechterd.

  • johnkeates
  • Registratie: februari 2008
  • Laatst online: 03:11
Dan werkt RAID0 inderdaad prima, vooral om dat Windows weinig andere opties heeft. Je kan sinds Windows 10 vanaf storage spaces booten, wat sneller en meer portable is dan Intel's FakeRAID/SoftRAID (gebeurt gewoon op de CPU maar is wel firmware afhankelijk, niet zo'n voordelige combo dus).

Als het zo werkt, lekker zo laten (en backups maken als het nodig is, kost weinig, kan makkelijk).
Pagina: 1


Apple iPhone XS Red Dead Redemption 2 LG W7 Google Pixel 3 XL OnePlus 6T (6GB ram) FIFA 19 Samsung Galaxy S10 Google Pixel 3

Tweakers vormt samen met Tweakers Elect, Hardware.Info, Autotrack, Nationale Vacaturebank, Intermediair en Independer de Persgroep Online Services B.V.
Alle rechten voorbehouden © 1998 - 2019 Hosting door True