Cookies op Tweakers

Tweakers is onderdeel van DPG Media en maakt gebruik van cookies, JavaScript en vergelijkbare technologie om je onder andere een optimale gebruikerservaring te bieden. Ook kan Tweakers hierdoor het gedrag van bezoekers vastleggen en analyseren. Door gebruik te maken van deze website, of door op 'Cookies accepteren' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt? Bekijk dan ons cookiebeleid.

Meer informatie
Toon posts:

Formule in Excel

Pagina: 1
Acties:

Vraag


  • riezert
  • Registratie: december 2016
  • Laatst online: 08-01 17:29
Goedemorgen allen,

Ik zit met het volgende.

Ik krijg dagelijk een prijslijst doorgestuurd met inkoopprijzen, hier moet ik mijn marge aan toevoegen. Nu ben ik hier handmatig mijn marges bij op aan het tellen.

Graag wil ik in Excel een formule maken die automatisch mijn marge toevoegt.

Dus.

Is de inkoopprijs < €1 wil ik + 0.06 cent toevoegen. 0,91 in H28 wordt dan 0,97 in I28

Ligt de inkoopprijs tussen de € 1 en €1,80 dan wil ik dat hij automatisch 0,08 cent toevoegt.

Alvast bedankt.

Beste antwoord (via riezert op 23-11-2018 14:06)


  • Chief
  • Registratie: januari 2009
  • Laatst online: 09:58
=ALS(E3>3,2;E3+0,2;ALS(E3>=2,20;E3+0,15;ALS(E3>=1,80;E3+0,10;ALS(E3>=1;E3+0,08;E3+0,06))))

Er stond een komma achteraan ergens wat een ; had moeten zijn. Mijn instellingen staan anders.

Ik kwam, ik zag, ik ging er keihard vandoor

Alle reacties


  • Keuvie
  • Registratie: oktober 2005
  • Laatst online: 19-06 12:28
Kan je aangeven welke formule je tot nu toe al in elkaar hebt gezet?

  • heuveltje
  • Registratie: februari 2000
  • Laatst online: 12:03

heuveltje

KoelkastFilosoof

je mist nog een regel voor wat er boven de 1.8 gebeurd ?
Voor de rest kun je =als(...) stacken door weer een als() functie op te geven voor een van de terug te geven waardes.

You cant build a better world for people.
Only people can build a better world for people.
Otherwise its just a fancy cage. T. Pratchett


  • riezert
  • Registratie: december 2016
  • Laatst online: 08-01 17:29
=H28<1=I28+0,06) ik weet dat dit nergens op slaat maar dit is wat ik in mijn hoofd heb zitten. Op websites van van support office wordt gepraat over ALS en EN maar dat zijn volgens mij niet de formules die ik moet hebben.

  • heuveltje
  • Registratie: februari 2000
  • Laatst online: 12:03

heuveltje

KoelkastFilosoof

riezert schreef op woensdag 21 november 2018 @ 10:18:
=H28<1=I28+0,06) ik weet dat dit nergens op slaat maar dit is wat ik in mijn hoofd heb zitten. Op websites van van support office wordt gepraat over ALS en EN maar dat zijn volgens mij niet de formules die ik moet hebben.
ALS is precies de formule die je wel moet hebben. je wilt immers iets anders doen gebaseerd op waarde in een cel. Waarom denk je anders ?

[Voor 7% gewijzigd door heuveltje op 21-11-2018 10:24]

You cant build a better world for people.
Only people can build a better world for people.
Otherwise its just a fancy cage. T. Pratchett


  • Sherlock
  • Registratie: mei 2000
  • Nu online

Sherlock

No Shit

code:
1
=ALS(A1<1;A1+0,06;(ALS(A1<1,8;A1+0,08;"")))


Is de meest eenvoudige variant. Ik zou 0,06 & 0,08 nog verwijzen naar een cel, zodat je de marge ook aan kunt passen met één handeling. En zoals heuveltje al vroeg; wat doe je met de waardes boven 1,80?

Ik ben er vanuit gegaan dat je 6 cent en 8 cent bedoelde, en niet 0,06 cent en 0,08 cent

  • riezert
  • Registratie: december 2016
  • Laatst online: 08-01 17:29
heuveltje schreef op woensdag 21 november 2018 @ 10:22:
[...]


ALS is precies de formule die je wel moet hebben. Waarom denk je anders ?
Je hebt gelijk, maar ik krijg de formule nog niet werkend.

=ALS(H28<1) .......

Heb jij wellicht een idee?

  • riezert
  • Registratie: december 2016
  • Laatst online: 08-01 17:29
Sherlock schreef op woensdag 21 november 2018 @ 10:25:
code:
1
=ALS(A1<1;A1+0,06;(ALS(A1<1,8;A1+0,08;"")))


Is de meest eenvoudige variant. Ik zou 0,06 & 0,08 nog verwijzen naar een cel, zodat je de marge ook aan kunt passen met één handeling. En zoals heuveltje al vroeg; wat doe je met de waardes boven 1,80?

Ik ben er vanuit gegaan dat je 6 cent en 8 cent bedoelde, en niet 0,06 cent en 0,08 cent
Met deze formule wordt slechts de marge weergegeven. Ik wil graag dat hij de marge bij de inkoopprijs optelt en deze weergeeft.

  • Nivado
  • Registratie: november 2004
  • Laatst online: 09:44

Nivado

Metabo UHE 2250 te koop

@riezert Dan doe je het niet goed. De formule van @Sherlock is volledig en juist en doet exact wat jij gevraagd hebt.

Metabo Combihamer te koop


  • riezert
  • Registratie: december 2016
  • Laatst online: 08-01 17:29
Sherlock schreef op woensdag 21 november 2018 @ 10:25:
code:
1
=ALS(A1<1;A1+0,06;(ALS(A1<1,8;A1+0,08;"")))


Is de meest eenvoudige variant. Ik zou 0,06 & 0,08 nog verwijzen naar een cel, zodat je de marge ook aan kunt passen met één handeling. En zoals heuveltje al vroeg; wat doe je met de waardes boven 1,80?

Ik ben er vanuit gegaan dat je 6 cent en 8 cent bedoelde, en niet 0,06 cent en 0,08 cent
Waardes boven de 1,80 wil ik ook graag verhogen met een marge. Als ik de formule van 1 staffel weet, weet ik ze toch allemaal?

  • riezert
  • Registratie: december 2016
  • Laatst online: 08-01 17:29
Nivado schreef op woensdag 21 november 2018 @ 10:30:
@riezert Dan doe je het niet goed. De formule van @Sherlock is volledig en juist en doet exact wat jij gevraagd hebt.
Dan doe ik idd iets verkeerd, ik kopieer die formule rechtstreeks naar excel en hij geeft slechts 0,06 aan.

  • Geer123
  • Registratie: juni 2015
  • Nu online
Dan moet je wel een getal invullen in cell A1 om de totaal prijs te zien

  • Nivado
  • Registratie: november 2004
  • Laatst online: 09:44

Nivado

Metabo UHE 2250 te koop

riezert schreef op woensdag 21 november 2018 @ 10:31:
[...]


Dan doe ik idd iets verkeerd, ik kopieer die formule rechtstreeks naar excel en hij geeft slechts 0,06 aan.
Heb je al geprobeerd "A1" in de formule te vervangen door de cel waar het te berekenen bedrag in staat? In jouw voorbeeld "H28". Dit is de standaard manier waarop fomules uitgelegd worden in Excel help. Je moet altijd de cellen in het voorbeeld veranderen in de voor jouw relevante cellen.

Metabo Combihamer te koop


  • Sherlock
  • Registratie: mei 2000
  • Nu online

Sherlock

No Shit

Ik heb hier een engelstalige Excel versie, maar de ALS functie is zo'n beetje de meestgebruikte functie die er is, wat extra uitleg te vinden via de help in Excel zelf:

SYNTAX:  IF(Something is True, then do this, otherwise do this)

Example: =IF(A1<B1;"OK";0)

EXPLANATION: If the value in A1 is less than the value in B1, the value "OK" is returned, otherwise return a 0.

  • riezert
  • Registratie: december 2016
  • Laatst online: 08-01 17:29
Nivado schreef op woensdag 21 november 2018 @ 10:34:
[...]


Heb je al geprobeerd "A1" in de formule te vervangen door de cel waar het te berekenen bedrag in staat? In jouw voorbeeld "H28". Dit is de standaard manier waarop fomules uitgelegd worden in Excel help. Je moet altijd de cellen in het voorbeeld veranderen in de voor jouw relevante cellen.
Haha, ik had hem al in de gaten 8)7 . Het is gelukt!

  • riezert
  • Registratie: december 2016
  • Laatst online: 08-01 17:29
Dank u allen! Het is gelukt. Fijne dag verder.

  • F_J_K
  • Registratie: juni 2001
  • Niet online

F_J_K

Moderator CSA/PB

Front verplichte underscores

offtopic:
Welkom op GoT!

Advies: ga een volgende keer eerst een tijdje oefenen met tutorials / voorbeelden op internet / ..., zonder de eigen sheet aan te raken. Je wilt dergelijke basisfunctionaliteit van Excel namelijk goed kennen voor je iets "in productie" gaat gebruiken. Anders is het veel te makkelijk fouten te maken en dan opeens je spullen voor 10x zo veel of weinig te verkopen :P

'Multiple exclamation marks,' he went on, shaking his head, 'are a sure sign of a diseased mind' (Terry Pratchett, Eric)


  • riezert
  • Registratie: december 2016
  • Laatst online: 08-01 17:29
Ik heb toch nog een vraag.

Ik heb nu per rij een formule geschreven, ziet er ongeveer zo uit

< 1 euro + 6 cent =ALS(E3<1;E3+0,06;)
1 euro – 1,80 euro + 8 cent =ALS(EN(E3>1;E3<1,8);E3+0,08;"")
1,80 euro – 2,20 euro + 10 cent =ALS(EN(E3>1,8;E3<2,2);E3+0,1;"")
2,20 euro – 3,20 euro + 15 cent =ALS(EN(E3>2,2;E3<3,2);E3+0,15;"")
> 3,20 euro + 20 cent =ALS(E3>3,2;E3+0,2;)

Nu wil ik dit alles in 1 cel bouwen, zodat ik gewoon het bedrag in zeg cel E3 kan invoeren en dat hij automatisch bepaald welke marge hij moet toevoegen.

Alle tips zijn welkom!

  • Chief
  • Registratie: januari 2009
  • Laatst online: 09:58
=ALS(E3>3,2;E3+0,2;ALS(E3>=2,20;E3+0,15;ALS(E3>=1,80;E3+0,10;ALS(E3>=1,E3+0,08;E3+0,06))))

[Voor 8% gewijzigd door Chief op 23-11-2018 13:49]

Ik kwam, ik zag, ik ging er keihard vandoor


  • riezert
  • Registratie: december 2016
  • Laatst online: 08-01 17:29
Chief schreef op vrijdag 23 november 2018 @ 13:48:
=ALS(E3>3,2;E3+0,2;ALS(E3>=2,20;E3+0,15;ALS(E3>=1,80;E3+0,10;ALS(E3>=1,E3+0,08;E3+0,06))))
Chief,

Bedankt voor je reactie, ik heb deze geplakt en aangepast aan de correcte cellen en krijg alleen de melding ONWAAR in de cel.

Enig idee?

Acties:
  • Beste antwoord
  • +1Henk 'm!

  • Chief
  • Registratie: januari 2009
  • Laatst online: 09:58
=ALS(E3>3,2;E3+0,2;ALS(E3>=2,20;E3+0,15;ALS(E3>=1,80;E3+0,10;ALS(E3>=1;E3+0,08;E3+0,06))))

Er stond een komma achteraan ergens wat een ; had moeten zijn. Mijn instellingen staan anders.

Ik kwam, ik zag, ik ging er keihard vandoor


  • riezert
  • Registratie: december 2016
  • Laatst online: 08-01 17:29
Chief schreef op vrijdag 23 november 2018 @ 13:58:
=ALS(E3>3,2;E3+0,2;ALS(E3>=2,20;E3+0,15;ALS(E3>=1,80;E3+0,10;ALS(E3>=1;E3+0,08;E3+0,06))))

Er stond een komma achteraan ergens wat een ; had moeten zijn. Mijn instellingen staan anders.
Ik kom er achter dat ik mijn eigen kennis moet uitbreiden. ;)

Hartelijke bedankt voor je antwoord, het werkt.

Prettig weekend

  • Reptile209
  • Registratie: juni 2001
  • Laatst online: 10:53

Reptile209

- gers -

Alvast voor je huiswerk: zorg dat je die grote 4-voudige ALS functie snapt. Tweede puntje is naar aanleiding van dit bericht van je:
riezert schreef op vrijdag 23 november 2018 @ 13:38:
[...]
1 euro – 1,80 euro + 8 cent =ALS(EN(E3>1;E3<1,8);E3+0,08;"")
1,80 euro – 2,20 euro + 10 cent =ALS(EN(E3>1,8;E3<2,2);E3+0,1;"")
[...]
Wat gebeurt er met deze twee formules als je precies 1,80 invult? Hit: er is een belangrijk verschil tussen bijvoorbeeld >1,8 en >=1,8.

Ik raad je aan om een uitgebreide lijst met testbedragen in te vullen en te kijken of je de resultaten krijgt die je verwacht. Let daarbij vooral op bedragen die net boven, net onder opleiding precies op een grens zitten.

If you're not part of the solution, you're part of the precipitate.


  • dix-neuf
  • Registratie: juli 2018
  • Niet online
Ook mogelijk:
code:
1
=E3+zoeken(E3;{0;1;1,8;2,2;3,2};{0,06;0,08;0,1;0,15;0,2;0,2})
waarbij de grenswaarden steeds als 'tot' en niet 'tot en met' zijn beschouwd.
Als dit een foutmelding geeft, gebruik dan 'opzoeken' in plaats van 'zoeken' (een en ander is afhankelijk van de gebruikte Excelversie).
Pagina: 1


Apple iPad Pro (2021) 11" Wi-Fi, 8GB ram Microsoft Xbox Series X LG CX Google Pixel 5a 5G Sony XH90 / XH92 Samsung Galaxy S21 5G Sony PlayStation 5 Nintendo Switch Lite

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2021 Hosting door True