Toon posts:

Formule in Excel

Pagina: 1
Acties:

Vraag


  • riezert
  • Registratie: December 2016
  • Laatst online: 25-01 14:25
Goedemorgen allen,

Ik zit met het volgende.

Ik krijg dagelijk een prijslijst doorgestuurd met inkoopprijzen, hier moet ik mijn marge aan toevoegen. Nu ben ik hier handmatig mijn marges bij op aan het tellen.

Graag wil ik in Excel een formule maken die automatisch mijn marge toevoegt.

Dus.

Is de inkoopprijs < €1 wil ik + 0.06 cent toevoegen. 0,91 in H28 wordt dan 0,97 in I28

Ligt de inkoopprijs tussen de € 1 en €1,80 dan wil ik dat hij automatisch 0,08 cent toevoegt.

Alvast bedankt.

Beste antwoord (via riezert op 23-11-2018 14:06)


  • Chief
  • Registratie: Januari 2009
  • Laatst online: 27-01 08:08
=ALS(E3>3,2;E3+0,2;ALS(E3>=2,20;E3+0,15;ALS(E3>=1,80;E3+0,10;ALS(E3>=1;E3+0,08;E3+0,06))))

Er stond een komma achteraan ergens wat een ; had moeten zijn. Mijn instellingen staan anders.

Ik kwam, ik zag, ik ging er keihard vandoor

Alle reacties


  • Keuvie
  • Registratie: Oktober 2005
  • Laatst online: 29-01 11:34
Kan je aangeven welke formule je tot nu toe al in elkaar hebt gezet?

  • heuveltje
  • Registratie: Februari 2000
  • Laatst online: 17:38

heuveltje

KoelkastFilosoof

je mist nog een regel voor wat er boven de 1.8 gebeurd ?
Voor de rest kun je =als(...) stacken door weer een als() functie op te geven voor een van de terug te geven waardes.

Heuveltjes CPU geschiedenis door de jaren heen : AMD 486dx4 100, Cyrix PR166+, Intel Pentium 233MMX, Intel Celeron 366Mhz, AMD K6-450, AMD duron 600, AMD Thunderbird 1200mhz, AMD Athlon 64 x2 5600, AMD Phenom X3 720, Intel i5 4460, AMD Ryzen 5 3600


  • riezert
  • Registratie: December 2016
  • Laatst online: 25-01 14:25
=H28<1=I28+0,06) ik weet dat dit nergens op slaat maar dit is wat ik in mijn hoofd heb zitten. Op websites van van support office wordt gepraat over ALS en EN maar dat zijn volgens mij niet de formules die ik moet hebben.

  • heuveltje
  • Registratie: Februari 2000
  • Laatst online: 17:38

heuveltje

KoelkastFilosoof

riezert schreef op woensdag 21 november 2018 @ 10:18:
=H28<1=I28+0,06) ik weet dat dit nergens op slaat maar dit is wat ik in mijn hoofd heb zitten. Op websites van van support office wordt gepraat over ALS en EN maar dat zijn volgens mij niet de formules die ik moet hebben.
ALS is precies de formule die je wel moet hebben. je wilt immers iets anders doen gebaseerd op waarde in een cel. Waarom denk je anders ?

[Voor 7% gewijzigd door heuveltje op 21-11-2018 10:24]

Heuveltjes CPU geschiedenis door de jaren heen : AMD 486dx4 100, Cyrix PR166+, Intel Pentium 233MMX, Intel Celeron 366Mhz, AMD K6-450, AMD duron 600, AMD Thunderbird 1200mhz, AMD Athlon 64 x2 5600, AMD Phenom X3 720, Intel i5 4460, AMD Ryzen 5 3600


  • Sherlock
  • Registratie: Mei 2000
  • Laatst online: 17:00

Sherlock

No Shit

code:
1
=ALS(A1<1;A1+0,06;(ALS(A1<1,8;A1+0,08;"")))


Is de meest eenvoudige variant. Ik zou 0,06 & 0,08 nog verwijzen naar een cel, zodat je de marge ook aan kunt passen met één handeling. En zoals heuveltje al vroeg; wat doe je met de waardes boven 1,80?

Ik ben er vanuit gegaan dat je 6 cent en 8 cent bedoelde, en niet 0,06 cent en 0,08 cent

  • riezert
  • Registratie: December 2016
  • Laatst online: 25-01 14:25
heuveltje schreef op woensdag 21 november 2018 @ 10:22:
[...]


ALS is precies de formule die je wel moet hebben. Waarom denk je anders ?
Je hebt gelijk, maar ik krijg de formule nog niet werkend.

=ALS(H28<1) .......

Heb jij wellicht een idee?

  • riezert
  • Registratie: December 2016
  • Laatst online: 25-01 14:25
Sherlock schreef op woensdag 21 november 2018 @ 10:25:
code:
1
=ALS(A1<1;A1+0,06;(ALS(A1<1,8;A1+0,08;"")))


Is de meest eenvoudige variant. Ik zou 0,06 & 0,08 nog verwijzen naar een cel, zodat je de marge ook aan kunt passen met één handeling. En zoals heuveltje al vroeg; wat doe je met de waardes boven 1,80?

Ik ben er vanuit gegaan dat je 6 cent en 8 cent bedoelde, en niet 0,06 cent en 0,08 cent
Met deze formule wordt slechts de marge weergegeven. Ik wil graag dat hij de marge bij de inkoopprijs optelt en deze weergeeft.

  • Nivado
  • Registratie: November 2004
  • Nu online
@riezert Dan doe je het niet goed. De formule van @Sherlock is volledig en juist en doet exact wat jij gevraagd hebt.

  • riezert
  • Registratie: December 2016
  • Laatst online: 25-01 14:25
Sherlock schreef op woensdag 21 november 2018 @ 10:25:
code:
1
=ALS(A1<1;A1+0,06;(ALS(A1<1,8;A1+0,08;"")))


Is de meest eenvoudige variant. Ik zou 0,06 & 0,08 nog verwijzen naar een cel, zodat je de marge ook aan kunt passen met één handeling. En zoals heuveltje al vroeg; wat doe je met de waardes boven 1,80?

Ik ben er vanuit gegaan dat je 6 cent en 8 cent bedoelde, en niet 0,06 cent en 0,08 cent
Waardes boven de 1,80 wil ik ook graag verhogen met een marge. Als ik de formule van 1 staffel weet, weet ik ze toch allemaal?

  • riezert
  • Registratie: December 2016
  • Laatst online: 25-01 14:25
Nivado schreef op woensdag 21 november 2018 @ 10:30:
@riezert Dan doe je het niet goed. De formule van @Sherlock is volledig en juist en doet exact wat jij gevraagd hebt.
Dan doe ik idd iets verkeerd, ik kopieer die formule rechtstreeks naar excel en hij geeft slechts 0,06 aan.

  • Geer123
  • Registratie: Juni 2015
  • Laatst online: 27-01 07:53
Dan moet je wel een getal invullen in cell A1 om de totaal prijs te zien

  • Nivado
  • Registratie: November 2004
  • Nu online
riezert schreef op woensdag 21 november 2018 @ 10:31:
[...]


Dan doe ik idd iets verkeerd, ik kopieer die formule rechtstreeks naar excel en hij geeft slechts 0,06 aan.
Heb je al geprobeerd "A1" in de formule te vervangen door de cel waar het te berekenen bedrag in staat? In jouw voorbeeld "H28". Dit is de standaard manier waarop fomules uitgelegd worden in Excel help. Je moet altijd de cellen in het voorbeeld veranderen in de voor jouw relevante cellen.

  • Sherlock
  • Registratie: Mei 2000
  • Laatst online: 17:00

Sherlock

No Shit

Ik heb hier een engelstalige Excel versie, maar de ALS functie is zo'n beetje de meestgebruikte functie die er is, wat extra uitleg te vinden via de help in Excel zelf:

SYNTAX:  IF(Something is True, then do this, otherwise do this)

Example: =IF(A1<B1;"OK";0)

EXPLANATION: If the value in A1 is less than the value in B1, the value "OK" is returned, otherwise return a 0.

  • riezert
  • Registratie: December 2016
  • Laatst online: 25-01 14:25
Nivado schreef op woensdag 21 november 2018 @ 10:34:
[...]


Heb je al geprobeerd "A1" in de formule te vervangen door de cel waar het te berekenen bedrag in staat? In jouw voorbeeld "H28". Dit is de standaard manier waarop fomules uitgelegd worden in Excel help. Je moet altijd de cellen in het voorbeeld veranderen in de voor jouw relevante cellen.
Haha, ik had hem al in de gaten 8)7 . Het is gelukt!

  • riezert
  • Registratie: December 2016
  • Laatst online: 25-01 14:25
Dank u allen! Het is gelukt. Fijne dag verder.

  • F_J_K
  • Registratie: Juni 2001
  • Niet online

F_J_K

Moderator CSA/PB

Front verplichte underscores

offtopic:
Welkom op GoT!

Advies: ga een volgende keer eerst een tijdje oefenen met tutorials / voorbeelden op internet / ..., zonder de eigen sheet aan te raken. Je wilt dergelijke basisfunctionaliteit van Excel namelijk goed kennen voor je iets "in productie" gaat gebruiken. Anders is het veel te makkelijk fouten te maken en dan opeens je spullen voor 10x zo veel of weinig te verkopen :P

'Multiple exclamation marks,' he went on, shaking his head, 'are a sure sign of a diseased mind' (Terry Pratchett, Eric)


  • riezert
  • Registratie: December 2016
  • Laatst online: 25-01 14:25
Ik heb toch nog een vraag.

Ik heb nu per rij een formule geschreven, ziet er ongeveer zo uit

< 1 euro + 6 cent =ALS(E3<1;E3+0,06;)
1 euro – 1,80 euro + 8 cent =ALS(EN(E3>1;E3<1,8);E3+0,08;"")
1,80 euro – 2,20 euro + 10 cent =ALS(EN(E3>1,8;E3<2,2);E3+0,1;"")
2,20 euro – 3,20 euro + 15 cent =ALS(EN(E3>2,2;E3<3,2);E3+0,15;"")
> 3,20 euro + 20 cent =ALS(E3>3,2;E3+0,2;)

Nu wil ik dit alles in 1 cel bouwen, zodat ik gewoon het bedrag in zeg cel E3 kan invoeren en dat hij automatisch bepaald welke marge hij moet toevoegen.

Alle tips zijn welkom!

  • Chief
  • Registratie: Januari 2009
  • Laatst online: 27-01 08:08
=ALS(E3>3,2;E3+0,2;ALS(E3>=2,20;E3+0,15;ALS(E3>=1,80;E3+0,10;ALS(E3>=1,E3+0,08;E3+0,06))))

[Voor 8% gewijzigd door Chief op 23-11-2018 13:49]

Ik kwam, ik zag, ik ging er keihard vandoor


  • riezert
  • Registratie: December 2016
  • Laatst online: 25-01 14:25
Chief schreef op vrijdag 23 november 2018 @ 13:48:
=ALS(E3>3,2;E3+0,2;ALS(E3>=2,20;E3+0,15;ALS(E3>=1,80;E3+0,10;ALS(E3>=1,E3+0,08;E3+0,06))))
Chief,

Bedankt voor je reactie, ik heb deze geplakt en aangepast aan de correcte cellen en krijg alleen de melding ONWAAR in de cel.

Enig idee?

Acties:
  • Beste antwoord
  • +1Henk 'm!

  • Chief
  • Registratie: Januari 2009
  • Laatst online: 27-01 08:08
=ALS(E3>3,2;E3+0,2;ALS(E3>=2,20;E3+0,15;ALS(E3>=1,80;E3+0,10;ALS(E3>=1;E3+0,08;E3+0,06))))

Er stond een komma achteraan ergens wat een ; had moeten zijn. Mijn instellingen staan anders.

Ik kwam, ik zag, ik ging er keihard vandoor


  • riezert
  • Registratie: December 2016
  • Laatst online: 25-01 14:25
Chief schreef op vrijdag 23 november 2018 @ 13:58:
=ALS(E3>3,2;E3+0,2;ALS(E3>=2,20;E3+0,15;ALS(E3>=1,80;E3+0,10;ALS(E3>=1;E3+0,08;E3+0,06))))

Er stond een komma achteraan ergens wat een ; had moeten zijn. Mijn instellingen staan anders.
Ik kom er achter dat ik mijn eigen kennis moet uitbreiden. ;)

Hartelijke bedankt voor je antwoord, het werkt.

Prettig weekend

  • Reptile209
  • Registratie: Juni 2001
  • Laatst online: 16:43

Reptile209

- gers -

Alvast voor je huiswerk: zorg dat je die grote 4-voudige ALS functie snapt. Tweede puntje is naar aanleiding van dit bericht van je:
riezert schreef op vrijdag 23 november 2018 @ 13:38:
[...]
1 euro – 1,80 euro + 8 cent =ALS(EN(E3>1;E3<1,8);E3+0,08;"")
1,80 euro – 2,20 euro + 10 cent =ALS(EN(E3>1,8;E3<2,2);E3+0,1;"")
[...]
Wat gebeurt er met deze twee formules als je precies 1,80 invult? Hit: er is een belangrijk verschil tussen bijvoorbeeld >1,8 en >=1,8.

Ik raad je aan om een uitgebreide lijst met testbedragen in te vullen en te kijken of je de resultaten krijgt die je verwacht. Let daarbij vooral op bedragen die net boven, net onder opleiding precies op een grens zitten.

Ik verafschuw wat u zegt, maar ik zal uw recht om het te zeggen met mijn leven verdedigen. - Voltaire


  • dix-neuf
  • Registratie: Juli 2018
  • Niet online
Ook mogelijk:
code:
1
=E3+zoeken(E3;{0;1;1,8;2,2;3,2};{0,06;0,08;0,1;0,15;0,2;0,2})
waarbij de grenswaarden steeds als 'tot' en niet 'tot en met' zijn beschouwd.
Als dit een foutmelding geeft, gebruik dan 'opzoeken' in plaats van 'zoeken' (een en ander is afhankelijk van de gebruikte Excelversie).
Pagina: 1


Tweakers maakt gebruik van cookies

Tweakers plaatst functionele en analytische cookies voor het functioneren van de website en het verbeteren van de website-ervaring. Deze cookies zijn noodzakelijk. Om op Tweakers relevantere advertenties te tonen en om ingesloten content van derden te tonen (bijvoorbeeld video's), vragen we je toestemming. Via ingesloten content kunnen derde partijen diensten leveren en verbeteren, bezoekersstatistieken bijhouden, gepersonaliseerde content tonen, gerichte advertenties tonen en gebruikersprofielen opbouwen. Hiervoor worden apparaatgegevens, IP-adres, geolocatie en surfgedrag vastgelegd.

Meer informatie vind je in ons cookiebeleid.

Sluiten

Toestemming beheren

Hieronder kun je per doeleinde of partij toestemming geven of intrekken. Meer informatie vind je in ons cookiebeleid.

Functioneel en analytisch

Deze cookies zijn noodzakelijk voor het functioneren van de website en het verbeteren van de website-ervaring. Klik op het informatie-icoon voor meer informatie. Meer details

janee

    Relevantere advertenties

    Dit beperkt het aantal keer dat dezelfde advertentie getoond wordt (frequency capping) en maakt het mogelijk om binnen Tweakers contextuele advertenties te tonen op basis van pagina's die je hebt bezocht. Meer details

    Tweakers genereert een willekeurige unieke code als identifier. Deze data wordt niet gedeeld met adverteerders of andere derde partijen en je kunt niet buiten Tweakers gevolgd worden. Indien je bent ingelogd, wordt deze identifier gekoppeld aan je account. Indien je niet bent ingelogd, wordt deze identifier gekoppeld aan je sessie die maximaal 4 maanden actief blijft. Je kunt deze toestemming te allen tijde intrekken.

    Ingesloten content van derden

    Deze cookies kunnen door derde partijen geplaatst worden via ingesloten content. Klik op het informatie-icoon voor meer informatie over de verwerkingsdoeleinden. Meer details

    janee