Cookies op Tweakers

Tweakers is onderdeel van DPG Media en maakt gebruik van cookies, JavaScript en vergelijkbare technologie om je onder andere een optimale gebruikerservaring te bieden. Ook kan Tweakers hierdoor het gedrag van bezoekers vastleggen en analyseren. Door gebruik te maken van deze website, of door op 'Cookies accepteren' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt? Bekijk dan ons cookiebeleid.

Meer informatie
Toon posts:

Na handmatig geinstalleerde .deb wil apt niet meer updaten

Pagina: 1
Acties:

Vraag


  • WoBBeL
  • Registratie: juni 2004
  • Laatst online: 22-06 12:28
Vandaag mijn Ubuntu 18.04 handmatig voorzien van de laatste Unifi installatie. Omdat deze upgrade niet beschikbaar was via apt (omdat hij mongodb 3.6.0 verwacht en ik mongodb 3.6.3 had) heb ik deze update gedownload via "apt-get download unifi", daarna heb ik de file geinstalleerd met "sudo dpkg --force-depends -i unifi_5.9.29-11384-1_all.deb" waarna deze package netjes geinstalleerd is. Succes dacht ik _/-\o_

Echter, nu kan ik helemaal niks meer installeren met "apt" of "apt-get" zonder dat ik de volgende foutmelding krijgt (zowel bij "upgrade" of "install")

code:
1
2
3
4
5
6
7
8
9
10
roy@server:~$ sudo apt upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 unifi : Depends: mongodb-server (< 1:3.6.0) but 1:3.6.3-0ubuntu1 is installed or
                  mongodb-10gen (< 3.6.0) but it is not installable or
                  mongodb-org-server (< 3.6.0) but it is not installable
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).


Echter, als ik "apt --fix-broken install" uitvoer wil hij unifi + bijbehorende dependencies weer verwijderen, dat wil ik juist niet :o Hoe zorg ik ervoor dat mijn apt deze dependencies negeert?

Hosted VoIP SIP trunks Vast mobiel

Alle reacties


  • thunder7
  • Registratie: januari 2003
  • Nu online

thunder7

houten vaas/schaal nodig?

Wat doet

apt-get remove --purge unifi

of

dpkg -r unifi_5.9.29-11384-1_all

hout-nerd - www.hetmooistehout.nl of www.houtenschalen.nl


  • Dirk
  • Registratie: november 2004
  • Laatst online: 13:02

Dirk

Coördinator Frontpagemoderatie
Dan is hij unifi natuurlijk ook weer kwijt. Als unifi wel gewoon werkt (waarom wil hij perse een lagere versie van mongodb, wat is het is het verschil?), dan kun je in de debian package van unifi de dependecies zelf aanpassen en het versienummer van unifi met een extra postfix ophogen. Je loopt dan alleen een risico dat unifi toch niet goed werkt omdat hij toch perse die lagere versie van mongodb nodig had.

All statements are true in some sense, false in some sense, meaningless in some sense, true and false in some sense, true and meaningless in some sense, false and meaningless in some sense, and true and false and meaningless in some sense.


  • WoBBeL
  • Registratie: juni 2004
  • Laatst online: 22-06 12:28
@Dirk de unifi draait helemaal goed met deze MongoDB versie (wel na installatie handmatig 1 file van Unifi aan moeten passen), dus alles draait nu perfect met uitzondering van de foutmelding in apt.

Hoe pas ik in de debian package nu de versie aan? Ik heb hier werkelijk geen kaas van gegeten.

Hosted VoIP SIP trunks Vast mobiel


  • Hero of Time
  • Registratie: oktober 2004
  • Laatst online: 23-06 18:03

Hero of Time

Moderator NOS

There is only one Legend

Welke repositories heb je allemaal? Wan het ziet er naar uit dat je juist een versie van Unify hebt geïnstalleerd die niet voor 18.04 is bedoelt. Anders zou het niet om een versie <3.6.0 gaan vragen. Wat ook kan is dat je een andere bron voor MongoDB hebt toegevoegd en zo nieuwer draait dan wat in de main repo aanwezig is, wat dan ook weer het verschil teweeg brengt.

Je hebt nu een staat waar je package management niet tevreden is met de staat van alle packages en zal niets meer doen totdat je dit oplost. Of je nou /var/lib/dpkg/status handmatig aanpast en zo de afhankelijkheden van unify hackt of gewoon netjes met de juiste versies gaat werken is aan jou.

Commandline FTW | Tweakt met mate


  • Kees
  • Registratie: juni 1999
  • Laatst online: 11:41

Kees

Serveradmin / BOFH / DoC
Het makkelijkste is om de source van de unify package te vinden, de mongo dependancy te updaten en opnieuw te instaleren.

Unify roept dat hij mongo onder 3.6 wil hebben (dus niet eens 3.6.0). Waarschijnlijk hebben ze er problemen mee gehad dat ze hem zo strikt zetten. Of je installeert een 16.04 package in een 18.04 omgeving.

Nog beter is natuurlijk hun repository te gebruiken (https://help.ubnt.com/hc/...a-APT-on-Debian-or-Ubuntu)
"sudo dpkg --force-depends -i unifi_5.9.29-11384-1_all.deb" waarna deze package netjes geinstalleerd is. Succes dacht ik
Je forceert dus een install omdat hij anders niet wil instaleren en dan kijk je vreemd op als je apt stuk is? ;)

"Een serveradmin, voluit een serveradministrator, is dan weer een slavenbeheerder oftewel een slavendrijver" - Rataplan

Pagina: 1


Apple iPad Pro (2021) 11" Wi-Fi, 8GB ram Microsoft Xbox Series X LG CX Google Pixel 5a 5G Sony XH90 / XH92 Samsung Galaxy S21 5G Sony PlayStation 5 Nintendo Switch Lite

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2021 Hosting door True