Cookies op Tweakers

Tweakers is onderdeel van DPG Media en maakt gebruik van cookies, JavaScript en vergelijkbare technologie om je onder andere een optimale gebruikerservaring te bieden. Ook kan Tweakers hierdoor het gedrag van bezoekers vastleggen en analyseren. Door gebruik te maken van deze website, of door op 'Cookies accepteren' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt? Bekijk dan ons cookiebeleid.

Meer informatie
Toon posts:

PfSense XS4ALL FTTH en IPv6

Pagina: 1
Acties:

  • mterwoord
  • Registratie: april 2005
  • Laatst online: 14-05 11:46
Hallo Allemaal,

Ik ben bezig met het installeren van PfSense als router op een Xs4all glasvezel verbinding. Internet werkt, en IPTV (routed) werkt ook stabiel.
Hiervoor heb ik de instructie gevolgd op: Venxblog: KPN glasvezel via PFSense

Ik wil IPv6 ook aan hebben. Dit heb ik geprobeerd via de instructies van ErnoRV (van 21 juli). Helaas krijg ik geen IPv6 adres, behalve de link-local adres.

In de System Logs, sectie DHCP, kom ik "Sending Solicit" en "transmit failed: Permission denied" berichten tegen. Heeft dit hiermee te maken?

Ik denk dat ik iets kleins mis, maar heb het juiste vinkje nog niet gevonden en hoop dat iemand mij kan helpen.

  • KRGT
  • Registratie: september 2001
  • Niet online

KRGT

Have a nice day!


  • mterwoord
  • Registratie: april 2005
  • Laatst online: 14-05 11:46
Ja.

  • KRGT
  • Registratie: september 2001
  • Niet online

KRGT

Have a nice day!


  • mterwoord
  • Registratie: april 2005
  • Laatst online: 14-05 11:46
Ja.

Als ik de nederlandse link volg, krijg ik geen IPv6 range op de lan interface.

Ik heb eigenlijk geen idee hoe ik dit kan diagnosticeren. Een soort van stappen lijst met dingen die wel of niet moeten werken, om bijv te zien dat de helft werkt etc..

Iemand tips?

  • mterwoord
  • Registratie: april 2005
  • Laatst online: 14-05 11:46
Heb wat verder gegoogle'd, en kom de volgende thread tegen:
https://forum.netgate.com...operation-not-permitted/5

Hierin staat een commando tegen waarmee je handmatig de dhcp6 client kunt triggeren, en daarmee meer informatie kunt zien.

Het resultaat van dit commando is:

Nov/12/2018 15:09:01: Sending Solicit
Nov/12/2018 15:09:01: set client ID (len 14)
Nov/12/2018 15:09:01: set identity association
Nov/12/2018 15:09:01: set elapsed time (len 2)
Nov/12/2018 15:09:01: set option request (len 4)
Nov/12/2018 15:09:01: set IA_PD
Nov/12/2018 15:09:01: transmit failed: Permission denied
Nov/12/2018 15:09:01: reset a timer on pppoe0, state=SOLICIT, timeo=7, retrans=118956

De voorlaatste regel zal de reden zijn van mijn problemen.

Mijn configuratie is:
interface pppoe0 {
send ia-na 0;
send ia-pd 0;
request domain-name-servers;
request domain-name;
script "/var/etc/dhcp6c_wan_script.sh";
};
id-assoc na 0 { };
id-assoc pd 0 {
prefix-interface igb2 {
sla-id 0;
sla-len 16;
};
};

Het commando dat ik uitvoer is:

/usr/local/sbin/dhcp6c -f -d -D -c /var/etc/hdpc6c_wan.conf -p /var/run/dhcp6c_pppoe0.pid pppoe0

Iemand suggesties?

Alvast hartstikke bedankt!

  • mterwoord
  • Registratie: april 2005
  • Laatst online: 14-05 11:46
Ik heb het werkend gekregen. Met een 2e software router heb ik alle instellingen overgenomen vanaf de bestaande, en nu werkt alles perfect!
Site-to-site vpn met 3 locaties, road-warriors onderweg, etc.
Indien er interesse is, wil ik wel de gedane instellingen hier posten.

  • tom1687
  • Registratie: maart 2009
  • Laatst online: 09-05-2020
Als je wil doen graag ik krijg het ook niet voor elkaar!

  • Neptunus
  • Registratie: januari 2001
  • Laatst online: 12-06 17:57
mterwoord schreef op dinsdag 20 november 2018 @ 12:27:
Ik heb het werkend gekregen. Met een 2e software router heb ik alle instellingen overgenomen vanaf de bestaande, en nu werkt alles perfect!
Site-to-site vpn met 3 locaties, road-warriors onderweg, etc.
Indien er interesse is, wil ik wel de gedane instellingen hier posten.
Kom maar op :P

  • mterwoord
  • Registratie: april 2005
  • Laatst online: 14-05 11:46
Ik zie net pas dat er (al 2) reactie(s) zijn. Ik ga dat komend weekend doen.
Aangezien er op zich goede resources online te vinden zijn mbt pfsense/vpn etc, zal ik me beperken tot het xs4all gebeuren.

  • mterwoord
  • Registratie: april 2005
  • Laatst online: 14-05 11:46
Excuses voor de vertraging.

Een groot probleem hierbij is dat er volgordelijkheid in zit, met andere woorden, doe je dingen in de verkeerde volgorde, dan werkt het niet. Dit heeft mij veel trial & error gekost.
De volgorde weet ik niet 100% zeker meer, maar dit is hem volgens mij:

Eerst de WAN instellen:
  1. Bij IPv6 Configuration Type, geef je DHCP6 op
  2. vervolgens onder het blokje DHCP6 Client Configuration:
  3. "Request a IPv6 prefix/information through the IPv4 connectivity link " aanvinken
  4. "Only request an IPv6 prefix, do not request an IPv6 address" aanvinken
  5. Bij "DHCPv6 Prefix Delegation Size" de waarde 48 kiezen
  6. "Send IPv6 prefix hint" aanvinken
Dan hier opslaan.


Vervolgens ga je naar de LAN:
  1. Bij "IPv6 Configuration Type" de waarde 'Track Interface" kiezen
  2. Onder "Track IPv6 Interface":
  3. Bij "IPv6 Interface" de WAN interface kiezen
  4. IPv6 prefix kan op 0 blijven staan
Volgens mij zijn dit de instellingen zoals ik ze gedaan heb.

Wat mij opviel bij xs4all, is dat bij het minste of geringste de verbinding weg viel, en je pfsense en het modem moest rebooten.
Toen ik dat eenmaal doorhad ging een en ander wat makkelijker.

Mochten er vragen zijn hoor ik dat graag.
Pagina: 1


Apple iPad Pro (2021) 11" Wi-Fi, 8GB ram Microsoft Xbox Series X LG CX Google Pixel 5a 5G Sony XH90 / XH92 Samsung Galaxy S21 5G Sony PlayStation 5 Nintendo Switch Lite

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2021 Hosting door True