Cookies op Tweakers

Tweakers is onderdeel van DPG Media en maakt gebruik van cookies, JavaScript en vergelijkbare technologie om je onder andere een optimale gebruikerservaring te bieden. Ook kan Tweakers hierdoor het gedrag van bezoekers vastleggen en analyseren. Door gebruik te maken van deze website, of door op 'Cookies accepteren' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt? Bekijk dan ons cookiebeleid.

Meer informatie
Toon posts:

VLAN interface op Raspbian Stretch

Pagina: 1
Acties:

  • Tomba
  • Registratie: mei 2000
  • Laatst online: 22:06

Tomba

Quis custodiet ipsos custodes?

Topicstarter
Omdat we binnenkort een SolarEdge omvormer krijgen en ik deze graag in mijn eigen database zou willen loggen heb ik een oude RaspBerry Pi B geinstallleerd met Raspbian Stretch. Omdat ik een managed switch heb wil ik mbv VLANs de ethernet poort op de RasPi splitsen waarbij de SolarEdge via de RasPi naar het internet mag.

Ik heb dit werkend gekregen door een bestand /etc/network/interfaces.d/vlans aan te maken:
code:
1
2
3
auto eth0.113
iface eth0.113 inet manual
    vlan-raw-device eth0

en een aanpassing te maken in /etc/dhcpcd.conf :
code:
1
2
interface eth0.113
static ip_address=192.168.113.1/24

DNSMasq en iptables zorgen er vervolgens voor dat er internet verkeer mogelijk is tussen eth0.113 en eth0 en het achterliggende device kan dan op internet maar al het verkeer loopt netjes via de RasPi. Voordeel is ook dat de SolarEdge ook alleen zaken naar internet kan sturen als de RasPi online is dus een stuk minder kans op data verlies (de SE houdt eea vast tot hij een werkende internet verbinding heeft)

Het probleem waar ik tegenaan loop is dat de eth0.113 interface niet op komt na booten. Pas na:
code:
1
2
3
service networking restart
service dhcpcd restart
service dnsmasq restart

komt deze interface op en werkt alles naar wens. Daarvoor heb ik alleen een eth0 (die via DHCP een IP heeft gekregen) en de lo interface.
Eventueel zou ik dit mbv een Crontab scriptje kunnen fixen maar ik los lever de oorzaak op. Heeft iemand een gouden tip?

tomba.tweakblogs.net || Mijn V&A


  • Hero of Time
  • Registratie: oktober 2004
  • Laatst online: 22:53

Hero of Time

Moderator NOS

There is only one Legend

Met Raspbian Stretch kan je net als in normaal Debian gewoon een vast IP via het interfaces bestand opgeven. Dat haalt weer de DHCP stap en vertraging weg.

Je zal iig moeten uitzoeken waarom de tagged interface niet op komt door logs te lezen. Het constateren is 1, maar achterhalen waarom is de eerste stap naar de oplossing en dat mist nu.

Commandline FTW | Tweakt met mate


  • Tomba
  • Registratie: mei 2000
  • Laatst online: 22:06

Tomba

Quis custodiet ipsos custodes?

Topicstarter
Hero of Time schreef op zaterdag 3 november 2018 @ 15:56:
Met Raspbian Stretch kan je net als in normaal Debian gewoon een vast IP via het interfaces bestand opgeven. Dat haalt weer de DHCP stap en vertraging weg.

Je zal iig moeten uitzoeken waarom de tagged interface niet op komt door logs te lezen. Het constateren is 1, maar achterhalen waarom is de eerste stap naar de oplossing en dat mist nu.
Ik wil juist dat mijn UTM de IP adressen uitdeelt (en dus geen fixed IP op de eth0 op de RasPi). Welke logs moet ik doorspitten @Hero of Time ? Ik ben alleen bekend met de oude networking methodiek, dhcpcd is op dit moment nog een behoorlijke onbekende voor mij. (sowieso vind ik het raar dat de interface helemaal niet op komt als er op de 'regulier' eth0 (nog) geen IP adres is maar de interface al wel op is maar das weer een heel andere kwestie ;) )

tomba.tweakblogs.net || Mijn V&A


  • Hero of Time
  • Registratie: oktober 2004
  • Laatst online: 22:53

Hero of Time

Moderator NOS

There is only one Legend

Tomba schreef op zaterdag 3 november 2018 @ 16:01:
[...]

Ik wil juist dat mijn UTM de IP adressen uitdeelt (en dus geen fixed IP op de eth0 op de RasPi).
Deze opmerking komt niet overeen met wat je hier hebt gedaan:
Tomba schreef op zaterdag 3 november 2018 @ 14:57:
en een aanpassing te maken in /etc/dhcpcd.conf :
code:
1
2
interface eth0.113
static ip_address=192.168.113.1/24
Hier geef je 'm zelf een vast IP adres.
Welke logs moet ik doorspitten @Hero of Time ? Ik ben alleen bekend met de oude networking methodiek, dhcpcd is op dit moment nog een behoorlijke onbekende voor mij. (sowieso vind ik het raar dat de interface helemaal niet op komt als er op de 'regulier' eth0 (nog) geen IP adres is maar de interface al wel op is maar das weer een heel andere kwestie ;) )
Welke logs kan je online al genoeg over vinden, maar het eerste wat je kan bekijken is de uitvoer van journalctl. Daar zou al alles in moeten staan.

Dan raad ik je ook nog aan de man-page van interfaces te lezen, dan snap je ook wat je hiermee effectief doet:
code:
1
2
3
auto eth0.113
iface eth0.113 inet manual
    vlan-raw-device eth0

Ik geef je wel een hint: het gedrag wat je nu ziet is exact wat je hier hebt opgegeven.

Commandline FTW | Tweakt met mate


  • Tomba
  • Registratie: mei 2000
  • Laatst online: 22:06

Tomba

Quis custodiet ipsos custodes?

Topicstarter
Hero of Time schreef op zaterdag 3 november 2018 @ 16:11:
[...]

Deze opmerking komt niet overeen met wat je hier hebt gedaan:

[...]

Hier geef je 'm zelf een vast IP adres.


[...]

Welke logs kan je online al genoeg over vinden, maar het eerste wat je kan bekijken is de uitvoer van journalctl. Daar zou al alles in moeten staan.

Dan raad ik je ook nog aan de man-page van interfaces te lezen, dan snap je ook wat je hiermee effectief doet:
code:
1
2
3
auto eth0.113
iface eth0.113 inet manual
    vlan-raw-device eth0

Ik geef je wel een hint: het gedrag wat je nu ziet is exact wat je hier hebt opgegeven.
Wellicht is het plaatje wat onduidelijk maar wat ik probeer te bereiken:
eth0, VLAN12 (Untagged), DHCP
eth0.113, VLAN113 (Tagged), Fixed

Vandaar
dus
code:
1
2
3
auto eth0.113
iface eth0.113 inet manual
    vlan-raw-device eth0

Ik geef jou dus ook een hint, hij doet dus inderdaad precies wat ik wil, maar ik moet er wel eerst 3 services voor herstarten na de reboot ;) Tot dat moment is er geen eth0.113 interface en dat is niet bepaald set it and forget it, waar ik hier voor wil gaan.

Mijn UTM ziet VLAN113 nooit, die is er puur en alleen tussen de SolarEdge en de RasPi. Ik ga effe in journalctl duiken.

[Voor 8% gewijzigd door Tomba op 03-11-2018 16:26]

tomba.tweakblogs.net || Mijn V&A


  • Hero of Time
  • Registratie: oktober 2004
  • Laatst online: 22:53

Hero of Time

Moderator NOS

There is only one Legend

Lees de man-page nou maar, dan zie je dat het niet doet wat jij wilt, maar wel wat je hebt opgegeven wat het moet doen.

Daarbij, het hebben van twee DHCP services in je netwerk is vragen om problemen. Want ik ga uit van je configuratie dat je helemaal geen enkele beperking aan dhcpd hebt gegeven. En hoewel je het niet zegt, ga ik er ook vanuit dat je SE een statisch adres heeft of deze op een andere manier verkrijgt.

Commandline FTW | Tweakt met mate


  • Tomba
  • Registratie: mei 2000
  • Laatst online: 22:06

Tomba

Quis custodiet ipsos custodes?

Topicstarter
Hero of Time schreef op zaterdag 3 november 2018 @ 16:26:
Lees de man-page nou maar, dan zie je dat het niet doet wat jij wilt, maar wel wat je hebt opgegeven wat het moet doen.

[…]
Dat doet het dus wel... ;)
Zodra ik de 3 services herstart heeft de RasPi op eth0 een DHCP adres van de UTM, een vast IP adres op eth0.113 en devices die op de RasPi aangesloten worden krijgen netjes (via dnsmasq, die uiteraard alleen op eth0.113 draait) een IP adres in de op de RasPi gedefinieerde range. Exact wat ik wil dus, maar het werkt niet na een reboot totdat de 3 services herstart worden. Ik vermoed een timing issue vanwege het totale gebrek aan snelheid op de Pi. Als ik er niet uitkom knutsel ik wel een systemd script in elkaar die na de boot alsnog de services een schop geeft maar dat is eigenlijk gewoon symptoom bestrijding en daar houd ik niet van.
Hero of Time schreef op zaterdag 3 november 2018 @ 16:26:

[…]
Daarbij, het hebben van twee DHCP services in je netwerk is vragen om problemen. Want ik ga uit van je configuratie dat je helemaal geen enkele beperking aan dhcpd hebt gegeven. En hoewel je het niet zegt, ga ik er ook vanuit dat je SE een statisch adres heeft of deze op een andere manier verkrijgt.
2 DHCP services op hetzelfde netwerk is inderdaad niet handig, maar dat is hier ook niet het geval (of wellicht begrijp ik juist jou verkeerd :P)
Concept tekening:
https://tweakers.net/ext/f/mUwz4KjZsqm0rhv9RvdNeCVr/full.png

[Update]
De enige melding die ik in journalctl vind over de VLAN interface is:
code:
1
Nov 03 15:59:41 raspberrypi dnsmasq[344]: warning: interface eth0.113 does not currently exist

Wat ook klopt :P Tot de herstart van networking verschijnt deze interface niet :(

[Voor 20% gewijzigd door Tomba op 03-11-2018 16:55]

tomba.tweakblogs.net || Mijn V&A


  • Hero of Time
  • Registratie: oktober 2004
  • Laatst online: 22:53

Hero of Time

Moderator NOS

There is only one Legend

De man-page:
code:
1
2
3
4
   The manual Method
       This method may be used to define interfaces for which no  configura-
       tion  is  done by default. Such interfaces can be configured manually
       by means of up and down commands or /etc/network/if-*.d scripts.

Kan je mij uitleggen wat hier staat en wat het betekend? En wat het in jouw situatie dus doet?

Mbt dhcp begrijp je mij mogelijk verkeerd. Je geeft namelijk de configuratie er niet van, alleen die twee regels voor een vast IP. Standaard doet dhcp op elke interface luisteren. En wat heb je aangepast van de standaard dhcpd.conf? Alleen die twee regels voor zover je het hier noemt.

Commandline FTW | Tweakt met mate


  • Tomba
  • Registratie: mei 2000
  • Laatst online: 22:06

Tomba

Quis custodiet ipsos custodes?

Topicstarter
Had niet verwacht dat niemand hier op Tweakers hier ervaring mee had, maar heb gelukkig de oplossing gevonden door de laatste entry in dit topic op het Raspberry forum.

Door het bestand /etc/dhcpcd.enter-hook aan te maken en te vullen met
code:
1
ifup eth0.113

is de interface eth0.113 direct beschikbaar na boot en werkt alles zonder verdere aanpassingen.

Korte samenvatting;

- Maak een bestand aan in /etc/network/interfaces.d/ (ik heb deze vlans genoemd) met daarin je VLAN interface (het nummer achter de punt bepaalt welk VLAN, hier dus 113)
code:
1
2
auto eth0.113
iface eth0.113 inet manual


- Configureer je IP settings in /etc/dhcpcd.conf (let op dus niet dhcpd.conf! Die is om de DHCP Server te configureren):
code:
1
2
interface eth0.113
static ip_address=192.168.113.1/24


Maak het bestand /etc/dhcpcd.enter-hook aan (deze wordt gerund nadat dhcpcd zijn ding gedaan heeft) en breng hier de gedefinieerde interface mee op
code:
1
ifup eth0.113


Complete blogpost op Tweakblogs volgt nog zodra de SolarEdge binnen is :)

[Voor 46% gewijzigd door Tomba op 04-11-2018 13:42. Reden: vlan-raw-device eth0 verwijderd, thanks @eric.1]

tomba.tweakblogs.net || Mijn V&A


  • Hero of Time
  • Registratie: oktober 2004
  • Laatst online: 22:53

Hero of Time

Moderator NOS

There is only one Legend

Ehm, "- Configureer je IP settings in /etc/dhcpcd.conf (let op dus niet dhcpd.conf! Die is om de DHCP Server te configureren):", je past dus het bestand aan wat je niet moet hebben. :? Bedoel je niet dhclient.conf?

En dat je 'ifup eth0.113' moet doen komt juist door je 'iface eth0.113 inet manual' in je interfaces bestand. Iets wat ik je juist duidelijk probeerde te maken door je naar de man-page te verwijzen. Zou je 'manual' veranderen naar 'dhcp' dan hoef je geen 'ifup' te doen. En als je 'static' gebruikt gevolgd door de IP configuratie, omdat je een vast IP adres wilt hebben op je vlan interface, kan je het deel voor dhcpd/dhclient ook overslaan.

Commandline FTW | Tweakt met mate


  • CurlyMo
  • Registratie: februari 2011
  • Laatst online: 07:03

CurlyMo

www.pilight.org

Tomba schreef op zondag 4 november 2018 @ 09:29:
Maak het bestand /etc/dhcpcd.enter-hook aan (deze wordt gerund nadat dhcpcd zijn ding gedaan heeft) en breng hier de gedefinieerde interface mee op
code:
1
ifup eth0.113
Oftewel, je had ook gewoon alle handmatige stappen in een /etc/rc.local kunnen plempen en dan had het ook gewerkt. Het GoT RPi subforum staat (met alle respect) niet bekend om de mensen met de hoge mate van linux kennis. Vandaar deze dirty hack.

Luister dus nou gewoon naar @Hero of Time :)

geen vragen via PM die ook op het forum gesteld kunnen worden.


  • Tomba
  • Registratie: mei 2000
  • Laatst online: 22:06

Tomba

Quis custodiet ipsos custodes?

Topicstarter
Hero of Time schreef op zondag 4 november 2018 @ 12:27:
Ehm, "- Configureer je IP settings in /etc/dhcpcd.conf (let op dus niet dhcpd.conf! Die is om de DHCP Server te configureren):", je past dus het bestand aan wat je niet moet hebben. :? Bedoel je niet dhclient.conf?

En dat je 'ifup eth0.113' moet doen komt juist door je 'iface eth0.113 inet manual' in je interfaces bestand. Iets wat ik je juist duidelijk probeerde te maken door je naar de man-page te verwijzen. Zou je 'manual' veranderen naar 'dhcp' dan hoef je geen 'ifup' te doen. En als je 'static' gebruikt gevolgd door de IP configuratie, omdat je een vast IP adres wilt hebben op je vlan interface, kan je het deel voor dhcpd/dhclient ook overslaan.
offtopic:
Pak dit aub niet verkeerd op, maar ben jij toevallig dyslectisch?

Anyway; dhcpcd.conf niet dhcpd.conf. Scheelt 1 lettertje maar dat maakt toch een wereld van verschil. Op een Raspbian werkt het gewoon anders dan de Linux variant die jij gewend bent gok ik.
CurlyMo schreef op zondag 4 november 2018 @ 12:37:
[...]

Oftewel, je had ook gewoon alle handmatige stappen in een /etc/rc.local kunnen plempen en dan had het ook gewerkt.
[…]
Yes, klopt helemaal, vind persoonlijk deze methode wat netter omdat ik dan zeker ben dat dhcpcd klaar is.
CurlyMo schreef op zondag 4 november 2018 @ 12:37:
[…]
Het GoT RPi subforum staat (met alle respect) niet bekend om de mensen met de hoge mate van linux kennis. Vandaar deze dirty hack.

Luister dus nou gewoon niet naar @Hero of Time :)
Yes, zover was ik inmiddels ;)

[Voor 4% gewijzigd door Tomba op 04-11-2018 12:47]

tomba.tweakblogs.net || Mijn V&A


  • Hero of Time
  • Registratie: oktober 2004
  • Laatst online: 22:53

Hero of Time

Moderator NOS

There is only one Legend

Tomba schreef op zondag 4 november 2018 @ 12:41:
[...]

offtopic:
Pak dit aub niet verkeerd op, maar ben jij toevallig dyslectisch?

Anyway; dhcpcd.conf niet dhcpd.conf. Scheelt 1 lettertje maar dat maakt toch een wereld van verschil.
Dyslectisch ben ik niet, maar die 'c' voor de 'd' is best makkelijk te missen. ;)
Op een Raspbian werkt het gewoon anders dan de Linux variant die jij gewend bent gok ik.
Ik heb zelf ook een Pi en heb dat een vast IP gegeven via de manier dat ook gewoon werkt op de 'normale' Debian releases. Dat is juist iets wat met Raspbian Stretch is verbetert. Maar als je stug naar oude blogs kijkt voor informatie en de 'nieuwere' die het gewoon op dezelfde oude, incorrecte manier blijven doen (wat overigens ook nog werkt, daar niet van) kan je tips en hints om het wél goed te doen en zo min mogelijk gedoe te hebben negeren.

We zijn uiteindelijk allemaal wel eens eigenwijs.

Commandline FTW | Tweakt met mate


  • eric.1
  • Registratie: juli 2014
  • Laatst online: 23:55
Tomba schreef op zondag 4 november 2018 @ 09:29:
code:
1
2
3
auto eth0.113
iface eth0.113 inet manual
    vlan-raw-device eth0
Dit is een beetje dubbelop niet? :)
Je configureert de virtuele adapter op eth0 (eth0.113), dan geef je aan dat je dat op eth0 doet (vlan-raw-device eth0).

Kan je uit netheid net zo goed
code:
1
2
3
auto vlan113
iface vlan113 inet manual
    vlan-raw-device eth0

van maken.

Of
code:
1
2
3
4
5
auto vlan113
iface vlan113 inet static
    vlan-raw-device eth0
    address ....
    netmask ....

of
code:
1
2
3
4
auto eth0.113
iface eth0.113 inet static
    address ....
    netmask ....

aangezien je toch een static adres wilt.

  • Tomba
  • Registratie: mei 2000
  • Laatst online: 22:06

Tomba

Quis custodiet ipsos custodes?

Topicstarter
Hero of Time schreef op zondag 4 november 2018 @ 12:50:
[...]

Dyslectisch ben ik niet, maar die 'c' voor de 'd' is best makkelijk te missen. ;)


[...]
Helder, je leest te snel ;)
Hero of Time schreef op zondag 4 november 2018 @ 12:50:
[...]

Ik heb zelf ook een Pi en heb dat een vast IP gegeven via de manier dat ook gewoon werkt op de 'normale' Debian releases. Dat is juist iets wat met Raspbian Stretch is verbetert. Maar als je stug naar oude blogs kijkt voor informatie en de 'nieuwere' die het gewoon op dezelfde oude, incorrecte manier blijven doen (wat overigens ook nog werkt, daar niet van) kan je tips en hints om het wél goed te doen en zo min mogelijk gedoe te hebben negeren.

We zijn uiteindelijk allemaal wel eens eigenwijs.
Super! Alleen gaat het hier niet over het toewijzen van een vast IP adres maar om het niet opkomen van de hele iface, dus ik denk dat jij een probleem op probeerde te lossen dat ik niet had.
offtopic:
Erg jammer dat je het nodig vindt om allerlei aannames te doen terwijl je op jouw manier (denk ik?) toch probeert te helpen.


Anyway, ik ga hier met jou niet uitkomen @Hero of Time dus ik ga het qua communicatie met jou hierbij laten als jij dat goed vindt.
eric.1 schreef op zondag 4 november 2018 @ 12:54:
[...]

Dit is een beetje dubbelop niet? :)
Je configureert de virtuele adapter op eth0 (eth0.113), dan geef je aan dat je dat op eth0 doet (vlan-raw-device eth0).

Kan je uit netheid net zo goed
code:
1
2
3
auto vlan113
iface vlan113 inet manual
    vlan-raw-device eth0

van maken.

Of
code:
1
2
3
4
5
auto vlan113
iface vlan113 inet static
    vlan-raw-device eth0
    address ....
    netmask ....

of
code:
1
2
3
4
auto eth0.113
iface eth0.113 inet static
    address ....
    netmask ....

aangezien je toch een static adres wilt.
Kijk, fijn dat je inhoudelijk in gaat op wat ik probeer te bereiken. Ik heb e.e.a. op mijn interpretatie van de debian manpages gedaan maar ik zie nu dat ik daar te snel doorheen gelezen heb ;)
Ik ga eens testen of als ik de regel vlan-raw-device eth0 weg haal de iface wel op komt. (want ik verval wellicht in herhaling, ik heb geen probleem met het toewijzen van een vast IP, maar dat de iface niet op komt na boot...)

[Update]
vlan-raw-device eth0 verwijderd en VLAN werkt inderdaad (zoals verwacht ;) ) nog, dank je @eric.1, toch wat netter zo. Helaas lost het mijn probleem niet op, als ik geen ifup uitvoer op eth0.113 wordt die iface niet actief. (en ja, inet static met address en netmask gezet in die test) Op Ubuntu 18.04 werkt alles zo out of the box voor me dus het is toch iets met Raspbian dunkt me?

Maar goed, ik heb een werkende oplossing gevonden (ifup uit laten voeren via /etc/dhcpcd.enter-hook)

[Voor 9% gewijzigd door Tomba op 04-11-2018 13:29]

tomba.tweakblogs.net || Mijn V&A


  • Hero of Time
  • Registratie: oktober 2004
  • Laatst online: 22:53

Hero of Time

Moderator NOS

There is only one Legend

En ik probeer je nou de hele tijd duidelijk te maken dat het niet opkomen van je interface precies is wat je hebt opgegeven te doen door 'manual' te kiezen als methode voor je interface. Wat in de man-page naar mijn idee toch wel heel duidelijk staat vermeld. Ik los dus wel degelijk een probleem op dat je hebt, je ziet het alleen niet omdat je, blijkbaar, de man-pages compleet verkeert interpreteert.

Commandline FTW | Tweakt met mate


  • eric.1
  • Registratie: juli 2014
  • Laatst online: 23:55
Tomba schreef op zondag 4 november 2018 @ 13:06:
Ik ga eens testen of als ik de regel vlan-raw-device eth0 weg haal de iface wel op komt. (want ik verval wellicht in herhaling, ik heb geen probleem met het toewijzen van een vast IP, maar dat de iface niet op komt na boot...)
Dat zal het niet oplossen, dat zit eerder in de 'manual' icm hoe je de interface daarna "handmatig" (door de dhcp client) "up" brengt.

Alleen snap ik niet waarom je voor deze virtuele interface 'manual' gebruikt, om vervolgens in de dhcp client een adres toe te wijzen wat net zo goed in de interface-definitie kan.

Correct me if i'm wrong, maar met;
code:
1
2
3
4
5
6
7
auto eth0
iface eth0 inet dhcp

auto eth0.113
iface eth0.113 inet static
    address 192.168.113.1
    netmask 255.255.255.0

Zou je geen problemen moeten hebben om die interfaces automatisch op te laten komen.

edit; oi, je update gemist :)

  • Tomba
  • Registratie: mei 2000
  • Laatst online: 22:06

Tomba

Quis custodiet ipsos custodes?

Topicstarter
eric.1 schreef op zondag 4 november 2018 @ 13:29:
[...]

Dat zal het niet oplossen, dat zit eerder in de 'manual' icm hoe je de interface daarna "handmatig" (door de dhcp client) "up" brengt.

Alleen snap ik niet waarom je voor deze virtuele interface 'manual' gebruikt, om vervolgens in de dhcp client een adres toe te wijzen wat net zo goed in de interface-definitie kan.

Correct me if i'm wrong, maar met;
code:
1
2
3
4
5
6
7
auto eth0
iface eth0 inet dhcp

auto eth0.113
iface eth0.113 inet static
    address 192.168.113.1
    netmask 255.255.255.0

Zou je geen problemen moeten hebben om die interfaces automatisch op te laten komen.
Ik ook niet, exact zo had ik het oorspronkelijk ingericht om er vervolgens tegenaan te lopen dat eth0.113 gewoon niet automatisch opkomt.
Wellicht als ik dhcpcd helemaal uitschakel ten faveure van oldschool network wellicht maar ik accepteer maar dat het gewoon 1 van die quirks van Raspbian is en neem genoegen met een werkende situatie :)

tomba.tweakblogs.net || Mijn V&A


  • CurlyMo
  • Registratie: februari 2011
  • Laatst online: 07:03

CurlyMo

www.pilight.org

Tomba schreef op zondag 4 november 2018 @ 13:32:
[...]

Ik ook niet, exact zo had ik het oorspronkelijk ingericht om er vervolgens tegenaan te lopen dat eth0.113 gewoon niet automatisch opkomt.
Wellicht als ik dhcpcd helemaal uitschakel ten faveure van oldschool network wellicht maar ik accepteer maar dat het gewoon 1 van die quirks is en neem genoegen met een werkende situatie :)
@Tomba Debian doet precies wat je vraagt: "Laat mij manual mijn netwerkadapter aanzetten".

En configureer ook gewoon alles vanuit die /etc/network/interfaces[.d]. Debian pakt het vanuit daar verder op. Je hoeft dhcpcd helemaal niet aan te raken. Jij laat je net als anti-vaxxers door de verkeerde mensen overtuigen.

Luister dus nou gewoon naar @Hero of Time :X

geen vragen via PM die ook op het forum gesteld kunnen worden.


  • Tomba
  • Registratie: mei 2000
  • Laatst online: 22:06

Tomba

Quis custodiet ipsos custodes?

Topicstarter
CurlyMo schreef op zondag 4 november 2018 @ 13:34:
[...]

@Tomba Debian doet precies wat je vraagt: "Laat mij manual mijn netwerkadapter aanzetten".

En configureer ook gewoon alles vanuit die /etc/network/interfaces[.d]. Debian pakt het vanuit daar verder op. Je hoeft dhcpcd helemaal niet aan te raken. Jij laat je net als anti-vaxxers door de verkeerde mensen overtuigen.

Luister dus nou gewoon naar @Hero of Time :X
'Exact zo' betekent exact zo en daar staat toch echt:

iface eth0.113 inet static

[Voor 6% gewijzigd door Tomba op 04-11-2018 13:38]

tomba.tweakblogs.net || Mijn V&A


  • CurlyMo
  • Registratie: februari 2011
  • Laatst online: 07:03

CurlyMo

www.pilight.org

Tomba schreef op zondag 4 november 2018 @ 13:37:
[...]

Exact zo betekent exact zo en daar staat toch echt:

auto eth0.113
iface eth0.113 inet static
address 192.168.113.1
netmask 255.255.255.0
En heb je nu de rest ongemoeid gelaten? Oftewel, is dit de enige configuratie die je hebt gedaan voor je netwerk?

geen vragen via PM die ook op het forum gesteld kunnen worden.


  • Tomba
  • Registratie: mei 2000
  • Laatst online: 22:06

Tomba

Quis custodiet ipsos custodes?

Topicstarter
CurlyMo schreef op zondag 4 november 2018 @ 13:38:
[...]

En heb je nu de rest ongemoeid gelaten? Oftewel, is dit de enige configuratie die je hebt gedaan voor je netwerk?
Hoe bedoel je 'nu'? Dat was juist mijn startpunt, zou je aub wat moeite willen doen om mijn reacties te lezen?

tomba.tweakblogs.net || Mijn V&A


  • CurlyMo
  • Registratie: februari 2011
  • Laatst online: 07:03

CurlyMo

www.pilight.org

Tomba schreef op zondag 4 november 2018 @ 13:40:
[...]

Hoe bedoel je nu? Dat was het startpunt, zou je aub wat moeite willen doen om mijn reacties te lezen?
Als dit je reacties zijn (zoals ook in de lijn met die naar @Hero of Time ) niet nee. Succes @Hero of Time ;w

* CurlyMo out

geen vragen via PM die ook op het forum gesteld kunnen worden.


  • Tomba
  • Registratie: mei 2000
  • Laatst online: 22:06

Tomba

Quis custodiet ipsos custodes?

Topicstarter
CurlyMo schreef op zondag 4 november 2018 @ 13:46:
[...]

Als dit je reacties zijn (zoals ook in de lijn met die naar @Hero of Time ) niet nee. Succes @Hero of Time ;w

* CurlyMo out
OK! Dank je voor je poging tot helpen.

tomba.tweakblogs.net || Mijn V&A

Pagina: 1


Apple iPad Pro (2021) 11" Wi-Fi, 8GB ram Microsoft Xbox Series X LG CX Google Pixel 5a 5G Sony XH90 / XH92 Samsung Galaxy S21 5G Sony PlayStation 5 Nintendo Switch Lite

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2021 Hosting door True