Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie
Toon posts:

Zwart / vervormd scherm na GRUB bij Debian / Proxmox install

Pagina: 1
Acties:

Vraag


  • mdbraber
  • Registratie: juli 2010
  • Laatst online: 09-11 17:39
Hoi,

Ik heb een nieuwe server gebouwd op basis van een Coffee Lake CPU (i3-8100) met Fujitsu 3644-B moederbord (Intel Integrated Graphics 630). Bij het installeren van Debian (of Proxmox) blijft de installer na het laden van GRUB hangen of met wat tweaks (i915.alpha_support=1, modeset=0 etc) krijg ik een aparte situatie: 10 mini versies van het scherm dat ik zou moeten zien in de ongeveer eerste ~60 pixels aan de bovenkant. Zie de foto voor wat ik bedoel:



In bovenstaande situatie kan ik zien dat het keyboard etc. gewoon werkt maar ik kan dus niets lezen van wat er eigenlijk staat. Ik kan de debian installatie helemaal op de tast doen, maar heb toch graag bij een reboot wel gewoon beeld ;-) Het interessante is dat de Ubuntu installer wel gewoon volledig werkt. Ik heb zowel de Debian stable als testing installers gewerkt (ervanuitgaande dat de testing installer een nieuwere kernel versie / drivers heeft).

Iemand een idee wat verder nog te proberen om gewoon beeld te krijgen? Ik gok dat het een issue is met de i915 driver, maar wellicht kijk ik ergens overheen en is het iets anders?

Beste antwoord (via Hero of Time op 19-03-2019 14:38)


  • mdbraber
  • Registratie: juli 2010
  • Laatst online: 09-11 17:39
Succes! Met dank aan de fantastische customer support van 'juggernaut' op de heide.de fora heb ik de oplossing voor mijn 'garbled display' probleem gevonden: https://www.heise.de/foru...an/posting-33297616/show/

Ga in de BIOS naar "PCI settings" en disable daar onderaan de optie "Above 4GB decoding" (die is standaard enabled). Die had ik geloof ik zelf niet zo snel gevonden... (zeker niet omdat het een PCI optie is). De Debian installer werkt nu gewoon. Op naar de volgende stap.

Alle reacties


  • Hero of Time
  • Registratie: oktober 2004
  • Laatst online: 20:30

Hero of Time

Moderator NOS/CSA

There is only one Legend

Kan je de text-based installer uitvoeren? Krijg je daar hetzelfde mee? En wat als je niet via UEFI start, maar met CSM/Legacy boot?

Spekkies | Commandline FTW


  • mdbraber
  • Registratie: juli 2010
  • Laatst online: 09-11 17:39
Hero of Time schreef op maandag 22 oktober 2018 @ 10:09:
Kan je de text-based installer uitvoeren? Krijg je daar hetzelfde mee? En wat als je niet via UEFI start, maar met CSM/Legacy boot?
Text-based installer zelfde probleem. Non-UEFI boot is niet meer aanwezig op dit moederbord, dus is helaas geen optie (en uiteindelijk wil ik sowieso UEFI boot dus heb ik het ook tijdens install nodig...) Wat zou overigens de invloed van UEFI boot hierop kunnen zijn?

mdbraber wijzigde deze reactie 22-10-2018 10:39 (25%)


  • mrmrmr
  • Registratie: april 2007
  • Niet online
Wat zegt dmesg? (/var/log/messages)

  • mdbraber
  • Registratie: juli 2010
  • Laatst online: 09-11 17:39
mrmrmr schreef op maandag 22 oktober 2018 @ 10:40:
Wat zegt dmesg? (/var/log/messages)
Goeie vraag - hoe kom ik daarbij? Ik kan dus na GRUB niets zien... (ik heb geprobeerd een Serial-over-Console boot te doen met AMT maar dat werkt tot nu toe nog niet)

mdbraber wijzigde deze reactie 22-10-2018 10:41 (18%)


  • mdbraber
  • Registratie: juli 2010
  • Laatst online: 09-11 17:39
Dat werkt dus helaas niet omdat alle output gaat naar die 10 mini schermpjes bovenaan die ik niet kan lezen :-(

  • mrmrmr
  • Registratie: april 2007
  • Niet online
Werkt de muis? Misschien kun je daarmee een van die schermen activeren. Of misschien met tab / shift-tab of PgDn / PgUp.

Een andere optie is om het nogmaals zonder de GRUB tweaks (en dus zonder die schermpjes bovenaan) te proberen en dan proberen om in een alternatieve consolescherm te komen. Ctrl+Left Alt+F2 en zo verder met Ctrl+Left Alt+Fn (n=debugschermnummer).

  • mdbraber
  • Registratie: juli 2010
  • Laatst online: 09-11 17:39
mrmrmr schreef op maandag 22 oktober 2018 @ 11:56:
Werkt de muis? Misschien kun je daarmee een van die schermen activeren. Of misschien met tab / shift-tab of PgDn / PgUp.

Een andere optie is om het nogmaals zonder de GRUB tweaks (en dus zonder die schermpjes bovenaan) te proberen en dan proberen om in een alternatieve consolescherm te komen. Ctrl+Left Alt+F2 en zo verder met Ctrl+Left Alt+Fn (n=debugschermnummer).
Ik heb er geen muis op aangesloten, maar basically werkt 'gewoon' dat mini-schermpje bovenin alleen ik heb geen idee wat er staat. De rest van de output (dat GRUB gedeelte) is 'frozen' en blijft dus staan...

  • Brahiewahiewa
  • Registratie: oktober 2001
  • Laatst online: 16-11 16:39

Brahiewahiewa

boelkloedig

mdbraber schreef op maandag 22 oktober 2018 @ 10:41:
[...]


Goeie vraag - hoe kom ik daarbij? Ik kan dus na GRUB niets zien... (ik heb geprobeerd een Serial-over-Console boot te doen met AMT maar dat werkt tot nu toe nog niet)
sshd aanzetten en remote inloggen?

QnJhaGlld2FoaWV3YQ==


  • SlaadjeBla
  • Registratie: september 2002
  • Laatst online: 22:47
Ik had iets soortgelijks. UEFI maakt het mogelijk in een hogere resolutie te booten. Deze optie resulteerde bij mij in een onleesbaar bootscherm totdat X gestart was. Wanneer ik het password voor de disk encryptie moest invullen was daardoor altijd een beetje een gok.

Laatst kwam ik er toevallig achter dat ik op mijn laptop ook UEFI in low-res modus kon starten. Ik kan nu even niet controleren hoe deze optie heet, maar hij stond tussen de boot opties. Wellicht heb jij ook zo'n optie? Ik had er overigens alleen last van als ik mijn dedicated Nvidia videokaart gebruik. Als ik deze uitschakelde en de integrated gpu gebruikte, had ik altijd goed beeld.

Deze optie (CSM staat blijkbaar voor Compatibility Support Module):

SlaadjeBla wijzigde deze reactie 22-10-2018 15:22 (7%)


  • mdbraber
  • Registratie: juli 2010
  • Laatst online: 09-11 17:39
@SlaadjeBla tnx! Helaas heeft dit moederbord (Fujitsu 3644-B) geen LegacyOS / CSM opties meer. Ik zal eens bij Fujitsu informeren of zij het probleem kennen. Wat me wel intrigeert is dat Ubuntu er dus geen probleem mee heeft...

Hier in ieder geval een bevestiging van Fujitsu dat zij het niet (meer) ondersteunen omdat sinds Coffee Lake er geen officieel support voor CSM meer is: https://www.heise.de/foru...nt/posting-33097829/show/

mdbraber wijzigde deze reactie 22-10-2018 15:52 (42%)
Reden: Reactie Fujitsu toegevoegd


  • SlaadjeBla
  • Registratie: september 2002
  • Laatst online: 22:47
Heb je al geprobeerd te booten met nomodeset?
Deze persoon lijkt daar succes mee te hebben gehad.

Dat Debian niet goed werkt, maar Ubuntu wel, zou kunnen liggen aan de oudere kernel + modules die Debian doorgaans meescheept ten opzichte van Ubuntu. Dat Ubuntu geen problemen heeft, geeft wel vertrouwen dat er een oplossing zou moeten bestaan, wellicht in de vorm van een kernel upgrade.

edit:
het lijkt erop dat modeset=0 de moderne variant is van nomodeset.

SlaadjeBla wijzigde deze reactie 22-10-2018 16:52 (9%)


  • mdbraber
  • Registratie: juli 2010
  • Laatst online: 09-11 17:39
SlaadjeBla schreef op maandag 22 oktober 2018 @ 16:49:
Heb je al geprobeerd te booten met nomodeset?
Deze persoon lijkt daar succes mee te hebben gehad.

edit:
het lijkt erop dat modeset=0 de moderne variant is van nomodeset.
Thanks voor het zoeken! Met 'modeset=0' heb ik dezelfde garbled output en kan ik zien dat er iets probeert te booten wat in een continuous loop terechtkomt (maar ik kan dus niet zien wat daar staat, frustrerend genoeg) |:(

Ik heb het via het forum van Heise wel even neergelegd bij Fujitsu die er naar gaan kijken.
Dat Debian niet goed werkt, maar Ubuntu wel, zou kunnen liggen aan de oudere kernel + modules die Debian doorgaans meescheept ten opzichte van Ubuntu. Dat Ubuntu geen problemen heeft, geeft wel vertrouwen dat er een oplossing zou moeten bestaan, wellicht in de vorm van een kernel upgrade.
Ja, dat denk ik ook. Wat dan wel weer raar is dat de Proxmox installer ook niet werkt en die is juist gebaseerd op de Ubuntu 18.04 LTS kernel (die wel weer prima werkt). Schiet mij maar lek ;-)

  • Hero of Time
  • Registratie: oktober 2004
  • Laatst online: 20:30

Hero of Time

Moderator NOS/CSA

There is only one Legend

mdbraber schreef op maandag 22 oktober 2018 @ 17:06:
[...]

Ja, dat denk ik ook. Wat dan wel weer raar is dat de Proxmox installer ook niet werkt en die is juist gebaseerd op de Ubuntu 18.04 LTS kernel (die wel weer prima werkt). Schiet mij maar lek ;-)
Wat juist vreemder is, is dat je Testing hebt geprobeerd. Die heeft een nieuwere kernel (4.18 momenteel) dan Ubuntu 18.04 (4.15).

Omdat je aangeeft dat Ubuntu wel prima werkt mbt installer kan je nog proberen om de initrd bestanden van Ubuntu te pakken en die van Debian of Proxmox vervangen ermee. Vereist wel een installatie USB stick, maar denk dat je die wel hebt.

Kijk overigens ook eens naar de command line opties die bij Ubuntu gebruikt worden vergeleken met Debian. Misschien zit daar nog iets van verschil in.

Spekkies | Commandline FTW


Acties:
  • Beste antwoord
  • +2Henk 'm!

  • mdbraber
  • Registratie: juli 2010
  • Laatst online: 09-11 17:39
Succes! Met dank aan de fantastische customer support van 'juggernaut' op de heide.de fora heb ik de oplossing voor mijn 'garbled display' probleem gevonden: https://www.heise.de/foru...an/posting-33297616/show/

Ga in de BIOS naar "PCI settings" en disable daar onderaan de optie "Above 4GB decoding" (die is standaard enabled). Die had ik geloof ik zelf niet zo snel gevonden... (zeker niet omdat het een PCI optie is). De Debian installer werkt nu gewoon. Op naar de volgende stap.

  • itsjohan
  • Registratie: januari 2001
  • Laatst online: 20-07 23:25
Held!

Ik heb exact hetzelde probleem met een D3643-H en ook bij mij blijkt de 4G encoding de oplossing te zijn nadat ik die hier las. Bedankt voor het delen.
Pagina: 1


Apple iPhone 11 Nintendo Switch Lite LG OLED C9 Google Pixel 4 FIFA 20 Samsung Galaxy S10 Sony PlayStation 5 Auto

'14 '15 '16 '17 2018

Tweakers vormt samen met Hardware Info, AutoTrack, Gaspedaal.nl, Nationale Vacaturebank, Intermediair en Independer DPG Online Services B.V.
Alle rechten voorbehouden © 1998 - 2019 Hosting door True