Toon posts:

excel vraag mbt Match index kolom.

Pagina: 1
Acties:

Vraag


  • Matthewhay
  • Registratie: Oktober 2010
  • Laatst online: 26-01 16:04
Beste Tweakers,

Ik heb een vraag mbt een excel formule waar ik niet uit kom.

Ik heb de volgende tabel:


0.1%0.2%0.3%0.5%0.6%0.75%1%Bedrag geinvesteerd
name 1 096,42 € 1 954,12 € 2 931,18 € 3 908,24 € 4 885,30 € 5 862,35 € 7 327,94 € 5000€


Nu wil ik dat de formule in de matrix kijkt naar het eerste getal in die reeks dat => is dan kolom bedrag geinversteerd,& als die kolom leeg is minimaal 3000 in de matrix te zoeken.

Wat ik al geprobeert heb is een lange als functie die redelijk werkt maarals de kolom leeg is alleen maar de header van de eerste kolom weergeeft.

Alvast bedankt :)

Beste antwoord (via Matthewhay op 24-09-2018 11:51)


  • Hortz
  • Registratie: Januari 2010
  • Laatst online: 16:53
Matthewhay schreef op vrijdag 21 september 2018 @ 15:20:

Nu wil ik dat de formule in de matrix kijkt naar het eerste getal in die reeks dat => is dan kolom bedrag geinversteerd,& als die kolom leeg is minimaal 3000 in de matrix te zoeken.
Als die kolom leeg is bedoel je het Bedrag geinvesteerd? Dus als daar 0 staat of helemaal niks?
Wat moet het eind resultaat zijn? De opbrengst of het %percentage?

De volgende formule heeft zelfde effect op 0 en als helemaal leeg en geeft de opbrengst weer.
=ALS(I2>0;INDEX(B2:H2;VERGELIJKEN(WAAR;INDEX(B2:H2>=I2;0);));INDEX(B2:H2;VERGELIJKEN(WAAR;INDEX(B2:H2>=3000;0);)))
Het kan vast effectiever, maar dit werkt voor zover ik kon testen.
Je kan meer vinden op: https://www.extendoffice....t-value-greater-than.html

Alle reacties


Acties:
  • Beste antwoord
  • 0Henk 'm!

  • Hortz
  • Registratie: Januari 2010
  • Laatst online: 16:53
Matthewhay schreef op vrijdag 21 september 2018 @ 15:20:

Nu wil ik dat de formule in de matrix kijkt naar het eerste getal in die reeks dat => is dan kolom bedrag geinversteerd,& als die kolom leeg is minimaal 3000 in de matrix te zoeken.
Als die kolom leeg is bedoel je het Bedrag geinvesteerd? Dus als daar 0 staat of helemaal niks?
Wat moet het eind resultaat zijn? De opbrengst of het %percentage?

De volgende formule heeft zelfde effect op 0 en als helemaal leeg en geeft de opbrengst weer.
=ALS(I2>0;INDEX(B2:H2;VERGELIJKEN(WAAR;INDEX(B2:H2>=I2;0);));INDEX(B2:H2;VERGELIJKEN(WAAR;INDEX(B2:H2>=3000;0);)))
Het kan vast effectiever, maar dit werkt voor zover ik kon testen.
Je kan meer vinden op: https://www.extendoffice....t-value-greater-than.html

  • Lustucru
  • Registratie: Januari 2004
  • Niet online

Lustucru

26 03 2016

Matthewhay schreef op vrijdag 21 september 2018 @ 15:20:
Wat ik al geprobeert heb is een lange als functie die redelijk werkt maarals de kolom leeg is alleen maar de header van de eerste kolom weergeeft.
Dan geef je toch op zijn minst die formule in je startpost? :( En ter inspiratie zijn er de afgelopen dagen best wel wat posts geplaatst over het optimaliseren van als.dan constructies.

De oever waar we niet zijn noemen wij de overkant / Die wordt dan deze kant zodra we daar zijn aangeland


  • Matthewhay
  • Registratie: Oktober 2010
  • Laatst online: 26-01 16:04
Hortz schreef op vrijdag 21 september 2018 @ 15:57:
[...]


Als die kolom leeg is bedoel je het Bedrag geinvesteerd? Dus als daar 0 staat of helemaal niks?
Wat moet het eind resultaat zijn? De opbrengst of het %percentage?

De volgende formule heeft zelfde effect op 0 en als helemaal leeg en geeft de opbrengst weer.


[...]


Het kan vast effectiever, maar dit werkt voor zover ik kon testen.
Je kan meer vinden op: https://www.extendoffice....t-value-greater-than.html
Bedankt voor je antwoord, hiermee ben ik al een heel eind opgeschoten, wat ik hierna heb gedaan is de volgende formule in de kolom er naast gezet om de juiste kolom header terug te krijgen: {=INDEX($J$1:$Q$1;MAX(ALS($J$2:$Q$211=X2;KOLOM($J$2:$Q$211)-KOLOM($J$1)+1)))}


Bref, wellicht is er nog een andere manier om dit efficienter te doen maar ik heb het antwoord dat ik wil hebben. Nogmaals bedankt voor je hulp :)


Tweakers maakt gebruik van cookies

Tweakers plaatst functionele en analytische cookies voor het functioneren van de website en het verbeteren van de website-ervaring. Deze cookies zijn noodzakelijk. Om op Tweakers relevantere advertenties te tonen en om ingesloten content van derden te tonen (bijvoorbeeld video's), vragen we je toestemming. Via ingesloten content kunnen derde partijen diensten leveren en verbeteren, bezoekersstatistieken bijhouden, gepersonaliseerde content tonen, gerichte advertenties tonen en gebruikersprofielen opbouwen. Hiervoor worden apparaatgegevens, IP-adres, geolocatie en surfgedrag vastgelegd.

Meer informatie vind je in ons cookiebeleid.

Sluiten

Toestemming beheren

Hieronder kun je per doeleinde of partij toestemming geven of intrekken. Meer informatie vind je in ons cookiebeleid.

Functioneel en analytisch

Deze cookies zijn noodzakelijk voor het functioneren van de website en het verbeteren van de website-ervaring. Klik op het informatie-icoon voor meer informatie. Meer details

janee

    Relevantere advertenties

    Dit beperkt het aantal keer dat dezelfde advertentie getoond wordt (frequency capping) en maakt het mogelijk om binnen Tweakers contextuele advertenties te tonen op basis van pagina's die je hebt bezocht. Meer details

    Tweakers genereert een willekeurige unieke code als identifier. Deze data wordt niet gedeeld met adverteerders of andere derde partijen en je kunt niet buiten Tweakers gevolgd worden. Indien je bent ingelogd, wordt deze identifier gekoppeld aan je account. Indien je niet bent ingelogd, wordt deze identifier gekoppeld aan je sessie die maximaal 4 maanden actief blijft. Je kunt deze toestemming te allen tijde intrekken.

    Ingesloten content van derden

    Deze cookies kunnen door derde partijen geplaatst worden via ingesloten content. Klik op het informatie-icoon voor meer informatie over de verwerkingsdoeleinden. Meer details

    janee