Cookies op Tweakers

Tweakers maakt gebruik van cookies, onder andere om de website te analyseren, het gebruiksgemak te vergroten en advertenties te tonen. Door gebruik te maken van deze website, of door op 'Ga verder' te klikken, geef je toestemming voor het gebruik van cookies. Wil je meer informatie over cookies en hoe ze worden gebruikt, bekijk dan ons cookiebeleid.

Meer informatie

Vraag


  • Jan_V
  • Registratie: maart 2002
  • Laatst online: 21-04 17:22
Sinds kort heb ik een nette NAS en kan daar Docker containers op draaien.

Een van de containers welke ik wil installeren is pihole/pihole (= versie 4). Dit is gelukt en ik zie in de web portaal dat deze ook goed z'n werk doet.

Ieder request dat ik vanaf een device doe (telefoon, laptop, desktop) lijkt geresolved te worden.

Echter is er 1 probleem. M'n laptop en desktop lijken namelijk niet de DNS resultaten terug te krijgen vanaf PiHole. Een DNS request lijkt wel afgevuurd te worden richting PiHole, maar bij een nslookup of ping krijg ik niets terug.
code:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
D:\Temp>nslookup google.nl
DNS request timed out.
    timeout was 2 seconds.
Server:  UnKnown
Address:  192.168.1.158

DNS request timed out.
    timeout was 2 seconds.
DNS request timed out.
    timeout was 2 seconds.
DNS request timed out.
    timeout was 2 seconds.
DNS request timed out.
    timeout was 2 seconds.
*** Request to UnKnown timed-out

Maar zoals gezegd, zie ik in de web portaal wel het request voorbij komen
code:
1
2018-08-23 21:20:24     AAAA    google.nl   172.17.0.1  OK (forwarded)  N/A

Er is blijkbaar ook een firewall op de Synology. Deze stond uit, maar heb ik inmiddels aan gezet waarbij ik al het verkeer op Allow heb gezet. Ook heb ik de Windows firewall uit gezet.
Helaas lijkt dit niet te helpen.

Qua poorten heb ik poort 53 van de Synology doorgelust naar 53 van de container.

Poort 80 en 443 heb ik helaas (nog) niet goed ingesteld, maar dat zou de werking van PiHole niet in de weg moeten zitten. Alleen advertenties worden dan wat raarder geblokkeerd.
Poort 67 is alleen nodig voor DHCP, wat ik toch (nog) niet wil doen via PiHole.

De container draait in het Bridge netwerk op de Synology. Op zich zou dit geen probleem moeten zijn, aangezien de correcte poorten worden doorgelust als het goed is.
De container op Host draaien lijkt ook niet te werken. Ook dan lijkt het geheel niet te werken. Ik dacht eerst omdat de publieke poorten dan Auto worden toegekend, maar kan natuurlijk ook zijn dat hetzelfde issue heeft.

Voor de volledigheid nog een screenshot van de Service pagina onder Info

Stiekem had ik hier ook de geconfigureerde poorten (waaronder 53) verwacht onder Docker. Wellicht dat dit dan wel het issue is, maar ik zie ook even niet hoe ik dat toe kan voegen. De Test Connection knop lijkt ook vrij weinig te doen.

Battle.net - Jandev#2601 / XBOX: VriesDeJ

Alle reacties


  • Jan_V
  • Registratie: maart 2002
  • Laatst online: 21-04 17:22
Eindelijk weer tijd gehad om het een en ander uit te zoeken.

Binnen PiHole zag ik dat er een kopje `Interface listening behavior` is.
Hier stond de optie op `Listen only on interface eth0`.
Deze heb ik nu gewijzigd naar `Listen on all interfaces` en het timeout probleem lijkt opgelost te zijn!

Wel heb ik het netwerk nu weer op `Host` gezet. In `Bridge` met het routeren van de juiste poorten treden er nog steeds timeouts op.

Jan_V wijzigde deze reactie 09-01-2019 21:46 (18%)

Battle.net - Jandev#2601 / XBOX: VriesDeJ



OnePlus 7 Microsoft Xbox One S All-Digital Edition LG W7 Google Pixel 3 XL OnePlus 6T (6GB ram) FIFA 19 Samsung Galaxy S10 Sony PlayStation 5

Tweakers vormt samen met Tweakers Elect, Hardware.Info, Autotrack, Nationale Vacaturebank, Intermediair en Independer de Persgroep Online Services B.V.
Alle rechten voorbehouden © 1998 - 2019 Hosting door True